gnu: Add texlive-generic-xstring.
[jackhill/guix/guix.git] / gnu / packages / nettle.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2016, 2021 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2017, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
5 ;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages nettle)
23 #:use-module (guix utils)
24 #:use-module (guix licenses)
25 #:use-module (guix packages)
26 #:use-module (guix download)
27 #:use-module (guix build-system gnu)
28 #:use-module (gnu packages)
29 #:use-module (gnu packages multiprecision)
30 #:use-module (gnu packages m4))
31
32 (define-public nettle-2
33 (package
34 (name "nettle")
35 (version "2.7.1")
36 (source (origin
37 (method url-fetch)
38 (uri (string-append "mirror://gnu/nettle/nettle-"
39 version ".tar.gz"))
40 (sha256
41 (base32
42 "0h2vap31yvi1a438d36lg1r1nllfx3y19r4rfxv7slrm6kafnwdw"))))
43 (build-system gnu-build-system)
44 (arguments
45 ;; 'sexp-conv' and other programs need to have their RUNPATH point to
46 ;; $libdir, which is not the case by default. Work around it.
47 '(#:configure-flags (list (string-append "LDFLAGS=-Wl,-rpath="
48 (assoc-ref %outputs "out")
49 "/lib"))
50 #:phases (modify-phases %standard-phases
51 (add-after 'install 'move-static-libraries
52 (lambda* (#:key outputs #:allow-other-keys)
53 (let ((out (assoc-ref outputs "out"))
54 (slib (string-append (assoc-ref outputs "static")
55 "/lib")))
56 (mkdir-p slib)
57 (with-directory-excursion (string-append out "/lib")
58 (for-each (lambda (ar)
59 (rename-file ar (string-append
60 slib "/"
61 (basename ar))))
62 (find-files "." "\\.a$")))
63 #t))))))
64 (outputs '("out" "debug" "static"))
65 (native-inputs (list m4))
66 (propagated-inputs (list gmp))
67 (home-page "https://www.lysator.liu.se/~nisse/nettle/")
68 (synopsis "C library for low-level cryptographic functionality")
69 (description
70 "GNU Nettle is a low-level cryptographic library. It is designed to
71 fit in easily in almost any context. It can be easily included in
72 cryptographic toolkits for object-oriented languages or in applications
73 themselves.")
74 (license gpl2+)))
75
76 (define-public nettle
77 ;; This version is not API-compatible with version 2. In particular, lsh
78 ;; cannot use it yet. So keep it separate.
79 (package (inherit nettle-2)
80 (version "3.7.3")
81 (source (origin
82 (method url-fetch)
83 (uri (string-append "mirror://gnu/nettle/nettle-"
84 version ".tar.gz"))
85 (sha256
86 (base32
87 "1w5wwc3q0r97d2ifhx77cw7y8s20bm8x52is9j93p2h47yq5w7v6"))))
88 (arguments
89 (substitute-keyword-arguments (package-arguments nettle-2)
90 ((#:configure-flags flags)
91 ;; Build "fat" binaries where the right implementation is chosen
92 ;; at run time based on CPU features (starting from 3.1.)
93 `(cons "--enable-fat" ,flags))))))