gnu: Add kanatest.
[jackhill/guix/guix.git] / gnu / packages / education.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
3 ;;; Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
4 ;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
5 ;;; Copyright © 2017, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
6 ;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
7 ;;; Copyright © 2018, 2019, 2020, 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
8 ;;; Copyright © 2020 Robert Smith <robertsmith@posteo.net>
9 ;;; Copyright © 2020 Guy Fleury Iteriteka <gfleury@disroot.org>
10 ;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
11 ;;; Copyright © 2020 Prafulla Giri <pratheblackdiamond@gmail.com>
12 ;;; Copyright © 2021 Nicolò Balzarotti <nicolo@nixo.xyz>
13 ;;;
14 ;;; This file is part of GNU Guix.
15 ;;;
16 ;;; GNU Guix is free software; you can redistribute it and/or modify it
17 ;;; under the terms of the GNU General Public License as published by
18 ;;; the Free Software Foundation; either version 3 of the License, or (at
19 ;;; your option) any later version.
20 ;;;
21 ;;; GNU Guix is distributed in the hope that it will be useful, but
22 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
23 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
24 ;;; GNU General Public License for more details.
25 ;;;
26 ;;; You should have received a copy of the GNU General Public License
27 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
28
29 (define-module (gnu packages education)
30 #:use-module (ice-9 regex)
31 #:use-module (gnu packages)
32 #:use-module (gnu packages audio)
33 #:use-module (gnu packages base)
34 #:use-module (gnu packages bash)
35 #:use-module (gnu packages compression)
36 #:use-module (gnu packages curl)
37 #:use-module (gnu packages databases)
38 #:use-module (gnu packages flex)
39 #:use-module (gnu packages fonts)
40 #:use-module (gnu packages freedesktop)
41 #:use-module (gnu packages game-development)
42 #:use-module (gnu packages gettext)
43 #:use-module (gnu packages glib)
44 #:use-module (gnu packages gnome)
45 #:use-module (gnu packages golang)
46 #:use-module (gnu packages gtk)
47 #:use-module (gnu packages image)
48 #:use-module (gnu packages javascript)
49 #:use-module (gnu packages kde)
50 #:use-module (gnu packages kde-frameworks) ; extra-cmake-modules
51 #:use-module (gnu packages mp3)
52 #:use-module (gnu packages ncurses)
53 #:use-module (gnu packages perl)
54 #:use-module (gnu packages pkg-config)
55 #:use-module (gnu packages python)
56 #:use-module (gnu packages python-web)
57 #:use-module (gnu packages python-xyz)
58 #:use-module (gnu packages qt)
59 #:use-module (gnu packages readline)
60 #:use-module (gnu packages sdl)
61 #:use-module (gnu packages sqlite)
62 #:use-module (gnu packages texinfo)
63 #:use-module (gnu packages tls)
64 #:use-module (gnu packages video)
65 #:use-module (gnu packages xorg)
66 #:use-module (gnu packages xml)
67 #:use-module ((guix licenses) #:prefix license:)
68 #:use-module (guix packages)
69 #:use-module (guix download)
70 #:use-module (guix git-download)
71 #:use-module (guix svn-download)
72 #:use-module (guix utils)
73 #:use-module (guix build-system cmake)
74 #:use-module (guix build-system gnu)
75 #:use-module (guix build-system go)
76 #:use-module (guix build-system python)
77 #:use-module (guix build-system qt)
78 #:use-module (guix build-system trivial)
79 #:use-module (srfi srfi-1))
80
81 (define-public gcompris
82 (package
83 (name "gcompris")
84 (version "17.05")
85 (source (origin
86 (method url-fetch)
87 (uri (string-append "http://gcompris.net/download/gtk/src/gcompris-"
88 version ".tar.bz2"))
89 (sha256
90 (base32
91 "18y483alb4r4vfmh80nnl0pah5gv0b8frcm6l1drb9njn5xlcpgc"))))
92 (build-system gnu-build-system)
93 (arguments
94 `(#:configure-flags
95 ;; Use SDL mixer because otherwise GCompris would need an old version
96 ;; of Gstreamer.
97 (list "--enable-sdlmixer"
98 "LDFLAGS=-lgmodule-2.0")
99 #:phases
100 (modify-phases %standard-phases
101 (add-after 'set-paths 'set-sdl-paths
102 (lambda* (#:key inputs #:allow-other-keys)
103 (setenv "CPATH"
104 (string-append (assoc-ref inputs "sdl-mixer")
105 "/include/SDL:"
106 (or (getenv "CPATH") "")))
107 #t)))))
108 (inputs
109 `(("gtk+" ,gtk+-2)
110 ("librsvg" ,librsvg)
111 ("libxml2" ,libxml2)
112 ("sdl-mixer" ,sdl-mixer)
113 ("sqlite" ,sqlite)
114 ("glib:bin" ,glib)
115 ("python" ,python)))
116 (native-inputs
117 `(("intltool" ,intltool)
118 ("texinfo" ,texinfo)
119 ("texi2html" ,texi2html)
120 ("glib:bin" ,glib "bin")
121 ("pkg-config" ,pkg-config)))
122 (home-page "https://gcompris.net")
123 (synopsis "Educational software suite")
124 (description "GCompris is an educational software suite comprising of
125 numerous activities for children aged 2 to 10. Some of the activities are
126 game orientated, but nonetheless still educational. Below you can find a list
127 of categories with some of the activities available in that category.
128
129 @enumerate
130 @item computer discovery: keyboard, mouse, different mouse gestures, ...
131 @item arithmetic: table memory, enumeration, double entry table, mirror image, ...
132 @item science: the canal lock, the water cycle, the submarine, electric simulation ...
133 @item geography: place the country on the map
134 @item games: chess, memory, connect 4, oware, sudoku ...
135 @item reading: reading practice
136 @item other: learn to tell time, puzzle of famous paintings, vector drawing, cartoon making, ...
137 @end enumerate
138 ")
139 (license license:gpl3+)))
140
141 (define-public gcompris-qt
142 (package
143 (name "gcompris-qt")
144 (version "1.0")
145 (source
146 (origin
147 (method url-fetch)
148 (uri (string-append
149 "https://gcompris.net/download/qt/src/gcompris-qt-"
150 version ".tar.xz"))
151 (sha256
152 (base32 "08dw1q0h4qz2q0ksa5pbmb9v60hr1zv9skx6z8dlq9b1i7harnds"))))
153 (build-system cmake-build-system)
154 (arguments
155 `(#:phases
156 (modify-phases %standard-phases
157 (add-before 'check 'start-xorg-server
158 (lambda* (#:key inputs #:allow-other-keys)
159 ;; The test suite requires a running X server.
160 (system (string-append (assoc-ref inputs "xorg-server")
161 "/bin/Xvfb :1 &"))
162 (setenv "DISPLAY" ":1")
163 ;; The test suite wants to write to /homeless-shelter
164 (setenv "HOME" (getcwd))
165 #t))
166 (add-after 'install 'wrap-executable
167 (lambda* (#:key inputs outputs #:allow-other-keys)
168 (let ((out (assoc-ref outputs "out")))
169 (wrap-program (string-append out "/bin/gcompris-qt")
170 `("QT_PLUGIN_PATH" ":" prefix
171 ,(map (lambda (label)
172 (string-append (assoc-ref inputs label)
173 "/lib/qt5/plugins"))
174 '("qtbase" "qtdeclarative" "qtmultimedia" "qtsvg")))
175 `("QML2_IMPORT_PATH" ":" prefix
176 ,(map (lambda (label)
177 (string-append (assoc-ref inputs label)
178 "/lib/qt5/qml"))
179 '("qtdeclarative" "qtgraphicaleffects"
180 "qtmultimedia" "qtquickcontrols"))))
181 #t))))
182 #:configure-flags (list "-DQML_BOX2D_MODULE=disabled"
183 "-DBUILD_TESTING=TRUE")))
184 (native-inputs
185 `(("extra-cmake-modules" ,extra-cmake-modules)
186 ("gettext" ,gettext-minimal)
187 ("kdoctools" ,kdoctools)
188 ("perl" ,perl)
189 ("qttools" ,qttools)
190 ("xorg-server" ,xorg-server-for-tests)))
191 (inputs
192 `(("openssl" ,openssl)
193 ("python" ,python-wrapper)
194 ("qtbase" ,qtbase)
195 ("qtdeclarative" ,qtdeclarative)
196 ("qtgraphicaleffects" ,qtgraphicaleffects)
197 ("qtmultimedia" ,qtmultimedia)
198 ("qtquickcontrols" ,qtquickcontrols)
199 ("qtsensors" ,qtsensors)
200 ("qtsvg" ,qtsvg)
201 ("qtxmlpatterns" ,qtxmlpatterns)))
202 (home-page "https://gcompris.net/index-en.html")
203 (synopsis "Educational games for small children")
204 (description
205 "Gcompris offers a large collection of educational games for small
206 children, designed to be a unified interface to integrate more educational
207 games. Language-oriented games contain vocabulary, sounds, and voices for
208 many different languages.
209 Currently available boards include:
210 @enumerate
211 @item learning how to use a mouse and keyboard
212 @item learning simple arithmetic
213 @item learning how to read an analog clock
214 @item recognize letters after hearing their names
215 @item reading practice
216 @item small games (memory games, jigsaw puzzles, ...)
217 @end enumerate\n")
218 (license (list license:silofl1.1 ; bundled fonts
219 license:gpl3+))))
220
221 (define-public tipp10
222 (package
223 (name "tipp10")
224 (version "2.1.0")
225 (source (origin
226 (method url-fetch)
227 ;; guix download is not able to handle the download links on the
228 ;; home-page, which use '<meta http-equiv="refresh" …>'
229 (uri (string-append "mirror://debian/pool/main/"
230 "t/tipp10/tipp10_2.1.0.orig.tar.gz"))
231 (sha256
232 (base32
233 "0d387b404j88gsv6kv0rb7wxr23v5g5vl6s5l7602x8pxf7slbbx"))
234 ;; Apply patches in the order determined by Debian
235 (patches (search-patches "tipp10-fix-compiling.patch"
236 "tipp10-remove-license-code.patch"
237 "tipp10-disable-downloader.patch"
238 "tipp10-qt5.patch"))))
239 (build-system cmake-build-system)
240 (arguments
241 `(#:tests? #f ; packages has no tests
242 #:phases
243 (modify-phases %standard-phases
244 (add-after 'unpack 'disable-new-version-check
245 (lambda _
246 ;; Make new version check to default to false.
247 ;; TODO: Remove the checkbox from the dialog and the check itself
248 (substitute* '("widget/settingspages.cpp" "widget/mainwindow.cpp")
249 (("settings.value(\"check_new_version\", true)")
250 "settings.value(\"check_new_version\", false)"))
251 #t))
252 (replace 'configure
253 (lambda* (#:key outputs #:allow-other-keys)
254 (let ((out (assoc-ref outputs "out")))
255 ;; Make program honor $PREFIX
256 (substitute* "tipp10.pro"
257 (("\\.path = /usr/") (string-append ".path = " out "/")))
258 (substitute* "def/defines.h"
259 (("\"/usr/") (string-append "\"" out "/")))
260 ;; Recreate Makefile
261 (invoke "qmake")))))))
262 (inputs
263 `(("qtbase" ,qtbase)
264 ("qtmultimedia" ,qtmultimedia)))
265 (home-page "https://www.tipp10.com/")
266 (synopsis "Touch typing tutor")
267 (description "Tipp10 is a touch typing tutor. The ingenious thing about
268 the software is its intelligence feature: characters that are mistyped are
269 repeated more frequently. Beginners will find their way around right away so
270 they can start practicing without a hitch.
271
272 Useful support functions and an extensive progress tracker, topical lessons
273 and the ability to create your own practice lessons make learning to type
274 easy.")
275 (license license:gpl2)))
276
277 (define-public snap
278 (package
279 (name "snap")
280 (version "6.6.0")
281 (source
282 (origin
283 (method git-fetch)
284 (uri (git-reference
285 (url "https://github.com/jmoenig/Snap")
286 (commit (string-append "v" version))))
287 (file-name (git-file-name name version))
288 (sha256
289 (base32 "1k0j0sp6zz2hnh7zc7f086zc3sld01h7sk277j6fak914yv6slzy"))))
290 (build-system trivial-build-system)
291 (arguments
292 `(#:modules ((guix build utils))
293 #:builder
294 (begin
295 (use-modules (guix build utils))
296 (let* ((source (assoc-ref %build-inputs "source"))
297 (out (assoc-ref %outputs "out"))
298 (share (string-append out "/share/snap")))
299 (copy-recursively source share)
300 ;; Replace the sole minified file in the package.
301 (with-directory-excursion (string-append share "/src")
302 (delete-file "FileSaver.min.js")
303 (symlink (string-append (assoc-ref %build-inputs "js-filesaver")
304 "/share/javascript/FileSaver.min.js")
305 "FileSaver.min.js"))
306 ;; Create a "snap" executable.
307 (let* ((bin (string-append out "/bin"))
308 (script (string-append bin "/snap"))
309 (snap (string-append share "/snap.html"))
310 (bash (string-append (assoc-ref %build-inputs "bash")
311 "/bin/sh"))
312 (xdg-open (string-append (assoc-ref %build-inputs "xdg-utils")
313 "/bin/xdg-open")))
314 (mkdir-p bin)
315 (call-with-output-file script
316 (lambda (port)
317 (format port "#!~a\n~a '~a'" bash xdg-open snap)))
318 (chmod script #o555)))
319 #t)))
320 (inputs
321 `(("bash" ,bash-minimal)
322 ("js-filesaver" ,js-filesaver)
323 ("xdg-utils" ,xdg-utils)))
324 (home-page "https://snap.berkeley.edu")
325 (synopsis "Visual, blocks based programming language")
326 (description "Snap! (formerly BYOB) is a visual, drag-and-drop
327 programming language. It is an extended reimplementation of Scratch (a
328 project of the Lifelong Kindergarten Group at the MIT Media Lab) that
329 allows you to Build Your Own Blocks. It also features first class
330 lists, first class procedures, and continuations. These added
331 capabilities make it suitable for a serious introduction to computer
332 science for high school or college students.
333
334 This package provides a @command{snap} executable calling @command{xdg-open}
335 to open the application in a web browser, for offline usage.")
336 (license license:agpl3+)))
337
338 (define-public toutenclic
339 (package
340 (name "toutenclic")
341 (version "7.00")
342 (source
343 (origin
344 (method url-fetch)
345 (uri (string-append "http://www.bipede.fr/downloads/logiciels/"
346 "ToutEnClic-" version "-src.zip"))
347 (sha256
348 (base32 "0xg24p925rl5bfqsq3jb2lrkidb0f3kbmay5iyxxmjsn3ra0blyh"))))
349 (build-system python-build-system)
350 (arguments
351 `(#:tests? #f ; no tests
352 #:phases
353 (modify-phases %standard-phases
354 (delete 'build)
355 (replace 'install
356 (lambda* (#:key outputs #:allow-other-keys)
357 (let* ((out (assoc-ref outputs "out"))
358 (share (string-append out "/share/toutenclic"))
359 (pixmaps (string-append out "/share/pixmaps"))
360 (doc (string-append out "share/doc/" ,name "-" ,version))
361 (bin (string-append out "/bin"))
362 (executable "toutenclic"))
363 ;; Install icon.
364 (install-file "toutenclic.png" pixmaps)
365 ;; Move files into "share/" directory.
366 (for-each (lambda (f) (install-file f share))
367 (find-files "." "\\.py$"))
368 ;; Install documentation.
369 (install-file "ToutEnClic.pdf" doc)
370 ;; Create executable in "bin/".
371 (mkdir-p bin)
372 (with-directory-excursion bin
373 (symlink (string-append share "/" executable ".py")
374 executable)))
375 #t))
376 (add-after 'install 'create-desktop-file
377 (lambda* (#:key outputs #:allow-other-keys)
378 (let* ((out (assoc-ref outputs "out"))
379 (applications (string-append out "/share/applications")))
380 (mkdir-p applications)
381 (call-with-output-file
382 (string-append applications "/toutenclic.desktop")
383 (lambda (file)
384 (format file
385 "[Desktop Entry]~@
386 Name=ToutEnClic~@
387 Comment=For schooling without difference~@
388 Exec=~a/bin/toutenclic~@
389 TryExec=~@*~a/bin/toutenclic~@
390 Terminal=false~@
391 Icon=toutenclic~@
392 Type=Application~%"
393 out)))
394 #t))))))
395 (native-inputs
396 `(("unzip" ,unzip)))
397 (inputs
398 `(("python-pyqt" ,python-pyqt)))
399 (synopsis "School tools for physically disabled children")
400 (description "ToutEnClic is intended to facilitate the schooling
401 of physically disabled children in ordinary schools. It is both
402 a multi-page virtual exercise book and a kit including pencil,
403 scissors, glue, ruler, compass, protractor and square. A virtual
404 keyboard is also available if the child does not have any other
405 specialized device.")
406 (home-page "https://bipede.fr/contrib/")
407 (license license:gpl3)))
408
409 (define-public childsplay
410 (package
411 (name "childsplay")
412 (version "3.4")
413 (source (origin
414 (method url-fetch)
415 (uri (string-append
416 "mirror://sourceforge/schoolsplay/"
417 "childsplay-" version ".tgz"))
418 (sha256
419 (base32
420 "0z7yp2swjnbz51vn2zyfnjn40jq38l5mbh15yafmx1z3vn2z1m77"))))
421 (build-system python-build-system)
422 (arguments
423 `(#:python ,python-2
424 #:tests? #f
425 #:phases
426 (modify-phases %standard-phases
427 (add-after 'unpack 'unbundle-dejavu-font
428 (lambda* (#:key inputs #:allow-other-keys)
429 (let* ((dejavu-dir
430 (string-append (assoc-ref inputs "font-dejavu")
431 "/share/fonts/truetype"))
432 (dejavu-font
433 (string-append dejavu-dir
434 "/DejaVuSansCondensed-Bold.ttf")))
435 (substitute* "SPConstants.py"
436 (("^(TTF(BOLD)? = ).*" _ prefix)
437 (string-append prefix "'" dejavu-font "'\n")))
438 (for-each (lambda (f) (delete-file f))
439 (find-files "lib/SPData" "DejaVu"))
440 #t)))
441 (delete 'build)
442 (replace 'install
443 (lambda* (#:key outputs #:allow-other-keys)
444 (let* ((out (assoc-ref outputs "out"))
445 (pixmaps (string-append out "/share/pixmaps"))
446 (share (string-append out "/share/childsplay"))
447 (doc (string-append out "/share/doc/" ,name "-",version)))
448 ;; Install icon.
449 (install-file "lib/SPData/themes/childsplay/logo_cp.svg" pixmaps)
450 ;; Install data.
451 (mkdir-p share)
452 (for-each (lambda (f)
453 (copy-recursively f (string-append share "/" f)))
454 '("alphabet-sounds" "lib" "locale" "SPWidgets"))
455 (for-each (lambda (f) (install-file f share))
456 (find-files "." "\\.(py|dev|db)$"))
457 ;; Install documentation.
458 (mkdir-p doc)
459 (copy-recursively "docs" doc)
460 #t)))
461 (add-after 'install 'create-executable
462 (lambda* (#:key outputs inputs #:allow-other-keys)
463 (let* ((python (string-append (assoc-ref inputs "python")
464 "/bin/python"))
465 (out (assoc-ref outputs "out"))
466 (bin (string-append out "/bin"))
467 (executable (string-append bin "/childsplay")))
468 (mkdir-p bin)
469 (call-with-output-file executable
470 (lambda (file)
471 (format file
472 "~a ~a"
473 python
474 (string-append out "/share/childsplay/childsplay.py"))))
475 (chmod executable #o555)
476 #t)))
477 (add-after 'install 'create-desktop-file
478 (lambda* (#:key outputs #:allow-other-keys)
479 (let* ((out (assoc-ref outputs "out"))
480 (applications (string-append out "/share/applications")))
481 (mkdir-p applications)
482 (call-with-output-file
483 (string-append applications "/childsplay.desktop")
484 (lambda (file)
485 (format file
486 "[Desktop Entry]~@
487 Name=Childsplay~@
488 Comment=Suite of educational games for young children~@
489 Comment[ca]=Conjunt de jocs educatius per a xiquets~@
490 Comment[es]=Conjunto de juegos educativos para niños~@
491 Comment[de]=Sammlung mit lehrreichen Spielen für kleine Kinder~@
492 Exec=~a/bin/childsplay~@
493 Terminal=false~@
494 Icon=logo_cp.svg~@
495 Type=Application~@
496 Categories=Application;Game;Education;KidsGame;~@
497 Keywords=suite;children;games;young;educational;~%"
498 out)))
499 #t))))))
500 (inputs
501 `(("font-dejavu" ,font-dejavu)
502 ("pygame" ,python2-pygame)
503 ("sqlalchemy" ,python2-sqlalchemy)))
504 (synopsis "Suite of educational games for young children")
505 (description "Childsplay is a collection of educational activities
506 for young children. Childsplay can be used at home, kindergartens and
507 pre-schools. Childsplay is a fun and safe way to let young children
508 use the computer and at the same time teach them a little math,
509 letters of the alphabet, spelling, eye-hand coordination, etc.")
510 (home-page "http://www.schoolsplay.org")
511 (license license:gpl3+)))
512
513 (define-public omnitux
514 (package
515 (name "omnitux")
516 (version "1.2.1")
517 (source
518 (origin
519 (method url-fetch)
520 (uri (string-append "mirror://sourceforge/omnitux/omnitux/"
521 "v" version "/omnitux-" version ".tar.bz2"))
522 (sha256
523 (base32 "1wmmmbzmxd0blhn00d4g91xwavnab143a31ca3i8hrqgzh6qz9w6"))
524 (modules '((guix build utils)))
525 (snippet
526 '(begin
527 ;; Remove pre-compiled .pyc files from source.
528 (for-each delete-file (find-files "bin" "\\.pyc$"))
529 #t))))
530 (build-system python-build-system)
531 (inputs
532 `(("python2-pygame" ,python2-pygame)
533 ("python2-pygtk" ,python2-pygtk)))
534 (arguments
535 `(#:tests? #f ;no test
536 #:python ,python-2
537 #:phases
538 (modify-phases %standard-phases
539 (delete 'build) ;no setup.py
540 (replace 'install
541 (lambda* (#:key outputs #:allow-other-keys)
542 (let* ((out (assoc-ref outputs "out"))
543 (share (string-append out "/share"))
544 (data (string-append share "/omnitux")))
545 ;; Install documentation.
546 (let ((doc (string-append share "/doc/" ,name "-" ,version)))
547 (for-each (lambda (f) (install-file f doc))
548 '("LICENSE.txt" "README.txt")))
549 ;; Install data.
550 (install-file "omnitux.sh" data)
551 (for-each (lambda (d)
552 (copy-recursively d (string-append data "/" d)))
553 '("bin" "data"))
554 ;; Install the launcher.
555 (let* ((bin (string-append out "/bin"))
556 (script (string-append bin "/omnitux"))
557 (bash (string-append (assoc-ref %build-inputs "bash")
558 "/bin/bash"))
559 (python (string-append (assoc-ref %build-inputs "python")
560 "/bin/python2")))
561 (mkdir-p bin)
562 (with-output-to-file script
563 (lambda ()
564 (format #t "#!~a~%" bash)
565 (format #t
566 "cd ~a; ~a menu.py~%"
567 (string-append data "/bin")
568 python)))
569 (chmod script #o755))
570 ;; Install icon and desktop file.
571 (let ((pixmaps (string-append share "/pixmaps")))
572 (install-file "data/default/icons/Omnitux_logo.svg" pixmaps))
573 (let ((apps (string-append out "/share/applications")))
574 (mkdir-p apps)
575 (with-output-to-file (string-append apps "/omnitux.desktop")
576 (lambda _
577 (format #t
578 "[Desktop Entry]~@
579 Name=Omnitux~@
580 GenericName=Omnitux
581 Comment=An educational game based on multimedia elements.~@
582 Comment[fr]=Un jeu ludo-éducatif basé sur des éléments multimédias.~@
583 Exec=~a/bin/omnitux~@
584 Type=Application~@
585 Categories=Game;Education;~@
586 Terminal=false~@
587 Icon=Omnitux_logo.svg~@"
588 out))))
589 #t))))))
590 (home-page "http://omnitux.sourceforge.net/")
591 (synopsis "Educational activities based on multimedia elements")
592 (description "The project aims to provide various educational
593 activities around multimedia elements (images, sounds, texts). Types
594 of activities include:
595 @itemize
596 @item associations,
597 @item items to place on a map or a schema,
598 @item counting activities,
599 @item puzzles,
600 @item card faces to remember,
601 @item find differences between two pictures,
602 @item ...
603 @end itemize
604
605 Activities are available in English, French, German, Polish,
606 Portuguese, Spanish and Italian.")
607 ;; Project's license is GPL3+, but multimedia elements are
608 ;; released under various licenses.
609 (license (list license:gpl3+
610 license:gpl2+
611 license:cc-by-sa2.0
612 license:cc-by-sa3.0
613 license:public-domain))))
614
615 (define-public fet
616 (package
617 (name "fet")
618 (version "6.0.2")
619 (source
620 (origin
621 (method url-fetch)
622 (uri (string-append "https://www.lalescu.ro/liviu/fet/download/"
623 "fet-" version ".tar.bz2"))
624 (sha256
625 (base32 "08q265i43bnj9syh3xlp11fr47xmzb0nma3nnwm76xq314102f0f"))))
626 (build-system gnu-build-system)
627 (arguments
628 `(#:phases
629 (modify-phases %standard-phases
630 (add-after 'unpack 'fix-hardcoded-directories
631 (lambda* (#:key outputs #:allow-other-keys)
632 (substitute* (list "fet.pro"
633 "src/src.pro"
634 "src/src-cl.pro"
635 "src/interface/fet.cpp")
636 (("/usr") (assoc-ref outputs "out")))
637 #t))
638 (replace 'configure
639 (lambda _ (invoke "qmake" "fet.pro"))))))
640 (inputs
641 `(("qtbase" ,qtbase)))
642 (home-page "https://www.lalescu.ro/liviu/fet/")
643 (synopsis "Timetabling software")
644 (description
645 "FET is a program for automatically scheduling the timetable of a school,
646 high-school or university. It uses a fast and efficient timetabling
647 algorithm.
648
649 Usually, FET is able to solve a complicated timetable in maximum 5-20 minutes.
650 For extremely difficult timetables, it may take a longer time, a matter of
651 hours.")
652 (license license:agpl3+)))
653
654 (define-public klavaro
655 (package
656 (name "klavaro")
657 (version "3.12")
658 (source
659 (origin
660 (method url-fetch)
661 (uri (string-append "mirror://sourceforge/klavaro/klavaro-"
662 version ".tar.bz2"))
663 (sha256
664 (base32 "0ymrmgllyjk9wp1f1ayw51xc3myar8ld9a5531wdbrym0xzy4l64"))))
665 (build-system gnu-build-system)
666 (native-inputs
667 `(("intltool" ,intltool)
668 ("pkg-config" ,pkg-config)))
669 (inputs
670 `(("cairo" ,cairo)
671 ("curl" ,curl)
672 ("gtk+" ,gtk+)
673 ("gtkdatabox" ,gtkdatabox)
674 ("pango" ,pango)))
675 (home-page "https://klavaro.sourceforge.io/en/index.html")
676 (synopsis "Touch typing tutor")
677 (description
678 "Klavaro is a simple tutor to teach correct typing, almost independently of
679 language and very flexible regarding to new or unknown keyboard layouts.")
680 (license license:gpl3+)))
681
682 (define-public ktouch
683 (package
684 (name "ktouch")
685 (version "20.12.1")
686 (source
687 (origin
688 (method url-fetch)
689 (uri (string-append "mirror://kde/stable/release-service/"
690 version "/src/ktouch-" version ".tar.xz"))
691 (sha256
692 (base32 "10lm2p8w26c9n6lhvw3301myfss0dq7hl7rawzb3hsy1lqvmvdib"))))
693 (build-system qt-build-system)
694 (native-inputs
695 `(("extra-cmake-modules" ,extra-cmake-modules)
696 ("kdoctools" ,kdoctools)
697 ("pkg-config" ,pkg-config)))
698 (inputs
699 `(("kcmutils" ,kcmutils)
700 ("kcompletion" ,kcompletion)
701 ("kconfig" ,kconfig)
702 ("kconfigwidgets" ,kconfigwidgets)
703 ("kcoreaddons" ,kcoreaddons)
704 ("kdeclarative" ,kdeclarative)
705 ("ki18n" ,ki18n)
706 ("kiconthemes" ,kiconthemes)
707 ("kitemviews" ,kitemviews)
708 ("kqtquickcharts" ,kqtquickcharts)
709 ("ktextwidgets" ,ktextwidgets)
710 ("kwidgetsaddons" ,kwidgetsaddons)
711 ("kwindowsystem" ,kwindowsystem)
712 ("kxmlgui" ,kxmlgui)
713 ("libxcb" ,libxcb)
714 ("libxkbfile" ,libxkbfile)
715 ("qtbase" ,qtbase)
716 ("qtdeclarative" ,qtdeclarative)
717 ("qtgraphicaleffects" ,qtgraphicaleffects)
718 ("qtquickcontrols2" ,qtquickcontrols2)
719 ("qtx11extras" ,qtx11extras)
720 ("qtxmlpatterns" ,qtxmlpatterns)))
721 (home-page "https://edu.kde.org/ktouch/")
722 (synopsis "Touch typing tutor")
723 (description
724 "KTouch is an aid for learning how to type with speed and accuracy. It
725 provides a sample text to type and indicates which fingers should be used for
726 each key. A collection of lessons are included for a wide range of different
727 languages and keyboard layouts, and typing statistics are used to dynamically
728 adjust the level of difficulty.")
729 (license license:gpl2)))
730
731 (define-public kanatest
732 ;; Latest release tarball is 0.4.8, which is really old and does not build
733 ;; commit on sourceforge are not tagged, we take the latest
734 (let ((commit "860e790a35f547cc96669f805d371a5ba3d8daff")
735 (revision "0"))
736 (package
737 (name "kanatest")
738 (version (git-version "0.4.10" revision commit))
739 (source
740 (origin
741 (method git-fetch)
742 (uri (git-reference
743 (url "https://git.code.sf.net/p/kanatest/code")
744 (commit commit)))
745 (file-name (git-file-name name version))
746 (sha256
747 (base32 "0dz63m9p4ggzw0yb309qmgnl664qb5q268vaa3i9v0i8qsl66d78"))))
748 (build-system gnu-build-system)
749 (native-inputs
750 `(("gettext" ,gettext-minimal) ; for msgfmt
751 ("pkg-config" ,pkg-config)))
752 (inputs
753 `(("libxml2" ,libxml2)
754 ("gtk+" ,gtk+)))
755 (home-page "https://kanatest.sourceforge.io/")
756 (synopsis "Hiragana and Katakana simple flashcard tool")
757 (description "Kanatest is a Japanese kana (Hiragana and Katakana) simple
758 flashcard tool.
759
760 During test the Kanatest displays randomly selected kana char (respecting mode
761 and lesson) and waits for user answer expected as romaji equivalent. This
762 process continues until all questions will be answered or all questions will
763 be answered correctly (depends on options). At the end of test a short info
764 about drilling time and correctness ratio is displayed. The results are
765 stored and user can review his performance in any time.")
766 (license license:gpl2+))))
767
768 (define-public anki
769 (package
770 (name "anki")
771 ;; Later versions have dependencies on npm packages not yet in Guix.
772 (version "2.1.16")
773 (source
774 (origin
775 (method url-fetch)
776 (uri (string-append "https://apps.ankiweb.net/downloads/archive/anki-"
777 version "-source.tgz"))
778 (sha256
779 (base32 "1gfr51rnllkyzli73p4r51h5ypzfa3m7lic3m3rzpywmqwrxs07k"))
780 (patches (search-patches "anki-mpv-args.patch"))))
781 (build-system gnu-build-system)
782 (arguments
783 `(#:make-flags (list (string-append "PREFIX=" %output))
784 #:tests? #f ;no check target
785 #:modules ((guix build gnu-build-system)
786 (guix build utils)
787 (ice-9 match))
788 #:phases
789 (modify-phases %standard-phases
790 (add-after 'unpack 'disable-update-check
791 ;; Don't ‘phone home’ unasked to check for updates.
792 (lambda _
793 (substitute* "aqt/update.py"
794 (("requests\\.post")
795 "throw.an.exception.instead"))
796 #t))
797 (delete 'configure) ;no configure script
798 (add-after 'install 'wrap
799 (lambda* (#:key inputs outputs #:allow-other-keys)
800 (let ((bin (string-append (assoc-ref outputs "out") "/bin"))
801 ;; List of paths to the site-packages directories of Python
802 ;; library inputs.
803 (site-packages
804 (map (lambda (pyinput)
805 (string-append
806 (cdr pyinput)
807 "/lib/python"
808 ;; Calculate the python version to avoid breaking
809 ;; with future 3.X releases.
810 ,(version-major+minor
811 (package-version python-wrapper))
812 "/site-packages"))
813 (filter (match-lambda
814 ((label . _)
815 (string-prefix? "python-" label)))
816 inputs)))
817 (qtwebengineprocess
818 (string-append (assoc-ref inputs "qtwebengine")
819 "/lib/qt5/libexec/QtWebEngineProcess")))
820 ;; The program fails to find the QtWebEngineProcess program, so
821 ;; we set QTWEBENGINEPROCESS_PATH to help it. PYTHONPATH is
822 ;; wrapped to avoid declaring Python libraries as propagated
823 ;; inputs.
824 (for-each (lambda (program)
825 (wrap-program program
826 `("QTWEBENGINEPROCESS_PATH" =
827 (,qtwebengineprocess))
828 `("PATH" prefix (,(string-append
829 (assoc-ref inputs "mpv")
830 "/bin")))
831 `("PYTHONPATH" = ,site-packages)))
832 (find-files bin ".")))
833 #t)))))
834 (native-inputs
835 `(("xdg-utils" ,xdg-utils)))
836 (inputs
837 `(("lame" ,lame)
838 ("mpv" ,mpv)
839 ("python" ,python-wrapper)
840 ("python-beautifulsoup4" ,python-beautifulsoup4)
841 ("python-decorator" ,python-decorator)
842 ("python-distro" ,python-distro)
843 ("python-jsonschema" ,python-jsonschema)
844 ("python-markdown" ,python-markdown)
845 ("python-pyaudio" ,python-pyaudio)
846 ;; `python-pyqtwebengine' must precede `python-pyqt' in PYTHONPATH.
847 ("python-pyqtwebengine" ,python-pyqtwebengine)
848 ("python-pyqt" ,python-pyqt)
849 ("python-requests" ,python-requests)
850 ("python-send2trash" ,python-send2trash)
851 ("python-sip" ,python-sip)
852 ;; `qtwebengine' is included in `pyqtwebengine', included here for easy
853 ;; wrapping.
854 ("qtwebengine" ,qtwebengine)))
855 (home-page "https://apps.ankiweb.net/")
856 (synopsis "Powerful, intelligent flash cards")
857 (description "Anki is a program which makes remembering things
858 easy. Because it's a lot more efficient than traditional study
859 methods, you can either greatly decrease your time spent studying, or
860 greatly increase the amount you learn.
861
862 Anyone who needs to remember things in their daily life can benefit
863 from Anki. Since it is content-agnostic and supports images, audio,
864 videos and scientific markup (via LaTeX), the possibilities are
865 endless. For example:
866 @itemize
867 @item Learning a language
868 @item Studying for medical and law exams
869 @item Memorizing people's names and faces
870 @item Brushing up on geography
871 @item Mastering long poems
872 @item Even practicing guitar chords!
873 @end itemize")
874 (license license:agpl3+)))
875
876 (define-public t4k-common
877 (package
878 (name "t4k-common")
879 (version "0.1.1")
880 (source
881 (origin
882 (method git-fetch)
883 (uri (git-reference
884 (url "https://github.com/tux4kids/t4kcommon")
885 (commit (string-append "upstream/" version))))
886 (file-name (git-file-name name version))
887 (sha256
888 (base32 "13q02xpmps9qg8zrzzy2gzv4a6afgi28lxk4z242j780v0gphchp"))
889 (patches
890 (search-patches "t4k-common-libpng16.patch"))))
891 (build-system cmake-build-system)
892 (arguments
893 `(#:tests? #f ;FIXME: cannot find how to run tests
894 #:phases
895 (modify-phases %standard-phases
896 (add-after 'set-paths 'set-sdl-paths
897 (lambda* (#:key inputs #:allow-other-keys)
898 (setenv "CPATH" (string-append (assoc-ref inputs "sdl")
899 "/include/SDL:"
900 (or (getenv "CPATH") "")))))
901 (add-after 'unpack 'fix-andika-font-path
902 (lambda* (#:key inputs #:allow-other-keys)
903 (substitute* "src/t4k_sdl.c"
904 (("(/usr/share/.*?)/AndikaDesRevG\\.ttf")
905 (string-append (assoc-ref inputs "font-andika")
906 "/share/fonts/truetype")))
907 #t)))))
908 (native-inputs
909 `(("pkg-config" ,pkg-config)))
910 (inputs
911 `(("font-andika" ,font-sil-andika)
912 ("libpng" ,libpng)
913 ("librsvg" ,librsvg)
914 ("libxml2" ,libxml2)
915 ("sdl" ,(sdl-union (list sdl sdl-image sdl-mixer sdl-net sdl-pango)))))
916 (home-page "https://github.com/tux4kids/t4kcommon")
917 (synopsis "Library of code shared between TuxMath and TuxType")
918 (description "Tux4Kids-Common is a library of code shared between
919 TuxMath and TuxType.")
920 (license license:gpl3+)))
921
922 (define-public tuxmath
923 (package
924 (name "tuxmath")
925 (version "2.0.3")
926 (source
927 (origin
928 (method git-fetch)
929 (uri (git-reference
930 (url "https://github.com/tux4kids/tuxmath")
931 (commit (string-append "upstream/" version))))
932 (file-name (git-file-name name version))
933 (sha256
934 (base32 "1f1pz83w6d3mbik2h6xavfxmk5apxlngxbkh80x0m55lhniwkdxv"))
935 (modules '((guix build utils)))
936 ;; Unbundle fonts.
937 (snippet
938 `(begin
939 (for-each delete-file (find-files "data/fonts" "\\.ttf$"))
940 #t))))
941 (build-system gnu-build-system)
942 (arguments
943 `(#:tests? #f ;no test
944 #:phases
945 (modify-phases %standard-phases
946 (add-after 'set-paths 'set-sdl-paths
947 (lambda* (#:key inputs #:allow-other-keys)
948 (setenv "CPATH"
949 (string-append (assoc-ref inputs "sdl")
950 "/include/SDL:"
951 (or (getenv "CPATH") "")))
952 #t))
953 (add-after 'install 'install-desktop-file
954 (lambda* (#:key outputs #:allow-other-keys)
955 (let* ((out (assoc-ref outputs "out"))
956 (apps (string-append out "/share/applications"))
957 (pixmaps (string-append out "/share/pixmaps")))
958 (install-file "tuxmath.desktop" apps)
959 (for-each (lambda (f) (install-file f pixmaps))
960 (find-files "data/images/icons/"
961 "tuxmath\\.(png|ico|svg)$"))
962 #t))))))
963 (native-inputs
964 `(("pkg-config" ,pkg-config)))
965 (inputs
966 `(("librsvg" ,librsvg)
967 ("libxml2" ,libxml2)
968 ("sdl" ,(sdl-union (list sdl sdl-image sdl-mixer sdl-net sdl-pango)))
969 ("t4k-common" ,t4k-common)))
970 (home-page "https://github.com/tux4kids/tuxmath")
971 (synopsis "Educational math tutorial game")
972 (description "@emph{Tux, of Math Command} is an educational math
973 tutorial game starring Tux, the Linux penguin, in which you play the
974 part of Commander Tux, as he defends his friends from an attack of
975 math equations. Comets are crashing towards the friendly penguins in
976 their igloos, and you must destroy the comets by solving their
977 equations.
978
979 TuxMath also includes Factoroids, a game that gives practice in
980 factoring numbers and simplifying fractions, as well as zapping rocks
981 floating through space.")
982 (license license:gpl3+)))
983
984 (define-public mdk
985 (package
986 (name "mdk")
987 (version "1.3.0")
988 (source
989 (origin
990 (method url-fetch)
991 (uri (string-append "mirror://gnu/mdk/v" version "/mdk-"
992 version ".tar.gz"))
993 (sha256
994 (base32
995 "0bhk3c82kyp8167h71vdpbcr852h5blpnwggcswqqwvvykbms7lb"))))
996 (build-system gnu-build-system)
997 (arguments
998 `(#:configure-flags (list "--enable-gui=yes" "-with-readline=yes")))
999 (native-inputs
1000 `(("flex" ,flex)
1001 ("intltool" ,intltool)
1002 ("pkg-config" ,pkg-config)))
1003 (inputs
1004 `(("glib" ,glib)
1005 ("gtk+" ,gtk+)
1006 ("libglade" ,libglade)
1007 ("ncurses" ,ncurses)
1008 ("pango" ,pango)
1009 ("readline" ,readline)))
1010 (home-page "https://www.gnu.org/software/mdk/manual/")
1011 (synopsis "Virtual development environment for Knuth's MIX")
1012 (description
1013 "GNU MDK is the Mix Development Kit, an emulation of the pedagogical
1014 computer MIX and its assembly language MIXAL. MIX has a virtual CPU with
1015 standard features such as registers, memory cells, an overflow toggle,
1016 comparison flags, input-output devices, and a set of binary instructions.
1017 The package includes a compiler, a virtual machine, a GUI for the virtual
1018 machine, and more.")
1019 (license license:gpl3+)))
1020
1021 (define-public exercism
1022 (package
1023 (name "exercism")
1024 (version "3.0.13")
1025 (source
1026 (origin
1027 (method git-fetch)
1028 (uri (git-reference
1029 (url "https://github.com/exercism/cli")
1030 (commit (string-append "v" version))))
1031 (file-name (git-file-name name version))
1032 (sha256
1033 (base32
1034 "17gvz9a0sn4p36hf4l77bxhhfipf4x998iay31layqwbnzmb4xy7"))
1035 (patches (search-patches "exercism-disable-self-update.patch"))))
1036 (build-system go-build-system)
1037 (arguments
1038 `(#:import-path "github.com/exercism/cli/exercism"
1039 #:unpack-path "github.com/exercism/cli"
1040 #:install-source? #f))
1041 (inputs
1042 `(("github.com/blang/semver" ,go-github-com-blang-semver)
1043 ("github.com/spf13/cobra" ,go-github-com-spf13-cobra)
1044 ("github.com/spf13/pflag" ,go-github-com-spf13-pflag)
1045 ("github.com/spf13/viper" ,go-github-com-spf13-viper)
1046 ("golang.org/x/net" ,go-golang-org-x-net)
1047 ("golang.org/x/text" ,go-golang-org-x-text)))
1048 (home-page "https://exercism.io")
1049 (synopsis "Mentored learning for programming languages")
1050 (description "Commandline client for exercism.io, a free service providing
1051 mentored learning for programming languages.")
1052 (license license:expat)))