gnu: tarlz: Update to 0.21.
[jackhill/guix/guix.git] / gnu / packages / emacs.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2019, 2021 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
4 ;;; Copyright © 2014 Taylan Ulrich Bayirli/Kammer <taylanbayirli@gmail.com>
5 ;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019, 2020 Mark H Weaver <mhw@netris.org>
6 ;;; Copyright © 2014, 2015, 2016, 2017 Alex Kost <alezost@gmail.com>
7 ;;; Copyright © 2016, 2018 Arun Isaac <arunisaac@systemreboot.net>
8 ;;; Copyright © 2016 Federico Beffa <beffa@fbengineering.ch>
9 ;;; Copyright © 2016 David Thompson <dthompson2@worcester.edu>
10 ;;; Copyright © 2016 Nikita <nikita@n0.is>
11 ;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
12 ;;; Copyright © 2017, 2019, 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
13 ;;; Copyright © 2017 Alex Vong <alexvong1995@gmail.com>
14 ;;; Copyright © 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
15 ;;; Copyright © 2017 Jan Nieuwenhuizen <janneke@gnu.org>
16 ;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
17 ;;; Copyright © 2018 Mathieu Othacehe <m.othacehe@gmail.com>
18 ;;; Copyright © 2018, 2019, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
19 ;;; Copyright © 2019 Jesse John Gildersleve <jessejohngildersleve@zohomail.eu>
20 ;;; Copyright © 2019 Valentin Ignatev <valentignatev@gmail.com>
21 ;;; Copyright © 2019 Leo Prikler <leo.prikler@student.tugraz.at>
22 ;;; Copyright © 2019 Amin Bandali <bandali@gnu.org>
23 ;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
24 ;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
25 ;;;
26 ;;; This file is part of GNU Guix.
27 ;;;
28 ;;; GNU Guix is free software; you can redistribute it and/or modify it
29 ;;; under the terms of the GNU General Public License as published by
30 ;;; the Free Software Foundation; either version 3 of the License, or (at
31 ;;; your option) any later version.
32 ;;;
33 ;;; GNU Guix is distributed in the hope that it will be useful, but
34 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
35 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
36 ;;; GNU General Public License for more details.
37 ;;;
38 ;;; You should have received a copy of the GNU General Public License
39 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
40
41 (define-module (gnu packages emacs)
42 #:use-module ((guix licenses) #:prefix license:)
43 #:use-module (guix packages)
44 #:use-module (guix download)
45 #:use-module (guix git-download)
46 #:use-module (guix build-system gnu)
47 #:use-module (guix build-system glib-or-gtk)
48 #:use-module (gnu packages)
49 #:use-module (gnu packages acl)
50 #:use-module (gnu packages autotools)
51 #:use-module (gnu packages base)
52 #:use-module (gnu packages compression)
53 #:use-module (gnu packages fontutils)
54 #:use-module (gnu packages fribidi)
55 #:use-module (gnu packages gd)
56 #:use-module (gnu packages gettext)
57 #:use-module (gnu packages glib)
58 #:use-module (gnu packages gnome) ; for librsvg
59 #:use-module (gnu packages gtk)
60 #:use-module (gnu packages guile)
61 #:use-module (gnu packages image)
62 #:use-module (gnu packages linux) ; alsa-lib, gpm
63 #:use-module (gnu packages mail) ; for mailutils
64 #:use-module (gnu packages multiprecision)
65 #:use-module (gnu packages ncurses)
66 #:use-module (gnu packages pkg-config)
67 #:use-module (gnu packages texinfo)
68 #:use-module (gnu packages tls)
69 #:use-module (gnu packages web) ; for jansson
70 #:use-module (gnu packages webkit)
71 #:use-module (gnu packages xml)
72 #:use-module (gnu packages xorg)
73 #:use-module (guix utils)
74 #:use-module (srfi srfi-1))
75
76 (define-public emacs
77 (package
78 (name "emacs")
79 (version "27.2")
80 (source (origin
81 (method url-fetch)
82 (uri (string-append "mirror://gnu/emacs/emacs-"
83 version ".tar.xz"))
84 (sha256
85 (base32
86 "1ff182gjw9wqsbx1kj5gl2r5pbqhp4ar54g04j33fgz6g17cr9xl"))
87 (patches (search-patches "emacs-exec-path.patch"
88 "emacs-fix-scheme-indent-function.patch"
89 "emacs-ignore-empty-xim-styles.patch"
90 "emacs-source-date-epoch.patch"))
91 (modules '((guix build utils)))
92 (snippet
93 '(with-directory-excursion "lisp"
94 ;; Delete the bundled byte-compiled elisp files and generated
95 ;; autoloads.
96 (for-each delete-file
97 (append (find-files "." "\\.elc$")
98 (find-files "." "loaddefs\\.el$")
99 (find-files "eshell" "^esh-groups\\.el$")))
100
101 ;; Make sure Tramp looks for binaries in the right places on
102 ;; remote Guix System machines, where 'getconf PATH' returns
103 ;; something bogus.
104 (substitute* "net/tramp-sh.el"
105 ;; Patch the line after "(defcustom tramp-remote-path".
106 (("\\(tramp-default-remote-path")
107 (format #f "(tramp-default-remote-path ~s ~s ~s ~s "
108 "~/.guix-profile/bin" "~/.guix-profile/sbin"
109 "/run/current-system/profile/bin"
110 "/run/current-system/profile/sbin")))
111
112 ;; Make sure Man looks for C header files in the right
113 ;; places.
114 (substitute* "man.el"
115 (("\"/usr/local/include\"" line)
116 (string-join
117 (list line
118 "\"~/.guix-profile/include\""
119 "\"/var/guix/profiles/system/profile/include\"")
120 " ")))
121 #t))))
122 (build-system glib-or-gtk-build-system)
123 (arguments
124 `(#:tests? #f ; no check target
125 #:configure-flags (list "--with-modules"
126 "--with-cairo"
127 "--disable-build-details")
128 #:phases
129 (modify-phases %standard-phases
130 (add-after 'unpack 'patch-program-file-names
131 (lambda _
132 (substitute* '("src/callproc.c"
133 "lisp/term.el"
134 "lisp/htmlfontify.el"
135 "lisp/textmodes/artist.el"
136 "lisp/progmodes/sh-script.el")
137 (("\"/bin/sh\"")
138 (format #f "~s" (which "sh"))))
139 #t))
140 (add-before 'configure 'fix-/bin/pwd
141 (lambda _
142 ;; Use `pwd', not `/bin/pwd'.
143 (substitute* (find-files "." "^Makefile\\.in$")
144 (("/bin/pwd")
145 "pwd"))
146 #t))
147 (add-after 'install 'install-site-start
148 ;; Use 'guix-emacs' in "site-start.el", which is used autoload the
149 ;; Elisp packages found in EMACSLOADPATH.
150 (lambda* (#:key inputs outputs #:allow-other-keys)
151 (let* ((out (assoc-ref outputs "out"))
152 (lisp-dir (string-append out "/share/emacs/site-lisp"))
153 (emacs (string-append out "/bin/emacs")))
154
155 ;; This is duplicated from emacs-utils to prevent coupling.
156 (define* (emacs-byte-compile-directory dir)
157 (let ((expr `(progn
158 (setq byte-compile-debug t)
159 (byte-recompile-directory
160 (file-name-as-directory ,dir) 0 1))))
161 (invoke emacs "--quick" "--batch"
162 (format #f "--eval=~s" expr))))
163
164 (copy-file (assoc-ref inputs "guix-emacs.el")
165 (string-append lisp-dir "/guix-emacs.el"))
166 (with-output-to-file (string-append lisp-dir "/site-start.el")
167 (lambda ()
168 (display
169 (string-append "(when (require 'guix-emacs nil t)\n"
170 " (guix-emacs-autoload-packages))\n"))))
171 ;; Remove the extraneous subdirs.el file, as it causes Emacs to
172 ;; add recursively all the the sub-directories of a profile's
173 ;; share/emacs/site-lisp union when added to EMACSLOADPATH,
174 ;; which leads to conflicts.
175 (delete-file (string-append lisp-dir "/subdirs.el"))
176 ;; Byte compile the site-start files.
177 (emacs-byte-compile-directory lisp-dir))
178 #t))
179 (add-after 'glib-or-gtk-wrap 'restore-emacs-pdmp
180 ;; restore the dump file that Emacs installs somewhere in
181 ;; libexec/ to its original state
182 (lambda* (#:key outputs target #:allow-other-keys)
183 (let* ((libexec (string-append (assoc-ref outputs "out")
184 "/libexec"))
185 ;; each of these find-files should return one file
186 (pdmp (find-files libexec "^emacs\\.pdmp$"))
187 (pdmp-real (find-files libexec
188 "^\\.emacs\\.pdmp-real$")))
189 (for-each (lambda (wrapper real)
190 (delete-file wrapper)
191 (rename-file real wrapper))
192 pdmp pdmp-real))
193 #t))
194 (add-after 'glib-or-gtk-wrap 'strip-double-wrap
195 (lambda* (#:key outputs #:allow-other-keys)
196 ;; Directly copy emacs-X.Y to emacs, so that it is not wrapped
197 ;; twice. This also fixes a minor issue, where WMs would not be
198 ;; able to track emacs back to emacs.desktop.
199 (with-directory-excursion (assoc-ref outputs "out")
200 (copy-file
201 (car (find-files "bin" "^emacs-([0-9]+\\.)+[0-9]+$"))
202 "bin/emacs")
203 #t)))
204 (add-after 'strip-double-wrap 'wrap-emacs-paths
205 (lambda* (#:key inputs outputs #:allow-other-keys)
206 (let* ((out (assoc-ref outputs "out"))
207 (lisp-dirs (find-files (string-append out "/share/emacs")
208 "^lisp$"
209 #:directories? #t)))
210 (for-each
211 (lambda (prog)
212 (wrap-program prog
213 ;; emacs-next and variants rely on uname being in PATH for
214 ;; Tramp. Tramp paths can't be hardcoded, because they
215 ;; need to be portable.
216 `("PATH" suffix
217 ,(map (lambda (in) (string-append in "/bin"))
218 (list (assoc-ref inputs "gzip")
219 (assoc-ref inputs "coreutils"))))
220 `("EMACSLOADPATH" suffix ,lisp-dirs)))
221 (find-files (string-append out "/bin")
222 ;; Matches versioned and unversioned emacs binaries.
223 ;; We don't patch emacsclient, because it takes its
224 ;; environment variables from emacs.
225 ;; Likewise, we don't need to patch helper binaries
226 ;; like etags, ctags or ebrowse.
227 "^emacs(-[0-9]+(\\.[0-9]+)*)?$"))
228 #t)))
229 (add-before 'reset-gzip-timestamps 'make-compressed-files-writable
230 ;; The 'reset-gzip-timestamps phase will throw a permission error
231 ;; if gzip files aren't writable then. This phase is needed when
232 ;; building from a git checkout.
233 (lambda _
234 (for-each make-file-writable
235 (find-files %output ".*\\.t?gz$"))
236 #t)))))
237 (inputs
238 `(("gnutls" ,gnutls)
239 ("ncurses" ,ncurses)
240
241 ;; Required for "core" functionality, such as dired and compression.
242 ("coreutils" ,coreutils)
243 ("gzip" ,gzip)
244
245 ;; Avoid Emacs's limited movemail substitute that retrieves POP3 email
246 ;; only via insecure channels. This is not needed for (modern) IMAP.
247 ("mailutils" ,mailutils)
248
249 ;; TODO: Add the optional dependencies.
250 ("gpm" ,gpm)
251 ("libx11" ,libx11)
252 ("gtk+" ,gtk+)
253 ("cairo" ,cairo)
254 ("pango" ,pango)
255 ("harfbuzz" ,harfbuzz)
256 ("libxft" ,libxft)
257 ("libtiff" ,libtiff)
258 ("giflib" ,giflib)
259 ("libjpeg" ,libjpeg-turbo)
260 ("acl" ,acl)
261 ("jansson" ,jansson)
262 ("gmp" ,gmp)
263
264 ;; When looking for libpng `configure' links with `-lpng -lz', so we
265 ;; must also provide zlib as an input.
266 ("libpng" ,libpng)
267 ("zlib" ,zlib)
268
269 ("librsvg" ,librsvg)
270 ("libxpm" ,libxpm)
271 ("libxml2" ,libxml2)
272 ("libice" ,libice)
273 ("libsm" ,libsm)
274 ("alsa-lib" ,alsa-lib)
275 ("dbus" ,dbus)
276
277 ;; multilingualization support
278 ("libotf" ,libotf)
279 ("m17n-lib" ,m17n-lib)))
280 (native-inputs
281 `(("guix-emacs.el" ,(search-auxiliary-file "emacs/guix-emacs.el"))
282 ("pkg-config" ,pkg-config)
283 ("texinfo" ,texinfo)))
284
285 (native-search-paths
286 (list (search-path-specification
287 (variable "EMACSLOADPATH")
288 (files '("share/emacs/site-lisp")))
289 (search-path-specification
290 (variable "INFOPATH")
291 (files '("share/info")))))
292
293 (home-page "https://www.gnu.org/software/emacs/")
294 (synopsis "The extensible, customizable, self-documenting text editor")
295 (description
296 "GNU Emacs is an extensible and highly customizable text editor. It is
297 based on an Emacs Lisp interpreter with extensions for text editing. Emacs
298 has been extended in essentially all areas of computing, giving rise to a
299 vast array of packages supporting, e.g., email, IRC and XMPP messaging,
300 spreadsheets, remote server editing, and much more. Emacs includes extensive
301 documentation on all aspects of the system, from basic editing to writing
302 large Lisp programs. It has full Unicode support for nearly all human
303 languages.")
304 (license license:gpl3+)))
305
306 (define-public emacs-next
307 (let ((commit "2ea34662c20f71d35dd52a5ed996542c7386b9cb")
308 (revision "0"))
309 (package
310 (inherit emacs)
311 (name "emacs-next")
312 (version (git-version "28.0.50" revision commit))
313 (source
314 (origin
315 (inherit (package-source emacs))
316 (method git-fetch)
317 (uri (git-reference
318 (url "https://git.savannah.gnu.org/git/emacs.git/")
319 (commit commit)))
320 (file-name (git-file-name name version))
321 (sha256
322 (base32
323 "0igjm9kwiswn2dpiy2k9xikbdfc7njs07ry48fqz70anljj8y7y3"))))
324 (native-inputs
325 `(("autoconf" ,autoconf)
326 ,@(package-native-inputs emacs))))))
327
328 (define-public emacs-next-pgtk
329 (let ((commit "ae18c8ec4f0ef37c8c9cda473770ff47e41291e2")
330 (revision "1"))
331 (package
332 (inherit emacs-next)
333 (name "emacs-next-pgtk")
334 (version (git-version "28.0.50" revision commit))
335 (source
336 (origin
337 (method git-fetch)
338 (uri (git-reference
339 (url "https://git.savannah.gnu.org/git/emacs.git/")
340 (commit commit)))
341 (file-name (git-file-name name version))
342 (sha256
343 (base32
344 "07hgfqh965zmra0rbmnf63p3lsinpv5hn5payqcrjx25pl75xnaf"))))
345 (arguments
346 (substitute-keyword-arguments (package-arguments emacs-next)
347 ((#:configure-flags flags ''())
348 `(cons* "--with-pgtk" "--with-xwidgets" ,flags))))
349 (propagated-inputs
350 `(("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
351 ("glib-networking" ,glib-networking)))
352 (inputs
353 `(("webkitgtk" ,webkitgtk)
354 ,@(package-inputs emacs-next)))
355 (home-page "https://github.com/masm11/emacs")
356 (synopsis "Emacs text editor with @code{pgtk} and @code{xwidgets} support")
357 (description "This is an unofficial Emacs fork build with a pure-GTK
358 graphical toolkit to work natively on Wayland. In addition to that, xwidgets
359 also enabled and works without glitches even on X server."))))
360
361 (define-public emacs-minimal
362 ;; This is the version that you should use as an input to packages that just
363 ;; need to byte-compile .el files.
364 (package/inherit emacs
365 (name "emacs-minimal")
366 (synopsis "The extensible text editor (used only for byte-compilation)")
367 (build-system gnu-build-system)
368 (arguments
369 (substitute-keyword-arguments (package-arguments emacs)
370 ((#:configure-flags flags ''())
371 `(list "--with-gnutls=no" "--disable-build-details"))
372 ((#:phases phases)
373 `(modify-phases ,phases
374 (delete 'restore-emacs-pdmp)
375 (delete 'strip-double-wrap)))))
376 (inputs
377 `(("guix-emacs.el" ,(search-auxiliary-file "emacs/guix-emacs.el"))
378 ("ncurses" ,ncurses)
379 ("coreutils" ,coreutils)
380 ("gzip" ,gzip)))
381 (native-inputs
382 `(("pkg-config" ,pkg-config)))))
383
384 (define-public emacs-xwidgets
385 (package/inherit emacs
386 (name "emacs-xwidgets")
387 (synopsis "The extensible, customizable, self-documenting text
388 editor (with xwidgets support)")
389 (build-system gnu-build-system)
390 (arguments
391 (substitute-keyword-arguments (package-arguments emacs)
392 ((#:configure-flags flags ''())
393 `(cons "--with-xwidgets" ,flags))
394 ((#:phases phases)
395 `(modify-phases ,phases
396 (delete 'restore-emacs-pdmp)
397 (delete 'strip-double-wrap)))))
398 (inputs
399 `(("webkitgtk" ,webkitgtk)
400 ("libxcomposite" ,libxcomposite)
401 ,@(package-inputs emacs)))))
402
403 (define-public emacs-no-x
404 (package/inherit emacs
405 (name "emacs-no-x")
406 (synopsis "The extensible, customizable, self-documenting text
407 editor (console only)")
408 (build-system gnu-build-system)
409 (inputs (fold alist-delete
410 (package-inputs emacs)
411 '("libx11" "gtk+" "libxft" "libtiff" "giflib" "libjpeg"
412 "imagemagick" "libpng" "librsvg" "libxpm" "libice"
413 "libsm" "cairo" "pango" "harfbuzz"
414
415 ;; These depend on libx11, so remove them as well.
416 "libotf" "m17n-lib" "dbus")))
417 (arguments
418 (substitute-keyword-arguments (package-arguments emacs)
419 ((#:configure-flags flags ''())
420 `(delete "--with-cairo" ,flags))
421 ((#:phases phases)
422 `(modify-phases ,phases
423 (delete 'restore-emacs-pdmp)
424 (delete 'strip-double-wrap)))))))
425
426 (define-public emacs-no-x-toolkit
427 (package/inherit emacs
428 (name "emacs-no-x-toolkit")
429 (synopsis "The extensible, customizable, self-documenting text
430 editor (without an X toolkit)" )
431 (build-system gnu-build-system)
432 (inputs (append `(("inotify-tools" ,inotify-tools))
433 (alist-delete "gtk+" (package-inputs emacs))))
434 (arguments
435 (substitute-keyword-arguments (package-arguments emacs)
436 ((#:configure-flags flags ''())
437 `(cons "--with-x-toolkit=no" ,flags))
438 ((#:phases phases)
439 `(modify-phases ,phases
440 (delete 'restore-emacs-pdmp)
441 (delete 'strip-double-wrap)))))))
442
443 (define-public emacs-wide-int
444 (package/inherit emacs
445 (name "emacs-wide-int")
446 (synopsis "The extensible, customizable, self-documenting text
447 editor (with wide ints)" )
448 (arguments
449 (substitute-keyword-arguments (package-arguments emacs)
450 ((#:configure-flags flags)
451 `(cons "--with-wide-int" ,flags))))))
452
453 (define-public guile-emacs
454 (let ((commit "41120e0f595b16387eebfbf731fff70481de1b4b")
455 (revision "0"))
456 (package
457 (inherit emacs)
458 (name "guile-emacs")
459 (version (git-version "0.0.0" revision commit))
460 (source (origin
461 (method git-fetch)
462 (uri (git-reference
463 (url "https://git.hcoop.net/git/bpt/emacs.git")
464 (commit commit)))
465 (file-name (git-file-name name version))
466 (patches (search-patches "guile-emacs-fix-configure.patch"))
467 (sha256
468 (base32
469 "0lvcvsz0f4mawj04db35p1dvkffdqkz8pkhc0jzh9j9x2i63kcz6"))))
470 (native-inputs
471 `(("autoconf" ,autoconf)
472 ("automake" ,automake)
473 ("guile" ,guile-for-guile-emacs)
474 ,@(package-native-inputs emacs)))
475 (arguments
476 (substitute-keyword-arguments `(;; Build fails if we allow parallel build.
477 #:parallel-build? #f
478 ;; Tests aren't passing for now.
479 #:tests? #f
480 ,@(package-arguments emacs))
481 ((#:configure-flags flags ''())
482 `(delete "--with-cairo" ,flags))
483 ((#:phases phases)
484 `(modify-phases ,phases
485 (add-after 'unpack 'autogen
486 (lambda _
487 (invoke "sh" "autogen.sh")))
488 ;; Build sometimes fails: deps/dispnew.d: No such file or directory
489 (add-before 'build 'make-deps-dir
490 (lambda _
491 (invoke "mkdir" "-p" "src/deps")))
492 (delete 'restore-emacs-pdmp)
493 (delete 'strip-double-wrap))))))))
494
495 (define-public m17n-db
496 (package
497 (name "m17n-db")
498 (version "1.8.0")
499 (source
500 (origin
501 (method url-fetch)
502 (uri (string-append "mirror://savannah/m17n/m17n-db-"
503 version ".tar.gz"))
504 (sha256
505 (base32
506 "0vfw7z9i2s9np6nmx1d4dlsywm044rkaqarn7akffmb6bf1j6zv5"))))
507 (build-system gnu-build-system)
508 (inputs
509 `(("gettext" ,gettext-minimal)))
510 (arguments
511 `(#:configure-flags
512 (list (string-append "--with-charmaps="
513 (assoc-ref %build-inputs "libc")
514 "/share/i18n/charmaps"))))
515 ;; With `guix lint' the home-page URI returns a small page saying
516 ;; that your browser does not handle frames. This triggers the "URI
517 ;; returns suspiciously small file" warning.
518 (home-page "https://www.nongnu.org/m17n/")
519 (synopsis "Multilingual text processing library (database)")
520 (description "The m17n library realizes multilingualization of
521 many aspects of applications. The m17n library represents
522 multilingual text as an object named M-text. M-text is a string with
523 attributes called text properties, and designed to substitute for
524 string in C. Text properties carry any information required to input,
525 display and edit the text.
526
527 This package contains the library database.")
528 (license license:lgpl2.1+)))
529
530 (define-public m17n-lib
531 (package
532 (name "m17n-lib")
533 (version "1.8.0")
534 (source
535 (origin
536 (method url-fetch)
537 (uri (string-append "mirror://savannah/m17n/m17n-lib-"
538 version ".tar.gz"))
539 (sha256
540 (base32
541 "0jp61y09xqj10mclpip48qlfhniw8gwy8b28cbzxy8hq8pkwmfkq"))))
542 (build-system gnu-build-system)
543 (inputs
544 `(("fribidi" ,fribidi)
545 ("gd" ,gd)
546 ("libotf" ,libotf)
547 ("libxft" ,libxft)
548 ("libxml2" ,libxml2)
549 ("m17n-db" ,m17n-db)))
550 (arguments
551 `(#:parallel-build? #f))
552 ;; With `guix lint' the home-page URI returns a small page saying
553 ;; that your browser does not handle frames. This triggers the "URI
554 ;; returns suspiciously small file" warning.
555 (home-page "https://www.nongnu.org/m17n/")
556 (synopsis "Multilingual text processing library (runtime)")
557 (description "The m17n library realizes multilingualization of
558 many aspects of applications. The m17n library represents
559 multilingual text as an object named M-text. M-text is a string with
560 attributes called text properties, and designed to substitute for
561 string in C. Text properties carry any information required to input,
562 display and edit the text.
563
564 This package contains the library runtime.")
565 (license license:lgpl2.1+)))