gnu: gnome-maps: Properly wrap GI_TYPELIB_PATH.
[jackhill/guix/guix.git] / gnu / packages / moe.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014, 2015, 2017 Eric Bavier <bavier@member.fsf.org>
3 ;;; Copyright © 2016, 2019, 2021 Efraim Flashner <efraim@flashner.co.il>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages moe)
21 #:use-module ((guix licenses) #:select (gpl2+))
22 #:use-module (gnu packages ncurses)
23 #:use-module (gnu packages compression)
24 #:use-module (guix packages)
25 #:use-module (guix download)
26 #:use-module (guix build-system gnu))
27
28 (define-public moe
29 (package
30 (name "moe")
31 (version "1.12")
32 (source
33 (origin
34 (method url-fetch)
35 (uri (string-append "mirror://gnu/moe/moe-"
36 version ".tar.lz"))
37 (sha256
38 (base32 "1s51swk8h5k32r2z4i1pla2l15b0v0mh35lwsd5f1y16whmmz24a"))))
39 (build-system gnu-build-system)
40 (native-inputs (list lzip))
41 (inputs (list ncurses))
42 (home-page "https://www.gnu.org/software/moe/moe.html")
43 (synopsis "Modeless, multiple-buffer, user-friendly 8-bit text editor")
44 (description
45 "GNU Moe is a powerful-but-simple-to-use text editor. It works in a
46 modeless manner, and features an intuitive set of key-bindings that
47 assign a degree of severity to each key; for example, key
48 combinations with the Alt key are for harmless commands like cursor
49 movements while combinations with the Control key are for commands
50 that will modify the text. Moe features multiple windows, unlimited
51 undo/redo, unlimited line length, global search and replace, and
52 more.")
53 (license gpl2+)))