gnu: r-biocviews: Update to 1.64.1.
[jackhill/guix/guix.git] / gnu / packages / weather.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2022 Nicolas Goaziou <mail@nicolasgoaziou.fr>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages weather)
20 #:use-module ((guix licenses) #:prefix license:)
21 #:use-module (guix build-system go)
22 #:use-module (guix git-download)
23 #:use-module (guix packages)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages golang))
26
27 (define-public wego
28 (package
29 (name "wego")
30 (version "2.1")
31 (source
32 (origin
33 (method git-fetch)
34 (uri (git-reference
35 (url "https://github.com/schachmat/wego")
36 (commit version)))
37 (file-name (git-file-name name version))
38 (sha256
39 (base32 "0bji9fywa0kg29zj1vrwq7l5f18hh0lcz6rl6sppi5id0qbjpiwl"))))
40 (build-system go-build-system)
41 (arguments '(#:import-path "github.com/schachmat/wego"))
42 (propagated-inputs
43 (list go-golang-org-x-sys
44 go-github-com-rivo-uniseg
45 go-github-com-mattn-go-isatty
46 go-github-com-schachmat-ingo
47 go-github-com-mattn-go-runewidth
48 go-github-com-mattn-go-colorable))
49 (home-page "https://github.com/schachmat/wego")
50 (synopsis "Weather client for the terminal")
51 (description "Wego is a weather client for the terminal. It shows
52 forecast for one or seven days. Displayed information includes temperature
53 range---felt and measured---, wind speed and direction, viewing distance,
54 precipitation amount and probability.")
55 (license license:isc)))