gnu: r-biocviews: Update to 1.64.1.
[jackhill/guix/guix.git] / gnu / packages / patches / fenics-dolfin-algorithm.patch
1 Fix compilation errors:
2
3 dolfin/geometry/IntersectionConstruction.cpp: In static member function ‘static std::vector<dolfin::Point> dolfin::IntersectionConstruction::intersection_segment_segment_2d(const dolfin::Point&, const dolfin::Point&, const dolfin::Point&, const dolfin::Point&)’:
4 dolfin/geometry/IntersectionConstruction.cpp:442:24: error: ‘min_element’ is not a member of ‘std’; did you mean ‘tuple_element’?
5 442 | const auto it = std::min_element(oo.begin(), oo.end());
6 | ^~~~~~~~~~~
7 | tuple_element
8
9 dolfin/mesh/MeshFunction.h: In member function ‘std::vector<long unsigned int> dolfin::MeshFunction<T>::where_equal(T)’:
10 dolfin/mesh/MeshFunction.h:652:26: error: ‘count’ is not a member of ‘std’; did you mean ‘cout’?
11 652 | std::size_t n = std::count(_values.get(), _values.get() + _size, value);
12 | ^~~~~
13 | cout
14
15 Submitted upstream at https://bitbucket.org/fenics-project/dolfin/issues/1128
16
17 --- a/dolfin/geometry/IntersectionConstruction.cpp
18 +++ b/dolfin/geometry/IntersectionConstruction.cpp
19 @@ -18,7 +18,8 @@
20 // First added: 2014-02-03
21 // Last changed: 2017-12-12
22
23 +#include <algorithm>
24 #include <iomanip>
25 #include <dolfin/mesh/MeshEntity.h>
26 #include "predicates.h"
27
28 --- a/dolfin/mesh/MeshFunction.h
29 +++ b/dolfin/mesh/MeshFunction.h
30 @@ -24,6 +24,7 @@
31 #ifndef __MESH_FUNCTION_H
32 #define __MESH_FUNCTION_H
33
34 +#include <algorithm>
35 #include <map>
36 #include <vector>
37