gnu: r-biocviews: Update to 1.64.1.
[jackhill/guix/guix.git] / gnu / packages / patches / emacs-exec-path.patch
1 Do not capture the build-time value of $PATH in the 'emacs' executable
2 since this can noticeably increase the size of the closure of Emacs
3 with things like GCC being referenced.
4
5 --- a/lisp/loadup.el
6 +++ b/lisp/loadup.el
7 @@ -530,7 +530,8 @@ lost after dumping")))
8 ((equal dump-mode "dump") "emacs")
9 ((equal dump-mode "bootstrap") "emacs")
10 ((equal dump-mode "pbootstrap") "bootstrap-emacs.pdmp")
11 - (t (error "Unrecognized dump mode %s" dump-mode)))))
12 + (t (error "Unrecognized dump mode %s" dump-mode))))
13 + (exec-path nil))
14 (when (and (featurep 'native-compile)
15 (equal dump-mode "pdump"))
16 ;; Don't enable this before bootstrap is completed, as the