gnu: gnome-shell-extension-dash-to-dock: Update to 66.
[jackhill/guix/guix.git] / gnu / packages / gnome-xyz.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2019 Leo Prikler <leo.prikler@student.tugraz.at>
3 ;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
4 ;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages gnome-xyz)
22 #:use-module (guix build-system trivial)
23 #:use-module (guix build-system gnu)
24 #:use-module (guix git-download)
25 #:use-module (guix packages)
26 #:use-module ((guix licenses) #:prefix license:)
27 #:use-module (gnu packages base)
28 #:use-module (gnu packages bash)
29 #:use-module (gnu packages glib)
30 #:use-module (gnu packages gnome)
31 #:use-module (gnu packages gtk)
32 #:use-module (gnu packages pkg-config)
33 #:use-module (gnu packages ruby)
34 #:use-module (gnu packages xml))
35
36 (define-public matcha-theme
37 (package
38 (name "matcha-theme")
39 (version "2019-11-02")
40 (source
41 (origin
42 (method git-fetch)
43 (uri
44 (git-reference
45 (url "https://github.com/vinceliuice/matcha")
46 (commit version)))
47 (file-name (git-file-name name version))
48 (sha256
49 (base32
50 "0wci9ahap8kynq8cbyxr7aba9ndb1d4kiq42xvzr34vw1rhcahrr"))))
51 (build-system trivial-build-system)
52 (arguments
53 '(#:modules ((guix build utils))
54 #:builder
55 (begin
56 (use-modules (guix build utils))
57 (let* ((out (assoc-ref %outputs "out"))
58 (source (assoc-ref %build-inputs "source"))
59 (bash (assoc-ref %build-inputs "bash"))
60 (coreutils (assoc-ref %build-inputs "coreutils"))
61 (themesdir (string-append out "/share/themes")))
62 (setenv "PATH"
63 (string-append coreutils "/bin:"
64 (string-append bash "/bin:")))
65 (copy-recursively source (getcwd))
66 (patch-shebang "Install")
67 (mkdir-p themesdir)
68 (invoke "./Install" "-d" themesdir)
69 #t))))
70 (inputs
71 `(("gtk-engines" ,gtk-engines)))
72 (native-inputs
73 `(("bash" ,bash)
74 ("coreutils" ,coreutils)))
75 (synopsis "Flat design theme for GTK 3, GTK 2 and GNOME-Shell")
76 (description "Matcha is a flat Design theme for GTK 3, GTK 2 and
77 Gnome-Shell which supports GTK 3 and GTK 2 based desktop environments
78 like Gnome, Unity, Budgie, Pantheon, XFCE, Mate and others.")
79 (home-page "https://github.com/vinceliuice/matcha")
80 (license license:gpl3+)))
81
82 (define-public delft-icon-theme
83 (package
84 (name "delft-icon-theme")
85 (version "1.10")
86 (source
87 (origin
88 (method git-fetch)
89 (uri (git-reference
90 (url "https://github.com/madmaxms/iconpack-delft.git")
91 (commit (string-append "v" version))))
92 (sha256
93 (base32
94 "0vw3yw9f9ygzfd2k3zrfih3r0vkzlhk1bmsk8sapvk7np24i1z9s"))
95 (file-name (git-file-name name version))))
96 (build-system trivial-build-system)
97 (arguments
98 `(#:modules ((guix build utils))
99 #:builder
100 (begin
101 (use-modules (guix build utils))
102 (copy-recursively (assoc-ref %build-inputs "source") "icons")
103 (substitute* "icons/Delft/index.theme"
104 (("gnome") "Adwaita"))
105 (delete-file "icons/README.md")
106 (delete-file "icons/LICENSE")
107 (delete-file "icons/logo.jpg")
108 (copy-recursively "icons" (string-append %output "/share/icons")))))
109 (home-page "https://www.gnome-look.org/p/1199881/")
110 (synopsis "Continuation of Faenza icon theme with up to date app icons")
111 (description "Delft is a fork of the popular icon theme Faenza with up to
112 date app icons. It will stay optically close to the original Faenza icons,
113 which haven't been updated for some years. The new app icons are ported from
114 the Obsidian icon theme.")
115 (license license:gpl3)))
116
117 (define-public gnome-shell-extension-dash-to-dock
118 (package
119 (name "gnome-shell-extension-dash-to-dock")
120 (version "66")
121 (source (origin
122 (method git-fetch)
123 (uri (git-reference
124 (url "https://github.com/micheleg/dash-to-dock.git")
125 (commit (string-append "extensions.gnome.org-v"
126 version))))
127 (sha256
128 (base32
129 "04krl6rxlp1qc97psraf2kwin7h0mx4c7pnfpi7vhplmvasrwkfh"))
130 (file-name (git-file-name name version))))
131 (build-system gnu-build-system)
132 (arguments
133 '(#:tests? #f
134 #:make-flags (list (string-append "INSTALLBASE="
135 (assoc-ref %outputs "out")
136 "/share/gnome-shell/extensions"))
137 #:phases
138 (modify-phases %standard-phases
139 (delete 'bootstrap)
140 (delete 'configure))))
141 (native-inputs
142 `(("intltool" ,intltool)
143 ("pkg-config" ,pkg-config)))
144 (propagated-inputs
145 `(("glib" ,glib)
146 ("glib" ,glib "bin")))
147 (synopsis "Transforms GNOME's dash into a dock")
148 (description "This extension moves the dash out of the
149 overview, transforming it into a dock for easier application launching and
150 faster window switching.")
151 (home-page "https://micheleg.github.io/dash-to-dock/")
152 (license license:gpl2+)))
153
154 (define-public gnome-shell-extension-noannoyance
155 (package
156 (name "gnome-shell-extension-noannoyance")
157 (version "5")
158 (source (origin
159 (method git-fetch)
160 (uri (git-reference
161 (url "https://github.com/BjoernDaase/noannoyance.git")
162 (commit "e37b5b3c31f577b4698bc6659bc9fec5ea9ac5d4")))
163 (sha256
164 (base32
165 "0fa8l3xlh8kbq07y4385wpb908zm6x53z81q16xlmin97dln32hh"))
166 (file-name (git-file-name name version))))
167 (build-system trivial-build-system)
168 (arguments
169 '(#:modules ((guix build utils))
170 #:builder
171 (begin
172 (use-modules (guix build utils))
173 (let ((dst (string-append
174 (assoc-ref %outputs "out")
175 "/share/gnome-shell/extensions/"
176 "noannoyance@daase.net")))
177 (mkdir-p dst)
178 (copy-recursively (assoc-ref %build-inputs "source") dst)))))
179 (synopsis "Removes 'Window is ready' annotation")
180 (description "One of the many extensions, that remove this message.
181 It uses ES6 syntax and claims to be more actively maintained than others.")
182 (home-page "https://extensions.gnome.org/extension/2182/noannoyance/")
183 (license license:gpl2)))
184
185 (define-public numix-theme
186 (package
187 (name "numix-theme")
188 (version "2.6.7")
189 (source (origin
190 (method git-fetch)
191 (uri (git-reference
192 (url "https://github.com/numixproject/numix-gtk-theme.git")
193 (commit version)))
194 (file-name (git-file-name name version))
195 (sha256
196 (base32
197 "12mw0kr0kkvg395qlbsvkvaqccr90cmxw5rrsl236zh43kj8grb7"))))
198 (build-system gnu-build-system)
199 (arguments
200 '(#:make-flags (list (string-append "DESTDIR=" (assoc-ref %outputs "out")))
201 #:phases
202 (modify-phases %standard-phases
203 (delete 'configure)
204 (delete 'check))))
205 (native-inputs
206 `(("glib:bin" ,glib "bin") ; for glib-compile-schemas
207 ("gnome-shell" ,gnome-shell)
208 ("gtk+" ,gtk+)
209 ("xmllint" ,libxml2)
210 ("ruby-sass" ,ruby-sass)))
211 (synopsis "Flat theme with light and dark elements")
212 (description "Numix is a modern flat theme with a combination of light and
213 dark elements. It supports GNOME, Unity, Xfce, and Openbox.")
214 (home-page "https://numixproject.github.io")
215 (license license:gpl3+)))