gnu: Add rust-sharded-slab-0.1.
[jackhill/guix/guix.git] / gnu / packages / php.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016-2020 Julien Lepiller <julien@lepiller.eu>
3 ;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
4 ;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
6 ;;; Copyright © 2019 Oleg Pykhalov <go.wigust@gmail.com>
7 ;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
8 ;;;
9 ;;; This file is part of GNU Guix.
10 ;;;
11 ;;; GNU Guix is free software; you can redistribute it and/or modify it
12 ;;; under the terms of the GNU General Public License as published by
13 ;;; the Free Software Foundation; either version 3 of the License, or (at
14 ;;; your option) any later version.
15 ;;;
16 ;;; GNU Guix is distributed in the hope that it will be useful, but
17 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
18 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
19 ;;; GNU General Public License for more details.
20 ;;;
21 ;;; You should have received a copy of the GNU General Public License
22 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
23
24 (define-module (gnu packages php)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages algebra)
27 #:use-module (gnu packages aspell)
28 #:use-module (gnu packages base)
29 #:use-module (gnu packages bison)
30 #:use-module (gnu packages compression)
31 #:use-module (gnu packages curl)
32 #:use-module (gnu packages cyrus-sasl)
33 #:use-module (gnu packages databases)
34 #:use-module (gnu packages dbm)
35 #:use-module (gnu packages fontutils)
36 #:use-module (gnu packages gd)
37 #:use-module (gnu packages gettext)
38 #:use-module (gnu packages glib)
39 #:use-module (gnu packages gnupg)
40 #:use-module (gnu packages icu4c)
41 #:use-module (gnu packages image)
42 #:use-module (gnu packages linux)
43 #:use-module (gnu packages multiprecision)
44 #:use-module (gnu packages openldap)
45 #:use-module (gnu packages pcre)
46 #:use-module (gnu packages pkg-config)
47 #:use-module (gnu packages readline)
48 #:use-module (gnu packages sqlite)
49 #:use-module (gnu packages textutils)
50 #:use-module (gnu packages tls)
51 #:use-module (gnu packages web)
52 #:use-module (gnu packages xml)
53 #:use-module (gnu packages xorg)
54 #:use-module (guix packages)
55 #:use-module (guix download)
56 #:use-module (guix build-system gnu)
57 #:use-module (guix utils)
58 #:use-module ((guix licenses) #:prefix license:))
59
60 (define-public php
61 (package
62 (name "php")
63 (version "7.4.13")
64 (home-page "https://secure.php.net/")
65 (source (origin
66 (method url-fetch)
67 (uri (string-append home-page "distributions/"
68 "php-" version ".tar.xz"))
69 (sha256
70 (base32
71 "1x402vsg3zq8mbar2fwln85vmvdvmrxm8q4ma8333hms78z31bdf"))
72 (modules '((guix build utils)))
73 (snippet
74 '(with-directory-excursion "ext"
75 (for-each delete-file-recursively
76 ;; Some of the bundled libraries have no proper upstream.
77 ;; Ideally we'd extract these out as separate packages:
78 ;;"mbstring/libmbfl"
79 ;;"date/lib"
80 ;;"bcmath/libbcmath"
81 ;;"fileinfo/libmagic" ; a patched version of libmagic
82 '("gd/libgd"
83 "pcre/pcre2lib"
84 "xmlrpc/libxmlrpc"))
85 #t))))
86 (build-system gnu-build-system)
87 (arguments
88 `(#:configure-flags
89 (let-syntax ((with (syntax-rules ()
90 ((_ option input)
91 (string-append option "="
92 (assoc-ref %build-inputs input))))))
93 (list (with "--with-bz2" "bzip2")
94 (with "--with-curl" "curl")
95 (with "--with-gdbm" "gdbm")
96 (with "--with-gettext" "glibc") ; libintl.h
97 (with "--with-gmp" "gmp")
98 (with "--with-ldap" "openldap")
99 (with "--with-ldap-sasl" "cyrus-sasl")
100 (with "--with-pdo-pgsql" "postgresql")
101 (with "--with-pdo-sqlite" "sqlite")
102 (with "--with-pgsql" "postgresql")
103 ;; PHP’s Pspell extension, while retaining its current name,
104 ;; now uses the Aspell library.
105 (with "--with-pspell" "aspell")
106 (with "--with-readline" "readline")
107 (with "--with-sqlite3" "sqlite")
108 (with "--with-tidy" "tidy")
109 (with "--with-xsl" "libxslt")
110 (with "--with-zlib-dir" "zlib")
111 ;; We could add "--with-snmp", but it requires netsnmp that
112 ;; we don't have a package for. It is used to build the snmp
113 ;; extension of php.
114 "--with-external-pcre"
115 "--with-external-gd"
116 "--with-iconv"
117 "--with-openssl"
118 "--with-mysqli" ; Required for, e.g. wordpress
119 "--with-pdo-mysql"
120 "--with-zip"
121 "--with-zlib"
122 "--enable-bcmath" ; Required for, e.g. Zabbix frontend
123 "--enable-calendar"
124 "--enable-dba=shared"
125 "--enable-exif"
126 "--enable-flatfile"
127 "--enable-fpm"
128 "--enable-ftp"
129 "--enable-gd"
130 "--enable-inifile"
131 "--enable-intl"
132 "--enable-mbstring"
133 "--enable-pcntl"
134 "--enable-sockets"))
135 #:phases
136 (modify-phases %standard-phases
137 (add-after 'unpack 'do-not-record-build-flags
138 (lambda _
139 ;; Prevent configure flags from being stored and causing
140 ;; unnecessary runtime dependencies.
141 (substitute* "scripts/php-config.in"
142 (("@CONFIGURE_OPTIONS@") "")
143 (("@PHP_LDFLAGS@") ""))
144 ;; This file has ISO-8859-1 encoding.
145 (with-fluids ((%default-port-encoding "ISO-8859-1"))
146 (substitute* "main/build-defs.h.in"
147 (("@CONFIGURE_COMMAND@") "(omitted)")))
148 #t))
149 (add-before 'build 'patch-/bin/sh
150 (lambda _
151 (substitute* '("run-tests.php" "ext/standard/proc_open.c")
152 (("/bin/sh") (which "sh")))
153 #t))
154 (add-before 'check 'prepare-tests
155 (lambda _
156 ;; Some of these files have ISO-8859-1 encoding, whereas others
157 ;; use ASCII, so we can't use a "catch-all" find-files here.
158 (with-fluids ((%default-port-encoding "ISO-8859-1"))
159 (substitute* '("ext/mbstring/tests/mb_send_mail02.phpt"
160 "ext/mbstring/tests/mb_send_mail04.phpt"
161 "ext/mbstring/tests/mb_send_mail05.phpt"
162 "ext/mbstring/tests/mb_send_mail06.phpt")
163 (("/bin/cat") (which "cat"))))
164 (substitute* '("ext/mbstring/tests/mb_send_mail01.phpt"
165 "ext/mbstring/tests/mb_send_mail03.phpt"
166 "ext/mbstring/tests/bug52681.phpt"
167 "ext/standard/tests/general_functions/bug34794.phpt"
168 "ext/standard/tests/general_functions/bug44667.phpt"
169 "ext/standard/tests/general_functions/proc_open.phpt")
170 (("/bin/cat") (which "cat")))
171
172 ;; The encoding of this file is not recognized, so we simply drop it.
173 (delete-file "ext/mbstring/tests/mb_send_mail07.phpt")
174
175 (substitute* "ext/standard/tests/streams/bug60602.phpt"
176 (("'ls'") (string-append "'" (which "ls") "'")))
177
178 ,@(if (string-prefix? "arm" (or (%current-system)
179 (%current-target-system)))
180 ;; Drop tests known to fail on armhf.
181 '((for-each delete-file
182 (list
183 "ext/calendar/tests/unixtojd_error1.phpt"
184 ;; arm can be a lot slower, so a time-related test fails
185 "ext/fileinfo/tests/cve-2014-3538-nojit.phpt"
186 "ext/pcre/tests/bug76514.phpt"
187 "ext/pcre/tests/preg_match_error3.phpt"
188 "ext/standard/tests/general_functions/var_export-locale.phpt"
189 "ext/standard/tests/general_functions/var_export_basic1.phpt"
190 "ext/intl/tests/timezone_getErrorCodeMessage_basic.phpt"
191 "ext/intl/tests/timezone_getOffset_error.phpt")))
192 '())
193
194 ;; Drop tests that are known to fail.
195 (for-each delete-file
196 '("ext/posix/tests/posix_getgrgid.phpt" ; Requires /etc/group.
197 "ext/posix/tests/posix_getgrnam_basic.phpt" ; Requires /etc/group.
198 "ext/sockets/tests/bug63000.phpt" ; Fails to detect OS.
199 "ext/sockets/tests/socket_shutdown.phpt" ; Requires DNS.
200 "ext/sockets/tests/socket_send.phpt" ; Likewise.
201 "ext/sockets/tests/mcast_ipv4_recv.phpt" ; Requires multicast.
202 ;; These needs /etc/services.
203 "ext/standard/tests/general_functions/getservbyname_basic.phpt"
204 "ext/standard/tests/general_functions/getservbyport_basic.phpt"
205 "ext/standard/tests/general_functions/getservbyport_variation1.phpt"
206 ;; And /etc/protocols.
207 "ext/standard/tests/network/getprotobyname_basic.phpt"
208 "ext/standard/tests/network/getprotobynumber_basic.phpt"
209 ;; And exotic locales.
210 "ext/standard/tests/strings/setlocale_basic1.phpt"
211 "ext/standard/tests/strings/setlocale_basic2.phpt"
212 "ext/standard/tests/strings/setlocale_basic3.phpt"
213 "ext/standard/tests/strings/setlocale_variation1.phpt"
214 ;; This failing test is skipped on PHP's Travis CI as it is
215 ;; supposedly inaccurate.
216 "ext/standard/tests/file/disk_free_space_basic.phpt"
217 ;; The following test erroneously expect the link
218 ;; count of a sub-directory to increase compared to
219 ;; its parent.
220 "ext/standard/tests/file/lstat_stat_variation8.phpt"
221 ;; This tests whether microseconds ‘differ enough’ and
222 ;; fails inconsistently on ‘fast’ machines.
223 "ext/date/tests/bug73837.phpt"
224
225 ;; XXX: These gd tests fails. Likely because our version
226 ;; is different from the (patched) bundled one.
227 ;; Here, gd quits immediately after "fatal libpng error"; while the
228 ;; test expects it to additionally return a "setjmp" error and warning.
229 "ext/gd/tests/bug39780_extern.phpt"
230 "ext/gd/tests/libgd00086_extern.phpt"
231 ;; Extra newline in gd-png output.
232 "ext/gd/tests/bug45799.phpt"
233 ;; Test expects generic "gd warning" but gets the actual function name.
234 "ext/gd/tests/createfromwbmp2_extern.phpt"
235 ;; This bug should have been fixed in gd 2.2.2.
236 ;; Is it a regression?
237 "ext/gd/tests/bug65148.phpt"
238 ;; This bug should have been fixed in the gd 2.2
239 ;; series. Perhaps a regression introduced by gd
240 ;; 2.3.0?
241 "ext/gd/tests/bug66590.phpt"
242 ;; This bug should have been fixed in the php-5.5
243 ;; series. Perhaps a regression introduced by gd
244 ;; 2.3.0?
245 "ext/gd/tests/bug70102.phpt"
246 ;; This bug should have been fixed in the php-5.6
247 ;; series. Perhaps a regression introduced by gd
248 ;; 2.3.0?
249 "ext/gd/tests/bug73869.phpt"
250 ;; Some WebP related tests fail.
251 "ext/gd/tests/webp_basic.phpt"
252 "ext/gd/tests/imagecreatefromstring_webp.phpt"
253 ;; Expected error message, but from the wrong function
254 "ext/gd/tests/bug77269.phpt"
255 ;; TODO: Enable these when libgd is built with xpm support.
256 "ext/gd/tests/xpm2gd.phpt"
257 "ext/gd/tests/xpm2jpg.phpt"
258 "ext/gd/tests/xpm2png.phpt"
259 ;; Whitespace difference, probably caused by a very
260 ;; long store path
261 "ext/gd/tests/bug77479.phpt"
262 ;; Expected invalid XBM but got EOF before image was
263 ;; complete. It's a warning in both cases and test
264 ;; result is the same.
265 "ext/gd/tests/bug77973.phpt"
266 ;; Test expects uninitialized value to be false, but
267 ;; instead gets "resource(5) of type (gd)".
268 "ext/gd/tests/bug79067.phpt"
269 ;; The following test fails with "The image size
270 ;; differs: expected 114x115, got 117x117".
271 "ext/gd/tests/bug79068.phpt"
272
273 ;; XXX: These iconv tests have the expected outcome,
274 ;; but with different error messages.
275 ;; Expects "illegal character", instead gets "unknown error (84)".
276 "ext/iconv/tests/bug52211.phpt"
277 "ext/iconv/tests/bug60494.phpt"
278 ;; Expects "wrong charset", gets unknown error (22).
279 "ext/iconv/tests/iconv_strlen_error2.phpt"
280 "ext/iconv/tests/iconv_substr_error2.phpt"
281 ;; Expects conversion error, gets "error condition Termsig=11".
282 "ext/iconv/tests/iconv_strpos_error2.phpt"
283 "ext/iconv/tests/iconv_strrpos_error2.phpt"
284 ;; Expects "invalid multibyte sequence" but got
285 ;; "unknown error".
286 "ext/iconv/tests/bug76249.phpt"
287
288 ;; XXX: These test failures appear legitimate, needs investigation.
289 ;; open_basedir() restriction failure.
290 "ext/curl/tests/bug61948-unix.phpt"
291 ;; Expects a false boolean, gets empty array from glob().
292 "ext/standard/tests/file/bug41655_1.phpt"
293 "ext/standard/tests/file/glob_variation5.phpt"
294 ;; The test expects an Array, but instead get the contents(?).
295 "ext/gd/tests/bug43073.phpt"
296 ;; imagettftext() returns wrong coordinates.
297 "ext/gd/tests/bug48732-mb.phpt"
298 "ext/gd/tests/bug48732.phpt"
299 ;; Similarly for imageftbbox().
300 "ext/gd/tests/bug48801-mb.phpt"
301 "ext/gd/tests/bug48801.phpt"
302 ;; Different expected output from imagecolorallocate().
303 "ext/gd/tests/bug53504.phpt"
304 ;; Wrong image size after scaling an image.
305 "ext/gd/tests/bug73272.phpt"
306 ;; Expects iconv to detect illegal characters, instead gets
307 ;; "unknown error (84)" and heap corruption(!).
308 "ext/iconv/tests/bug48147.phpt"
309 ;; Expects illegal character ".", gets "=?utf-8?Q?."
310 "ext/iconv/tests/bug51250.phpt"
311 ;; iconv throws "buffer length exceeded" on some string checks.
312 "ext/iconv/tests/iconv_mime_encode.phpt"
313 ;; file_get_contents(): iconv stream filter
314 ;; ("ISO-8859-1"=>"UTF-8") unknown error.
315 "ext/standard/tests/file/bug43008.phpt"
316 ;; Table data not created in sqlite(?).
317 "ext/pdo_sqlite/tests/bug_42589.phpt"
318 ;; Expects an Array with 3 preg_matches; gets 0.
319 "ext/pcre/tests/bug79846.phpt"
320 ;; Expects an empty Array; gets one with " " in it.
321 "ext/pcre/tests/bug80118.phpt"))
322
323 ;; Skip tests requiring network access.
324 (setenv "SKIP_ONLINE_TESTS" "1")
325 ;; Without this variable, 'make test' passes regardless of failures.
326 (setenv "REPORT_EXIT_STATUS" "1")
327 ;; Skip tests requiring I/O facilities that are unavailable in the
328 ;; build environment
329 (setenv "SKIP_IO_CAPTURE_TESTS" "1")
330 #t)))
331 #:test-target "test"))
332 (inputs
333 `(("aspell" ,aspell)
334 ("bzip2" ,bzip2)
335 ("curl" ,curl)
336 ("cyrus-sasl" ,cyrus-sasl)
337 ("gd" ,gd)
338 ("gdbm" ,gdbm)
339 ("glibc" ,glibc)
340 ("gmp" ,gmp)
341 ("gnutls" ,gnutls)
342 ("icu4c" ,icu4c)
343 ("libgcrypt" ,libgcrypt)
344 ("libpng" ,libpng)
345 ("libxml2" ,libxml2)
346 ("libxslt" ,libxslt)
347 ("libx11" ,libx11)
348 ("libzip" ,libzip)
349 ("oniguruma" ,oniguruma)
350 ("openldap" ,openldap)
351 ("openssl" ,openssl)
352 ("pcre" ,pcre2)
353 ("postgresql" ,postgresql)
354 ("readline" ,readline)
355 ("sqlite" ,sqlite)
356 ("tidy" ,tidy)
357 ("zlib" ,zlib)))
358 (native-inputs
359 `(("pkg-config" ,pkg-config)
360 ("bison" ,bison)
361 ("intltool" ,intltool)
362 ("procps" ,procps))) ; for tests
363 (synopsis "PHP programming language")
364 (description
365 "PHP (PHP Hypertext Processor) is a server-side (CGI) scripting
366 language designed primarily for web development but is also used as
367 a general-purpose programming language. PHP code may be embedded into
368 HTML code, or it can be used in combination with various web template
369 systems, web content management systems and web frameworks." )
370 (license (list
371 (license:non-copyleft "file://LICENSE") ; The PHP license.
372 (license:non-copyleft "file://Zend/LICENSE") ; The Zend license.
373 license:lgpl2.1 ; ext/mbstring/libmbfl
374 license:lgpl2.1+ ; ext/bcmath/libbcmath
375 license:bsd-2 ; ext/fileinfo/libmagic
376 license:expat)))) ; ext/date/lib