gnu: Add rust-sharded-slab-0.1.
[jackhill/guix/guix.git] / gnu / packages / linphone.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;;
3 ;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
4 ;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
5 ;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages linphone)
23 #:use-module (gnu packages)
24 #:use-module (gnu packages admin)
25 #:use-module (gnu packages audio)
26 #:use-module (gnu packages base)
27 #:use-module (gnu packages compression)
28 #:use-module (gnu packages documentation)
29 #:use-module (gnu packages gettext)
30 #:use-module (gnu packages gl)
31 #:use-module (gnu packages glib)
32 #:use-module (gnu packages gnome)
33 #:use-module (gnu packages gnome-xyz)
34 #:use-module (gnu packages graphviz)
35 #:use-module (gnu packages gtk)
36 #:use-module (gnu packages image)
37 #:use-module (gnu packages linux)
38 #:use-module (gnu packages pulseaudio)
39 #:use-module (gnu packages python)
40 #:use-module (gnu packages python-xyz)
41 #:use-module (gnu packages qt)
42 #:use-module (gnu packages java)
43 #:use-module (gnu packages sqlite)
44 #:use-module (gnu packages telephony)
45 #:use-module (gnu packages tls)
46 #:use-module (gnu packages video)
47 #:use-module (gnu packages xiph)
48 #:use-module (gnu packages xml)
49 #:use-module (gnu packages xorg)
50 #:use-module ((guix licenses) #:prefix license:)
51 #:use-module (guix packages)
52 #:use-module (guix download)
53 #:use-module (guix git-download)
54 #:use-module (guix build-system cmake)
55 #:use-module (guix build-system qt)
56 #:use-module (guix build-system glib-or-gtk)
57 #:use-module (guix build-system gnu))
58
59 (define-public bcunit
60 (package
61 (name "bcunit")
62 (version "3.0.2")
63 (source
64 (origin
65 (method url-fetch)
66 (uri
67 (string-append "https://www.linphone.org/releases/sources/" name
68 "/" name "-" version ".tar.gz"))
69 (sha256
70 (base32 "0ylchj8w98ic2fkqpxc6yk4s6s0h0ql2zsz5n49jd7126m4h8dqk"))))
71 (build-system cmake-build-system)
72 (arguments
73 '(#:tests? #f ; No test target
74 #:configure-flags
75 (list "-DENABLE_STATIC=NO"))) ; Not required
76 (synopsis "Belledonne Communications Unit Testing Framework")
77 (description "BCUnit is a fork of the defunct project CUnit, with several
78 fixes and patches applied. It is an unit testing framework for writing,
79 administering, and running unit tests in C.")
80 (home-page "https://gitlab.linphone.org/BC/public/bcunit")
81 (license license:lgpl2.0+)))
82
83 (define-public bctoolbox
84 (package
85 (name "bctoolbox")
86 (version "0.6.0")
87 (source
88 (origin
89 (method url-fetch)
90 (uri
91 (string-append "https://www.linphone.org/releases/sources/" name
92 "/" name "-" version ".tar.gz"))
93 (sha256
94 (base32 "1a1i70pb4hhnykkwyhhc7fv67q556l8kprny8xzgfqpj1nby2ms6"))))
95 (build-system cmake-build-system)
96 (arguments
97 '(#:tests? #f ; No test target
98 #:configure-flags
99 (list "-DENABLE_STATIC=OFF"))) ; Not required
100 (inputs
101 `(("bcunit" ,bcunit)
102 ("mbedtls" ,mbedtls-apache)))
103 (synopsis "Belledonne Communications Tool Box")
104 (description "BcToolBox is an utilities library used by Belledonne
105 Communications software like belle-sip, mediastreamer2 and linphone.")
106 (home-page "https://gitlab.linphone.org/BC/public/bctoolbox")
107 (license license:gpl2+)))
108
109 (define-public belr
110 (package
111 (name "belr")
112 (version "0.1.3")
113 (source
114 (origin
115 (method url-fetch)
116 (uri
117 (string-append "https://www.linphone.org/releases/sources/" name
118 "/" name "-" version ".tar.gz"))
119 (sha256
120 (base32 "1fwv2cg3qy9vdc7dimcda7nqcqc1h2cdd7ikhk7ng7q4ys8m96c1"))))
121 (build-system cmake-build-system)
122 (arguments
123 `(#:tests? #f ; No test target
124 #:configure-flags
125 (list "-DENABLE_STATIC=OFF"))) ; Not required
126 (inputs
127 `(("bctoolbox" ,bctoolbox)))
128 (synopsis "Belledonne Communications Language Recognition Library")
129 (description "Belr is Belledonne Communications' language recognition
130 library, written in C++11. It parses text inputs formatted according to a
131 language defined by an ABNF grammar, such as the protocols standardized at
132 IETF.")
133 (home-page "https://gitlab.linphone.org/BC/public/belr")
134 (license license:gpl3+)))
135
136 (define-public belcard
137 (package
138 (name "belcard")
139 (version "1.0.2")
140 (source
141 (origin
142 (method url-fetch)
143 (uri
144 (string-append "https://www.linphone.org/releases/sources/" name
145 "/" name "-" version ".tar.gz"))
146 (sha256
147 (base32 "0iiyrll1shnbb0561pkvdqcmx9b2cdr76xpsbaqdirc3s4xzcl0k"))))
148 (build-system cmake-build-system)
149 (arguments
150 `(#:tests? #f ; No test target
151 #:configure-flags
152 (list "-DENABLE_STATIC=OFF"))) ; Not required
153 (inputs
154 `(("bctoolbox" ,bctoolbox)
155 ("belr" ,belr)))
156 (synopsis "Belledonne Communications VCard Library")
157 (description "Belcard is a C++ library to manipulate VCard standard
158 format.")
159 (home-page "https://gitlab.linphone.org/BC/public/belcard")
160 (license license:gpl3+)))
161
162 (define-public bcmatroska2
163 (package
164 (name "bcmatroska2")
165 (version "0.23")
166 (source
167 (origin
168 (method url-fetch)
169 (uri
170 (string-append "https://www.linphone.org/releases/sources/" name
171 "/" name "-" version ".tar.gz"))
172 (sha256
173 (base32 "1a0vlk4fhh189pfzrwbc3xbc5vyx6cnxy642d1h40045jz9y4h15"))))
174 (build-system cmake-build-system)
175 (arguments
176 `(#:tests? #f ; No test target
177 #:configure-flags
178 (list
179 "-DENABLE_STATIC=NO"))) ; Not required
180 (synopsis "Belledonne Communications Media Container")
181 (description "BcMatroska is a free and open standard multi-media container
182 format. It can hold an unlimited number of video, audio, picture, or subtitle
183 tracks in one file. ")
184 (home-page "https://gitlab.linphone.org/BC/public/bcmatroska2")
185 (license
186 (list
187 ;; For Core C and LibEBML2.
188 ;; https://www.matroska.org/node/47
189 license:bsd-4
190 ;; For LibMatroska2.
191 ;; https://www.matroska.org/node/47
192 license:lgpl2.1+))))
193
194 (define-public bcg729
195 (package
196 (name "bcg729")
197 (version "1.1.1")
198 (source
199 (origin
200 (method git-fetch)
201 (uri (git-reference
202 (url "git://git.linphone.org/bcg729.git")
203 (commit version)))
204 (file-name (git-file-name name version))
205 (sha256
206 (base32 "1hal6b3w6f8y5r1wa0xzj8sj2jjndypaxyw62q50p63garp2h739"))))
207 (build-system cmake-build-system)
208 (arguments
209 `(#:tests? #f ; No test target
210 #:configure-flags
211 (list "-DENABLE_STATIC=NO"))) ; Not required
212 (synopsis "Belledonne Communications G729 Codec")
213 (description "BcG729 is an implementation of both encoder and decoder of
214 the ITU G729 speech codec. The library written in C 99 is fully portable and
215 can be executed on many platforms including both ARM and x86 processors. It
216 supports concurrent channels encoding and decoding for multi call application
217 such as conferencing.")
218 (home-page "https://gitlab.linphone.org/BC/public/belcard")
219 (license license:gpl2+)))
220
221 (define-public ortp
222 (package
223 (name "ortp")
224 (version "1.0.2")
225 (source
226 (origin
227 (method url-fetch)
228 (uri
229 (string-append "https://www.linphone.org/releases/sources/" name
230 "/" name "-" version ".tar.gz"))
231 (sha256
232 (base32 "016qg0lmdgmqh2kv19w9qhi4kkiyi5h1xp35g2s65b1j8ccm25d5"))))
233 (build-system cmake-build-system)
234 (arguments
235 `(#:tests? #f ; No test target
236 #:configure-flags
237 (list "-DENABLE_STATIC=NO"))) ; Not required
238 (native-inputs
239 `(("dot" ,graphviz)
240 ("doxygen" ,doxygen)))
241 (inputs
242 `(("bctoolbox" ,bctoolbox)))
243 (synopsis "Belledonne Communications RTP Library")
244 (description "oRTP is a C library implementing the RTP protocol. It
245 implements the RFC 3550 standard.")
246 (home-page "https://gitlab.linphone.org/BC/public/ortp")
247 (license license:gpl2+)))
248
249 (define-public bzrtp
250 (package
251 (name "bzrtp")
252 (version "1.0.6")
253 (source
254 (origin
255 (method url-fetch)
256 (uri
257 (string-append "https://www.linphone.org/releases/sources/" name
258 "/" name "-" version ".tar.gz"))
259 (sha256
260 (base32 "12y0kkh90pixaaxfyx26ca2brhy6nw57fsypp6vh8jk1illv0j5z"))))
261 (build-system cmake-build-system)
262 (arguments
263 `(#:tests? #f ; No test target
264 #:configure-flags
265 (list "-DENABLE_STATIC=NO"))) ; Not required
266 (inputs
267 `(("bctoolbox" ,bctoolbox)
268 ("sqlite3" ,sqlite)
269 ("xml2" ,libxml2)))
270 (synopsis "Belledonne Communications ZRTP Library")
271 (description "BZRTP is an implementation of ZRTP keys exchange protocol,
272 written in C. It is fully portable and can be executed on many platforms
273 including both ARM and x86.")
274 (home-page "https://gitlab.linphone.org/BC/public/bzrtp")
275 (license license:gpl2+)))
276
277 (define-public belle-sip
278 (package
279 (name "belle-sip")
280 (version "1.6.3")
281 (source
282 (origin
283 (method url-fetch)
284 (uri
285 (string-append "https://www.linphone.org/releases/sources/" name
286 "/" name "-" version ".tar.gz"))
287 (sha256
288 (base32 "0s55kggmgxap54dkw5856bgk4xg7yvbzialpxnjm0zhpic3hff1z"))))
289 (build-system cmake-build-system)
290 (arguments
291 `(#:tests? #f ; Requires network access
292 #:configure-flags
293 (list "-DENABLE_STATIC=NO") ; Not required
294 #:phases
295 (modify-phases %standard-phases
296 (add-after 'unpack 'patch
297 (lambda _
298 (substitute* "src/CMakeLists.txt"
299 ;; ANTLR would use multithreaded DFA generation otherwise,
300 ;; which would not be reproducible.
301 (("-Xmultithreaded ") ""))
302 #t)))))
303 (inputs
304 `(("antlr3" ,antlr3-3.3)
305 ("antlr3c" ,libantlr3c)
306 ("bctoolbox" ,bctoolbox)
307 ("java" ,icedtea)
308 ("zlib" ,zlib)))
309 (synopsis "Belledonne Communications SIP Library")
310 (description "Belle-sip is a modern library implementing SIP transport,
311 transaction and dialog layers. It is written in C, with an object-oriented
312 API. It also comprises a simple HTTP/HTTPS client implementation.")
313 (home-page "https://gitlab.linphone.org/BC/public/belle-sip")
314 (license license:gpl2+)))
315
316 (define-public mediastreamer2
317 (package
318 (name "mediastreamer2")
319 (version "2.16.1")
320 (source
321 (origin
322 (method url-fetch)
323 (uri
324 (string-append "https://www.linphone.org/releases/sources/"
325 "mediastreamer/mediastreamer-" version ".tar.gz"))
326 (sha256
327 (base32 "0whpqr69wz0pnzvragkpfblxhd0rds8k06c3mw5a0ag216a1yd9k"))
328 (patches (search-patches "mediastreamer2-srtp2.patch"))))
329 (outputs '("out" "doc" "tester"))
330 (build-system cmake-build-system)
331 (arguments
332 `(#:tests? #f ; No test target
333 #:configure-flags
334 (list "-DENABLE_STATIC=NO" ; Not required
335 "-DENABLE_STRICT=NO" ; Would otherwise treat warnings as err
336 "-DENABLE_BV16=NO" ; Not available
337 "-DCMAKE_C_FLAGS=-DMS2_GIT_VERSION=\\\"unknown\\\""
338 "-DCMAKE_CXX_FLAGS=-DMS2_GIT_VERSION=\\\"unknown\\\"")
339 #:phases
340 (modify-phases %standard-phases
341 (add-after 'install 'separate-outputs
342 (lambda* (#:key outputs #:allow-other-keys)
343 (let* ((out (assoc-ref outputs "out"))
344 (doc (assoc-ref outputs "doc"))
345 (tester (assoc-ref outputs "tester"))
346 (tester-name (string-append ,name "_tester")))
347 ;; Copy the tester executable.
348 (mkdir-p (string-append tester "/bin"))
349 (rename-file (string-append out "/bin/" tester-name)
350 (string-append tester "/bin/" tester-name))
351 ;; Copy the tester data files.
352 (copy-recursively (string-append out "/share/" tester-name)
353 (string-append tester "/share/" tester-name))
354 (delete-file-recursively (string-append out "/share/"
355 tester-name))
356 ;; Copy the HTML documentation.
357 (copy-recursively (string-append out "/share/doc/"
358 ,name "-" ,version "/html")
359 (string-append doc "/share/doc/"
360 ,name "-" ,version "/html"))
361 (delete-file-recursively (string-append out "/share/doc/"
362 ,name "-" ,version
363 "/html"))
364 #t))))))
365 (native-inputs
366 `(("dot" ,graphviz)
367 ("doxygen" ,doxygen)
368 ("python" ,python)))
369 (inputs
370 `(("alsa" ,alsa-lib)
371 ("bcg729" ,bcg729)
372 ("bcmatroska2" ,bcmatroska2)
373 ("bctoolbox" ,bctoolbox)
374 ("ffmpeg" ,ffmpeg)
375 ("glew" ,glew)
376 ("glu" ,glu)
377 ("glx" ,mesa-utils)
378 ("gsm" ,gsm)
379 ("opengl" ,mesa)
380 ("opus" ,opus)
381 ("ortp" ,ortp)
382 ("pcap" ,libpcap)
383 ("portaudio" ,portaudio)
384 ("pulseaudio" ,pulseaudio)
385 ("spandsp" ,spandsp)
386 ("speex" ,speex)
387 ("speexdsp" ,speexdsp)
388 ("srtp" ,libsrtp)
389 ("theora" ,libtheora)
390 ("turbojpeg" ,libjpeg-turbo)
391 ("v4l" ,v4l-utils)
392 ("vpx" ,libvpx)
393 ("x11" ,libx11)
394 ("xv" ,libxv)
395 ("zrtp" ,bzrtp)))
396 (synopsis "Belledonne Communications Streaming Engine")
397 (description "Mediastreamer2 is a powerful and lightweight streaming engine
398 for telephony applications. This media processing and streaming toolkit is
399 responsible for receiving and sending all multimedia streams in Linphone,
400 including media capture, encoding and decoding, and rendering.")
401 (home-page "https://gitlab.linphone.org/BC/public/mediastreamer2")
402 (license license:gpl2+)))
403
404 (define-public liblinphone
405 (package
406 (name "liblinphone")
407 (version "3.12.0")
408 (source
409 (origin
410 (method url-fetch)
411 (uri
412 (string-append "https://www.linphone.org/releases/sources/linphone"
413 "/linphone-" version ".tar.gz"))
414 (sha256
415 (base32 "0phhkx55xdyg28d4wn8l8q4yvsmdgzmjiw584d4s190sq1azm91x"))))
416 (outputs '("out" "doc" "tester"))
417 (build-system cmake-build-system)
418 (arguments
419 `(#:tests? #f ; No test target
420 #:configure-flags
421 (list (string-append "-DGTK2_GDKCONFIG_INCLUDE_DIR="
422 (string-append (assoc-ref %build-inputs "gtk2")
423 "/lib/gtk-2.0/include"))
424 (string-append "-DGTK2_GLIBCONFIG_INCLUDE_DIR="
425 (string-append (assoc-ref %build-inputs "glib")
426 "/lib/glib-2.0/include"))
427 "-DENABLE_STATIC=NO" ; Not required
428 "-DENABLE_STRICT=NO"
429 "-DENABLE_GTK_UI=YES") ; for legacy UI
430 #:imported-modules (,@%cmake-build-system-modules
431 (guix build glib-or-gtk-build-system))
432 #:modules ((guix build cmake-build-system)
433 ((guix build glib-or-gtk-build-system) #:prefix glib-or-gtk:)
434 (guix build utils))
435 #:phases
436 (modify-phases %standard-phases
437 (add-after 'unpack 'patch
438 (lambda _
439 (substitute* "gtk/main.c"
440 (("#include \"liblinphone_gitversion.h\"")
441 ""))
442 #t))
443 (add-after 'install 'separate-outputs
444 (lambda* (#:key outputs #:allow-other-keys)
445 (let* ((out (assoc-ref outputs "out"))
446 (doc (assoc-ref outputs "doc"))
447 (tester (assoc-ref outputs "tester"))
448 (tester-name (string-append ,name "_tester")))
449 ;; Copy the tester executable.
450 (mkdir-p (string-append tester "/bin"))
451 (rename-file (string-append out "/bin/" tester-name)
452 (string-append tester "/bin/" tester-name))
453 ;; Copy the tester data files.
454 (mkdir-p (string-append tester "/share/"))
455 (rename-file (string-append out "/share/" tester-name)
456 (string-append tester "/share/" tester-name))
457 ;; Copy the HTML and XML documentation.
458 (copy-recursively
459 (string-append out "/share/doc/linphone-" ,version)
460 (string-append doc "/share/doc/" ,name "-" ,version))
461 (delete-file-recursively
462 (string-append out "/share/doc/linphone-" ,version))
463 #t)))
464 (add-after 'install 'install-man-pages
465 (lambda* (#:key outputs #:allow-other-keys)
466 (let* ((out (assoc-ref outputs "out"))
467 (man (string-append out "/share/man/man1")))
468 (for-each (lambda (file)
469 (install-file file man))
470 (find-files ".." ".*.1$"))
471 #t)))
472 (add-after 'separate-outputs 'glib-or-gtk-compile-schemas
473 (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
474 (add-after 'glib-or-gtk-compile-schemas 'glib-or-gtk-wrap
475 (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
476 (native-inputs
477 `(("gettext" ,gettext-minimal)
478 ("udev" ,eudev) ;for libudev.h
479 ;; For generating the C++ wrappers.
480 ("dot" ,graphviz)
481 ("doxygen" ,doxygen)
482 ("python" ,python)
483 ("pystache" ,python-pystache)
484 ("six" ,python-six)))
485 (inputs
486 `(("bctoolbox" ,bctoolbox)
487 ("belcard" ,belcard)
488 ("bellesip" ,belle-sip)
489 ("bzrtp" ,bzrtp)
490 ("iconv" ,libiconv)
491 ("glib" ,glib)
492 ("gtk2" ,gtk+-2)
493 ("mediastreamer2" ,mediastreamer2)
494 ("notify" ,libnotify)
495 ("ortp" ,ortp)
496 ("sqlite" ,sqlite)
497 ("xml2" ,libxml2)
498 ("zlib" ,zlib)))
499 (synopsis "Belledonne Communications Softphone Library")
500 (description "Liblinphone is a high-level SIP library integrating
501 all calling and instant messaging features into an unified
502 easy-to-use API. It is the cross-platform VoIP library on which the
503 Linphone application is based on, and that anyone can use to add audio
504 and video calls or instant messaging capabilities to an application.")
505 (home-page "https://gitlab.linphone.org/BC/public/liblinphone")
506 (license license:gpl2+)))
507
508 (define-public linphoneqt
509 (package
510 (name "linphoneqt")
511 (version "4.1.1")
512 (source
513 (origin
514 (method url-fetch)
515 (uri
516 (string-append "https://www.linphone.org/releases/sources/" name
517 "/" name "-" version ".tar.gz"))
518 (sha256
519 (base32 "1g2zrr9li0g1hgs6vys06vr98h5dx36z22hx7a6ry231536c002a"))
520 (patches (search-patches "linphoneqt-tabbutton.patch"))))
521 (build-system qt-build-system)
522 (arguments
523 `(#:tests? #f ; No test target
524 #:phases
525 (modify-phases %standard-phases
526 (add-after 'unpack 'fix-cmake-error
527 (lambda _
528 ;; This is fixed in commit efed2fd8 of the master branch.
529 (substitute* "CMakeLists.txt"
530 (("js)\\$\"")
531 "js$\""))
532 #t))
533 (add-after 'unpack 'set-version-string
534 (lambda _
535 (substitute* "src/app/AppController.cpp"
536 (("LINPHONE_QT_GIT_VERSION")
537 (format #f "~s" ,version)))
538 #t))
539 (add-after 'install 'extend-shared-resources
540 ;; Not using the FHS exposes an issue where the client refers to
541 ;; its own "share" directory, which lacks sound files installed by
542 ;; liblinphone.
543 (lambda* (#:key inputs outputs #:allow-other-keys)
544 (let ((liblinphone (assoc-ref inputs "linphone"))
545 (out (assoc-ref outputs "out")))
546 (symlink (string-append liblinphone "/share/sounds")
547 (string-append out "/share/sounds"))
548 #t))))))
549 (native-inputs
550 `(("qttools" ,qttools)))
551 (inputs
552 `(("bctoolbox" ,bctoolbox)
553 ("belcard" ,belcard)
554 ("bellesip" ,belle-sip)
555 ("linphone" ,liblinphone)
556 ("mediastreamer2" ,mediastreamer2)
557 ("qtbase" ,qtbase)
558 ("qtdeclarative" ,qtdeclarative)
559 ("qtgraphicaleffects" ,qtgraphicaleffects)
560 ("qtquickcontrols" ,qtquickcontrols)
561 ("qtquickcontrols2" ,qtquickcontrols2)
562 ("qtsvg" ,qtsvg)))
563 (synopsis "Desktop client for the Linphone SIP softphone")
564 (description "Linphone is a SIP softphone for voice and video over IP calling
565 (VoIP) and instant messaging. Amongst its features are:
566 @itemize
567 @item High Definition (HD) audio and video calls
568 @item Multiple call management (pause and resume)
569 @item Call transfer
570 @item Audio conferencing (merge calls into a conference call)
571 @item Call recording and replay (audio only)
572 @item Instant Messaging with message delivery status (IMDN)
573 @item Picture and file sharing
574 @item Echo cancellation
575 @item Secure user authentication using TLS client certificates
576 @item SRTP, zRTP and SRTP-DTLS voice and video encryption
577 @item Telephone tone (DTMF) support using SIP INFO or RFC 4733
578 @item Audio codecs: opus, speex, g711, g729, gsm, iLBC, g722, SILK, etc.
579 @item Video codecs: VP8, H.264 and H.265 with resolutions up to 1080P, MPEG4
580 @end itemize")
581 (home-page "https://gitlab.linphone.org/BC/public/linphone-desktop")
582 (license license:gpl2+)))
583
584 (define-public msopenh264
585 (package
586 (name "msopenh264")
587 (version "1.2.1")
588 (source
589 (origin
590 (method url-fetch)
591 (uri
592 (string-append "https://www.linphone.org/releases/sources/plugins/"
593 name "/" name "-" version ".tar.gz"))
594 (sha256
595 (base32 "0rdxgazm52560g52pp6mp3mwx6j1z3h2zyizzfycp8y8zi92fqm8"))
596 (patches
597 (list
598 ;; For support for OpenH264 version >= 2.
599 (origin
600 (method url-fetch)
601 (uri
602 (string-append "https://gitlab.linphone.org/BC/public/msopenh264/"
603 "commit/493d147d28c9a0f788ba4e50b47a1ce7b18bf326"
604 ".diff"))
605 (file-name "msopenh264-openh264.patch")
606 (sha256
607 (base32
608 "0mmd7nz5n9ian4rcwn200nldmy5j0dpdrna7r32rqnaw82bx3kdb")))))))
609 (build-system cmake-build-system)
610 (arguments
611 `(#:tests? #f ; No test target
612 #:configure-flags
613 (list "-DENABLE_STATIC=NO"))) ; Not required
614 (inputs
615 `(("mediastreamer2" ,mediastreamer2)
616 ("openh264" ,openh264)
617 ("ortp" ,ortp)))
618 (synopsis "Media Streamer H.264 Codec")
619 (description "MsOpenH264 is an H.264 encoder/decoder plugin for
620 mediastreamer2 based on the openh264 library.")
621 (home-page "https://gitlab.linphone.org/BC/public/msopenh264")
622 (license license:gpl2+)))
623
624 (define-public mssilk
625 (package
626 (name "mssilk")
627 (version "1.1.1")
628 (source
629 (origin
630 (method url-fetch)
631 (uri
632 (string-append "https://www.linphone.org/releases/sources/plugins/"
633 name "/" name "-" version ".tar.gz"))
634 (sha256
635 (base32 "07ip0vd29d1n98lnqs5wpimcsmpm65yl7g5vk4hbqghcbsjw94lj"))))
636 (build-system cmake-build-system)
637 (arguments
638 `(#:tests? #f ; No test target
639 #:configure-flags
640 (list "-DENABLE_STATIC=NO"))) ; Not required
641 (inputs
642 `(("mediastreamer2" ,mediastreamer2)
643 ("ortp" ,ortp)))
644 (synopsis "Media Streamer SILK Codec")
645 (description "MSSILK is a plugin of MediaStreamer, adding support for AMR
646 codec. It is based on the Skype's SILK implementation.")
647 (home-page "https://gitlab.linphone.org/BC/public/mssilk")
648 (license license:gpl2+)))
649
650 (define-public mswebrtc
651 (package
652 (name "mswebrtc")
653 (version "1.1.1")
654 (source
655 (origin
656 (method url-fetch)
657 (uri
658 (string-append "https://www.linphone.org/releases/sources/plugins/"
659 name "/" name "-" version ".tar.gz"))
660 (sha256
661 (base32 "1wj28hl9myhshqmn64xg0jf07aw75gmnilb5rff6rcbdxim87mqr"))))
662 (build-system cmake-build-system)
663 (arguments
664 `(#:tests? #f ; No test target
665 #:configure-flags
666 (list
667 "-DENABLE_STATIC=NO"))) ; Not required
668 (inputs
669 `(("bctoolbox" ,bctoolbox)
670 ("mediastreamer2" ,mediastreamer2)
671 ("ortp" ,ortp)))
672 (synopsis "Media Streamer WebRTC Codec")
673 (description "MSWebRTC is a plugin of MediaStreamer, adding support for
674 WebRTC codec. It includes features from WebRTC, such as, iSAC and AECM.")
675 (home-page "https://gitlab.linphone.org/BC/public/mswebrtc")
676 (license license:gpl2+)))
677
678 (define-public msamr
679 (package
680 (name "msamr")
681 (version "1.1.3")
682 (source
683 (origin
684 (method url-fetch)
685 (uri
686 (string-append "https://www.linphone.org/releases/sources/plugins/"
687 name "/" name "-" version ".tar.gz"))
688 (sha256
689 (base32 "16c9f3z4wnj73k7y8gb0fgpr4axsm7b5zrbjvy8vsgz9gyg3agm5"))))
690 (build-system cmake-build-system)
691 (arguments
692 `(#:tests? #f ; No test target
693 #:configure-flags
694 (list "-DENABLE_STATIC=NO" ; Not required
695 "-DENABLE_WIDEBAND=YES")))
696 (inputs
697 `(("mediastreamer2" ,mediastreamer2)
698 ("opencoreamr" ,opencore-amr)
699 ("ortp" ,ortp)
700 ("voamrwbenc" ,vo-amrwbenc)))
701 (synopsis "Media Streamer AMR Codec")
702 (description "MSAMR is a plugin of MediaStreamer, adding support for AMR
703 codec. It is based on the opencore-amr implementation.")
704 (home-page "https://gitlab.linphone.org/BC/public/msamr")
705 (license license:gpl3+)))