gnu: python-debian: Set version to build reproducibly.
[jackhill/guix/guix.git] / gnu / packages / patches / python-flake8-polyfill-flake8-4-compat.patch
1 https://github.com/PyCQA/flake8-polyfill/commit/3cf414350e82ceb835ca2edbd5d5967d33e9ff35.patch
2
3
4 From 3cf414350e82ceb835ca2edbd5d5967d33e9ff35 Mon Sep 17 00:00:00 2001
5 From: Ian Stapleton Cordasco <graffatcolmingov@gmail.com>
6 Date: Mon, 1 Nov 2021 19:18:04 -0500
7 Subject: [PATCH] Skip unnecessary tests on Flake8 4.x+
8
9 ---
10 tests/test_stdin.py | 4 ++++
11 1 file changed, 4 insertions(+)
12
13 diff --git a/tests/test_stdin.py b/tests/test_stdin.py
14 index 4350967..212b309 100644
15 --- a/tests/test_stdin.py
16 +++ b/tests/test_stdin.py
17 @@ -1,4 +1,5 @@
18 """Tests for polyfill's stdin monkey patching."""
19 +import flake8
20 import pep8
21 import pycodestyle
22 import pytest
23 @@ -6,6 +7,9 @@
24 from flake8_polyfill import stdin
25 from flake8_polyfill import version
26
27 +if (4, 0, 0) <= flake8.__version_info__:
28 + pytestmark = pytest.mark.skip
29 +
30
31 def test_modules_dict():
32 """Verify that it works the way we expect."""