gnu: evisum: Build translations.
[jackhill/guix/guix.git] / gnu / packages / enlightenment.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Tomáš Čech <sleep_walker@suse.cz>
3 ;;; Copyright © 2015 Daniel Pimentel <d4n1@member.fsf.org>
4 ;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
5 ;;; Copyright © 2017 Nikita <nikita@n0.is>
6 ;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
7 ;;; Copyright © 2018 Timo Eisenmann <eisenmann@fn.de>
8 ;;;
9 ;;; This file is part of GNU Guix.
10 ;;;
11 ;;; GNU Guix is free software; you can redistribute it and/or modify it
12 ;;; under the terms of the GNU General Public License as published by
13 ;;; the Free Software Foundation; either version 3 of the License, or (at
14 ;;; your option) any later version.
15 ;;;
16 ;;; GNU Guix is distributed in the hope that it will be useful, but
17 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
18 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
19 ;;; GNU General Public License for more details.
20 ;;;
21 ;;; You should have received a copy of the GNU General Public License
22 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
23
24 (define-module (gnu packages enlightenment)
25 #:use-module ((guix licenses) #:prefix license:)
26 #:use-module (guix packages)
27 #:use-module (guix download)
28 #:use-module (guix utils)
29 #:use-module (guix build-system gnu)
30 #:use-module (guix build-system meson)
31 #:use-module (guix build-system python)
32 #:use-module (gnu packages)
33 #:use-module (gnu packages algebra)
34 #:use-module (gnu packages bittorrent)
35 #:use-module (gnu packages check)
36 #:use-module (gnu packages code)
37 #:use-module (gnu packages compression)
38 #:use-module (gnu packages curl)
39 #:use-module (gnu packages fontutils)
40 #:use-module (gnu packages freedesktop)
41 #:use-module (gnu packages fribidi)
42 #:use-module (gnu packages game-development)
43 #:use-module (gnu packages gettext)
44 #:use-module (gnu packages ghostscript)
45 #:use-module (gnu packages gl)
46 #:use-module (gnu packages glib)
47 #:use-module (gnu packages gnome)
48 #:use-module (gnu packages gstreamer)
49 #:use-module (gnu packages gtk)
50 #:use-module (gnu packages ibus)
51 #:use-module (gnu packages image)
52 #:use-module (gnu packages linux)
53 #:use-module (gnu packages llvm)
54 #:use-module (gnu packages lua)
55 #:use-module (gnu packages pdf)
56 #:use-module (gnu packages perl)
57 #:use-module (gnu packages photo)
58 #:use-module (gnu packages pkg-config)
59 #:use-module (gnu packages pulseaudio)
60 #:use-module (gnu packages python)
61 #:use-module (gnu packages python-xyz)
62 #:use-module (gnu packages tls)
63 #:use-module (gnu packages video)
64 #:use-module (gnu packages xdisorg)
65 #:use-module (gnu packages xorg)
66 #:use-module (ice-9 match))
67
68 (define-public efl
69 (package
70 (name "efl")
71 (version "1.25.0")
72 (source (origin
73 (method url-fetch)
74 (uri (string-append
75 "https://download.enlightenment.org/rel/libs/efl/efl-"
76 version ".tar.xz"))
77 (sha256
78 (base32
79 "0vlmf0rp2qxdl06pdmrd1xdfa10sdz30vnxzc98inpdg1n8iz52k"))))
80 (build-system meson-build-system)
81 (native-inputs
82 `(("check" ,check)
83 ("gettext" ,gettext-minimal)
84 ("pkg-config" ,pkg-config)))
85 (inputs
86 `(("curl" ,curl)
87 ("giflib" ,giflib)
88 ("gstreamer" ,gstreamer)
89 ("gst-plugins-base" ,gst-plugins-base)
90 ("ibus" ,ibus)
91 ("mesa" ,mesa)
92 ("libraw" ,libraw)
93 ("librsvg" ,librsvg)
94 ("libspectre" ,libspectre)
95 ("libtiff" ,libtiff)
96 ("libxau" ,libxau)
97 ("libxcomposite" ,libxcomposite)
98 ("libxcursor" ,libxcursor)
99 ("libxdamage" ,libxdamage)
100 ("libxdmcp" ,libxdmcp)
101 ("libxext" ,libxext)
102 ("libxi" ,libxi)
103 ("libxfixes" ,libxfixes)
104 ("libxinerama" ,libxinerama)
105 ("libxrandr" ,libxrandr)
106 ("libxrender" ,libxrender)
107 ("libxss" ,libxscrnsaver)
108 ("libxtst" ,libxtst)
109 ("libwebp" ,libwebp)
110 ("openjpeg" ,openjpeg)
111 ("poppler" ,poppler)
112 ("util-linux" ,util-linux "lib")
113 ("wayland-protocols" ,wayland-protocols)))
114 (propagated-inputs
115 ;; All these inputs are in package config files in section
116 ;; Requires.private.
117 `(("dbus" ,dbus)
118 ("elogind" ,elogind)
119 ("eudev" ,eudev)
120 ("fontconfig" ,fontconfig)
121 ("freetype" ,freetype)
122 ("fribidi" ,fribidi)
123 ("glib" ,glib)
124 ("harfbuzz" ,harfbuzz)
125 ("libinput" ,libinput-minimal)
126 ("libjpeg" ,libjpeg-turbo)
127 ("libsndfile" ,libsndfile)
128 ("libpng" ,libpng)
129 ("libx11" ,libx11)
130 ("libxkbcommon" ,libxkbcommon)
131 ("luajit" ,luajit)
132 ("lz4" ,lz4)
133 ("openssl" ,openssl)
134 ("pulseaudio" ,pulseaudio)
135 ("wayland" ,wayland)
136 ("zlib" ,zlib)))
137 (arguments
138 `(#:configure-flags '("-Dembedded-lz4=false"
139 "-Dbuild-examples=false"
140 "-Decore-imf-loaders-disabler=scim"
141 "-Dglib=true"
142 "-Dmount-path=/run/setuid-programs/mount"
143 "-Dunmount-path=/run/setuid-programs/umount"
144 ;(string-append "-Ddictionaries-hyphen-dir="
145 ; (assoc-ref %build-inputs "hyphen")
146 ; "/share/hyphen")
147 "-Dnetwork-backend=connman"
148 ;; for wayland
149 "-Dwl=true"
150 "-Ddrm=true")
151 #:tests? #f ; Many tests fail due to timeouts and network requests.
152 #:phases
153 (modify-phases %standard-phases
154 ;; If we don't hardcode the location of libcurl.so and others then we
155 ;; have to wrap the outputs of efl's dependencies in those libraries.
156 (add-after 'unpack 'hardcode-dynamic-libraries
157 (lambda* (#:key inputs #:allow-other-keys)
158 (let ((curl (assoc-ref inputs "curl"))
159 (pulse (assoc-ref inputs "pulseaudio"))
160 (sndfile (assoc-ref inputs "libsndfile"))
161 (elogind (assoc-ref inputs "elogind"))
162 (lib "/lib/"))
163 (substitute* "src/lib/ecore_con/ecore_con_url_curl.c"
164 (("libcurl.so.?" libcurl) ; libcurl.so.[45]
165 (string-append curl lib libcurl)))
166 (substitute* "src/lib/ecore_audio/ecore_audio.c"
167 (("libpulse.so.0" libpulse)
168 (string-append pulse lib libpulse))
169 (("libsndfile.so.1" libsnd)
170 (string-append sndfile lib libsnd)))
171 (substitute* "src/lib/elput/elput_logind.c"
172 (("libelogind.so.0" libelogind)
173 (string-append elogind "/lib/" libelogind)))
174 #t)))
175 (add-after 'unpack 'fix-install-paths
176 (lambda _
177 (substitute* "dbus-services/meson.build"
178 (("install_dir.*")
179 "install_dir: join_paths(dir_data, 'dbus-1', 'services'))\n"))
180 (substitute* "src/tests/elementary/meson.build"
181 (("dir_data") "meson.source_root(), 'test-output'"))
182 #t))
183 (add-after 'unpack 'set-home-directory
184 ;; FATAL: Cannot create run dir '/homeless-shelter/.run' - errno=2
185 (lambda _ (setenv "HOME" "/tmp") #t)))))
186 (home-page "https://www.enlightenment.org/about-efl")
187 (synopsis "Enlightenment Foundation Libraries")
188 (description
189 "Enlightenment Foundation Libraries is a set of libraries developed
190 for Enlightenment. Libraries covers data serialization, wide support for
191 graphics rendering, UI layout and themes, interaction with OS, access to
192 removable devices or support for multimedia.")
193 ;; Different parts are under different licenses.
194 (license (list license:bsd-2 license:lgpl2.1 license:zlib))))
195
196 (define-public terminology
197 (package
198 (name "terminology")
199 (version "1.8.1")
200 (source (origin
201 (method url-fetch)
202 (uri
203 (string-append "https://download.enlightenment.org/rel/apps/"
204 "terminology/terminology-" version ".tar.xz"))
205 (sha256
206 (base32
207 "1fxqjf7g30ix4qxi6366rrax27s3maxq43z2vakwnhz4mp49m9h4"))
208 (modules '((guix build utils)))
209 ;; Remove the bundled fonts.
210 (snippet
211 '(begin
212 (delete-file-recursively "data/fonts")
213 (substitute* "data/meson.build"
214 (("subdir\\('fonts'\\)") ""))
215 #t))))
216 (build-system meson-build-system)
217 (arguments
218 `(#:configure-flags (list "-Dtests=true"
219 (string-append "-Dedje-cc="
220 (assoc-ref %build-inputs "efl")
221 "/bin/edje_cc"))
222 #:phases
223 (modify-phases %standard-phases
224 (add-after 'unpack 'set-home-directory
225 ;; FATAL: Cannot create run dir '/homeless-shelter/.run' - errno=2
226 (lambda _ (setenv "HOME" "/tmp") #t))
227 (replace 'check
228 (lambda _
229 (with-directory-excursion
230 (string-append "../" ,name "-" ,version "/tests")
231 (invoke "sh" "run_tests.sh" "--verbose"
232 "-t" "../../build/src/bin/tytest"))))
233 (add-after 'install 'remove-test-binary
234 (lambda* (#:key outputs #:allow-other-keys)
235 ;; This file is not meant to be installed.
236 (delete-file (string-append (assoc-ref outputs "out")
237 "/bin/tytest"))
238 #t)))))
239 (native-inputs
240 `(("gettext" ,gettext-minimal)
241 ("perl" ,perl)
242 ("pkg-config" ,pkg-config)))
243 (inputs
244 `(("efl" ,efl)))
245 (home-page "https://www.enlightenment.org/about-terminology")
246 (synopsis "Powerful terminal emulator based on EFL")
247 (description
248 "Terminology is fast and feature rich terminal emulator. It is solely
249 based on Enlightenment Foundation Libraries. It supports multiple tabs, UTF-8,
250 URL and local path detection, themes, popup based content viewer for non-text
251 contents and more.")
252 (license license:bsd-2)))
253
254 (define-public rage
255 (package
256 (name "rage")
257 (version "0.3.1")
258 (source (origin
259 (method url-fetch)
260 (uri
261 (string-append
262 "https://download.enlightenment.org/rel/apps/rage/rage-"
263 version ".tar.xz"))
264 (sha256
265 (base32
266 "04fdk23bbgvni212zrfy4ndg7vmshbsjgicrhckdvhay87pk9i75"))))
267 (build-system meson-build-system)
268 (arguments
269 '(#:phases
270 (modify-phases %standard-phases
271 (add-after 'unpack 'set-home-directory
272 ;; FATAL: Cannot create run dir '/homeless-shelter/.run' - errno=2
273 (lambda _ (setenv "HOME" "/tmp") #t)))))
274 (native-inputs
275 `(("pkg-config" ,pkg-config)))
276 (inputs
277 `(("efl" ,efl)))
278 (home-page "https://www.enlightenment.org/about-rage")
279 (synopsis "Video and audio player based on EFL")
280 (description
281 "Rage is a video and audio player written with Enlightenment Foundation
282 Libraries with some extra bells and whistles.")
283 (license license:bsd-2)))
284
285 (define-public enlightenment
286 (package
287 (name "enlightenment")
288 (version "0.24.2")
289 (source (origin
290 (method url-fetch)
291 (uri
292 (string-append "https://download.enlightenment.org/rel/apps/"
293 "enlightenment/enlightenment-" version ".tar.xz"))
294 (sha256
295 (base32
296 "1wfz0rwwsx7c1mkswn4hc9xw1i6bsdirhxiycf7ha2vcipqy465y"))
297 (patches (search-patches "enlightenment-fix-setuid-path.patch"))))
298 (build-system meson-build-system)
299 (arguments
300 `(#:configure-flags
301 (let ((efl (assoc-ref %build-inputs "efl")))
302 (list "-Dsystemd=false"
303 "-Dpackagekit=false"
304 "-Dwl=true"
305 (string-append "-Dedje-cc=" efl "/bin/edje_cc")
306 (string-append "-Deldbus-codegen=" efl "/bin/eldbus-codegen")
307 (string-append "-Deet=" efl "/bin/eet")))
308 #:phases
309 (modify-phases %standard-phases
310 (delete 'bootstrap) ; We don't want to run the autogen script.
311 (add-before 'configure 'set-system-actions
312 (lambda* (#:key inputs #:allow-other-keys)
313 (setenv "HOME" "/tmp")
314 (let ((xkeyboard (assoc-ref inputs "xkeyboard-config"))
315 (setxkbmap (assoc-ref inputs "setxkbmap"))
316 (libc (assoc-ref inputs "libc"))
317 (bc (assoc-ref inputs "bc"))
318 (efl (assoc-ref inputs "efl")))
319 ;; We need to patch the path to 'base.lst' to be able
320 ;; to switch the keyboard layout in E.
321 (substitute* (list "src/modules/xkbswitch/e_mod_parse.c"
322 "src/modules/wizard/page_011.c")
323 (("/usr/share/X11/xkb/rules/xorg.lst")
324 (string-append xkeyboard
325 "/share/X11/xkb/rules/base.lst")))
326 (substitute* "src/bin/e_xkb.c"
327 (("\"setxkbmap \"")
328 (string-append "\"" setxkbmap "/bin/setxkbmap \"")))
329 (substitute* (list "src/bin/e_intl.c"
330 "src/modules/conf_intl/e_int_config_intl.c"
331 "src/modules/wizard/page_010.c")
332 (("locale -a") (string-append libc "/bin/locale -a")))
333 (substitute* "src/modules/everything/evry_plug_apps.c"
334 (("/usr/bin/") ""))
335 (substitute* '("src/bin/e_sys_main.c"
336 "src/bin/e_util_suid.h")
337 (("PATH=/bin:/usr/bin:/sbin:/usr/sbin")
338 (string-append "PATH=/run/setuid-programs:"
339 "/run/current-system/profile/bin:"
340 "/run/current-system/profile/sbin")))
341 (substitute* "src/modules/everything/evry_plug_calc.c"
342 (("bc -l") (string-append bc "/bin/bc -l")))
343 (substitute* "data/etc/meson.build"
344 (("/bin/mount") "/run/setuid-programs/mount")
345 (("/bin/umount") "/run/setuid-programs/umount")
346 (("/usr/bin/eject") "/run/current-system/profile/bin/eject"))
347 (substitute* "src/bin/system/e_system_power.c"
348 (("systemctl") "loginctl"))
349 #t))))))
350 (native-inputs
351 `(("gettext" ,gettext-minimal)
352 ("pkg-config" ,pkg-config)))
353 (inputs
354 `(("alsa-lib" ,alsa-lib)
355 ("bc" ,bc)
356 ("bluez" ,bluez)
357 ("dbus" ,dbus)
358 ("freetype" ,freetype)
359 ("libxcb" ,libxcb)
360 ("libxext" ,libxext)
361 ("linux-pam" ,linux-pam)
362 ("puleseaudio" ,pulseaudio)
363 ("setxkbmap" ,setxkbmap)
364 ("xcb-util-keysyms" ,xcb-util-keysyms)
365 ("xkeyboard-config" ,xkeyboard-config)
366 ("xorg-server-xwayland" ,xorg-server-xwayland)))
367 (propagated-inputs
368 `(("efl" ,efl)
369 ("libxkbcommon" ,libxkbcommon)
370 ("wayland-protocols" ,wayland-protocols)))
371 (home-page "https://www.enlightenment.org/about-enlightenment")
372 (synopsis "Lightweight desktop environment")
373 (description
374 "Enlightenment is resource friendly desktop environment with integrated
375 file manager, wide range of configuration options, plugin system allowing to
376 unload unused functionality, with support for touchscreen and suitable for
377 embedded systems.")
378 (license license:bsd-2)))
379
380 (define-public enlightenment-wayland
381 (deprecated-package "enlightenment-wayland" enlightenment))
382
383 (define-public python-efl
384 (package
385 (name "python-efl")
386 (version "1.24.0")
387 (source
388 (origin
389 (method url-fetch)
390 (uri (string-append "https://download.enlightenment.org/rel/bindings/"
391 "python/python-efl-" version ".tar.xz"))
392 (sha256
393 (base32
394 "1vk1cdd959gia4a9qzyq56a9zw3lqf9ck66k8c9g3c631mp5cfpy"))
395 (modules '((guix build utils)))
396 ;; Remove files generated by Cython
397 (snippet
398 '(begin
399 (for-each (lambda (file)
400 (let ((generated-file
401 (string-append (string-drop-right file 3) "c")))
402 (when (file-exists? generated-file)
403 (delete-file generated-file))))
404 (find-files "efl" "\\.pyx$"))
405 (delete-file "efl/eo/efl.eo_api.h")
406 #t))))
407 (build-system python-build-system)
408 (arguments
409 '(#:phases
410 (modify-phases %standard-phases
411 (replace 'build
412 (lambda _
413 (setenv "ENABLE_CYTHON" "1")
414 (invoke "python" "setup.py" "build")))
415 (add-before 'build 'set-flags
416 (lambda _
417 (setenv "CFLAGS"
418 (string-append "-I" (assoc-ref %build-inputs "python-dbus")
419 "/include/dbus-1.0"))
420 #t))
421 (add-before 'check 'set-environment
422 (lambda _
423 ;; Some tests require write access to HOME.
424 (setenv "HOME" "/tmp")
425 ;; These tests try to connect to the internet.
426 (delete-file "tests/ecore/test_09_file_download.py")
427 (delete-file "tests/ecore/test_11_con.py")
428 #t)))))
429 (native-inputs
430 `(("pkg-config" ,pkg-config)
431 ("python-cython" ,python-cython)))
432 (inputs
433 `(("efl" ,efl)
434 ("python-dbus" ,python-dbus)))
435 (home-page "https://www.enlightenment.org/")
436 (synopsis "Python bindings for EFL")
437 (description
438 "PYTHON-EFL are the python bindings for the whole Enlightenment Foundation
439 Libraries stack (eo, evas, ecore, edje, emotion, ethumb and elementary).")
440 (license license:lgpl3)))
441
442 (define-public python2-efl
443 (package-with-python2 python-efl))
444
445 (define-public edi
446 (package
447 (name "edi")
448 (version "0.8.0")
449 (source
450 (origin
451 (method url-fetch)
452 (uri (string-append "https://github.com/Enlightenment/edi/releases/"
453 "download/v" version "/edi-" version ".tar.xz"))
454 (sha256
455 (base32
456 "01k8gp8r2wa6pyg3dkbm35m6hdsbss06hybghg0qjmd4mzswcd3a"))))
457 (build-system meson-build-system)
458 (arguments
459 '(#:phases
460 (modify-phases %standard-phases
461 (add-after 'unpack 'fix-clang-header
462 (lambda _
463 (substitute* "scripts/clang_include_dir.sh"
464 (("grep clang") "grep clang | head -n1"))
465 #t))
466 (add-after 'unpack 'set-home-directory
467 ;; FATAL: Cannot create run dir '/homeless-shelter/.run' - errno=2
468 (lambda _ (setenv "HOME" "/tmp") #t)))
469 #:tests? #f)) ; tests require running dbus service
470 (native-inputs
471 `(("check" ,check)
472 ("gettext" ,gettext-minimal)
473 ("pkg-config" ,pkg-config)))
474 (inputs
475 `(("clang" ,clang)
476 ("efl" ,efl)))
477 (home-page "https://www.enlightenment.org/about-edi")
478 (synopsis "Development environment for Enlightenment")
479 (description "EDI is a development environment designed for and built using
480 the EFL. It's aim is to create a new, native development environment for Linux
481 that tries to lower the barrier to getting involved in Enlightenment development
482 and in creating applications based on the Enlightenment Foundation Library suite.")
483 (license (list license:public-domain ; data/extra/skeleton
484 license:gpl2 ; edi
485 license:gpl3)))) ; data/extra/examples/images/mono-runtime.png
486
487 (define-public lekha
488 (package
489 (name "lekha")
490 (version "0.2.1")
491 (source (origin
492 (method url-fetch)
493 (uri (pypi-uri "Lekha" version))
494 (sha256
495 (base32
496 "0zr6i74ik58pbzrd7r9l7sawqbdv0r2c1a9927qkqzwga27x8j15"))))
497 (build-system python-build-system)
498 (arguments
499 `(#:tests? #f ; no test target
500 #:python ,python-2
501 #:phases
502 (modify-phases %standard-phases
503 (add-after 'unpack 'fix-data-location
504 (lambda _ (substitute* "setup.py"
505 (("'/usr/")"'"))
506 #t)))))
507 (propagated-inputs
508 `(("python2-efl" ,python2-efl)
509 ("python2-pypdf2" ,python2-pypdf2)
510 ("python2-pyxdg" ,python2-pyxdg)))
511 (synopsis "Simple PDF viewer")
512 (description
513 "Simple PDF viewer based on the Enlightenment Foundation Libraries.")
514 (home-page "https://github.com/kaihu/lekha")
515 (license license:gpl3+)))
516
517 (define-public ephoto
518 (package
519 (name "ephoto")
520 (version "1.5")
521 (source
522 (origin
523 (method url-fetch)
524 (uri (string-append "https://download.enlightenment.org/rel/"
525 "apps/ephoto/ephoto-" version ".tar.xz"))
526 (sha256
527 (base32 "1q7v9abjp9jrs08xc7pqaac64yzax24dk1snjb9rciarzzh3mlzy"))))
528 (build-system gnu-build-system)
529 (arguments
530 '(#:phases
531 (modify-phases %standard-phases
532 (add-after 'unpack 'set-home-directory
533 ;; FATAL: Cannot create run dir '/homeless-shelter/.run' - errno=2
534 (lambda _ (setenv "HOME" "/tmp") #t)))))
535 (native-inputs
536 `(("check" ,check)
537 ("pkg-config" ,pkg-config)))
538 (inputs
539 `(("efl" ,efl)))
540 (home-page "https://smhouston.us/projects/ephoto/")
541 (synopsis "EFL image viewer/editor/manipulator/slideshow creator")
542 (description "Ephoto is an image viewer and editor written using the
543 @dfn{Enlightenment Foundation Libraries} (EFL). It focuses on simplicity and
544 ease of use, while taking advantage of the speed and small footprint the EFL
545 provide.
546
547 Ephoto’s features include:
548 @enumerate
549 @item Browsing the file system and displaying images in an easy-to-use grid view.
550 @item Browsing images in a single image view format.
551 @item Viewing images in a slideshow.
552 @item Editing your image with features such as cropping, auto enhance,
553 blurring, sharpening, brightness/contrast/gamma adjustments, hue/saturation/value
554 adjustments, and color level adjustment.
555 @item Applying artistic filters to your image such as black and white and old
556 photo.
557 @item Drag And Drop along with file operations to easily maintain your photo
558 directories.
559 @end enumerate\n")
560 (license (list
561 license:bsd-2 ; Ephoto's thumbnailing code
562 license:bsd-3))))
563
564 (define-public evisum
565 (package
566 (name "evisum")
567 (version "0.5.6")
568 (source
569 (origin
570 (method url-fetch)
571 (uri (string-append "https://download.enlightenment.org/rel/apps/"
572 "evisum/evisum-" version ".tar.xz"))
573 (sha256
574 (base32 "1l8pym7738kncvic5ga03sj9d5igigvmcxa9lbg47z2yvdjwzv97"))))
575 (build-system meson-build-system)
576 (arguments
577 '(#:tests? #f)) ; no tests
578 (native-inputs
579 `(("gettext" ,gettext-minimal)
580 ("pkg-config" ,pkg-config)))
581 (inputs
582 `(("efl" ,efl)))
583 (home-page "https://www.enlightenment.org")
584 (synopsis "EFL process viewer")
585 (description
586 "This is a process monitor and system monitor using the
587 @dfn{Enlightenment Foundation Libraries} (EFL).")
588 (license license:bsd-2)))
589
590 (define-public epour
591 (package
592 (name "epour")
593 (version "0.7.0")
594 (source
595 (origin
596 (method url-fetch)
597 (uri (string-append "https://download.enlightenment.org/rel/apps/epour"
598 "/epour-" version ".tar.xz"))
599 (sha256
600 (base32
601 "0g9f9p01hsq6dcf4cs1pwq95g6fpkyjgwqlvdjk1km1i5gj5ygqw"))))
602 (build-system python-build-system)
603 (arguments
604 `(#:tests? #f ; no test target
605 #:use-setuptools? #f
606 #:phases
607 (modify-phases %standard-phases
608 (add-after 'unpack 'find-theme-dir
609 (lambda* (#:key outputs #:allow-other-keys)
610 (let ((out (assoc-ref outputs "out")))
611 (substitute* "epour/gui/__init__.py"
612 (("join\\(data_path")
613 (string-append "join(\"" out "/share/epour\"")))
614 #t))))))
615 (native-inputs
616 `(("intltool" ,intltool)
617 ("python-distutils-extra" ,python-distutils-extra)))
618 (inputs
619 `(("libtorrent-rasterbar" ,libtorrent-rasterbar)
620 ("python-dbus" ,python-dbus)
621 ("python-efl" ,python-efl)
622 ("python-pyxdg" ,python-pyxdg)))
623 (home-page "https://www.enlightenment.org")
624 (synopsis "EFL Bittorrent client")
625 (description "Epour is a BitTorrent client based on the @dfn{Enlightenment
626 Foundation Libraries} (EFL) and rb-libtorrent.")
627 (license license:gpl3+)))