Merge branch 'master' into staging
[jackhill/guix/guix.git] / gnu / packages / sphinx.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 David Thompson <davet@gnu.org>
3 ;;; Copyright © 2015, 2017, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
4 ;;; Copyright © 2015, 2016, 2017 Leo Famulari <leo@famulari.name>
5 ;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
6 ;;; Copyright © 2016, 2017, 2018, 2019 Marius Bakke <mbakke@fastmail.com>
7 ;;; Copyright © 2017 Danny Milosavljevic <dannym+a@scratchpost.org>
8 ;;; Copyright © 2017, 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
9 ;;; Copyright © 2017 Frederick M. Muriithi <fredmanglis@gmail.com>
10 ;;; Copyright © 2017 Christopher Allan Webber <cwebber@dustycloud.org>
11 ;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
12 ;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
13 ;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
14 ;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
15 ;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
16 ;;;
17 ;;; This file is part of GNU Guix.
18 ;;;
19 ;;; GNU Guix is free software; you can redistribute it and/or modify it
20 ;;; under the terms of the GNU General Public License as published by
21 ;;; the Free Software Foundation; either version 3 of the License, or (at
22 ;;; your option) any later version.
23 ;;;
24 ;;; GNU Guix is distributed in the hope that it will be useful, but
25 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
26 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
27 ;;; GNU General Public License for more details.
28 ;;;
29 ;;; You should have received a copy of the GNU General Public License
30 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
31
32 (define-module (gnu packages sphinx)
33 #:use-module (guix packages)
34 #:use-module (guix download)
35 #:use-module (guix git-download)
36 #:use-module (guix utils)
37 #:use-module (guix build-system python)
38 #:use-module ((guix licenses) #:prefix license:)
39 #:use-module (gnu packages)
40 #:use-module (gnu packages check)
41 #:use-module (gnu packages graphviz)
42 #:use-module (gnu packages image)
43 #:use-module (gnu packages imagemagick)
44 #:use-module (gnu packages python-web)
45 #:use-module (gnu packages python-xyz)
46 #:use-module (gnu packages time))
47
48 (define-public python-sphinx
49 (package
50 (name "python-sphinx")
51 (version "3.1.2")
52 (source
53 (origin
54 (method url-fetch)
55 (uri (pypi-uri "Sphinx" version))
56 (sha256
57 (base32
58 "1zd8l4dh0v4p8m7s51xr001k09cq2023dd0953ygw7xa76dypnmr"))))
59 (build-system python-build-system)
60 (arguments
61 `(#:phases
62 (modify-phases %standard-phases
63 (replace 'check
64 (lambda _
65 ;; Requires Internet access.
66 (delete-file "tests/test_build_linkcheck.py")
67 (substitute* "tests/test_build_latex.py"
68 (("@pytest.mark.sphinx\\('latex', testroot='images'\\)")
69 "@pytest.mark.skip()"))
70 (invoke "make" "test"))))))
71 (propagated-inputs
72 `(("python-babel" ,python-babel)
73 ("python-docutils" ,python-docutils)
74 ("python-jinja2" ,python-jinja2)
75 ("python-imagesize" ,python-imagesize)
76 ("python-packaging" ,python-packaging)
77 ("python-pygments" ,python-pygments)
78 ("python-requests" ,python-requests)
79 ("python-snowballstemmer" ,python-snowballstemmer)
80 ("python-sphinx-alabaster-theme"
81 ,python-sphinx-alabaster-theme)
82 ("python-sphinxcontrib-applehelp" ,python-sphinxcontrib-applehelp)
83 ("python-sphinxcontrib-devhelp" ,python-sphinxcontrib-devhelp)
84 ("python-sphinxcontrib-htmlhelp" ,python-sphinxcontrib-htmlhelp)
85 ("python-sphinxcontrib-jsmath" ,python-sphinxcontrib-jsmath)
86 ("python-sphinxcontrib-qthelp" ,python-sphinxcontrib-qthelp)
87 ("python-sphinxcontrib-serializinghtml"
88 ,python-sphinxcontrib-serializinghtml)))
89 (native-inputs
90 `(("graphviz" ,graphviz)
91 ("imagemagick" ,imagemagick) ;for "convert"
92 ("python-html5lib" ,python-html5lib)
93 ("python-mock" ,python-mock)
94 ("python-nose" ,python-nose)
95 ("python-pytest" ,python-pytest)))
96 (home-page "https://www.sphinx-doc.org")
97 (synopsis "Python documentation generator")
98 (description "Sphinx is a tool that makes it easy to create documentation
99 for Python projects or other documents consisting of multiple reStructuredText
100 sources.")
101 (license license:bsd-2)
102 (properties `((python2-variant . ,(delay python-sphinx))))))
103
104 (define-public python-sphinxcontrib-applehelp
105 (package
106 (name "python-sphinxcontrib-applehelp")
107 (version "1.0.2")
108 (source (origin
109 (method url-fetch)
110 (uri (pypi-uri "sphinxcontrib-applehelp" version))
111 (sha256
112 (base32
113 "0n5wrn4l7x6gxvi1g7c6y72hkxgc223axz1jykipaxhfr1g76wm0"))))
114 (build-system python-build-system)
115 (arguments
116 `(#:tests? #f)) ;XXX: circular dependency on Sphinx
117 (home-page "https://github.com/sphinx-doc/sphinxcontrib-applehelp")
118 (synopsis "Sphinx extension for creating Apple help books")
119 (description
120 "@code{sphinxcontrib-applehelp} is a Sphinx extension which outputs
121 Apple help books.")
122 (license license:bsd-2)))
123
124 (define-public python-sphinx-copybutton
125 (package
126 (name "python-sphinx-copybutton")
127 (version "0.2.6")
128 (source
129 (origin
130 (method url-fetch)
131 (uri (pypi-uri "sphinx-copybutton" version))
132 (sha256
133 (base32
134 "0ny9jpygj93z8jyjpi4v6jjz90pmns74s389wq16igzzq2mpgfjm"))))
135 (build-system python-build-system)
136 (arguments
137 `(#:tests? #f)) ; XXX: Check requires network access.
138 (propagated-inputs
139 `(("python-flit" ,python-flit)
140 ("python-setuptools" ,python-setuptools)
141 ("python-sphinx" ,python-sphinx)
142 ("python-wheel" ,python-wheel)))
143 (home-page "https://github.com/choldgraf/sphinx-copybutton")
144 (synopsis "Sphinx extension to add \"copy\" buttons to code blocks")
145 (description
146 "This package provides a small sphinx extension to add \"copy\" buttons
147 to code blocks.")
148 (license license:expat)))
149
150 (define-public python-sphinxcontrib-devhelp
151 (package
152 (name "python-sphinxcontrib-devhelp")
153 (version "1.0.2")
154 (source (origin
155 (method url-fetch)
156 (uri (pypi-uri "sphinxcontrib-devhelp" version))
157 (sha256
158 (base32
159 "1r1qngsbjqbg4rj93kpj44qqy7n4x5khldkr0c3ffhlnggx1lzzz"))))
160 (build-system python-build-system)
161 (arguments
162 `(#:tests? #f)) ;XXX: circular dependency on Sphinx
163 (home-page "https://github.com/sphinx-doc/sphinxcontrib-devhelp")
164 (synopsis "Sphinx extension for creating Devhelp documents")
165 (description
166 "@code{sphinxcontrib-devhelp} is a Sphinx extension which outputs
167 @url{Devhelp,https://wiki.gnome.org/Apps/Devhelp} documents.")
168 (license license:bsd-2)))
169
170 (define-public python-sphinxcontrib-htmlhelp
171 (package
172 (name "python-sphinxcontrib-htmlhelp")
173 (version "1.0.3")
174 (source (origin
175 (method url-fetch)
176 (uri (pypi-uri "sphinxcontrib-htmlhelp" version))
177 (sha256
178 (base32
179 "16v5jdnibwrqjdr5aqchgyzpwy3rgamwhdf4kidv5nxj65zbpxg8"))))
180 (build-system python-build-system)
181 (arguments
182 `(#:tests? #f)) ;XXX: circular dependency on Sphinx
183 (home-page "https://github.com/sphinx-doc/sphinxcontrib-htmlhelp")
184 (synopsis "Sphinx extension for rendering HTML help files")
185 (description
186 "@code{sphinxcontrib-htmlhelp} is a Sphinx extension which renders
187 HTML help files.")
188 (license license:bsd-2)))
189
190 (define-public python-sphinxcontrib-jsmath
191 (package
192 (name "python-sphinxcontrib-jsmath")
193 (version "1.0.1")
194 (source (origin
195 (method url-fetch)
196 (uri (pypi-uri "sphinxcontrib-jsmath" version))
197 (sha256
198 (base32
199 "1f64w19j33sp151jimibraw6qrbhd5gxy8hs3797w9478m55x4m9"))))
200 (build-system python-build-system)
201 (arguments
202 `(#:tests? #f)) ;XXX: circular dependency on Sphinx
203 (home-page "https://github.com/sphinx-doc/sphinxcontrib-jsmath")
204 (synopsis "Sphinx extension to render math equations")
205 (description
206 "@code{sphinxcontrib-jsmath} is a Sphinx extension which renders display
207 math in HTML via JavaScript.")
208 (license license:bsd-2)))
209
210 (define-public python-sphinxcontrib-newsfeed
211 (package
212 (name "python-sphinxcontrib-newsfeed")
213 (version "0.1.4")
214 (source (origin
215 (method url-fetch)
216 (uri (pypi-uri "sphinxcontrib-newsfeed" version))
217 (sha256
218 (base32
219 "1d7gam3mn8v4in4p16yn3v10vps7nnaz6ilw99j4klij39dqd37p"))))
220 (arguments '(#:tests? #f)) ; No tests.
221 (build-system python-build-system)
222 (propagated-inputs
223 `(("python-sphinx" ,python-sphinx)))
224 (synopsis "News Feed extension for Sphinx")
225 (description "Sphinxcontrib-newsfeed is an extension for adding a simple
226 Blog, News or Announcements section to a Sphinx website.")
227 (home-page "https://bitbucket.org/prometheus/sphinxcontrib-newsfeed")
228 (license license:bsd-2)))
229
230 (define-public python-sphinxcontrib-programoutput
231 (package
232 (name "python-sphinxcontrib-programoutput")
233 (version "0.15")
234 (source (origin
235 (method url-fetch)
236 (uri (pypi-uri "sphinxcontrib-programoutput" version))
237 (sha256
238 (base32
239 "155bz0z2cz544pphkd3nk7ph83mz7nn0ql135kzi62kqmd75ppc0"))))
240 (build-system python-build-system)
241 (arguments
242 ;; FIXME: Many tests are failing.
243 '(#:tests? #f))
244 (propagated-inputs
245 `(("python-sphinx" ,python-sphinx)))
246 (synopsis "Sphinx extension to include program output")
247 (description "A Sphinx extension to literally insert the output of arbitrary
248 commands into documents, helping you to keep your command examples up to date.")
249 (home-page "https://github.com/NextThought/sphinxcontrib-programoutput")
250 (license license:bsd-2)))
251
252 (define-public python2-sphinxcontrib-programoutput
253 (package-with-python2 python-sphinxcontrib-programoutput))
254
255 (define-public python-sphinxcontrib-qthelp
256 (package
257 (name "python-sphinxcontrib-qthelp")
258 (version "1.0.3")
259 (source (origin
260 (method url-fetch)
261 (uri (pypi-uri "sphinxcontrib-qthelp" version))
262 (sha256
263 (base32
264 "0wjsp96d262shzkx7pb7pra7mmf0j8c5rz56i6x0vdsqw1z7ccsc"))))
265 (build-system python-build-system)
266 (arguments
267 `(#:tests? #f)) ;XXX: circular dependency on Sphinx
268 (home-page "https://github.com/sphinx-doc/sphinxcontrib-qthelp")
269 (synopsis "Sphinx extension to output QtHelp documents")
270 (description
271 "@code{sphinxcontrib-qthelp} is a Sphinx extension which outputs QtHelp
272 documents.")
273 (license license:bsd-2)))
274
275 (define-public python-sphinxcontrib-serializinghtml
276 (package
277 (name "python-sphinxcontrib-serializinghtml")
278 (version "1.1.4")
279 (source (origin
280 (method url-fetch)
281 (uri (pypi-uri "sphinxcontrib-serializinghtml" version))
282 (sha256
283 (base32
284 "1g3pbx0g88zd9xzcrbaypa2k60axrh92vf5j76wsk0p9hv6fr87a"))))
285 (build-system python-build-system)
286 (arguments
287 `(#:tests? #f)) ;XXX: circular dependency on Sphinx
288 (home-page "https://github.com/sphinx-doc/sphinxcontrib-serializinghtml")
289 (synopsis "Sphinx extension to serialize HTML files")
290 (description
291 "@code{sphinxcontrib-serializinghtml} is a Sphinx extension which outputs
292 \"serialized\" HTML files.")
293 (license license:bsd-2)))
294
295 (define-public python-sphinxcontrib-svg2pdfconverter
296 (package
297 (name "python-sphinxcontrib-svg2pdfconverter")
298 (version "1.0.1")
299 (source (origin
300 (method url-fetch)
301 (uri (pypi-uri "sphinxcontrib-svg2pdfconverter" version))
302 (sha256
303 (base32
304 "1hhaxmqc7wh8gnyw5jaqckliknvk0p21y12wk3bdmncgkaf9ar8f"))))
305 (build-system python-build-system)
306 (propagated-inputs
307 `(("python-sphinx" ,python-sphinx)))
308 (home-page "https://github.com/missinglinkelectronics/sphinxcontrib-svg2pdfconverter")
309 (synopsis "Sphinx SVG to PDF converter extension")
310 (description "A Sphinx extension to convert SVG images to PDF in case the
311 builder does not support SVG images natively (e.g. LaTeX).")
312 (license license:bsd-2)))
313
314 (define-public python-sphinxcontrib-websupport
315 (package
316 (name "python-sphinxcontrib-websupport")
317 (version "1.2.0")
318 (source (origin
319 (method url-fetch)
320 (uri (pypi-uri "sphinxcontrib-websupport" version))
321 (sha256
322 (base32
323 "1smma7r0rhwcmbfvvkfs5djfz1qm8wbpcvp084ca6dmw2b9zplxs"))))
324 (build-system python-build-system)
325 (arguments
326 ;; FIXME: Tests depend on Sphinx, which depends on this.
327 `(#:tests? #f))
328 (home-page "https://sphinx-doc.org/")
329 (synopsis "Sphinx API for web applications")
330 (description "This package provides a Python API to easily integrate
331 Sphinx documentation into your web application. It provides tools to
332 integrate Sphinx documents in web templates and to handle searches.")
333 (license license:bsd-3)))
334
335 (define-public python2-sphinxcontrib-websupport
336 (package-with-python2 python-sphinxcontrib-websupport))
337
338 (define-public python-sphinx-gallery
339 (package
340 (name "python-sphinx-gallery")
341 (version "0.1.13")
342 (source (origin
343 (method git-fetch)
344 (uri (git-reference
345 (url "https://github.com/sphinx-gallery/sphinx-gallery")
346 (commit (string-append "v" version))))
347 (file-name (git-file-name name version))
348 (sha256
349 (base32
350 "14nbqh9krx2l2y2ylbln6l6w8iak3wac1lngvaf278y1cx7685kg"))))
351 (build-system python-build-system)
352 (arguments
353 ;; FIXME: Tests attempt to download <https://docs.python.org/3/objects.inv>,
354 ;; <https://docs.scipy.org/doc/numpy/objects.inv>, and
355 ;; <https://matplotlib.org/objects.inv>.
356 `(#:tests? #f))
357 (native-inputs
358 `(("python-pytest-runner" ,python-pytest-runner)))
359 (home-page "https://sphinx-gallery.github.io/")
360 (synopsis "Generate an examples gallery automatically")
361 (description
362 "@code{sphinx_gallery} is a Sphinx extension that builds an HTML version
363 from any set of Python scripts and puts it into an examples gallery.")
364 (license license:bsd-3)))
365
366 (define-public python2-sphinx-gallery
367 (package-with-python2 python-sphinx-gallery))
368
369 (define-public python-sphinx-me
370 (package
371 (name "python-sphinx-me")
372 (version "0.3")
373 (source
374 (origin
375 (method url-fetch)
376 (uri (pypi-uri "sphinx-me" version))
377 (sha256
378 (base32
379 "06jzgp213zihnvpcy2y5jy3ykid3apc2ncp2pg6a2g05lhiziglq"))))
380 (build-system python-build-system)
381 (home-page "https://github.com/stephenmcd/sphinx-me")
382 (synopsis "Create a Sphinx documentation shell")
383 (description
384 "Create a Sphinx documentation shell for your project and include the
385 README file as the documentation index. It handles extracting the required
386 meta data such as the project name, author and version from your project for
387 use in your Sphinx docs.")
388 (license license:bsd-2)))
389
390 (define-public python2-sphinx-me
391 (package-with-python2 python-sphinx-me))
392
393 (define-public python-sphinx-repoze-autointerface
394 (package
395 (name "python-sphinx-repoze-autointerface")
396 (version "0.8")
397 (source (origin
398 (method url-fetch)
399 (uri (pypi-uri "repoze.sphinx.autointerface" version))
400 (sha256
401 (base32
402 "08ycivzf7bh4a1zcyp31hbyqs1b2c9r26raa3vxjwwmbfqr3iw4f"))))
403 (build-system python-build-system)
404 (arguments '(#:tests? #f)) ; No tests.
405 (propagated-inputs
406 `(("python-sphinx" ,python-sphinx)
407 ("python-zope-interface" ,python-zope-interface)))
408 (synopsis "Auto-generate Sphinx API docs from Zope interfaces")
409 (description "This package defines an extension for the Sphinx documentation
410 system. The extension allows generation of API documentation by
411 introspection of @code{zope.interface} instances in code.")
412 (home-page "https://github.com/repoze/repoze.sphinx.autointerface")
413 (license license:repoze)))
414
415 (define-public python2-sphinx-repoze-autointerface
416 (package-with-python2 python-sphinx-repoze-autointerface))
417
418 (define-public python-sphinx-alabaster-theme
419 (package
420 (name "python-sphinx-alabaster-theme")
421 (version "0.7.12")
422 (source (origin
423 (method url-fetch)
424 (uri (pypi-uri "alabaster" version))
425 (sha256
426 (base32
427 "00nwwjj2d2ym4s2kk217x7jkx1hnczc3fvm8yxbqmsp6b0nxfqd6"))))
428 (build-system python-build-system)
429 (propagated-inputs
430 `(("python-pygments" ,python-pygments)))
431 (home-page "https://alabaster.readthedocs.io/")
432 (synopsis "Configurable sidebar-enabled Sphinx theme")
433 (description "Alabaster is a visually (c)lean, responsive, configurable
434 theme for the Sphinx documentation system. It's the default theme of Sphinx.")
435 (license license:bsd-3)))
436
437 (define-public python2-sphinx-alabaster-theme
438 (package-with-python2 python-sphinx-alabaster-theme))
439
440 (define-public python-sphinx-cloud-sptheme
441 (package
442 (name "python-sphinx-cloud-sptheme")
443 (version "1.8.0")
444 (source (origin
445 (method url-fetch)
446 (uri (pypi-uri "cloud_sptheme" version))
447 (sha256
448 (base32
449 "1dniqb6a39yh786f86c4jn666rwnyi1jvzn4616zhcchb7sfdshd"))))
450 (build-system python-build-system)
451 ;; FIXME: The 'pypi' release archive does not contain tests.
452 (arguments '(#:tests? #f))
453 (native-inputs
454 `(("python-sphinx" ,python-sphinx)))
455 (home-page "https://bitbucket.org/ecollins/cloud_sptheme")
456 (synopsis "'Cloud' theme for Sphinx documenter")
457 (description "This package contains the \"Cloud\" theme for Sphinx and some
458 related extensions.")
459 (license license:bsd-3)))
460
461 (define-public python2-sphinx-cloud-sptheme
462 (package-with-python2 python-sphinx-cloud-sptheme))
463
464 (define-public python-guzzle-sphinx-theme
465 (package
466 (name "python-guzzle-sphinx-theme")
467 (version "0.7.11")
468 (source
469 (origin
470 (method url-fetch)
471 (uri (pypi-uri "guzzle_sphinx_theme" version))
472 (sha256
473 (base32
474 "1rnkzrrsbnifn3vsb4pfaia3nlvgvw6ndpxp7lzjrh23qcwid34v"))))
475 (build-system python-build-system)
476 (propagated-inputs
477 `(("python-sphinx" ,python-sphinx)))
478 (home-page "https://github.com/guzzle/guzzle_sphinx_theme")
479 (synopsis "Sphinx theme used by Guzzle")
480 (description "This package provides guzzle_sphinx_theme, a theme for the
481 Sphinx documentation system, used by @uref{http://docs.guzzlephp.org, Guzzle}
482 and several other projects.")
483 (license license:expat)))
484
485 (define-public python2-guzzle-sphinx-theme
486 (package-with-python2 python-guzzle-sphinx-theme))
487
488 (define-public python-sphinx-rtd-theme
489 (package
490 (name "python-sphinx-rtd-theme")
491 (version "0.2.4")
492 (source
493 (origin
494 (method url-fetch)
495 (uri (pypi-uri "sphinx_rtd_theme" version))
496 (sha256
497 (base32
498 "05rlhjzdyapr2w74jjs7mrm8hi69qskcr5vya9f9drpsys7lpxrd"))))
499 (build-system python-build-system)
500 (arguments '(#:tests? #f)) ; No tests.
501 (propagated-inputs
502 `(("python-sphinx" ,python-sphinx)))
503 (home-page "https://github.com/snide/sphinx_rtd_theme/")
504 (synopsis "ReadTheDocs.org theme for Sphinx")
505 (description "A theme for Sphinx used by ReadTheDocs.org.")
506 (license license:expat)))
507
508 (define-public python2-sphinx-rtd-theme
509 (package-with-python2 python-sphinx-rtd-theme))
510
511 (define-public python-breathe
512 (package
513 (name "python-breathe")
514 (version "4.13.1")
515 (source
516 (origin
517 (method url-fetch)
518 (uri (pypi-uri "breathe" version))
519 (sha256
520 (base32
521 "1aw749n2ry27434qd7gr99dvsrs3x3chyi9aywmhjj1g4m2j6xf6"))))
522 (build-system python-build-system)
523 (propagated-inputs
524 `(("python-docutils" ,python-docutils)
525 ("python-six" ,python-six)
526 ("python-sphinx" ,python-sphinx)))
527 (home-page "https://github.com/michaeljones/breathe")
528 (synopsis "ReStructuredText and Sphinx bridge to Doxygen")
529 (description "This package is an extension to reStructuredText and Sphinx
530 to be able to read and render the Doxygen xml output.")
531 (license license:bsd-3)))
532
533 (define-public python-sphinx-intl
534 (package
535 (name "python-sphinx-intl")
536 (version "2.0.0")
537 (source
538 (origin
539 (method url-fetch)
540 (uri (pypi-uri "sphinx-intl" version))
541 (sha256
542 (base32
543 "0zbf1bh23b3kza8bnjykmv2k21xmmr4gamhi3lnicnr6ypnrphr5"))))
544 (build-system python-build-system)
545 (propagated-inputs
546 `(("python-sphinx" ,python-sphinx)
547 ("python-click" ,python-click)))
548 (home-page "https://github.com/sphinx-doc/sphinx-intl")
549 (synopsis
550 "Sphinx utility that makes it easy to translate and to apply translation")
551 (description
552 "A utility tool that provides several features that make it easy to
553 translate and to apply translation to Sphinx generated document.")
554 (license license:bsd-2)))
555
556 (define-public python-sphinx-autobuild
557 (package
558 (name "python-sphinx-autobuild")
559 (version "0.7.1")
560 (source
561 (origin
562 (method url-fetch)
563 (uri (pypi-uri "sphinx-autobuild" version))
564 (sha256
565 (base32
566 "0kn753dyh3b1s0h77lbk704niyqc7bamvq6v3s1f6rj6i20qyf36"))))
567 (build-system python-build-system)
568 (arguments
569 `(#:phases
570 (modify-phases %standard-phases
571 ;; See https://github.com/GaretJax/sphinx-autobuild/pull/72
572 (add-after 'unpack 'use-later-port-for
573 (lambda _
574 (substitute* "requirements.txt"
575 (("port_for==.*") "port_for\n"))
576 #t))
577 (delete 'check)
578 (add-after 'install 'check
579 (lambda* (#:key inputs outputs tests? #:allow-other-keys)
580 (when tests?
581 (add-installed-pythonpath inputs outputs)
582 (invoke "pytest" "-v"))
583 #t)))))
584 (propagated-inputs
585 `(("python-argh" ,python-argh)
586 ("python-livereload" ,python-livereload)
587 ("python-pathtools" ,python-pathtools)
588 ("python-port-for" ,python-port-for)
589 ("python-pyyaml" ,python-pyyaml)
590 ("python-tornado" ,python-tornado)
591 ("python-watchdog" ,python-watchdog)))
592 (native-inputs
593 `(("python-pytest" ,python-pytest)))
594 (home-page "https://github.com/GaretJax/sphinx-autobuild")
595 (synopsis "Rebuild Sphinx documentation when a change is detected")
596 (description
597 "This package lets you watch a Sphinx directory and rebuild the
598 documentation when a change is detected. It also includes a livereload
599 enabled web server.")
600 (license license:expat)))