gnu: Simplify package inputs.
[jackhill/guix/guix.git] / gnu / packages / perl-maths.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2021 Ricardo Wurmus <rekado@elephly.net>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages perl-maths)
20 #:use-module ((guix licenses) #:prefix license:)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system perl)
24 #:use-module (gnu packages perl)
25 #:use-module (gnu packages perl-check))
26
27 (define-public perl-math-cephes
28 (package
29 (name "perl-math-cephes")
30 (version "0.5305")
31 (source (origin
32 (method url-fetch)
33 (uri (string-append
34 "mirror://cpan/authors/id/S/SH/SHLOMIF/Math-Cephes-"
35 version ".tar.gz"))
36 (sha256
37 (base32
38 "18c3xg53d1vv7hlj43601jj7ks119fm6ndpwpv94irr2905806jn"))
39 ;; For reproducibility
40 (modules '((guix build utils)))
41 (snippet
42 '(substitute* "libmd/Makefile.PL"
43 (("readdir DIR") "sort readdir DIR")))))
44 (build-system perl-build-system)
45 (home-page "https://metacpan.org/release/Math-Cephes")
46 (synopsis "Perl interface to the Cephes math library")
47 (description "The Math::Cephes module provides a Perl interface to over
48 150 functions of the Cephes math library.")
49 (license license:perl-license)))
50
51 (define-public perl-math-matrixreal
52 (package
53 (name "perl-math-matrixreal")
54 (version "2.13")
55 (source (origin
56 (method url-fetch)
57 (uri (string-append
58 "mirror://cpan/authors/id/L/LE/LETO/Math-MatrixReal-"
59 version ".tar.gz"))
60 (sha256
61 (base32
62 "1cml5wqd99hm398gl8f147ccsck9v179l7a6vqjj4kfkdnja37sg"))))
63 (build-system perl-build-system)
64 (native-inputs
65 (list perl-module-build perl-test-most))
66 (home-page "https://metacpan.org/release/Math-MatrixReal")
67 (synopsis "Manipulate NxN matrices of real numbers")
68 (description "This package provides the @code{Math::MatrixReal} module.
69 It implements the data type \"matrix of real numbers\" (and consequently also
70 \"vector of real numbers\").")
71 (license license:perl-license)))