build: container: Add #:host-uids argument to call-with-container.
[jackhill/guix/guix.git] / gnu / packages / lxde.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Mathieu Lirzin <mthl@openmailbox.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages lxde)
20 #:use-module (gnu packages autotools)
21 #:use-module (gnu packages glib)
22 #:use-module (gnu packages gnome)
23 #:use-module (gnu packages gtk)
24 #:use-module (gnu packages pkg-config)
25 #:use-module (gnu packages xorg)
26 #:use-module (guix build-system gnu)
27 #:use-module (guix download)
28 #:use-module ((guix licenses) #:prefix license:)
29 #:use-module (guix packages)
30 #:use-module (guix utils))
31
32 (define-public libfm
33 (package
34 (name "libfm")
35 (version "1.2.3")
36 (source (origin
37 (method url-fetch)
38 (uri (string-append "mirror://sourceforge/project/pcmanfm/"
39 "PCManFM%20%2B%20Libfm%20%28tarball%20release"
40 "%29/LibFM/" name "-" version ".tar.xz"))
41 (sha256
42 (base32
43 "1ygvw52262r3jp1f45m9cdpx5xgvd4rkyfszslfqvg2c99ig34n6"))))
44 (build-system gnu-build-system)
45 (inputs `(("glib" ,glib)
46 ("gtk+" ,gtk+-2)))
47 (native-inputs `(("intltool" ,intltool)
48 ("glib" ,glib "bin") ; for gtester
49 ("libtool" ,libtool)
50 ("menu-cache" ,menu-cache)
51 ("pkg-config" ,pkg-config)
52 ("vala" ,vala)))
53 (synopsis "File management support (core library)")
54 (description "LibFM provides file management functions built on top of
55 Glib/GIO giving a higher-level API.")
56 (home-page "http://lxde.org")
57 (license license:gpl2+)))
58
59 (define-public libfm-extra
60 (package (inherit libfm)
61 (name "libfm-extra")
62 (arguments '(#:configure-flags '("--with-extra-only")))
63 (inputs `(("glib" ,glib)))
64 (native-inputs `(("intltool" ,intltool)
65 ("libtool" ,libtool)
66 ("pkg-config" ,pkg-config)))
67 (synopsis "File management support (extra library)")
68 (description "This package contains standalone library which extends the
69 libFM file management library.")))
70
71 (define-public lxappearance
72 (package
73 (name "lxappearance")
74 (version "0.6.1")
75 (source (origin
76 (method url-fetch)
77 (uri (string-append "mirror://sourceforge/project/lxde/"
78 "LXAppearance/" name "-" version ".tar.xz"))
79 (sha256
80 (base32
81 "1phnv1b2jdj2vlibjyc9z01izcf3k5zxj8glsaf0i3vh77zqmqq9"))))
82 (build-system gnu-build-system)
83 (inputs `(("gtk+" ,gtk+-2)))
84 (native-inputs `(("intltool" ,intltool)
85 ("pkg-config" ,pkg-config)))
86 (synopsis "LXDE GTK+ theme switcher")
87 (description "LXAppearance is a desktop-independent GTK+ theme switcher
88 able to change themes, icons, and fonts used by GTK+ applications.")
89 (home-page "http://lxde.org")
90 (license license:gpl2+)))
91
92 (define-public lxrandr
93 (package
94 (name "lxrandr")
95 (version "0.3.0")
96 (source (origin
97 (method url-fetch)
98 (uri (string-append "mirror://sourceforge/project/lxde/LXRandR"
99 "%20%28monitor%20config%20tool%29/LXRandR%20"
100 (version-major+minor version) ".x/"
101 name "-" version ".tar.xz"))
102 (sha256
103 (base32
104 "0xkbqv66hisbxkvnf7y5kwqbhrq26f49wd7w6ylhnjlccpnylg8q"))))
105 (build-system gnu-build-system)
106 (inputs `(("gtk+" ,gtk+-2)))
107 (native-inputs `(("intltool" ,intltool)
108 ("pkg-config" ,pkg-config)))
109 (synopsis "LXDE monitor configuration tool")
110 (description "LXRandR is a very basic monitor configuration tool. It
111 relies on the X11 resize-and-rotate (RandR) extension but doesn't aim to be a
112 full frontend of it. LXRandR only gives you some easy and quick options which
113 are intuitive. It's suitable for laptop users who frequently uses projectors
114 or external monitor.")
115 (home-page "http://lxde.org")
116 (license license:gpl2+)))
117
118 (define-public lxtask
119 (package
120 (name "lxtask")
121 (version "0.1.6")
122 (source (origin
123 (method url-fetch)
124 (uri (string-append "mirror://sourceforge/project/lxde/LXTask"
125 "%20%28task%20manager%29/LXTask%20"
126 (version-major+minor version) ".x/"
127 name "-" version ".tar.xz"))
128 (sha256
129 (base32
130 "0ia3i430lpwgl2kch6sl1za8qf96wc4fkcv91yhdzgnzafcnm3gp"))))
131 (build-system gnu-build-system)
132 (inputs `(("gtk+" ,gtk+-2)))
133 (native-inputs `(("intltool" ,intltool)
134 ("pkg-config" ,pkg-config)))
135 (synopsis "LXDE task manager")
136 (description "LXTask is a lightweight task manager derived from Xfce task
137 manager with all dependencies on Xfce removed. LXTask is based on the GTK+
138 toolkit. It allows users to monitor and control of running processes.")
139 (home-page "http://lxde.org")
140 (license license:gpl2+)))
141
142 (define-public lxterminal
143 (package
144 (name "lxterminal")
145 (version "0.2.0")
146 (source (origin
147 (method url-fetch)
148 (uri (string-append "mirror://sourceforge/project/lxde/LXTerminal"
149 "%20%28terminal%20emulator%29/LXTerminal%20"
150 version "/" name "-" version ".tar.gz"))
151 (sha256
152 (base32
153 "1brb506vmnncih8nyvlrckrrn6msbsvz2vwbm7bsqwigcnchwjqp"))))
154 (build-system gnu-build-system)
155 (inputs `(("gtk+" ,gtk+-2)
156 ("vte" ,vte/gtk+-2)))
157 (native-inputs `(("intltool" ,intltool)
158 ("pkg-config" ,pkg-config)))
159 (synopsis "LXDE terminal emulator")
160 (description "LXTerminal is a VTE-based terminal emulator. It supports
161 multiple tabs and has only minimal dependencies thus being completely
162 desktop-independent. In order to reduce memory usage and increase the
163 performance, all instances of the terminal are sharing a single process.")
164 (home-page "http://lxde.org")
165 (license license:gpl2+)))
166
167 (define-public menu-cache
168 (package
169 (name "menu-cache")
170 (version "1.0.0")
171 (source (origin
172 (method url-fetch)
173 (uri (string-append "mirror://sourceforge/project/lxde/" name "/"
174 (version-major+minor version) "/"
175 name "-" version ".tar.xz"))
176 (sha256
177 (base32
178 "1bws84fiwk3anp30hcr0lw1xw5cgp44x5ik2yv2ijcgxpcvz8zgz"))))
179 (build-system gnu-build-system)
180 (inputs `(("glib" ,glib)
181 ("libfm" ,libfm-extra)))
182 (native-inputs `(("pkg-config" ,pkg-config)))
183 (synopsis "LXDE implementation of the freedesktop menu's cache")
184 (description "Menu-cache is a library creating and utilizing caches to
185 speed up the access to freedesktop.org defined application menus.")
186 (home-page "http://lxde.org")
187 (license license:lgpl2.1+)))
188
189 (define-public pcmanfm
190 (package
191 (name "pcmanfm")
192 (version "1.2.3")
193 (source (origin
194 (method url-fetch)
195 (uri (string-append "mirror://sourceforge/project/" name "/"
196 "PCManFM%20%2B%20Libfm%20%28tarball%20release"
197 "%29/PCManFM/" name "-" version ".tar.xz"))
198 (sha256
199 (base32
200 "1033rw5jd7nlzbcdpx3bik7347kyh1sg1gkla424gq9vqqpxia6g"))))
201 (build-system gnu-build-system)
202 ;; (#:configure-flags '("--sysconfdir=/etc")) suggested in README.
203 (inputs `(("gtk+" ,gtk+-2)
204 ;; TODO: add ("gvfs" ,gvfs).
205 ("libfm" ,libfm)
206 ("libx11" ,libx11)))
207 (native-inputs `(("intltool" ,intltool)
208 ("libtool" ,libtool)
209 ("pkg-config" ,pkg-config)))
210 (synopsis "LXDE file manager")
211 (description "PCMan is a lightweight GTK+ based file manager, compliant
212 with freedesktop.org standard.")
213 (home-page "http://lxde.org")
214 (license license:gpl2+)))
215
216 ;;; lxde.scm ends here