build: container: Add #:host-uids argument to call-with-container.
[jackhill/guix/guix.git] / gnu / packages / gdbm.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages gdbm)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu))
24
25 (define-public gdbm
26 (package
27 (name "gdbm")
28 (version "1.11")
29 (source
30 (origin
31 (method url-fetch)
32 (uri (string-append "mirror://gnu/gdbm/gdbm-"
33 version ".tar.gz"))
34 (sha256
35 (base32
36 "1hz3jgh3pd4qzp6jy0l8pd8x01g9abw7csnrlnj1a2sxy122z4cd"))))
37 (arguments `(#:configure-flags '("--enable-libgdbm-compat")))
38 (build-system gnu-build-system)
39 (home-page "http://www.gnu.org/software/gdbm/")
40 (synopsis
41 "Hash library of database functions compatible with traditional dbm")
42 (description
43 "GDBM is a library for manipulating hashed databases. It is used to
44 store key/value pairs in a file in a manner similar to the Unix dbm library
45 and provides interfaces to the traditional file format.")
46 (license gpl3+)))