build: container: Add #:host-uids argument to call-with-container.
[jackhill/guix/guix.git] / gnu / packages / disk.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages disk)
21 #:use-module (guix licenses)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages check)
26 #:use-module (gnu packages gettext)
27 #:use-module (gnu packages linux)
28 #:use-module (gnu packages readline)
29 #:use-module (gnu packages guile)
30 #:use-module ((gnu packages compression)
31 #:select (lzip)))
32
33 (define-public parted
34 (package
35 (name "parted")
36 (version "3.1")
37 (source
38 (origin
39 (method url-fetch)
40 (uri (string-append "mirror://gnu/parted/parted-"
41 version ".tar.xz"))
42 (sha256
43 (base32
44 "05fa4m1bky9d13hqv91jlnngzlyn7y4rnnyq6d86w0dg3vww372y"))))
45 (build-system gnu-build-system)
46 (arguments `(#:configure-flags '("--disable-device-mapper")
47 #:phases (alist-cons-before
48 'configure 'fix-mkswap
49 (lambda* (#:key inputs #:allow-other-keys)
50 (let ((util-linux (assoc-ref inputs
51 "util-linux")))
52 (substitute*
53 "tests/t9050-partition-table-types.sh"
54 (("mkswap")
55 (string-append util-linux "/sbin/mkswap")))))
56 %standard-phases)))
57 (inputs
58 ;; XXX: add 'lvm2'.
59 `(("check" ,check)
60
61 ;; With Readline 6.3, parted/ui.c fails to build because it uses the
62 ;; now undefined 'CPPFunction' type.
63 ("readline" ,readline-6.2)
64
65 ("util-linux" ,util-linux)))
66 (native-inputs
67 `(("gettext" ,gnu-gettext)))
68 (home-page "http://www.gnu.org/software/parted/")
69 (synopsis "Disk partition editor")
70 (description
71 "GNU Parted is a package for creating and manipulating disk partition
72 tables. It includes a library and command-line utility.")
73 (license gpl3+)))
74
75 (define-public fdisk
76 (package
77 (name "fdisk")
78 (version "2.0.0a")
79 (source
80 (origin
81 (method url-fetch)
82 (uri (string-append "mirror://gnu/fdisk/gnufdisk-"
83 version ".tar.gz"))
84 (sha256
85 (base32
86 "04nd7civ561x2lwcmxhsqbprml3178jfc58fy1v7hzqg5k4nbhy3"))))
87 (build-system gnu-build-system)
88 (inputs
89 `(("gettext" ,gnu-gettext)
90 ("guile" ,guile-1.8)
91 ("util-linux" ,util-linux)
92 ("parted" ,parted)))
93 (home-page "https://www.gnu.org/software/fdisk/")
94 (synopsis "Low-level disk partitioning and formatting")
95 (description
96 "GNU fdisk provides a GNU version of the common disk partitioning tool
97 fdisk. fdisk is used for the creation and manipulation of disk partition
98 tables, and it understands a variety of different formats.")
99 (license gpl3+)))
100
101 (define-public ddrescue
102 (package
103 (name "ddrescue")
104 (version "1.19")
105 (source
106 (origin
107 (method url-fetch)
108 (uri (string-append "mirror://gnu/ddrescue/ddrescue-"
109 version ".tar.lz"))
110 (sha256
111 (base32
112 "1f278w7i9sx45jk6fsw1kyzx743k3alx1c4w1q8sk05ckafhr3gd"))))
113 (build-system gnu-build-system)
114 (home-page "http://www.gnu.org/software/ddrescue/ddrescue.html")
115 (synopsis "Data recovery utility")
116 (native-inputs `(("lzip" ,lzip)))
117 (description
118 "GNU ddrescue is a fully automated data recovery tool. It copies data
119 from one file to another, working to rescue data in case of read errors. The
120 program also includes a tool for manipulating its log files, which are used
121 to recover data more efficiently by only reading the necessary blocks.")
122 (license gpl3+)))
123
124 (define-public dosfstools
125 (package
126 (name "dosfstools")
127 (version "3.0.27")
128 (source
129 (origin
130 (method url-fetch)
131 (uri (string-append "https://github.com/" name "/" name
132 "/releases/download/v" version "/"
133 name "-" version ".tar.xz"))
134 (sha256
135 (base32
136 "1a2qs5g2zqbk1gzaaf4v3fw3yny6jgbzddpgcamkp3fjifn8wxl5"))))
137 (build-system gnu-build-system)
138 (arguments
139 `(#:make-flags (list (string-append "PREFIX=" %output)
140 "CC=gcc")
141 #:tests? #f ;no tests
142 #:phases (modify-phases %standard-phases
143 (delete 'configure))))
144 (home-page "https://github.com/dosfstools/dosfstools")
145 (synopsis "Utilities for making and checking MS-DOS FAT filesystems")
146 (description
147 "The dosfstools package includes the mkfs.fat and fsck.fat utilities,
148 which respectively make and check MS-DOS FAT filesystems.")
149 (license gpl3+)))