gnu: gf2x: Update to 1.3.0.
[jackhill/guix/guix.git] / gnu / packages / gsasl.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
4 ;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
5 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
6 ;;; Copyright © 2020-2022 Efraim Flashner <efraim@flashner.co.il>
7 ;;;
8 ;;; This file is part of GNU Guix.
9 ;;;
10 ;;; GNU Guix is free software; you can redistribute it and/or modify it
11 ;;; under the terms of the GNU General Public License as published by
12 ;;; the Free Software Foundation; either version 3 of the License, or (at
13 ;;; your option) any later version.
14 ;;;
15 ;;; GNU Guix is distributed in the hope that it will be useful, but
16 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
17 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
18 ;;; GNU General Public License for more details.
19 ;;;
20 ;;; You should have received a copy of the GNU General Public License
21 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
22
23 (define-module (gnu packages gsasl)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages compression)
26 #:use-module (gnu packages libidn)
27 #:use-module (gnu packages gnupg)
28 #:use-module (gnu packages nettle)
29 #:use-module (gnu packages kerberos)
30 #:use-module (gnu packages tls)
31 #:use-module ((guix licenses) #:prefix license:)
32 #:use-module (guix packages)
33 #:use-module (guix download)
34 #:use-module (guix build-system gnu))
35
36 (define-public libntlm
37 (package
38 (name "libntlm")
39 (version "1.6")
40 (source (origin
41 (method url-fetch)
42 (uri (string-append "https://www.nongnu.org/libntlm/releases/"
43 "libntlm-" version ".tar.gz"))
44 (sha256
45 (base32
46 "08b83nss16jsn213j326yhn1vnrz10k15fwq6jm5b1vdn23nndzj"))))
47 (build-system gnu-build-system)
48 (synopsis "Library that implements NTLM authentication")
49 (description
50 "Libntlm is a library that implements NTLM authentication.")
51 (license license:lgpl2.1+)
52 (home-page "https://www.nongnu.org/libntlm/")))
53
54 (define-public gss
55 (package
56 (name "gss")
57 (version "1.0.4")
58 (source (origin
59 (method url-fetch)
60 (uri (string-append "mirror://gnu/gss/gss-" version
61 ".tar.gz"))
62 (sha256 (base32
63 "0www841ax21f5f61pdjk9fjdn9s2xf1wnblb47kzrqyaykgapkpc"))))
64 (build-system gnu-build-system)
65 (inputs (list nettle shishi zlib))
66 (synopsis "Generic Security Service library")
67 (description
68 "The GNU Generic Security Service provides a free implementation of the
69 GSS-API specification. It provides a generic application programming
70 interface for programs to access security services. Security services present
71 a generic, GSS interface, with which the calling application interacts via
72 this library, freeing the application developer from needing to know about
73 the underlying security implementation.")
74 (license license:gpl3+)
75 (home-page "https://www.gnu.org/software/gss/")))
76
77 (define-public gsasl
78 (package
79 (name "gsasl")
80 (version "2.0.1")
81 (source (origin
82 (method url-fetch)
83 (uri (string-append "mirror://gnu/gsasl/gsasl-" version
84 ".tar.gz"))
85 (sha256
86 (base32
87 "0yhvq3n6smgnc7fp0smmly8d248248xr7q2apbcbqhc80117ab1j"))))
88 (build-system gnu-build-system)
89 (arguments
90 `(#:configure-flags '("--with-gssapi-impl=mit"
91 "--disable-static")))
92 (inputs
93 (list libgcrypt libidn libntlm mit-krb5 zlib))
94 (native-inputs
95 (list ;; Needed for cross compiling.
96 libgcrypt))
97 (propagated-inputs
98 ;; Propagate GnuTLS because libgnutls.la reads `-lnettle', and Nettle is a
99 ;; propagated input of GnuTLS.
100 (list gnutls))
101 (synopsis "Simple Authentication and Security Layer library")
102 (description
103 "GNU SASL is an implementation of the Simple Authentication and
104 Security Layer framework. On network servers such as IMAP or SMTP servers,
105 SASL is used to handle client/server authentication. This package contains
106 both a library and a command-line tool to access the library.")
107 (license license:gpl3+)
108 (home-page "https://www.gnu.org/software/gsasl/")))