gnu: mg: Update to 20180927.
[jackhill/guix/guix.git] / gnu / packages / text-editors.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 José Miguel Sánchez García <jmi2k@openmailbox.org>
3 ;;; Copyright © 2016 Carlo Zancanaro <carlo@zancanaro.id.au>
4 ;;; Copyright © 2017, 2018 Eric Bavier <bavier@member.fsf.org>
5 ;;; Copyright © 2017 Feng Shu <tumashu@163.com>
6 ;;; Copyright © 2017 ng0 <ng0@n0.is>
7 ;;; Copyright © 2014 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.org>
8 ;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
9 ;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
10 ;;; Copyright © 2019 Andreas Enge <andreas@enge.fr>
11 ;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
12 ;;;
13 ;;; This file is part of GNU Guix.
14 ;;;
15 ;;; GNU Guix is free software; you can redistribute it and/or modify it
16 ;;; under the terms of the GNU General Public License as published by
17 ;;; the Free Software Foundation; either version 3 of the License, or (at
18 ;;; your option) any later version.
19 ;;;
20 ;;; GNU Guix is distributed in the hope that it will be useful, but
21 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
22 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
23 ;;; GNU General Public License for more details.
24 ;;;
25 ;;; You should have received a copy of the GNU General Public License
26 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
27
28 (define-module (gnu packages text-editors)
29 #:use-module (guix packages)
30 #:use-module (guix download)
31 #:use-module (guix git-download)
32 #:use-module (guix utils)
33 #:use-module (guix build-system gnu)
34 #:use-module (guix build-system cmake)
35 #:use-module (guix build-system glib-or-gtk)
36 #:use-module ((guix licenses) #:prefix license:)
37 #:use-module (gnu packages)
38 #:use-module (gnu packages assembly)
39 #:use-module (gnu packages autotools)
40 #:use-module (gnu packages boost)
41 #:use-module (gnu packages documentation)
42 #:use-module (gnu packages fontutils)
43 #:use-module (gnu packages gcc)
44 #:use-module (gnu packages gettext)
45 #:use-module (gnu packages glib)
46 #:use-module (gnu packages gtk)
47 #:use-module (gnu packages guile)
48 #:use-module (gnu packages libbsd)
49 #:use-module (gnu packages libreoffice)
50 #:use-module (gnu packages lua)
51 #:use-module (gnu packages ncurses)
52 #:use-module (gnu packages pcre)
53 #:use-module (gnu packages perl)
54 #:use-module (gnu packages pkg-config)
55 #:use-module (gnu packages python)
56 #:use-module (gnu packages python-xyz)
57 #:use-module (gnu packages qt)
58 #:use-module (gnu packages regex)
59 #:use-module (gnu packages ruby)
60 #:use-module (gnu packages terminals)
61 #:use-module (gnu packages xml))
62
63 (define-public vis
64 (package
65 (name "vis")
66 (version "0.5")
67 (source (origin
68 (method url-fetch)
69 (uri (string-append "https://github.com/martanne/vis/releases"
70 "/download/v" version
71 "/vis-v" version ".tar.gz"))
72 (sha256
73 (base32
74 "0aw35n8xk7ir84ckvczc6yshj9ynishrlz0qlv4yc1afbra1gxmn"))))
75 (build-system gnu-build-system)
76 (arguments
77 `(#:test-target "test"
78 #:tests? #f ; no releases; snapshots are missing tests
79 #:phases
80 (modify-phases %standard-phases
81 (add-after 'install 'wrap-binary
82 (lambda* (#:key inputs outputs #:allow-other-keys)
83 (let* ((out (assoc-ref outputs "out"))
84 (lpeg (assoc-ref inputs "lua-lpeg"))
85 (lua-version ,(version-major+minor (package-version lua)))
86 (LUA_PATH (string-append lpeg "/share/lua/"
87 lua-version "/?.lua"))
88 (LUA_CPATH (string-append lpeg "/lib/lua/"
89 lua-version "/?.so")))
90 (wrap-program (string-append out "/bin/vis")
91 `("LUA_PATH" ":" prefix (,LUA_PATH))
92 `("LUA_CPATH" ":" prefix (,LUA_CPATH)))
93 #t))))))
94 (native-search-paths
95 (list (search-path-specification
96 (variable "VIS_PATH")
97 (files '("share/vis")))))
98 (inputs `(("lua" ,lua)
99 ("ncurses" ,ncurses)
100 ("libtermkey" ,libtermkey)
101 ("lua-lpeg" ,lua-lpeg)
102 ("tre" ,tre)))
103 (synopsis "Vim-like text editor")
104 (description
105 "Vis aims to be a modern, legacy free, simple yet efficient vim-like text
106 editor. It extends vim's modal editing with built-in support for multiple
107 cursors/selections and combines it with sam's structural regular expression
108 based command language.")
109 (home-page "https://github.com/martanne/vis")
110 (license (list license:isc ; Main distribution.
111 license:public-domain ; map.[ch]
112 license:expat)))) ; lexers and libutf.[ch]
113
114 (define-public kakoune
115 (package
116 (name "kakoune")
117 (version "2019.12.10")
118 (source
119 (origin
120 (method url-fetch)
121 (uri (string-append "https://github.com/mawww/kakoune/"
122 "releases/download/v" version "/"
123 "kakoune-" version ".tar.bz2"))
124 (sha256
125 (base32 "1y1gzax2dl7flh676k0rl1vacv10j7p5krkmb67b0afbrql8vbb6"))))
126 (build-system gnu-build-system)
127 (arguments
128 `(#:make-flags
129 (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
130 #:phases
131 (modify-phases %standard-phases
132 (add-after 'unpack 'patch-source
133 (lambda _
134 ;; kakoune uses confstr with _CS_PATH to find out where to find
135 ;; a posix shell, but this doesn't work in the build
136 ;; environment. This substitution just replaces that result
137 ;; with the "sh" path.
138 (substitute* "src/shell_manager.cc"
139 (("if \\(m_shell.empty\\(\\)\\)" line)
140 (string-append "m_shell = \"" (which "sh")
141 "\";\n " line)))
142 #t))
143 (delete 'configure) ; no configure script
144 ;; kakoune requires us to be in the src/ directory to build
145 (add-before 'build 'chdir
146 (lambda _ (chdir "src") #t)))))
147 (native-inputs
148 `(("asciidoc" ,asciidoc)
149 ("pkg-config" ,pkg-config)
150 ("ruby" ,ruby)))
151 (inputs
152 `(("ncurses" ,ncurses)))
153 (synopsis "Vim-inspired code editor")
154 (description
155 "Kakoune is a code editor heavily inspired by Vim, as such most of its
156 commands are similar to Vi's ones, and it shares Vi's \"keystrokes as a text
157 editing language\" model. Kakoune has a strong focus on interactivity, most
158 commands provide immediate and incremental results, while still being
159 competitive (as in keystroke count) with Vim.")
160 (home-page "https://kakoune.org/")
161 (license license:unlicense)))
162
163 (define-public joe
164 (package
165 (name "joe")
166 (version "4.6")
167 (source
168 (origin
169 (method url-fetch)
170 (uri (string-append "https://sourceforge.net/projects/joe-editor/"
171 "files/JOE sources/joe-" version "/"
172 "joe-" version ".tar.gz"))
173 (sha256
174 (base32
175 "1pmr598xxxm9j9dl93kq4dv36zyw0q2dh6d7x07hf134y9hhlnj9"))))
176 (build-system gnu-build-system)
177 (inputs `(("ncurses" ,ncurses)))
178 (home-page "http://joe-editor.sourceforge.net/")
179 (synopsis "Console screen editor")
180 (description
181 "JOE is a powerful console screen editor with a \"mode-less\" user
182 interface similar to many user-friendly editors. JOE has some of the key
183 bindings and many of the powerful features of GNU Emacs.")
184 (license license:gpl3+)))
185
186 (define-public leafpad
187 (package
188 (name "leafpad")
189 (version "0.8.18.1")
190 (source (origin
191 (method url-fetch)
192 (uri (string-append "mirror://savannah/"
193 "leafpad/leafpad-" version ".tar.gz"))
194 (sha256
195 (base32
196 "0b0az2wvqgvam7w0ns1j8xp2llslm1rx6h7zcsy06a7j0yp257cm"))))
197 (build-system glib-or-gtk-build-system)
198 (native-inputs
199 `(("intltool" ,intltool)
200 ("pkg-config" ,pkg-config)))
201 (inputs
202 `(("gtk+" ,gtk+-2)))
203 (home-page "http://tarot.freeshell.org/leafpad/")
204 (synopsis "GTK+ based text editor")
205 (description "Leafpad is a GTK+ text editor that emphasizes simplicity. As
206 development focuses on keeping weight down to a minimum, only the most essential
207 features are implemented in the editor. Leafpad is simple to use, is easily
208 compiled, requires few libraries, and starts up quickly. ")
209 (license license:gpl2+)))
210
211 (define-public e3
212 (package
213 (name "e3")
214 (version "2.82")
215 (source (origin
216 (method url-fetch)
217 (uri (string-append "https://sites.google.com/site/e3editor/Home/"
218 "e3-" version ".tgz"))
219 (sha256
220 (base32
221 "0919kadkas020maqq37852isnzp053q2fnws2zh3mz81d1jiviak"))
222 (modules '((guix build utils)))
223
224 ;; Remove pre-built binaries.
225 (snippet '(begin
226 (delete-file-recursively "bin")
227 #t))))
228 (build-system gnu-build-system)
229 (arguments
230 `(#:tests? #f
231 #:make-flags (list (string-append "PREFIX="
232 (assoc-ref %outputs "out")))
233 #:phases (modify-phases %standard-phases
234 (delete 'configure))))
235 (native-inputs
236 `(("nasm" ,nasm)))
237 (home-page "https://sites.google.com/site/e3editor/")
238 (synopsis "Tiny text editor written in assembly")
239 (description
240 "e3 is a micro text editor with an executable code size between 3800 and
241 35000 bytes. Except for ``syntax highlighting'', the e3 binary supports all
242 of the basic functions one expects plus built in arithmetic calculations.
243 UTF-8 coding of unicode characters is supported as well. e3 can use
244 Wordstar-, EMACS-, Pico, Nedit or vi-like key bindings. e3 can be used on
245 16, 32, and 64-bit CPUs.")
246 (supported-systems '("x86_64-linux" "i686-linux"))
247 (license license:gpl2+)))
248
249 (define-public mg
250 (package
251 (name "mg")
252 (version "20180927")
253 (source (origin
254 (method git-fetch)
255 (uri (git-reference
256 (url "https://github.com/hboetes/mg")
257 (commit version)))
258 (file-name (git-file-name name version))
259 (sha256
260 (base32
261 "14vrm8lvwksf697sqks7xfd1xaqjlqjc9afjk33sksq5p27wr203"))
262 (modules '((guix build utils)))
263 (snippet '(begin
264 (substitute* "GNUmakefile"
265 (("/usr/bin/") ""))
266 #t))))
267 (build-system gnu-build-system)
268 (native-inputs
269 `(("pkg-config" ,pkg-config)))
270 (inputs
271 `(("libbsd" ,libbsd)
272 ("ncurses" ,ncurses)))
273 (arguments
274 ;; No test suite available.
275 '(#:tests? #f
276 #:make-flags (list (string-append "prefix=" %output)
277 "CC=gcc")
278 #:phases (modify-phases %standard-phases
279 (delete 'configure) ; no configure script
280 (add-before 'build 'correct-location-of-difftool
281 (lambda _
282 (substitute* "buffer.c"
283 (("/usr/bin/diff")
284 (which "diff")))
285 #t))
286 (add-before 'install 'patch-tutorial-location
287 (lambda* (#:key outputs #:allow-other-keys)
288 (substitute* "mg.1"
289 (("/usr") (assoc-ref outputs "out")))
290 #t))
291 (add-after 'install 'install-tutorial
292 (lambda* (#:key outputs #:allow-other-keys)
293 (let* ((out (assoc-ref outputs "out"))
294 (doc (string-append out "/share/doc/mg")))
295 (install-file "tutorial" doc)
296 #t))))))
297 (home-page "https://homepage.boetes.org/software/mg/")
298 (synopsis "Microscopic GNU Emacs clone")
299 (description
300 "Mg (mg) is a GNU Emacs style editor, with which it is \"broadly\"
301 compatible. This is a portable version of the mg maintained by the OpenBSD
302 team.")
303 (license license:public-domain)))
304
305 (define-public ghostwriter
306 (package
307 (name "ghostwriter")
308 (version "1.7.4")
309 (source (origin
310 (method git-fetch)
311 (uri (git-reference
312 (url "https://github.com/wereturtle/ghostwriter.git")
313 (commit (string-append "v" version))))
314 (file-name (git-file-name name version))
315 (sha256
316 (base32
317 "1pqlr08z5syqcq5p282asxwzrrm7c1w94baxyb467swh8yp3fj5m"))))
318 (build-system gnu-build-system)
319 (native-inputs
320 `(("pkg-config" ,pkg-config)
321 ("qttools" ,qttools))) ; for lrelease
322 (inputs
323 `(("hunspell" ,hunspell)
324 ("qtbase" ,qtbase)
325 ("qtmultimedia" ,qtmultimedia)
326 ("qtsvg" ,qtsvg)
327 ("qtwebkit" ,qtwebkit)))
328 (arguments
329 `(#:phases
330 (modify-phases %standard-phases
331 (replace 'configure
332 (lambda* (#:key outputs #:allow-other-keys)
333 (let ((out (assoc-ref outputs "out")))
334 (invoke "qmake" (string-append "PREFIX=" out)))))
335 (add-after 'configure 'create-translations
336 (lambda _
337 ;; `lrelease` will not overwrite, so delete existing .qm files
338 (for-each delete-file (find-files "translations" ".*\\.qm"))
339 (apply invoke "lrelease" (find-files "translations" ".*\\.ts"))))
340 ;; Ensure that icons are found at runtime.
341 (add-after 'install 'wrap-executable
342 (lambda* (#:key inputs outputs #:allow-other-keys)
343 (let ((out (assoc-ref outputs "out")))
344 (wrap-program (string-append out "/bin/ghostwriter")
345 `("QT_PLUGIN_PATH" ":" prefix
346 ,(map (lambda (label)
347 (string-append (assoc-ref inputs label)
348 "/lib/qt5/plugins/"))
349 '("qtsvg" "qtmultimedia"))))))))))
350 (home-page "https://wereturtle.github.io/ghostwriter/")
351 (synopsis "Write without distractions")
352 (description
353 "@code{ghostwriter} provides a relaxing, distraction-free writing
354 environment with Markdown markup.")
355 (license license:gpl3+))) ; icons/* under CC-BY-SA3
356
357 (define-public editorconfig-core-c
358 (package
359 (name "editorconfig-core-c")
360 (version "0.12.3")
361 (source
362 (origin
363 (method git-fetch)
364 (uri (git-reference
365 (url "https://github.com/editorconfig/editorconfig-core-c.git")
366 (commit (string-append "v" version))))
367 (file-name (git-file-name name version))
368 (sha256
369 (base32
370 "0jkc69r4jwn4rih6h6cqvgljjc3ff49cxj8286mi515aczr48cm1"))))
371 (build-system cmake-build-system)
372 (arguments
373 '(#:phases
374 (modify-phases %standard-phases
375 (add-after 'unpack 'insert-tests
376 (lambda* (#:key inputs #:allow-other-keys)
377 (let ((tests (assoc-ref inputs "tests")))
378 (copy-recursively tests "tests"))
379 #t)))))
380 (native-inputs
381 `(("tests" ,(origin
382 (method git-fetch)
383 (uri (git-reference
384 (url "https://github.com/editorconfig/editorconfig-core-test")
385 (commit "6ea1d8ece62cac9cf72c79dce4879b046abe1fe7"))) ; matches version
386 (file-name (git-file-name "editorconfig-core-test" version))
387 (sha256
388 (base32
389 "1sf6910idnd4bgzbj8w8f9ldsbkaqa0lh6syymwy3hfqda63acj7"))))))
390 (inputs
391 `(("pcre2" ,pcre2)))
392 (home-page "https://editorconfig.org/")
393 (synopsis "EditorConfig core library written in C")
394 (description "EditorConfig makes it easy to maintain the correct coding
395 style when switching between different text editors and between different
396 projects. The EditorConfig project maintains a file format and plugins for
397 various text editors which allow this file format to be read and used by those
398 editors.")
399 (license license:bsd-2)))
400
401 (define-public texmacs
402 (package
403 (name "texmacs")
404 (version "1.99.11")
405 (source
406 (origin
407 (method url-fetch)
408 (uri (string-append "https://www.texmacs.org/Download/ftp/tmftp/"
409 "source/TeXmacs-" version "-src.tar.gz"))
410 (sha256
411 (base32 "12bp0f34izzqimz49lfpgf4lyz3h45s9xbmk8v6zsawdjki76alg"))
412 (modules '((guix build utils)))
413 (snippet
414 '(begin
415 (delete-file-recursively "3rdparty")
416 #t))))
417 (build-system gnu-build-system)
418 (native-inputs
419 `(("pkg-config" ,pkg-config)))
420 (inputs
421 `(("freetype" ,freetype)
422 ("guile" ,guile-1.8)
423 ("perl" ,perl)
424 ("python" ,python-wrapper)
425 ("qt" ,qt-4)))
426 (arguments
427 `(#:tests? #f ; no check target
428 #:phases
429 (modify-phases %standard-phases
430 (add-before 'configure 'gzip-flags
431 (lambda _
432 (substitute* "Makefile.in"
433 (("^GZIP = gzip -f") "GZIP = gzip -f -n")))))))
434 (synopsis "Editing platform with special features for scientists")
435 (description
436 "GNU TeXmacs is a text editing platform which is specialized for
437 scientists. It is ideal for editing structured documents with different
438 types of content. It has robust support for mathematical formulas and plots.
439 It can also act as an interface to external mathematical programs such as R
440 and Octave. TeXmacs is completely extensible via Guile.")
441 (license license:gpl3+)
442 (home-page "https://www.texmacs.org/tmweb/home/welcome.en.html")))
443
444 (define-public scintilla
445 (package
446 (name "scintilla")
447 (version "4.2.2")
448 (source (origin
449 (method url-fetch)
450 (uri (let ((v (apply string-append (string-split version #\.))))
451 (string-append
452 "https://www.scintilla.org/scintilla" v ".tgz")))
453 (sha256
454 (base32
455 "01gq31ggvasw4sy9xs544h7v1dmxrlxs5bzxpasqb9yi3ps3nl0f"))))
456 (build-system gnu-build-system)
457 (arguments
458 `(#:make-flags (list "GTK3=1" "CC=gcc" "-Cgtk")
459 #:tests? #f ;require un-packaged Pyside
460 #:phases
461 (modify-phases %standard-phases
462 (delete 'configure) ;no configure script
463 (add-after 'unpack 'build-shared-library
464 (lambda _
465 (substitute* "gtk/makefile"
466 (("scintilla\\.a") "libscintilla.so")
467 (("\\$\\(AR\\) \\$\\(ARFLAGS\\) \\$@ \\$\\^")
468 "$(CC) -shared $^ -o $@")
469 (("\\$\\(RANLIB\\) \\$@") ""))
470 #t))
471 (replace 'install
472 (lambda* (#:key outputs #:allow-other-keys)
473 (let* ((out (assoc-ref outputs "out"))
474 (lib (string-append out "/lib"))
475 (include (string-append out "/include")))
476 (install-file "bin/libscintilla.so" lib)
477 (for-each (lambda (f) (install-file f include))
478 (find-files "include/" "."))
479 #t))))))
480 (native-inputs
481 `(("pkg-config" ,pkg-config)
482 ("python" ,python-wrapper)))
483 (inputs
484 `(("gtk+" ,gtk+)))
485 (home-page "https://www.scintilla.org/")
486 (synopsis "Code editor for GTK+")
487 (description "Scintilla is a source code editing component for
488 GTK+. It has the usual features found in text editing components, as
489 well as some that are especially useful for editing and debugging
490 source code; these include support for syntax styling, error
491 indicators, code completion and call tips. Styling choices are more
492 open than with many editors: Scintilla lets you use proportional
493 fonts, bold and italics, multiple foreground and background colours,
494 and multiple fonts.")
495 (license license:hpnd)))
496
497 (define-public geany
498 (package
499 (name "geany")
500 (version "1.36")
501 (source (origin
502 (method url-fetch)
503 (uri (string-append "https://download.geany.org/"
504 "geany-" version ".tar.bz2"))
505 (sha256
506 (base32
507 "0gnm17cr4rf3pmkf0axz4a0fxwnvp55ji0q0lzy88yqbshyxv14i"))
508 (modules '((guix build utils)))
509 (snippet '(begin
510 (delete-file-recursively "scintilla")
511 #t))))
512 (build-system gnu-build-system)
513 (native-inputs
514 `(("autoconf" ,autoconf)
515 ("automake" ,automake)
516 ("doxygen" ,doxygen)
517 ("glib" ,glib "bin")
518 ("intltool" ,intltool)
519 ("libtool" ,libtool)
520 ("pkg-config" ,pkg-config)
521 ("python-docutils" ,python-docutils))) ;for rst2html
522 (inputs
523 `(("gtk+" ,gtk+)
524 ("scintilla" ,scintilla)))
525 (arguments
526 `(#:phases
527 (modify-phases %standard-phases
528 (add-after 'unpack 'use-scintilla-shared-library
529 (lambda* (#:key inputs #:allow-other-keys)
530 (substitute* "configure.ac"
531 (("scintilla/Makefile") "")
532 (("scintilla/include/Makefile") ""))
533 (substitute* "Makefile.am"
534 (("scintilla ") ""))
535 (substitute* "src/Makefile.am"
536 (("\\$\\(top_builddir\\)/scintilla/libscintilla.la") "")
537 (("geany_LDFLAGS =" all) (string-append all " -lscintilla")))
538 (substitute* "doc/Makefile.am"
539 (("\\$\\(INSTALL_DATA\\) \\$\\(top_srcdir\\)/scintilla/License.txt \\$\\(DOCDIR\\)/ScintillaLicense.txt") ""))
540 (substitute* "tests/Makefile.am"
541 (("AM_LDFLAGS =" all) (string-append all " -lscintilla")))
542 (for-each delete-file (list "autogen.sh" "configure" "Makefile.in"))
543 #t)))))
544 (home-page "https://www.geany.org")
545 (synopsis "Fast and lightweight IDE")
546 (description "Geany is a small and fast Integrated Development
547 Environment (IDE) that only has a few dependencies on other packages and is as
548 independent as possible from special desktop environments like KDE or GNOME.
549
550 The basic features of Geany are:
551 @itemize
552 @item syntax highlighting
553 @item code completion
554 @item auto completion of often constructed constructs like if, for and while
555 @item auto completion of XML and HTML tags
556 @item call tips
557 @item folding
558 @item many supported filetypes like C, Java, PHP, HTML, Python, Perl, Pascal
559 @item symbol lists
560 @item embedded terminal emulation
561 @item extensibility through plugins
562 @end itemize")
563 (license license:gpl2+)))
564
565 (define-public fe
566 (package
567 (name "fe")
568 ;; Stable release is 1.8. However, this development version
569 ;; introduces support for UTF-8.
570 (version "2.0")
571 (source (origin
572 (method url-fetch)
573 (uri (string-append "http://www.moria.de/~michael/fe/"
574 "fe-" version ".tar.gz"))
575 (sha256
576 (base32
577 "1hwws7si1752z6hp61zxznvgsb6846lp8zl1hn5ddhsbafwalwb9"))))
578 (build-system gnu-build-system)
579 (arguments
580 `(#:tests? #f ;no test
581 ;; Sendmail is only used to send a crash log. Disable the
582 ;; feature since it is (1) undocumented (2) not very useful.
583 #:configure-flags (list "--disable-sendmail")
584 #:phases
585 (modify-phases %standard-phases
586 (add-after 'install 'install-doc
587 (lambda* (#:key outputs #:allow-other-keys)
588 (let* ((out (assoc-ref outputs "out"))
589 (doc (string-append out "/share/doc/" ,name "-" ,version)))
590 (for-each (lambda (f) (install-file f doc))
591 '("fe.doc" "fe.html" "fe.ps" "feref.ps" "README"))
592 #t))))))
593 (native-inputs
594 `(("gettext" ,gettext-minimal)))
595 (inputs
596 `(("ncurses" ,ncurses)))
597 (home-page "http://www.moria.de/~michael/fe/")
598 (synopsis "Small folding editor")
599 (description "Fe is a small folding editor. It allows to fold
600 arbitrary text regions; it is not bound to syntactic units.
601
602 Fe has no configuration or extension language and requires no setup.
603 Its user interface is emacs-like and it has menus for the very most
604 important functions to help beginners. Further there is a reference
605 card. It offers:
606
607 @itemize
608 @item Regions and Emacs-like kill ring
609 @item Incremental search
610 @item Keyboard macros
611 @item Editing binary files
612 @item Multiple windows and views
613 @item Compose function for Latin 1 characters
614 @end itemize")
615 (license license:gpl2+)))