gnu: Add python-zope-i18nmessageid.
[jackhill/guix/guix.git] / gnu / packages / rsync.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013 Andreas Enge <andreas@enge.fr>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages rsync)
20 #:use-module (gnu packages)
21 #:use-module (gnu packages perl)
22 #:use-module (gnu packages acl)
23 #:use-module (gnu packages base)
24 #:use-module (guix licenses)
25 #:use-module (guix packages)
26 #:use-module (guix download)
27 #:use-module (guix build-system gnu))
28
29
30 (define-public rsync
31 (package
32 (name "rsync")
33 (version "3.1.0")
34 (source (origin
35 (method url-fetch)
36 (uri (string-append "http://rsync.samba.org/ftp/rsync/src/rsync-"
37 version ".tar.gz"))
38 (sha256
39 (base32
40 "0kirw8wglqvwi1v8bwxp373g03xg857h59j5k3mmgff9gzvj7jl1"))))
41 (build-system gnu-build-system)
42 (inputs `(("perl" ,perl)
43 ("acl" ,acl)))
44 (synopsis "Remote (and local) file copying tool")
45 (description
46 "Rsync is a fast and versatile file copying tool. It can copy locally,
47 to/from another host over any remote shell, or to/from a remote rsync daemon.
48 Its delta-transfer algorithm reduces the amount of data sent over the network
49 by sending only the differences between the source files and the existing
50 files in the destination.")
51 (license gpl3+)
52 (home-page "http://rsync.samba.org/")))
53
54 (define-public librsync
55 (package
56 (name "librsync")
57 (version "0.9.7")
58 (source (origin
59 (method url-fetch)
60 (uri (string-append "mirror://sourceforge/librsync/librsync/"
61 version "/librsync-" version ".tar.gz"))
62 (sha256
63 (base32
64 "1mj1pj99mgf1a59q9f2mxjli2fzxpnf55233pc1klxk2arhf8cv6"))))
65 (build-system gnu-build-system)
66 (native-inputs
67 `(("which" ,which)
68 ("perl" ,perl)))
69 (arguments '(#:configure-flags '("--enable-shared")))
70 (home-page "http://librsync.sourceforge.net/")
71 (synopsis "Implementation of the rsync remote-delta algorithm")
72 (description
73 "Librsync is a free software library that implements the rsync
74 remote-delta algorithm. This algorithm allows efficient remote updates of a
75 file, without requiring the old and new versions to both be present at the
76 sending end. The library uses a \"streaming\" design similar to that of zlib
77 with the aim of allowing it to be embedded into many different applications.")
78 (license lgpl2.1+)))