gnu: librime: Update to 1.4.0.
[jackhill/guix/guix.git] / gnu / packages / ibus.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015, 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
3 ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
4 ;;; Copyright © 2016 Chris Marusich <cmmarusich@gmail.com>
5 ;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
6 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
7 ;;; Copyright © 2018, 2019 Meiyo Peng <meiyo@disroot.org>
8 ;;;
9 ;;; This file is part of GNU Guix.
10 ;;;
11 ;;; GNU Guix is free software; you can redistribute it and/or modify it
12 ;;; under the terms of the GNU General Public License as published by
13 ;;; the Free Software Foundation; either version 3 of the License, or (at
14 ;;; your option) any later version.
15 ;;;
16 ;;; GNU Guix is distributed in the hope that it will be useful, but
17 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
18 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
19 ;;; GNU General Public License for more details.
20 ;;;
21 ;;; You should have received a copy of the GNU General Public License
22 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
23
24 (define-module (gnu packages ibus)
25 #:use-module (guix licenses)
26 #:use-module (guix packages)
27 #:use-module (guix download)
28 #:use-module (guix git-download)
29 #:use-module (guix build-system cmake)
30 #:use-module (guix build-system gnu)
31 #:use-module (guix build-system glib-or-gtk)
32 #:use-module (guix utils)
33 #:use-module (gnu packages)
34 #:use-module (gnu packages anthy)
35 #:use-module (gnu packages autotools)
36 #:use-module (gnu packages base)
37 #:use-module (gnu packages boost)
38 #:use-module (gnu packages check)
39 #:use-module (gnu packages cmake)
40 #:use-module (gnu packages databases)
41 #:use-module (gnu packages datastructures)
42 #:use-module (gnu packages dbm)
43 #:use-module (gnu packages freedesktop)
44 #:use-module (gnu packages gettext)
45 #:use-module (gnu packages glib)
46 #:use-module (gnu packages gnome)
47 #:use-module (gnu packages gtk)
48 #:use-module (gnu packages iso-codes)
49 #:use-module (gnu packages logging)
50 #:use-module (gnu packages pkg-config)
51 #:use-module (gnu packages python)
52 #:use-module (gnu packages serialization)
53 #:use-module (gnu packages sqlite)
54 #:use-module (gnu packages textutils)
55 #:use-module (gnu packages xorg))
56
57 (define-public ibus
58 (package
59 (name "ibus")
60 (version "1.5.19")
61 (source (origin
62 (method url-fetch)
63 (uri (string-append "https://github.com/ibus/ibus/"
64 "releases/download/"
65 version "/ibus-" version ".tar.gz"))
66 (sha256
67 (base32
68 "0a94bnpm24581317hdnihwr4cniriml10p4ffgxg14xhvaccfrjb"))))
69 (build-system glib-or-gtk-build-system)
70 (arguments
71 `(#:tests? #f ; tests fail because there's no connection to dbus
72 #:configure-flags `("--disable-emoji-dict" ; cannot find emoji.json path
73 "--disable-python2"
74 "--enable-python-library"
75 ,(string-append "--with-ucd-dir="
76 (getcwd) "/ucd")
77 "--enable-wayland")
78 #:make-flags
79 (list "CC=gcc"
80 (string-append "pyoverridesdir="
81 (assoc-ref %outputs "out")
82 "/lib/python"
83 ,(version-major+minor (package-version python))
84 "/site-packages/gi/overrides/"))
85 #:phases
86 (modify-phases %standard-phases
87 (add-after 'unpack 'prepare-ucd-dir
88 (lambda* (#:key inputs #:allow-other-keys)
89 (mkdir-p "../ucd")
90 (symlink (assoc-ref inputs "unicode-blocks") "../ucd/Blocks.txt")
91 (symlink (assoc-ref inputs "unicode-nameslist") "../ucd/NamesList.txt")
92 #t))
93 (add-before 'configure 'disable-dconf-update
94 (lambda _
95 (substitute* "data/dconf/Makefile.in"
96 (("dconf update") "echo dconf update"))
97 #t))
98 (add-after 'unpack 'delete-generated-files
99 (lambda _
100 (for-each (lambda (file)
101 (let ((c (string-append (string-drop-right file 4) "c")))
102 (when (file-exists? c)
103 (format #t "deleting ~a\n" c)
104 (delete-file c))))
105 (find-files "." "\\.vala"))
106 #t))
107 (add-after 'unpack 'fix-paths
108 (lambda* (#:key inputs #:allow-other-keys)
109 (substitute* "src/ibusenginesimple.c"
110 (("/usr/share/X11/locale")
111 (string-append (assoc-ref inputs "libx11")
112 "/share/X11/locale")))
113 (substitute* "ui/gtk3/xkblayout.vala"
114 (("\"(setxkbmap|xmodmap)\"" _ prog)
115 (string-append "\"" (assoc-ref inputs prog) "\"")))
116 #t))
117 (add-after 'wrap-program 'wrap-with-additional-paths
118 (lambda* (#:key outputs #:allow-other-keys)
119 ;; Make sure 'ibus-setup' runs with the correct PYTHONPATH and
120 ;; GI_TYPELIB_PATH.
121 (let ((out (assoc-ref outputs "out")))
122 (wrap-program (string-append out "/bin/ibus-setup")
123 `("PYTHONPATH" ":" prefix (,(getenv "PYTHONPATH")))
124 `("GI_TYPELIB_PATH" ":" prefix
125 (,(getenv "GI_TYPELIB_PATH")
126 ,(string-append out "/lib/girepository-1.0")))))
127 #t)))))
128 (inputs
129 `(("dbus" ,dbus)
130 ("dconf" ,dconf)
131 ("gconf" ,gconf)
132 ("gtk2" ,gtk+-2)
133 ("gtk+" ,gtk+)
134 ("intltool" ,intltool)
135 ("json-glib" ,json-glib)
136 ("libnotify" ,libnotify)
137 ("libx11" ,libx11)
138 ("setxkbmap" ,setxkbmap)
139 ("wayland" ,wayland)
140 ("xmodmap" ,xmodmap)
141 ("iso-codes" ,iso-codes)
142 ("pygobject2" ,python-pygobject)
143 ("python" ,python)))
144 (native-inputs
145 `(("glib" ,glib "bin") ; for glib-genmarshal
146 ("gobject-introspection" ,gobject-introspection) ; for g-ir-compiler
147 ("unicode-nameslist"
148 ,(origin
149 (method url-fetch)
150 (uri "https://www.unicode.org/Public/UNIDATA/NamesList.txt")
151 (sha256
152 (base32 "0yr2h0nfqhirfi3bxl33z6cc94qqshlpgi06c25xh9754irqsgv8"))))
153 ("unicode-blocks"
154 ,(origin
155 (method url-fetch)
156 (uri "https://www.unicode.org/Public/UNIDATA/Blocks.txt")
157 (sha256
158 (base32 "0lnh9iazikpr548bd7nkaq9r3vfljfvz0rg2462prac8qxk7ni8b"))))
159 ("vala" ,vala)
160 ("pkg-config" ,pkg-config)))
161 (native-search-paths
162 (list (search-path-specification
163 (variable "IBUS_COMPONENT_PATH")
164 (files '("share/ibus/component")))))
165 (synopsis "Input method framework")
166 (description
167 "IBus is an input framework providing a full-featured and user-friendly
168 input method user interface. It comes with multilingual input support. It
169 may also simplify input method development.")
170 (home-page "https://github.com/ibus/ibus/wiki")
171 (license lgpl2.1+)))
172
173 (define-public ibus-libpinyin
174 (package
175 (name "ibus-libpinyin")
176 (version "1.10.0")
177 (source (origin
178 (method url-fetch)
179 (uri (string-append "https://github.com/libpinyin/ibus-libpinyin/"
180 "releases/download/" version
181 "/ibus-libpinyin-" version ".tar.gz"))
182 (sha256
183 (base32
184 "0yq8aw4lddiviag8cnik6fp52vvk8lxv6bym13a3xya84c6zii3c"))))
185 (build-system glib-or-gtk-build-system)
186 (arguments
187 `(#:phases
188 (modify-phases %standard-phases
189 (add-after 'wrap-program 'wrap-with-additional-paths
190 (lambda* (#:key inputs outputs #:allow-other-keys)
191 ;; Make sure 'ibus-setup-libpinyin' runs with the correct
192 ;; PYTHONPATH and GI_TYPELIB_PATH.
193 (let ((out (assoc-ref outputs "out")))
194 (wrap-program (string-append out "/libexec/ibus-setup-libpinyin")
195 `("PYTHONPATH" ":" prefix
196 (,(getenv "PYTHONPATH")
197 ,(string-append (assoc-ref inputs "ibus")
198 "/lib/girepository-1.0")))
199 `("GI_TYPELIB_PATH" ":" prefix
200 (,(string-append (assoc-ref inputs "ibus")
201 "/lib/girepository-1.0"))))
202 #t))))))
203 (inputs
204 `(("ibus" ,ibus)
205 ("libpinyin" ,libpinyin)
206 ("bdb" ,bdb)
207 ("sqlite" ,sqlite)
208 ("python" ,python)
209 ("pyxdg" ,python-pyxdg)
210 ("gtk+" ,gtk+)))
211 (native-inputs
212 `(("pkg-config" ,pkg-config)
213 ("intltool" ,intltool)
214 ("glib" ,glib "bin")))
215 (synopsis "Chinese pinyin and ZhuYin input methods for IBus")
216 (description
217 "This package includes a Chinese pinyin input method and a Chinese
218 ZhuYin (Bopomofo) input method based on libpinyin for IBus.")
219 (home-page "https://github.com/libpinyin/ibus-libpinyin")
220 (license gpl2+)))
221
222 (define-public libpinyin
223 (package
224 (name "libpinyin")
225 (version "2.2.0")
226 (source (origin
227 (method url-fetch)
228 (uri (string-append "https://github.com/libpinyin/libpinyin/"
229 "releases/download/" version
230 "/libpinyin-2.2.0.tar.gz"))
231 (sha256
232 (base32
233 "1c4wxvcvjxvk23mcwqvsfsv4nhimx4kpjhabxa28gx1ih10l88gj"))))
234 (build-system gnu-build-system)
235 (inputs
236 `(("glib" ,glib)
237 ("bdb" ,bdb)))
238 (native-inputs
239 `(("pkg-config" ,pkg-config)))
240 (synopsis "Library to handle Chinese pinyin")
241 (description
242 "The libpinyin C++ library provides algorithms needed for sentence-based
243 Chinese pinyin input methods.")
244 (home-page "https://github.com/libpinyin/libpinyin")
245 (license gpl2+)))
246
247 (define-public ibus-anthy
248 (package
249 (name "ibus-anthy")
250 (version "1.5.9")
251 (source (origin
252 (method url-fetch)
253 (uri (string-append
254 "https://github.com/ibus/ibus-anthy/releases/download/"
255 version "/ibus-anthy-" version ".tar.gz"))
256 (sha256
257 (base32
258 "1y8sf837rmp662bv6zakny0xcm7c9c5qda7f9kq9riv9ywpcbw6x"))))
259 (build-system gnu-build-system)
260 (arguments
261 '(#:configure-flags
262 ;; Use absolute exec path in the anthy.xml.
263 (list (string-append "--libexecdir=" %output "/libexec"))
264 #:phases
265 (modify-phases %standard-phases
266 (add-after 'install 'wrap-programs
267 (lambda* (#:key outputs #:allow-other-keys)
268 (let ((out (assoc-ref outputs "out")))
269 (for-each
270 (lambda (prog)
271 (wrap-program (string-append out "/libexec/" prog)
272 `("PYTHONPATH" ":" prefix
273 (,(getenv "PYTHONPATH")))
274 `("GI_TYPELIB_PATH" ":" prefix
275 (,(getenv "GI_TYPELIB_PATH")
276 ,(string-append out "/lib/girepository-1.0")))))
277 '("ibus-engine-anthy" "ibus-setup-anthy"))
278 #t))))))
279 (native-inputs
280 `(("gettext" ,gettext-minimal)
281 ("intltool" ,intltool)
282 ("pkg-config" ,pkg-config)
283 ("python" ,python)))
284 (inputs
285 `(("anthy" ,anthy)
286 ("gtk+" ,gtk+)
287 ("ibus" ,ibus)
288 ("gobject-introspection" ,gobject-introspection)
289 ("python-pygobject" ,python-pygobject)))
290 (synopsis "Anthy Japanese language input method for IBus")
291 (description "IBus-Anthy is an engine for the input bus \"IBus\"). It
292 adds the Anthy Japanese language input method to IBus. Because most graphical
293 applications allow text input via IBus, installing this package will enable
294 Japanese language input in most graphical applications.")
295 (home-page "https://github.com/fujiwarat/ibus-anthy")
296 (license gpl2+)))
297
298 (define-public librime
299 (package
300 (name "librime")
301 (version "1.4.0")
302 (source
303 (origin
304 (method git-fetch)
305 (uri (git-reference
306 (url "https://github.com/rime/librime.git")
307 (commit version)))
308 (file-name (git-file-name name version))
309 (sha256
310 (base32
311 "1zkx1wfbd94v55gfycyd2b94jxclfyk2zl7yw35pyjx63qdlb6sd"))
312 (modules '((guix build utils)))
313 (snippet
314 '(begin
315 (delete-file-recursively "thirdparty/src")
316 (delete-file-recursively "thirdparty/bin")
317 (delete-file-recursively "thirdparty/include/X11")
318 #t))))
319 (build-system cmake-build-system)
320 (arguments
321 '(#:phases
322 (modify-phases %standard-phases
323 (add-after 'unpack 'patch-source
324 (lambda _
325 (substitute* "CMakeLists.txt"
326 (("include_directories\\($\\{PROJECT_SOURCE_DIR\\}/thirdparty/include\\)") "")
327 (("link_directories\\($\\{PROJECT_SOURCE_DIR\\}/thirdparty/lib\\)") ""))
328 #t)))))
329 (inputs
330 `(("boost" ,boost)
331 ("glog" ,glog)
332 ("leveldb" ,leveldb)
333 ("marisa" ,marisa)
334 ("opencc" ,opencc)
335 ("yaml-cpp" ,yaml-cpp)))
336 (native-inputs
337 `(("googletest" ,googletest)
338 ("xorgproto" ,xorgproto))) ; keysym.h
339 (home-page "https://rime.im/")
340 (synopsis "The core library of Rime Input Method Engine")
341 (description "@dfn{librime} is the core library of Rime Input Method
342 Engine, which is a lightweight, extensible input method engine supporting
343 various input schemas including glyph-based input methods, romanization-based
344 input methods as well as those for Chinese dialects. It has the ability to
345 compose phrases and sentences intelligently and provide very accurate
346 traditional Chinese output.")
347 (license bsd-3)))
348
349 (define-public rime-data
350 (package
351 (name "rime-data")
352 (version "0.38.20181029")
353 (source
354 (origin
355 (method git-fetch)
356 (uri (git-reference
357 (url "https://github.com/rime/plum.git")
358 (commit "fb4f829da2007f2dbb37d60a79bc67c25ea16568")))
359 (file-name "plum-checkout")
360 (sha256
361 (base32 "1m1wiv9j5bay4saga58c7dj4h8gqivsbyp16y245ifvxvp9czj67"))))
362 (build-system gnu-build-system)
363 (arguments
364 `(#:tests? #f ; no tests
365 #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
366 "no_update=1")
367 #:phases
368 (modify-phases %standard-phases
369 (add-after 'unpack 'patch-source
370 (lambda _
371 ;; Set .DEFAULT_GOAL to `all'.
372 ;; Don't build binary schemas. The output is not deterministic.
373 (substitute* "Makefile"
374 (("^\\.DEFAULT_GOAL := preset")
375 ".DEFAULT_GOAL := all"))
376 #t))
377 ;; Add schema packages into "package/rime" directory.
378 (add-after 'unpack 'add-packages
379 (lambda* (#:key inputs #:allow-other-keys)
380 (let* ((dest-dir "package/rime"))
381 (mkdir-p dest-dir)
382 (for-each (lambda (pkg)
383 (symlink (assoc-ref inputs pkg)
384 (string-append dest-dir "/" pkg)))
385 '("array"
386 "bopomofo"
387 "cangjie"
388 "combo-pinyin"
389 "double-pinyin"
390 "emoji"
391 "essay"
392 "ipa"
393 "jyutping"
394 "luna-pinyin"
395 "middle-chinese"
396 "pinyin-simp"
397 "prelude"
398 "quick"
399 "scj"
400 "soutzoe"
401 "stenotype"
402 "stroke"
403 "terra-pinyin"
404 "wubi"
405 "wugniu")))
406 #t))
407 (delete 'configure))))
408 (native-inputs
409 `(("array"
410 ,(origin
411 (method git-fetch)
412 (uri (git-reference
413 (url "https://github.com/rime/rime-array.git")
414 (commit "906e923902147584b0b0247028a782abbfbfd8a0")))
415 (file-name "rime-array-checkout")
416 (sha256
417 (base32
418 "1alk6ghn4ji4kvp7lfm57bwm2gjh99i79r0w9naz6wkdim8idvb1"))))
419 ("bopomofo"
420 ,(origin
421 (method git-fetch)
422 (uri (git-reference
423 (url "https://github.com/rime/rime-bopomofo.git")
424 (commit "8dc44ca1b6ef4e45b452e070b9da737f5da165e3")))
425 (file-name "rime-bopomofo-checkout")
426 (sha256
427 (base32
428 "16k6wfhcrw3a77rmbrp21ca0gmsmb3f68s193c1cfwr8i68k46nf"))))
429 ("cangjie"
430 ,(origin
431 (method git-fetch)
432 (uri (git-reference
433 (url "https://github.com/rime/rime-cangjie.git")
434 (commit "ab085e90856b3399b374dc3c8b4cb40d11f307a8")))
435 (file-name "rime-cangjie-checkout")
436 (sha256
437 (base32
438 "11fgj0rbv9nyzfijwm2l8pm8fznhif4h27ndrrcaaylkp7p5zsx2"))))
439 ("combo-pinyin"
440 ,(origin
441 (method git-fetch)
442 (uri (git-reference
443 (url "https://github.com/rime/rime-combo-pinyin.git")
444 (commit "f1bae63f20504f2b8113c5cbdf2700e858aa91eb")))
445 (file-name "rime-combo-pinyin-checkout")
446 (sha256
447 (base32
448 "1l1079akwm1hw4kkn0q6x9fpylnl2ka6z2fn7lmdpfpsr0xgn0n7"))))
449 ("double-pinyin"
450 ,(origin
451 (method git-fetch)
452 (uri (git-reference
453 (url "https://github.com/rime/rime-double-pinyin.git")
454 (commit "2101a5cd40e511ec38835769aa66d2dddf059c2e")))
455 (file-name "rime-double-pinyin-checkout")
456 (sha256
457 (base32
458 "19hh2qm0njbfk2js678hfm2hw9b796s43vs11yy3m1v9m0gk2vi7"))))
459 ("emoji"
460 ,(origin
461 (method git-fetch)
462 (uri (git-reference
463 (url "https://github.com/rime/rime-emoji.git")
464 (commit "6e6611b315f03ee4c33f958f9dbe960b13a0ed19")))
465 (file-name "rime-emoji-checkout")
466 (sha256
467 (base32
468 "1brfs3214w36j3345di9ygp468hbvbqdqpkjxxs1dbp437rayhyy"))))
469 ("essay"
470 ,(origin
471 (method git-fetch)
472 (uri (git-reference
473 (url "https://github.com/rime/rime-essay.git")
474 (commit "5e5c7a0ef41c9b030abdad81a9df07b56b1661e9")))
475 (file-name "rime-essay-checkout")
476 (sha256
477 (base32
478 "0ana9is0zhh79m4gjshvmaxbrg3jiqysydx5bpm151i7i6vw5y1i"))))
479 ("ipa"
480 ,(origin
481 (method git-fetch)
482 (uri (git-reference
483 (url "https://github.com/rime/rime-ipa.git")
484 (commit "02a9e2c181921a2e95e1a81f88188c41132755c3")))
485 (file-name "rime-ipa-checkout")
486 (sha256
487 (base32
488 "1szrxgvqlgmxapj2aflw2cvbv0p6pl0sw0gyxa13dvdhhf7s9rvr"))))
489 ("jyutping"
490 ,(origin
491 (method git-fetch)
492 (uri (git-reference
493 (url "https://github.com/rime/rime-jyutping.git")
494 (commit "1402ec3d6cc0973f952fe3f9ef531294e4ffe9e0")))
495 (file-name "rime-jyutping-checkout")
496 (sha256
497 (base32
498 "17g03dy4gw6vyc9da1wjn3iy9hx64dfnwiwsfc7bkzan22x2m4dv"))))
499 ("luna-pinyin"
500 ,(origin
501 (method git-fetch)
502 (uri (git-reference
503 (url "https://github.com/rime/rime-luna-pinyin.git")
504 (commit "3b05132576f5c347ff8a70857d2dae080936ac3b")))
505 (file-name "rime-luna-pinyin-checkout")
506 (sha256
507 (base32
508 "0kgnpxjn10dm2d9718r12rdjlwqd2s2h84jvkhxhh5v0dkv1anl2"))))
509 ("middle-chinese"
510 ,(origin
511 (method git-fetch)
512 (uri (git-reference
513 (url "https://github.com/rime/rime-middle-chinese.git")
514 (commit "9ba8d70330654b9a730f882d35cfad7dbeddfd75")))
515 (file-name "rime-middle-chinese-checkout")
516 (sha256
517 (base32
518 "0hwg5zby5kphh0bcfay8mfxwr5bwqhamiw3cmmmf7kp9fbns5s23"))))
519 ("pinyin-simp"
520 ,(origin
521 (method git-fetch)
522 (uri (git-reference
523 (url "https://github.com/rime/rime-pinyin-simp.git")
524 (commit "74357ffd62c05fb60edf6eab5b86bc8c8c1907d0")))
525 (file-name "rime-pinyin-simp-checkout")
526 (sha256
527 (base32
528 "1paw3c7pv5bl54abnp9pidfxrkchdacyxy5m9zb311p5sgm7fhxh"))))
529 ("prelude"
530 ,(origin
531 (method git-fetch)
532 (uri (git-reference
533 (url "https://github.com/rime/rime-prelude.git")
534 (commit "33040568c3ddb2ee6340c9b669494317db21b77c")))
535 (file-name "rime-prelude-checkout")
536 (sha256
537 (base32
538 "1gwcasyyg6f0ib6s4qsrrjcqr1lcs7j3xqxl65rznsw44nhnbwwq"))))
539 ("quick"
540 ,(origin
541 (method git-fetch)
542 (uri (git-reference
543 (url "https://github.com/rime/rime-quick.git")
544 (commit "910a97d403ad8e72f322488da146da79c19d623f")))
545 (file-name "rime-quick-checkout")
546 (sha256
547 (base32
548 "0yrq3gbfmm29xlr52rmxc41mqfrb0295q7sdhbc3ax71677mpr0y"))))
549 ("scj"
550 ,(origin
551 (method git-fetch)
552 (uri (git-reference
553 (url "https://github.com/rime/rime-scj.git")
554 (commit "e0eae889f4376d2a434ac3b38523e0da7400db68")))
555 (file-name "rime-scj-checkout")
556 (sha256
557 (base32
558 "1whnv9zs349kvy0zi7dnmpqwil8i6gqwrzvhy3qdrjzy58y6gwxn"))))
559 ("soutzoe"
560 ,(origin
561 (method git-fetch)
562 (uri (git-reference
563 (url "https://github.com/rime/rime-soutzoe.git")
564 (commit "e47841a8ad6341731c41cdb814b7a25c837603c4")))
565 (file-name "rime-soutzoe-checkout")
566 (sha256
567 (base32
568 "1rgpmkxa72jy6gyy44fn8azpk3amk9s9lrdf7za03nv95d0fvm0p"))))
569 ("stenotype"
570 ,(origin
571 (method git-fetch)
572 (uri (git-reference
573 (url "https://github.com/rime/rime-stenotype.git")
574 (commit "d4ff379314fd95283853d1734854979cf3cbd287")))
575 (file-name "rime-stenotype-checkout")
576 (sha256
577 (base32
578 "1kckpi4l4884hvydr3d6vid3v7rsc1app29kmk7v8jf8vn16afhl"))))
579 ("stroke"
580 ,(origin
581 (method git-fetch)
582 (uri (git-reference
583 (url "https://github.com/rime/rime-stroke.git")
584 (commit "cfd29c675c46cf70b7a7f0a3836a913059316a0a")))
585 (file-name "rime-stroke-checkout")
586 (sha256
587 (base32
588 "135is9c1p4lm98fd9l1gxyflkm69cv5an129ka7sk614bq84m08d"))))
589 ("terra-pinyin"
590 ,(origin
591 (method git-fetch)
592 (uri (git-reference
593 (url "https://github.com/rime/rime-terra-pinyin.git")
594 (commit "15b5c73a796571cd6f9ef6c89f96656cb9df86f9")))
595 (file-name "rime-terra-pinyin-checkout")
596 (sha256
597 (base32
598 "1xsd84h1zw417h5hr4dbgyk5009zi7q2p9774w3ccr5sxgc3i3cm"))))
599 ("wubi"
600 ,(origin
601 (method git-fetch)
602 (uri (git-reference
603 (url "https://github.com/rime/rime-wubi.git")
604 (commit "d44403728a0b1cd8b47cb1f81b83f58e5f790b74")))
605 (file-name "rime-wubi-checkout")
606 (sha256
607 (base32
608 "0ld31bdn94lncxd1ka44w4sbl03skh08mc927dhdmwq5bpvrgn36"))))
609 ("wugniu"
610 ,(origin
611 (method git-fetch)
612 (uri (git-reference
613 (url "https://github.com/rime/rime-wugniu.git")
614 (commit "65bcc354ada3839591d7546a64c71dbdd0592b02")))
615 (file-name "rime-wugniu-checkout")
616 (sha256
617 (base32
618 "0g31awp40s778sp5c290x40s8np86n8aw011s17sslxrqhhb0bkx"))))))
619 (home-page "https://rime.im/")
620 (synopsis "Schema data of Rime Input Method Engine")
621 (description "@dfn{rime-data} provides the schema data of Rime Input
622 Method Engine.")
623 (license lgpl3+)))
624
625 (define-public ibus-rime
626 (package
627 (name "ibus-rime")
628 (version "1.3.0")
629 (source
630 (origin
631 (method git-fetch)
632 (uri (git-reference
633 (url "https://github.com/rime/ibus-rime.git")
634 (commit version)))
635 (file-name (git-file-name name version))
636 (sha256
637 (base32 "1nqi7ymv34a9kx24say3xj98lkrs9nkpv1n2ijb91wdz3cr012ly"))))
638 (build-system gnu-build-system)
639 (arguments
640 `(#:tests? #f ; no tests
641 #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
642 #:phases
643 (modify-phases %standard-phases
644 (add-after 'unpack 'patch-source
645 (lambda* (#:key inputs outputs #:allow-other-keys)
646 ;; Define RIME_DATA_DIR. It's required but not used by the code.
647 (substitute* "Makefile"
648 (("cmake")
649 (string-append "cmake -DRIME_DATA_DIR="
650 (assoc-ref inputs "rime-data")
651 "/share/rime-data")))
652 ;; rime_config.h defines the actual data directory.
653 (substitute* "rime_config.h"
654 (("^#define IBUS_RIME_INSTALL_PREFIX .*$")
655 (string-append "#define IBUS_RIME_INSTALL_PREFIX \""
656 (assoc-ref outputs "out")
657 "\"\n"))
658 (("^#define IBUS_RIME_SHARED_DATA_DIR .*$")
659 (string-append "#define IBUS_RIME_SHARED_DATA_DIR \""
660 (assoc-ref inputs "rime-data")
661 "/share/rime-data\"\n")))
662 #t))
663 (delete 'configure))))
664 (inputs
665 `(("gdk-pixbuf" ,gdk-pixbuf)
666 ("glib" ,glib)
667 ("ibus" ,ibus)
668 ("libnotify" ,libnotify)
669 ("librime" ,librime)
670 ("rime-data" ,rime-data)))
671 (native-inputs
672 `(("cmake" ,cmake)
673 ("pkg-config" ,pkg-config)))
674 (home-page "https://rime.im/")
675 (synopsis "Rime Input Method Engine for IBus")
676 (description "@dfn{ibus-rime} provides the Rime input method engine for
677 IBus. Rime is a lightweight, extensible input method engine supporting
678 various input schemas including glyph-based input methods, romanization-based
679 input methods as well as those for Chinese dialects. It has the ability to
680 compose phrases and sentences intelligently and provide very accurate
681 traditional Chinese output.")
682 (license gpl3+)))