Merge branch 'master' into core-updates-frozen
[jackhill/guix/guix.git] / gnu / packages / task-management.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Tomáš Čech <sleep_walker@suse.cz>
3 ;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
4 ;;; Copyright © 2021 Eric Bavier <bavier@posteo.net>
5 ;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
6 ;;; Copyright © 2021 LibreMiami <packaging-guix@libremiami.org>
7 ;;;
8 ;;; This file is part of GNU Guix.
9 ;;;
10 ;;; GNU Guix is free software; you can redistribute it and/or modify it
11 ;;; under the terms of the GNU General Public License as published by
12 ;;; the Free Software Foundation; either version 3 of the License, or (at
13 ;;; your option) any later version.
14 ;;;
15 ;;; GNU Guix is distributed in the hope that it will be useful, but
16 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
17 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
18 ;;; GNU General Public License for more details.
19 ;;;
20 ;;; You should have received a copy of the GNU General Public License
21 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
22
23 (define-module (gnu packages task-management)
24 #:use-module ((guix licenses) #:prefix license:)
25 #:use-module (guix packages)
26 #:use-module (gnu packages check)
27 #:use-module (gnu packages freedesktop)
28 #:use-module (gnu packages gettext)
29 #:use-module (gnu packages glib)
30 #:use-module (gnu packages gnome)
31 #:use-module (gnu packages gstreamer)
32 #:use-module (gnu packages gtk)
33 #:use-module (gnu packages linux)
34 #:use-module (gnu packages lua)
35 #:use-module (gnu packages pkg-config)
36 #:use-module (gnu packages python)
37 #:use-module (gnu packages python-xyz)
38 #:use-module (gnu packages tls)
39 #:use-module (guix download)
40 #:use-module (guix git-download)
41 #:use-module (guix hg-download)
42 #:use-module (guix utils)
43 #:use-module (guix build-system cmake)
44 #:use-module (guix build-system go)
45 #:use-module (guix build-system meson)
46 #:use-module (guix build-system python))
47
48 (define-public clikan
49 (let ((commit "55ab29e68263c6fed2844aef96fbebacda3eba9b")
50 (revision "1"))
51 (package
52 (name "clikan")
53 (version
54 (git-version "0.2.1" revision commit))
55 (source
56 (origin
57 (method git-fetch)
58 (uri (git-reference
59 (url "https://github.com/kitplummer/clikan")
60 (commit commit)))
61 (file-name (git-file-name name version))
62 (sha256
63 (base32 "1nyx80z53xxlbhpb5k22jnv4jajxqhjm0gz7qb18w9pqqlrvkqd4"))))
64 (build-system python-build-system)
65 (arguments
66 `(#:phases
67 (modify-phases %standard-phases
68 (replace 'check
69 (lambda* (#:key inputs outputs tests? #:allow-other-keys)
70 (setenv "HOME" (getenv "TEMP"))
71 (when tests?
72 (add-installed-pythonpath inputs outputs)
73 (invoke "pytest" "-vv")))))))
74 (native-inputs
75 `(("pytest" ,python-pytest)
76 ("click" ,python-click)))
77 (inputs
78 `(("click" ,python-click)
79 ("click-default-group" ,python-click-default-group)
80 ("pyyaml" ,python-pyyaml)
81 ("rich" ,python-rich)))
82 (home-page "https://github.com/kitplummer/clikan")
83 (synopsis "Command-line kanban utility")
84 (description
85 "Clikan is a super simple command-line utility for tracking tasks
86 following the Japanese kanban (boarding) style.")
87 (license license:expat))))
88
89 (define-public t-todo-manager
90 ;; Last release is more than 10 years old. Using latest commit.
91 (let ((changeset "89ad444c000b")
92 (revision "97"))
93 (package
94 (name "t-todo-manager")
95 (version (git-version "1.2.0" revision changeset))
96 (source
97 (origin
98 (method hg-fetch)
99 (uri (hg-reference
100 (url "https://hg.stevelosh.com/t")
101 (changeset changeset)))
102 (file-name (string-append name "-" version "-checkout"))
103 (sha256
104 (base32 "0c8zn7l0xq65wp07h7mxnb5ww56d1443l2vkjvx5sj6wpcchfn0s"))))
105 (build-system python-build-system)
106 (native-inputs
107 `(("python-cram" ,python-cram)))
108 (synopsis "Command-line todo list manager")
109 (description
110 "@command{t} is a command-line todo list manager for people that want
111 to finish tasks, not organize them.")
112 (home-page "https://stevelosh.com/projects/t/")
113 (license license:expat))))
114
115 (define-public taskwarrior
116 (package
117 (name "taskwarrior")
118 (version "2.5.3")
119 (source
120 (origin
121 (method url-fetch)
122 (uri (string-append
123 "http://taskwarrior.org/download/task-" version ".tar.gz"))
124 (sha256 (base32
125 "0fwnxshhlha21hlgg5z1ad01w13zm1hlmncs274y5n8i15gdfhvj"))))
126 (build-system cmake-build-system)
127 (inputs
128 `(("gnutls" ,gnutls)
129 ("util-linux" ,util-linux "lib")))
130 (arguments
131 `(#:tests? #f ; No tests implemented.
132 #:phases
133 (modify-phases %standard-phases
134 (delete 'install-license-files)))) ; Already installed by package
135 (home-page "https://taskwarrior.org")
136 (synopsis "Command line task manager")
137 (description
138 "Taskwarrior is a command-line task manager following the Getting Things
139 Done time management method. It supports network synchronization, filtering
140 and querying data, exposing task data in multiple formats to other tools.")
141 (license license:expat)))
142
143 (define-public dstask
144 (package
145 (name "dstask")
146 (version "0.24.1")
147 (source
148 (origin
149 (method git-fetch)
150 (uri (git-reference
151 (url "https://github.com/naggie/dstask")
152 (commit (string-append "v" version))))
153 (file-name (git-file-name name version))
154 (sha256
155 (base32 "03rl2wh58xd6a80ji43c7ak3h0ysi3ddg570pn8ry24s7s45zsz2"))))
156 (build-system go-build-system)
157 (arguments
158 `(#:import-path "github.com/naggie/dstask"
159 #:install-source? #f
160 #:phases
161 (modify-phases %standard-phases
162 (replace 'build
163 (lambda* (#:key import-path #:allow-other-keys)
164 (with-directory-excursion (string-append "src/" import-path)
165 (invoke "go" "build" "-o" "dstask" "cmd/dstask/main.go")
166 (invoke "go" "build" "-o" "dstask-import"
167 "cmd/dstask-import/main.go"))))
168 (replace 'install
169 (lambda* (#:key import-path outputs #:allow-other-keys)
170 (with-directory-excursion (string-append "src/" import-path)
171 (let* ((out (assoc-ref outputs "out"))
172 (bindir (string-append out "/bin"))
173 (zsh-completion (string-append
174 out "/share/zsh/site-functions/_dstask"))
175 (bash-completion
176 (string-append
177 out "/share/bash-completion/completions/_dstask")))
178 (install-file "dstask" bindir)
179 (install-file "dstask-import" bindir)
180 (install-file ".dstask-bash-completions.sh" bash-completion)
181 (install-file ".dstask-zsh-completions.sh" zsh-completion)))
182 #t)))))
183 (synopsis "CLI-based TODO manager with git-based sync + markdown notes per task")
184 (description "dstask is a personal task tracker that uses git for
185 synchronization. It offers a note command to attach a Markdown based note to
186 a task.")
187 (home-page "https://github.com/naggie/dstask")
188 (license license:expat)))
189
190 (define-public blanket
191 (package
192 (name "blanket")
193 (version "0.4.1")
194 (source
195 (origin
196 (method git-fetch)
197 (uri (git-reference
198 (url "https://github.com/rafaelmardojai/blanket/")
199 (commit version)))
200 (file-name (git-file-name name version))
201 (sha256
202 (base32 "1rk9xxiflj8rf75q56s907xp3jzxc7r88njlmxg07gl6i35mmcmi"))))
203 (build-system meson-build-system)
204 (arguments
205 `(#:glib-or-gtk? #t
206 #:tests? #f ;the "Validate appstream file" test fails
207 #:phases
208 (modify-phases %standard-phases
209 (add-after 'wrap 'wrap-libs
210 (lambda* (#:key outputs #:allow-other-keys)
211 (let* ((out (assoc-ref outputs "out"))
212 (gi-typelib-path (getenv "GI_TYPELIB_PATH"))
213 (gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH"))
214 (python-path (getenv "GUIX_PYTHONPATH")))
215 (wrap-program (string-append out "/bin/blanket")
216 `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))
217 `("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path))
218 `("GUIX_PYTHONPATH" ":" prefix (,python-path))))
219 #t)))))
220 (native-inputs
221 `(("desktop-file-utils" ,desktop-file-utils)
222 ("gettext" ,gettext-minimal)
223 ("glib:bin" ,glib "bin")
224 ("gobject-introspection" ,gobject-introspection)
225 ("gtk+:bin" ,gtk+ "bin")
226 ("pkg-config" ,pkg-config)))
227 (inputs
228 `(("appstream-glib" ,appstream-glib)
229 ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
230 ("gst-plugins-bad" ,gst-plugins-bad)
231 ("gst-plugins-good" ,gst-plugins-good) ;for ScaleTempo plugin
232 ("gtk+" ,gtk+)
233 ("libhandy" ,libhandy)
234 ("python-gst" ,python-gst)
235 ("python-pygobject" ,python-pygobject)))
236 (home-page "https://github.com/rafaelmardojai/blanket")
237 (synopsis "Ambient sound and noise player")
238 (description
239 "Blanket provides different ambient sounds and types of noise to listen
240 to with the goal of improving your focus and enhancing your productivity.
241 You can also use it to fall asleep in a noisy environment.")
242 (license license:gpl3+)))