Merge branch 'master' into core-updates-frozen
[jackhill/guix/guix.git] / gnu / packages / patchutils.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014, 2018 Eric Bavier <bavier@member.fsf.org>
3 ;;; Copyright © 2015, 2018 Leo Famulari <leo@famulari.name>
4 ;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;; Copyright © 2019 Christopher Baines <mail@cbaines.net>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages patchutils)
23 #:use-module (guix utils)
24 #:use-module (guix packages)
25 #:use-module (guix licenses)
26 #:use-module (guix download)
27 #:use-module (guix git-download)
28 #:use-module (guix build-system gnu)
29 #:use-module (guix build-system python)
30 #:use-module (gnu packages)
31 #:use-module (gnu packages ed)
32 #:use-module (gnu packages base)
33 #:use-module (gnu packages bash)
34 #:use-module (gnu packages check)
35 #:use-module (gnu packages databases)
36 #:use-module (gnu packages django)
37 #:use-module (gnu packages file)
38 #:use-module (gnu packages gawk)
39 #:use-module (gnu packages gettext)
40 #:use-module (gnu packages glib)
41 #:use-module (gnu packages gnome)
42 #:use-module (gnu packages gtk)
43 #:use-module (gnu packages less)
44 #:use-module (gnu packages mail)
45 #:use-module (gnu packages ncurses)
46 #:use-module (gnu packages perl)
47 #:use-module (gnu packages python)
48 #:use-module (gnu packages python-xyz)
49 #:use-module (gnu packages version-control)
50 #:use-module (gnu packages xml))
51
52 (define-public patchutils
53 (package
54 (name "patchutils")
55 (version "0.3.4")
56 (source
57 (origin
58 (method url-fetch)
59 (uri (string-append "http://cyberelk.net/tim/data/patchutils/stable/"
60 name "-" version ".tar.xz"))
61 (sha256
62 (base32
63 "0xp8mcfyi5nmb5a2zi5ibmyshxkb1zv1dgmnyn413m7ahgdx8mfg"))
64 (patches (search-patches "patchutils-test-perms.patch"))))
65 (build-system gnu-build-system)
66 (inputs `(("perl" ,perl)))
67 (arguments
68 '(#:parallel-tests? #f
69 #:phases
70 (modify-phases %standard-phases
71 (add-before 'check 'patch-test-scripts
72 (lambda _
73 (substitute* (find-files "tests" "^run-test$")
74 (("/bin/echo") (which "echo")))
75 #t))
76 (add-after 'install 'wrap-program
77 ;; Point installed scripts to the utilities they need.
78 (lambda* (#:key inputs outputs #:allow-other-keys)
79 (let* ((out (assoc-ref outputs "out"))
80 (diffutils (assoc-ref inputs "diffutils"))
81 (sed (assoc-ref inputs "sed"))
82 (gawk (assoc-ref inputs "gawk")))
83 (for-each
84 (lambda (prog)
85 (wrap-program (string-append out "/bin/" prog)
86 `("PATH" ":" prefix
87 ,(map (lambda (dir)
88 (string-append dir "/bin"))
89 (list diffutils sed gawk)))))
90 '("dehtmldiff" "editdiff" "espdiff")))
91 #t)))))
92 (home-page "http://cyberelk.net/tim/software/patchutils")
93 (synopsis "Collection of tools for manipulating patch files")
94 (description
95 "Patchutils is a collection of programs that can manipulate patch files
96 in useful ways such as interpolating between two pre-patches, combining two
97 incremental patches, fixing line numbers in hand-edited patches, and simply
98 listing the files modified by a patch.")
99 (license gpl2+)))
100
101 (define-public quilt
102 (package
103 (name "quilt")
104 (version "0.66")
105 (source
106 (origin
107 (method url-fetch)
108 (uri (string-append "mirror://savannah/quilt/"
109 "quilt-" version ".tar.gz"))
110 (sha256
111 (base32 "01vfvk4pqigahx82fhaaffg921ivd3k7rylz1yfvy4zbdyd32jri"))))
112 (build-system gnu-build-system)
113 (native-inputs
114 `(("gettext" ,gettext-minimal)))
115 (inputs `(("perl" ,perl)
116 ("less" ,less)
117 ("file" ,file)
118 ("ed" ,ed)
119 ("diffstat" ,diffstat)))
120 (arguments
121 '(#:parallel-tests? #f
122 #:phases
123 (modify-phases %standard-phases
124 (add-before 'check 'patch-tests
125 (lambda _
126 (substitute*
127 '("test/run"
128 "test/edit.test")
129 (("/bin/sh") (which "sh")))
130 #t))
131 (add-after 'install 'wrap-program
132 ;; quilt's configure checks for the absolute path to the utilities it
133 ;; needs, but uses only the name when invoking them, so we need to
134 ;; make sure the quilt script can find those utilities when run.
135 (lambda* (#:key inputs outputs #:allow-other-keys)
136 (let* ((out (assoc-ref outputs "out"))
137 (coreutils (assoc-ref inputs "coreutils"))
138 (diffutils (assoc-ref inputs "diffutils"))
139 (findutils (assoc-ref inputs "findutils"))
140 (diffstat (assoc-ref inputs "diffstat"))
141 (less (assoc-ref inputs "less"))
142 (file (assoc-ref inputs "file"))
143 (ed (assoc-ref inputs "ed"))
144 (sed (assoc-ref inputs "sed"))
145 (bash (assoc-ref inputs "bash"))
146 (grep (assoc-ref inputs "grep")))
147 (wrap-program (string-append out "/bin/quilt")
148 `("PATH" ":" prefix
149 ,(map (lambda (dir)
150 (string-append dir "/bin"))
151 (list coreutils diffutils findutils
152 less file ed sed bash grep
153 diffstat)))))
154 #t)))))
155 (home-page "https://savannah.nongnu.org/projects/quilt/")
156 (synopsis "Script for managing patches to software")
157 (description
158 "Quilt allows you to easily manage large numbers of patches by keeping
159 track of the changes each patch makes. Patches can be applied, un-applied,
160 refreshed, and more.")
161 (license gpl2)))
162
163 (define-public colordiff
164 (package
165 (name "colordiff")
166 (version "1.0.19")
167 (source
168 (origin
169 (method url-fetch)
170 (uri (list (string-append "https://www.colordiff.org/colordiff-"
171 version ".tar.gz")
172 (string-append "http://www.colordiff.org/archive/colordiff-"
173 version ".tar.gz")))
174 (sha256
175 (base32 "069vzzgs7b44bmfh3ks2psrdb26s1w19gp9w4xxbgi7nhx6w3s26"))))
176 (build-system gnu-build-system)
177 (arguments
178 `(#:tests? #f ; no tests
179 #:make-flags (list (string-append "DESTDIR=" (assoc-ref %outputs "out"))
180 "INSTALL_DIR=/bin" "MAN_DIR=/share/man/man1")
181 #:phases
182 (modify-phases %standard-phases
183 (delete 'configure) ; no configure script
184 (delete 'build)))) ; nothing to build
185 (inputs
186 `(("perl" ,perl)
187 ("xmlto" ,xmlto)))
188 (home-page "https://www.colordiff.org")
189 (synopsis "Display diff output with colors")
190 (description
191 "Colordiff is Perl script wrapper on top of diff command which provides
192 'syntax highlighting' for various patch formats.")
193 (license gpl2+)))
194
195 (define-public patches
196 (let ((commit "ef1b8a7d954b82ed4af3a08fd63d2085d19090ef"))
197 (package
198 (name "patches")
199 (home-page "https://github.com/stefanha/patches")
200 (version (string-append "0.0-1." (string-take commit 7)))
201 (source (origin
202 (method git-fetch)
203 (uri (git-reference
204 (url home-page)
205 (commit commit)))
206 (sha256
207 (base32
208 "11rdmhv0l1s8nqb20ywmw2zqizczch2p62qf9apyx5wqgxlnjshk"))
209 (file-name (string-append name "-"version "-checkout"))))
210 (build-system python-build-system)
211 (inputs `(("python-notmuch" ,python2-notmuch)))
212 (arguments
213 `(#:tests? #f ;no "test" target
214 #:python ,python-2)) ;not compatible with Python 3
215 (synopsis "Patch tracking tool")
216 (description
217 "@code{Patches} is a patch-tracking tool initially written for the QEMU
218 project. It provides commands that build a database of patches from a mailing
219 list, and commands that can search that database. It allows users to track
220 the status of a patch, apply patches, and search for patches---all that from
221 the command-line or from Emacs via its Notmuch integration.")
222 (license gpl2+))))
223
224 (define-public vbindiff
225 (package
226 (name "vbindiff")
227 (version "3.0_beta5")
228 (source (origin
229 (method url-fetch)
230 (uri (string-append "https://www.cjmweb.net/vbindiff/vbindiff-"
231 version ".tar.gz"))
232 (sha256
233 (base32
234 "1f1kj4jki08bnrwpzi663mjfkrx4wnfpzdfwd2qgijlkx5ysjkgh"))))
235 (build-system gnu-build-system)
236 (inputs
237 `(("ncurses" ,ncurses)))
238 (home-page "https://www.cjmweb.net/vbindiff/")
239 (synopsis "Console-based tool for comparing binary data")
240 (description "Visual Binary Diff (@command{vbindiff}) displays files in
241 hexadecimal and ASCII (or EBCDIC). It can also display two files at once, and
242 highlight the differences between them. It works well with large files (up to 4
243 GiB).")
244 (license gpl2+)))
245
246 (define-public meld
247 (package
248 (name "meld")
249 (version "3.20.4")
250 (source
251 (origin
252 (method url-fetch)
253 (uri (string-append "mirror://gnome/sources/meld/"
254 (version-major+minor version)
255 "/meld-" version ".tar.xz"))
256 (sha256
257 (base32 "04vx2mdbcdin0g3w8x910czfch5vyrl8drv1f2l8gxh6qvp113pl"))))
258 (build-system python-build-system)
259 (native-inputs
260 `(("intltool" ,intltool)
261 ("xmllint" ,libxml2)
262 ("glib-compile-schemas" ,glib "bin")
263 ("python-pytest" ,python-pytest)))
264 (inputs
265 `(("python-cairo" ,python-pycairo)
266 ("python-gobject" ,python-pygobject)
267 ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
268 ("gtksourceview" ,gtksourceview-3)))
269 (propagated-inputs
270 `(("dconf" ,dconf)))
271 (arguments
272 `(#:imported-modules ((guix build glib-or-gtk-build-system)
273 ,@%python-build-system-modules)
274 #:modules ((guix build python-build-system)
275 ((guix build glib-or-gtk-build-system) #:prefix glib-or-gtk:)
276 (guix build utils))
277 #:phases
278 (modify-phases %standard-phases
279 ;; This setup.py script does not support one of the Python build
280 ;; system's default flags, "--single-version-externally-managed".
281 (replace 'install
282 (lambda* (#:key outputs #:allow-other-keys)
283 (invoke "python" "setup.py"
284 ;; This setup.py runs gtk-update-icon-cache which we don't want.
285 "--no-update-icon-cache"
286 ;; "--no-compile-schemas"
287 "install"
288 (string-append "--prefix=" (assoc-ref outputs "out"))
289 "--root=/")))
290 ;; The tests need to be run after installation.
291 (delete 'check)
292 (add-after 'install 'check
293 (lambda* (#:key inputs outputs #:allow-other-keys)
294 ;; Tests look for installed package
295 (add-installed-pythonpath inputs outputs)
296 ;; The tests fail when HOME=/homeless-shelter.
297 (setenv "HOME" "/tmp")
298 (invoke "py.test" "-v" "-k"
299 ;; TODO: Those tests fail, why?
300 "not test_classify_change_actions")))
301 (add-after 'install 'copy-styles
302 (lambda* (#:key inputs outputs #:allow-other-keys)
303 (let ((styles "/share/gtksourceview-3.0/styles"))
304 (copy-recursively
305 (string-append (assoc-ref inputs "gtksourceview") styles)
306 (string-append (assoc-ref outputs "out") styles))
307 #t)))
308 (add-after 'wrap 'glib-or-gtk-wrap
309 (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap))
310 (add-after 'wrap 'wrap-typelib
311 (lambda* (#:key inputs outputs #:allow-other-keys)
312 (let ((out (assoc-ref outputs "out")))
313 (wrap-program (string-append out "/bin/meld")
314 `("GI_TYPELIB_PATH" prefix
315 ,(search-path-as-string->list (getenv "GI_TYPELIB_PATH"))))
316 #t))))))
317 (home-page "https://meldmerge.org/")
318 (synopsis "Compare files, directories and working copies")
319 (description "Meld is a visual diff and merge tool targeted at
320 developers. Meld helps you compare files, directories, and version controlled
321 projects. It provides two- and three-way comparison of both files and
322 directories, and has support for many popular version control systems.
323
324 Meld helps you review code changes and understand patches. It might even help
325 you to figure out what is going on in that merge you keep avoiding.")
326 (license gpl2)))
327
328 (define-public patchwork
329 (package
330 (name "patchwork")
331 (version "3.0.1")
332 (source (origin
333 (method git-fetch)
334 (uri (git-reference
335 (url "https://github.com/getpatchwork/patchwork")
336 (commit (string-append "v" version))))
337 (file-name (git-file-name name version))
338 (sha256
339 (base32
340 "049ih1fbbbmj11v5m9ilahifl8x7gi6wyba58552y9n9djzs8csc"))))
341 (build-system python-build-system)
342 (arguments
343 `(;; TODO: Tests require a running database
344 #:tests? #f
345 #:phases
346 (modify-phases %standard-phases
347 (delete 'configure)
348 (delete 'build)
349 (add-after 'unpack 'replace-wsgi.py
350 (lambda* (#:key inputs outputs #:allow-other-keys)
351 (delete-file "patchwork/wsgi.py")
352 (call-with-output-file "patchwork/wsgi.py"
353 (lambda (port)
354 ;; Embed the PYTHONPATH containing the dependencies, as well
355 ;; as the python modules in this package in the wsgi.py file,
356 ;; as this will ensure they are available at runtime.
357 (define pythonpath
358 (string-append (getenv "GUIX_PYTHONPATH")
359 ":"
360 (site-packages inputs outputs)))
361 (display
362 (string-append "
363 import os, sys
364
365 sys.path.extend('" pythonpath "'.split(':'))
366
367 from django.core.wsgi import get_wsgi_application
368
369 # By default, assume that patchwork is running as a Guix service, which
370 # provides the settings as the 'guix.patchwork.settings' Python module.
371 #
372 # When using httpd, it's hard to set environment variables, so rely on the
373 # default set here.
374 os.environ['DJANGO_SETTINGS_MODULE'] = os.getenv(
375 'DJANGO_SETTINGS_MODULE',
376 'guix.patchwork.settings' # default
377 )
378
379 application = get_wsgi_application()\n") port)))))
380 (replace 'check
381 (lambda* (#:key tests? #:allow-other-keys)
382 (when tests?
383 (setenv "DJANGO_SETTINGS_MODULE" "patchwork.settings.dev")
384 (invoke "python" "-Wonce" "./manage.py" "test" "--noinput"))
385 #t))
386 (replace 'install
387 (lambda* (#:key inputs outputs #:allow-other-keys)
388 (let ((out (assoc-ref outputs "out"))
389 (out-site-packages (site-packages inputs outputs)))
390 (for-each (lambda (directory)
391 (copy-recursively
392 directory
393 (string-append out-site-packages directory)))
394 '(;; Contains the python code
395 "patchwork"
396 ;; Contains the templates for the generated HTML
397 "templates"))
398 (delete-file-recursively
399 (string-append out-site-packages "patchwork/tests"))
400
401 ;; Install patchwork related tools
402 (for-each (lambda (file)
403 (install-file file (string-append out "/bin")))
404 (list
405 (string-append out-site-packages
406 "patchwork/bin/parsemail.sh")
407 (string-append out-site-packages
408 "patchwork/bin/parsemail-batch.sh")))
409
410 ;; Collect the static assets, this includes JavaScript, CSS and
411 ;; fonts. This is a standard Django process when running a
412 ;; Django application for regular use, and includes assets for
413 ;; dependencies like the admin site from Django.
414 ;;
415 ;; The intent here is that you can serve files from this
416 ;; directory through a webserver, which is recommended when
417 ;; running Django applications.
418 (let ((static-root
419 (string-append out "/share/patchwork/htdocs")))
420 (mkdir-p static-root)
421 (copy-file "patchwork/settings/production.example.py"
422 "patchwork/settings/assets.py")
423 (setenv "DJANGO_SECRET_KEY" "dummyvalue")
424 (setenv "DJANGO_SETTINGS_MODULE" "patchwork.settings.assets")
425 (setenv "STATIC_ROOT" static-root)
426 (invoke "./manage.py" "collectstatic" "--no-input"))
427
428 ;; The lib directory includes example configuration files that
429 ;; may be useful when deploying patchwork.
430 (copy-recursively "lib"
431 (string-append
432 out "/share/doc/" ,name "-" ,version)))
433 #t))
434 ;; The hasher script is used from the post-receive.hook
435 (add-after 'install 'install-hasher
436 (lambda* (#:key inputs outputs #:allow-other-keys)
437 (let* ((out (assoc-ref outputs "out"))
438 (out-site-packages (site-packages inputs outputs))
439 (out-hasher.py (string-append out-site-packages
440 "/patchwork/hasher.py")))
441 (chmod out-hasher.py #o555)
442 (symlink out-hasher.py (string-append out "/bin/hasher")))
443 #t))
444 ;; Create a patchwork specific version of Django's command line admin
445 ;; utility.
446 (add-after 'install 'install-patchwork-admin
447 (lambda* (#:key inputs outputs #:allow-other-keys)
448 (let* ((out (assoc-ref outputs "out")))
449 (mkdir-p (string-append out "/bin"))
450 (call-with-output-file (string-append out "/bin/patchwork-admin")
451 (lambda (port)
452 (simple-format port "#!~A
453 import os, sys
454
455 if __name__ == \"__main__\":
456 from django.core.management import execute_from_command_line
457
458 execute_from_command_line(sys.argv)" (which "python"))))
459 (chmod (string-append out "/bin/patchwork-admin") #o555))
460 #t)))))
461 (inputs
462 `(("python-wrapper" ,python-wrapper)))
463 (propagated-inputs
464 `(("python-django" ,python-django-2.2)
465 ;; TODO: Make this configurable
466 ("python-psycopg2" ,python-psycopg2)
467 ("python-mysqlclient" ,python-mysqlclient)
468 ("python-django-filter" ,python-django-filter)
469 ("python-djangorestframework" ,python-djangorestframework)
470 ("python-django-debug-toolbar" ,python-django-debug-toolbar)))
471 (synopsis "Web based patch tracking system")
472 (description
473 "Patchwork is a patch tracking system. It takes in emails containing
474 patches, and displays the patches along with comments and state information.
475 Users can login allowing them to change the state of patches.")
476 (home-page "http://jk.ozlabs.org/projects/patchwork/")
477 (license gpl2+)))
478
479 (define-public pwclient
480 (package
481 (name "pwclient")
482 (version "1.3.0")
483 (source (origin
484 (method git-fetch)
485 (uri (git-reference
486 (url "https://github.com/getpatchwork/pwclient")
487 (commit version)))
488 (file-name (git-file-name name version))
489 (sha256
490 (base32
491 "1xckwvcqklzpyh3xs4k2zm40ifp0q5fdkj2vmgb8vhfvl1ivs6jv"))))
492 (build-system python-build-system)
493 (arguments
494 `(#:phases
495 (modify-phases %standard-phases
496 (add-after 'unpack 'patch-requirements
497 (lambda _
498 (substitute* "test-requirements.txt"
499 ;; The pytest requirement is unnecessarily strict
500 (("pytest>=3.0,<5.0;")
501 "pytest>=3.0,<6.0;"))
502 #t))
503 (add-before 'build 'set-PBR_VERSION
504 (lambda _
505 (setenv "PBR_VERSION"
506 ,version)
507 #t))
508 (replace 'check
509 (lambda* (#:key tests? #:allow-other-keys)
510 (when tests?
511 (invoke "pytest"))
512 #t))
513 (add-after 'install 'install-man-page
514 (lambda* (#:key outputs #:allow-other-keys)
515 (install-file "man/pwclient.1"
516 (string-append
517 (assoc-ref outputs "out")
518 "/share/man/man1"))
519 #t)))))
520 (native-inputs
521 `(("python-pbr" ,python-pbr)
522 ("python-pytest" ,python-pytest)
523 ("python-pytest-cov" ,python-pytest-cov)
524 ("python-mock" ,python-mock)))
525 (home-page
526 "https://github.com/getpatchwork/pwclient")
527 (synopsis "Command-line client for the Patchwork patch tracking tool")
528 (description
529 "pwclient is a VCS-agnostic tool for interacting with Patchwork, the
530 web-based patch tracking system.")
531 (license gpl2+)))