gnu: guix: Update to 0.10.0.
[jackhill/guix/guix.git] / gnu / packages / suckless.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
3 ;;; Copyright © 2015 Amirouche Boubekki <amirouche@hypermove.net>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages suckless)
21 #:use-module ((guix licenses) #:prefix license:)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages xorg)
27 #:use-module (gnu packages fonts)
28 #:use-module (gnu packages pkg-config)
29 #:use-module (gnu packages fontutils))
30
31 (define-public dwm
32 (package
33 (name "dwm")
34 (version "6.0")
35 (source (origin
36 (method url-fetch)
37 (uri (string-append "http://dl.suckless.org/dwm/dwm-"
38 version ".tar.gz"))
39 (sha256
40 (base32 "0mpbivy9j80l1jqq4bd4g4z8s5c54fxrjj44avmfwncjwqylifdj"))))
41 (build-system gnu-build-system)
42 (arguments
43 `(#:tests? #f
44 #:phases
45 (alist-replace
46 'configure
47 (lambda _
48 (substitute* "Makefile" (("\\$\\{CC\\}") "gcc"))
49 #t)
50 (alist-replace
51 'install
52 (lambda* (#:key outputs #:allow-other-keys)
53 (let ((out (assoc-ref outputs "out")))
54 (zero?
55 (system* "make" "install"
56 (string-append "DESTDIR=" out) "PREFIX="))))
57 %standard-phases))))
58 (inputs
59 `(("libx11" ,libx11)
60 ("libxinerama" ,libxinerama)))
61 (home-page "http://dwm.suckless.org/")
62 (synopsis "Dynamic window manager")
63 (description
64 "dwm is a dynamic window manager for X. It manages windows in tiled,
65 monocle and floating layouts. All of the layouts can be applied dynamically,
66 optimising the environment for the application in use and the task performed.
67
68 In tiled layout windows are managed in a master and stacking area. The master
69 area contains the window which currently needs most attention, whereas the
70 stacking area contains all other windows. In monocle layout all windows are
71 maximised to the screen size. In floating layout windows can be resized and
72 moved freely. Dialog windows are always managed floating, regardless of the
73 layout applied.
74
75 Windows are grouped by tags. Each window can be tagged with one or multiple
76 tags. Selecting certain tags displays all windows with these tags.
77
78 Each screen contains a small status bar which displays all available tags, the
79 layout, the number of visible windows, the title of the focused window, and the
80 text read from the root window name property, if the screen is focused. A
81 floating window is indicated with an empty square and a maximised floating
82 window is indicated with a filled square before the windows title. The selected
83 tags are indicated with a different color. The tags of the focused window are
84 indicated with a filled square in the top left corner. The tags which are
85 applied to one or more windows are indicated with an empty square in the top
86 left corner.
87
88 dwm draws a small customizable border around windows to indicate the focus
89 state.")
90 (license license:x11)))
91
92 (define-public dmenu
93 (package
94 (name "dmenu")
95 (version "4.5")
96 (source (origin
97 (method url-fetch)
98 (uri (string-append "http://dl.suckless.org/tools/dmenu-"
99 version ".tar.gz"))
100 (sha256
101 (base32
102 "0l58jpxrr80fmyw5pgw5alm5qry49aw6y049745wl991v2cdcb08"))))
103 (build-system gnu-build-system)
104 (arguments
105 '(#:tests? #f ; no tests
106 #:make-flags (list "CC=gcc"
107 (string-append "PREFIX=" %output))
108 #:phases
109 (alist-delete 'configure %standard-phases)))
110 (inputs
111 `(("libx11" ,libx11)
112 ("libxinerama" ,libxinerama)))
113 (home-page "http://tools.suckless.org/dmenu/")
114 (synopsis "Dynamic menu")
115 (description
116 "A dynamic menu for X, originally designed for dwm. It manages large
117 numbers of user-defined menu items efficiently.")
118 (license license:x11)))
119
120 (define-public slock
121 (package
122 (name "slock")
123 (version "1.2")
124 (source (origin
125 (method url-fetch)
126 (uri (string-append "http://dl.suckless.org/tools/slock-"
127 version ".tar.gz"))
128 (sha256
129 (base32
130 "1crkyr4vblhciy6vnbjwwjnlkm9yg2hzq16v6hzxm20ai67na0il"))))
131 (build-system gnu-build-system)
132 (arguments
133 '(#:tests? #f ; no tests
134 #:make-flags (list "CC=gcc"
135 (string-append "PREFIX=" %output))
136 #:phases (alist-delete 'configure %standard-phases)))
137 (inputs
138 `(("libx11" ,libx11)
139 ("libxext" ,libxext)
140 ("libxinerama" ,libxinerama)))
141 (home-page "http://tools.suckless.org/slock/")
142 (synopsis "Simple X session lock")
143 (description
144 "Simple X session lock with trivial feedback on password entry.")
145 (license license:x11)))
146
147 (define-public st
148 (package
149 (name "st")
150 (version "0.5")
151 (source
152 (origin
153 (method url-fetch)
154 (uri (string-append "http://dl.suckless.org/st/st-"
155 version ".tar.gz"))
156 (sha256
157 (base32
158 "0knxpzaa86pprng6hak8hx8bw22yw22rpz1ffxjpcvqlz3xdv05f"))))
159 (build-system gnu-build-system)
160 (arguments
161 '(#:tests? #f ; no tests
162 #:make-flags (list "CC=gcc"
163 (string-append "PREFIX=" %output))
164 #:phases
165 (modify-phases %standard-phases
166 (delete 'configure)
167 (add-after 'unpack 'inhibit-terminfo-install
168 (lambda _
169 (substitute* "Makefile"
170 (("\t@tic -s st.info") ""))
171 #t)))))
172 (inputs
173 `(("libx11" ,libx11)
174 ("libxft" ,libxft)
175 ("libxcomposite" ,libxcomposite)
176 ("compositeproto" ,compositeproto)
177 ("libxext" ,libxext)
178 ("xextproto" ,xextproto)
179 ("libxrender" ,libxrender)
180 ("fontconfig" ,fontconfig)
181 ("freetype" ,freetype)
182 ("font-liberation" ,font-liberation)))
183 (native-inputs `(("pkg-config" ,pkg-config)))
184 (home-page "http://st.suckless.org/")
185 (synopsis "Simple terminal emulator")
186 (description
187 "St implements a simple and lightweight terminal emulator. It
188 implements 256 colors, most VT10X escape sequences, utf8, X11 copy/paste,
189 antialiased fonts (using fontconfig), fallback fonts, resizing, and line
190 drawing.")
191 (license license:x11)))