gnu: guix: Update to 0.10.0.
[jackhill/guix/guix.git] / gnu / packages / smalltalk.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages smalltalk)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages zip))
25
26 (define-public smalltalk
27 (package
28 (name "smalltalk")
29 (version "3.2.5")
30 (source
31 (origin
32 (method url-fetch)
33 (uri (string-append "mirror://gnu/smalltalk/smalltalk-"
34 version ".tar.xz"))
35 (sha256
36 (base32
37 "1k2ssrapfzhngc7bg1zrnd9n2vyxp9c9m70byvsma6wapbvib6l1"))))
38 (build-system gnu-build-system)
39 (inputs `(("zip" ,zip)))
40 (arguments
41 `(#:phases (alist-cons-before
42 'configure 'fix-libc
43 (lambda _
44 (let ((libc (assoc-ref %build-inputs "libc")))
45 (substitute* "libc.la.in"
46 (("@LIBC_SO_NAME@") "libc.so")
47 (("@LIBC_SO_DIR@") (string-append libc "/lib")))))
48 %standard-phases)))
49 (home-page "https://www.gnu.org/software/smalltalk/")
50 (synopsis "Smalltalk environment")
51 (description
52 "GNU Smalltalk is a free implementation of the Smalltalk language. It
53 implements the ANSI standard for the language and also includes extra classes
54 such as ones for networking and GUI programming.")
55 (license gpl2+)))