gnu: guix: Update to 0.10.0.
[jackhill/guix/guix.git] / gnu / packages / fonts.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2014 Joshua Grant <tadni@riseup.net>
5 ;;; Copyright © 2014 Alex Kost <alezost@gmail.com>
6 ;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
7 ;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
8 ;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
9 ;;; Copyright © 2016 Nils Gillmann <niasterisk@grrlz.net>
10 ;;; Copyright © 2016 Jookia <166291@gmail.com>
11 ;;;
12 ;;; This file is part of GNU Guix.
13 ;;;
14 ;;; GNU Guix is free software; you can redistribute it and/or modify it
15 ;;; under the terms of the GNU General Public License as published by
16 ;;; the Free Software Foundation; either version 3 of the License, or (at
17 ;;; your option) any later version.
18 ;;;
19 ;;; GNU Guix is distributed in the hope that it will be useful, but
20 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
21 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
22 ;;; GNU General Public License for more details.
23 ;;;
24 ;;; You should have received a copy of the GNU General Public License
25 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
26
27 (define-module (gnu packages fonts)
28 #:use-module (guix utils)
29 #:use-module ((guix licenses) #:prefix license:)
30 #:use-module (guix packages)
31 #:use-module (guix download)
32 #:use-module (guix build-system gnu)
33 #:use-module (guix build-system trivial)
34 #:use-module (gnu packages base)
35 #:use-module (gnu packages compression)
36 #:use-module (gnu packages zip)
37 #:use-module (gnu packages perl)
38 #:use-module (gnu packages xorg)
39 #:use-module (gnu packages pkg-config))
40
41 (define-public font-inconsolata
42 (package
43 (name "font-inconsolata")
44 (version "0.80")
45 (source (origin
46 (method url-fetch)
47 (uri "http://www.levien.com/type/myfonts/Inconsolata.otf")
48 (sha256
49 (base32
50 "06js6znbcf7swn8y3b8ki416bz96ay7d3yvddqnvi88lqhbfcq8m"))))
51 (build-system trivial-build-system)
52 (arguments
53 `(#:modules ((guix build utils))
54 #:builder (begin
55 (use-modules (guix build utils))
56 (let ((font-dir (string-append %output
57 "/share/fonts/opentype"))
58 (source (assoc-ref %build-inputs "source")))
59 (mkdir-p font-dir)
60 (copy-file source
61 (string-append font-dir "/" "inconsolata.otf"))))))
62 (native-inputs `(("source" ,source)))
63 (home-page "http://levien.com/type/myfonts/inconsolata.html")
64 (synopsis "Monospace font")
65 (description "A monospace font, designed for code listings and the like,
66 in print. With attention to detail for high resolution rendering.")
67 (license license:silofl1.1)))
68
69 (define-public font-ubuntu
70 (package
71 (name "font-ubuntu")
72 (version "0.83")
73 (source (origin
74 (method url-fetch)
75 (uri (string-append
76 "http://font.ubuntu.com/download/ubuntu-font-family-"
77 version ".zip"))
78 (sha256
79 (base32
80 "0hjvq2x758dx0sfwqhzflns0ns035qm7h6ygskbx1svzg517sva5"))))
81 (build-system trivial-build-system)
82 (arguments
83 `(#:modules ((guix build utils))
84 #:builder (begin
85 (use-modules (guix build utils)
86 (srfi srfi-26))
87
88 (let ((PATH (string-append (assoc-ref %build-inputs
89 "unzip")
90 "/bin"))
91 (font-dir (string-append %output
92 "/share/fonts/truetype"))
93 (doc-dir (string-append %output "/share/doc/"
94 ,name "-" ,version)))
95 (setenv "PATH" PATH)
96 (system* "unzip" (assoc-ref %build-inputs "source"))
97
98 (mkdir-p font-dir)
99 (mkdir-p doc-dir)
100 (chdir (string-append "ubuntu-font-family-" ,version))
101 (for-each (lambda (ttf)
102 (copy-file ttf
103 (string-append font-dir "/" ttf)))
104 (find-files "." "\\.ttf$"))
105 (for-each (lambda (doc)
106 (copy-file doc
107 (string-append doc-dir "/" doc)))
108 (find-files "." "\\.txt$"))))))
109 (native-inputs `(("source" ,source)
110 ("unzip" ,unzip)))
111 (home-page "http://font.ubuntu.com/")
112 (synopsis "The Ubuntu Font Family")
113 (description "The Ubuntu Font Family is a unique, custom designed font
114 that has a very distinctive look and feel. This package provides the
115 TrueType (TTF) files.")
116 (license
117 (license:non-copyleft
118 "http://font.ubuntu.com/ufl/ubuntu-font-licence-1.0.txt"
119 "Ubuntu Font License v1.0"))))
120
121 (define-public font-dejavu
122 (package
123 (name "font-dejavu")
124 (version "2.34")
125 (source (origin
126 (method url-fetch)
127 (uri (string-append "mirror://sourceforge/dejavu/"
128 version "/dejavu-fonts-ttf-"
129 version ".tar.bz2"))
130 (sha256
131 (base32
132 "0pgb0a3ngamidacmrvasg51ck3gp8gn93w6sf1s8snwzx4x2r9yh"))))
133 (build-system trivial-build-system)
134 (arguments
135 `(#:modules ((guix build utils))
136 #:builder (begin
137 (use-modules (guix build utils))
138
139 (let ((tar (string-append (assoc-ref %build-inputs
140 "tar")
141 "/bin/tar"))
142 (PATH (string-append (assoc-ref %build-inputs
143 "bzip2")
144 "/bin"))
145 (font-dir (string-append
146 %output "/share/fonts/truetype"))
147 (conf-dir (string-append
148 %output "/share/fontconfig/conf.avail"))
149 (doc-dir (string-append
150 %output "/share/doc/" ,name "-" ,version)))
151 (setenv "PATH" PATH)
152 (system* tar "xvf" (assoc-ref %build-inputs "source"))
153
154 (mkdir-p font-dir)
155 (mkdir-p conf-dir)
156 (mkdir-p doc-dir)
157 (chdir (string-append "dejavu-fonts-ttf-" ,version))
158 (for-each (lambda (ttf)
159 (copy-file ttf
160 (string-append font-dir "/"
161 (basename ttf))))
162 (find-files "ttf" "\\.ttf$"))
163 (for-each (lambda (conf)
164 (copy-file conf
165 (string-append conf-dir "/"
166 (basename conf))))
167 (find-files "fontconfig" "\\.conf$"))
168 (for-each (lambda (doc)
169 (copy-file doc
170 (string-append doc-dir "/"
171 (basename doc))))
172 (find-files "." "\\.txt$|^[A-Z][A-Z]*$"))))))
173 (native-inputs `(("source" ,source)
174 ("tar" ,tar)
175 ("bzip2" ,bzip2)))
176 (home-page "http://dejavu-fonts.org/")
177 (synopsis "Vera font family derivate with additional characters")
178 (description "DejaVu provides an expanded version of the Vera font family
179 aiming for quality and broader Unicode coverage while retaining the original
180 Vera style. DejaVu currently works towards conformance with the Multilingual
181 European Standards (MES-1 and MES-2) for Unicode coverage. The DejaVu fonts
182 provide serif, sans and monospaced variants.")
183 (license
184 (license:x11-style
185 "http://dejavu-fonts.org/"))))
186
187 (define-public font-bitstream-vera
188 (package
189 (name "font-bitstream-vera")
190 (version "1.10")
191 (source (origin
192 (method url-fetch)
193 (uri (string-append "mirror://gnome/sources/ttf-bitstream-vera/"
194 version "/ttf-bitstream-vera-"
195 version ".tar.bz2"))
196 (sha256
197 (base32
198 "1p3qs51x5327gnk71yq8cvmxc6wgx79sqxfvxcv80cdvgggjfnyv"))))
199 (build-system trivial-build-system)
200 (arguments
201 `(#:modules ((guix build utils))
202 #:builder (begin
203 (use-modules (guix build utils)
204 (srfi srfi-26))
205
206 (let ((tar (string-append (assoc-ref %build-inputs
207 "tar")
208 "/bin/tar"))
209 (PATH (string-append (assoc-ref %build-inputs
210 "bzip2")
211 "/bin"))
212 (font-dir (string-append %output
213 "/share/fonts/truetype"))
214 (doc-dir (string-append %output "/share/doc/"
215 ,name "-" ,version)))
216 (setenv "PATH" PATH)
217 (system* tar "xvf" (assoc-ref %build-inputs "source"))
218
219 (mkdir-p font-dir)
220 (mkdir-p doc-dir)
221 (chdir (string-append "ttf-bitstream-vera-" ,version))
222 (for-each (lambda (ttf)
223 (copy-file ttf
224 (string-append font-dir "/" ttf)))
225 (find-files "." "\\.ttf$"))
226 (for-each (lambda (doc)
227 (copy-file doc
228 (string-append doc-dir "/" doc)))
229 (find-files "." "\\.TXT$"))))))
230 (native-inputs `(("source" ,source)
231 ("tar" ,tar)
232 ("bzip2" ,bzip2)))
233 (home-page "http://www.gnome.org/fonts/")
234 (synopsis "Bitstream Vera sans-serif typeface")
235 (description "Vera is a sans-serif typeface from Bitstream, Inc. This
236 package provides the TrueType (TTF) files.")
237 (license
238 (license:x11-style
239 "http://www.gnome.org/fonts/#Final_Bitstream_Vera_Fonts"))))
240
241 (define-public font-cantarell
242 (package
243 (name "font-abattis-cantarell")
244 (version "0.0.24")
245 (source (origin
246 (method url-fetch)
247 (uri (string-append "mirror://gnome/sources/cantarell-fonts/"
248 (version-major+minor version)
249 "/cantarell-fonts-" version ".tar.xz"))
250 (sha256
251 (base32
252 "0r4jnc2x9yncf40lixjb1pqgpq8rzbi2fz33pshlqzjgx2d69bcw"))))
253 (build-system gnu-build-system)
254 (home-page "https://wiki.gnome.org/Projects/CantarellFonts")
255 (synopsis "Cantarell sans-serif typeface")
256 (description "The Cantarell font family is a contemporary Humanist
257 sans-serif designed for on-screen reading. It is used by GNOME@tie{}3.")
258 (license license:silofl1.1)))
259
260 (define-public font-gnu-freefont-ttf
261 (package
262 (name "font-gnu-freefont-ttf")
263 (version "20100919")
264 (source (origin
265 (method url-fetch)
266 (uri (string-append "mirror://gnu/freefont/freefont-ttf-"
267 version ".tar.gz"))
268 (sha256
269 (base32
270 "1q3h5jp1mbdkinkwxy0lfd0a1q7azlbagraydlzaa2ng82836wg4"))))
271 (build-system trivial-build-system)
272 (arguments
273 `(#:modules ((guix build utils))
274 #:builder (begin
275 (use-modules (guix build utils)
276 (srfi srfi-26))
277
278 (let ((tar (string-append (assoc-ref %build-inputs
279 "tar")
280 "/bin/tar"))
281 (PATH (string-append (assoc-ref %build-inputs
282 "gzip")
283 "/bin"))
284 (font-dir (string-append %output
285 "/share/fonts/truetype"))
286 (doc-dir (string-append %output "/share/doc/"
287 ,name "-" ,version)))
288 (setenv "PATH" PATH)
289 (system* tar "xvf" (assoc-ref %build-inputs "source"))
290
291 (mkdir-p font-dir)
292 (mkdir-p doc-dir)
293 (chdir (string-append "freefont-" ,version))
294 (for-each (lambda (file)
295 (let ((dir (if (string-suffix? "ttf" file)
296 font-dir
297 doc-dir)))
298 (copy-file file
299 (string-append dir "/" file))))
300 (find-files "." ""))))))
301 (native-inputs `(("source" ,source)
302 ("tar" ,tar)
303 ("gzip" ,gzip)))
304 (home-page "http://www.gnu.org/software/freefont/")
305 (synopsis "Unicode-encoded outline fonts")
306 (description
307 "The GNU Freefont project aims to provide a set of free outline
308 (PostScript Type0, TrueType, OpenType...) fonts covering the ISO
309 10646/Unicode UCS (Universal Character Set).")
310 (license license:gpl3+)))
311
312 (define-public font-liberation
313 (package
314 (name "font-liberation")
315 (version "2.00.1")
316 (source (origin
317 (method url-fetch)
318 (uri (string-append "https://fedorahosted.org/releases/l/i/"
319 "liberation-fonts/liberation-fonts-ttf-"
320 version ".tar.gz"))
321 (sha256
322 (base32
323 "010m4zfqan4w04b6bs9pm3gapn9hsb18bmwwgp2p6y6idj52g43q"))))
324 (build-system trivial-build-system)
325 (arguments
326 `(#:modules ((guix build utils))
327 #:builder
328 (begin
329 (use-modules (guix build utils))
330
331 (let ((tar (string-append (assoc-ref %build-inputs "tar")
332 "/bin/tar"))
333 (PATH (string-append (assoc-ref %build-inputs "gzip")
334 "/bin"))
335 (font-dir (string-append %output "/share/fonts/truetype"))
336 (doc-dir (string-append %output "/share/doc/" ,name)))
337 (setenv "PATH" PATH)
338 (system* tar "xvf" (assoc-ref %build-inputs "source"))
339 (mkdir-p font-dir)
340 (mkdir-p doc-dir)
341 (chdir (string-append "liberation-fonts-ttf-" ,version))
342 (for-each (lambda (ttf)
343 (copy-file ttf
344 (string-append font-dir "/"
345 (basename ttf))))
346 (find-files "." "\\.ttf$"))
347 (for-each (lambda (doc)
348 (copy-file doc
349 (string-append doc-dir "/"
350 (basename doc))))
351 '("AUTHORS" "ChangeLog" "LICENSE" "README" "TODO"))))))
352 (native-inputs
353 `(("source" ,source)
354 ("tar" ,tar)
355 ("gzip" ,gzip)))
356 (home-page "https://fedorahosted.org/liberation-fonts/")
357 (synopsis
358 "Fonts compatible with Arial, Times New Roman, and Courier New")
359 (description
360 "The Liberation font family aims at metric compatibility with
361 Arial, Times New Roman, and Courier New.
362
363 There are three sets:
364
365 - Sans (a substitute for Arial, Albany, Helvetica, Nimbus Sans L, and
366 Bitstream Vera Sans);
367
368 - Serif (a substitute for Times New Roman, Thorndale, Nimbus Roman, and
369 Bitstream Vera Serif);
370
371 - Mono (a substitute for Courier New, Cumberland, Courier, Nimbus Mono L,
372 and Bitstream Vera Sans Mono).
373
374 The Liberation Fonts are sponsored by Red Hat.")
375 (license license:silofl1.1)))
376
377 (define-public font-terminus
378 (package
379 (name "font-terminus")
380 (version "4.40")
381 (source
382 (origin
383 (method url-fetch)
384 (uri (string-append
385 "mirror://sourceforge/project/terminus-font/terminus-font-"
386 version
387 "/terminus-font-"
388 version
389 ".tar.gz"))
390 (sha256
391 (base32
392 "0487cyx5h1f0crbny5sg73a22gmym5vk1i7646gy7hgiscj2rxb4"))))
393 (build-system gnu-build-system)
394 (native-inputs
395 `(("pkg-config" ,pkg-config)
396 ("perl" ,perl)
397 ("bdftopcf" ,bdftopcf)
398 ("font-util" ,font-util)
399 ("mkfontdir" ,mkfontdir)))
400 (arguments
401 `(#:configure-flags (list
402 ;; install fonts into subdirectory of package output
403 ;; instead of font-util-?.?.?/share/fonts/X11
404 (string-append "--with-fontrootdir="
405 %output "/share/fonts/X11"))
406 #:tests? #f)) ;; No test target in tarball
407 (home-page "http://terminus-font.sourceforge.net/")
408 (synopsis "Simple bitmap programming font")
409 (description "Terminus Font is a clean, fixed width bitmap font, designed
410 for long (8 and more hours per day) work with computers.")
411 (license license:silofl1.1)))
412
413 (define-public font-adobe-source-han-sans
414 (package
415 (name "font-adobe-source-han-sans")
416 (version "1.004")
417 (source (origin
418 (method url-fetch)
419 (uri (string-append
420 "https://github.com/adobe-fonts/source-han-sans/archive/"
421 version "R.tar.gz"))
422 (file-name (string-append "source-han-sans-" version "R.tar.gz"))
423 (sha256
424 (base32
425 "1ssx0fw90sy6mj8fv8fv4dgzszpqwbmwpjnlx16g4pvaqzdmybbz"))))
426 (outputs '("out" ; OpenType/CFF Collection (OTC), 121 MiB.
427 "cn" "jp" "kr" "tw")) ; Region-specific Subset OpenType/CFF.
428 (build-system trivial-build-system)
429 (arguments
430 `(#:modules ((guix build utils))
431 #:builder
432 (begin
433 (use-modules (guix build utils))
434 (let ((tar (string-append (assoc-ref %build-inputs
435 "tar")
436 "/bin/tar"))
437 (PATH (string-append (assoc-ref %build-inputs
438 "gzip")
439 "/bin"))
440 (install-opentype-fonts
441 (lambda (fonts-dir out)
442 (copy-recursively fonts-dir
443 (string-append (assoc-ref %outputs out)
444 "/share/fonts/opentype")))))
445 (setenv "PATH" PATH)
446 (system* tar "xvf" (assoc-ref %build-inputs "source"))
447 (chdir (string-append "source-han-sans-" ,version "R"))
448 (install-opentype-fonts "OTC" "out")
449 (install-opentype-fonts "SubsetOTF/CN" "cn")
450 (install-opentype-fonts "SubsetOTF/JP" "jp")
451 (install-opentype-fonts "SubsetOTF/KR" "kr")
452 (install-opentype-fonts "SubsetOTF/TW" "tw")
453 (for-each delete-file (find-files %output "\\.zip$"))))))
454 (native-inputs
455 `(("gzip" ,gzip)
456 ("tar" ,tar)))
457 (home-page "https://github.com/adobe-fonts/source-han-sans")
458 (synopsis "Pan-CJK fonts")
459 (description
460 "Source Han Sans is a sans serif Pan-CJK font family that is offered in
461 seven weights: ExtraLight, Light, Normal, Regular, Medium, Bold, and Heavy.
462 And in several OpenType/CFF-based deployment configurations to accommodate
463 various system requirements or limitations. As the name suggests, Pan-CJK
464 fonts are intended to support the characters necessary to render or display
465 text in Simplified Chinese, Traditional Chinese, Japanese, and Korean.")
466 (license license:silofl1.1)))
467
468 (define-public font-wqy-zenhei
469 (package
470 (name "font-wqy-zenhei")
471 (version "0.9.45")
472 (source (origin
473 (method url-fetch)
474 (uri (string-append
475 "mirror://sourceforge/wqy/wqy-zenhei-"
476 version ".tar.gz"))
477 (file-name (string-append "wqy-zenhei-" version ".tar.gz"))
478 (sha256
479 (base32
480 "1mkmxq8g2hjcglb3zajfqj20r4r88l78ymsp2xyl5yav8w3f7dz4"))))
481 (build-system trivial-build-system)
482 (arguments
483 `(#:modules ((guix build utils))
484 #:builder
485 (begin
486 (use-modules (guix build utils))
487 (let ((PATH (string-append (assoc-ref %build-inputs "tar") "/bin:"
488 (assoc-ref %build-inputs "gzip") "/bin"))
489 (font-dir (string-append (assoc-ref %outputs "out")
490 "/share/fonts/wenquanyi/")))
491 (setenv "PATH" PATH)
492 (mkdir-p font-dir)
493 (system* "tar" "xvf" (assoc-ref %build-inputs "source"))
494 (chdir "wqy-zenhei")
495 (copy-file "wqy-zenhei.ttc"
496 (string-append font-dir "wqy-zenhei.ttc"))))))
497 (native-inputs
498 `(("gzip" ,gzip)
499 ("tar" ,tar)))
500 (home-page "http://wenq.org/wqy2/")
501 (synopsis "CJK font")
502 (description
503 "WenQuanYi Zen Hei is a Hei-Ti style (sans-serif type) Chinese outline
504 font. It is designed for general purpose text formatting and on-screen
505 display of Chinese characters and symbols from many other languages.
506 WenQuanYi Zen Hei provides a rather complete coverage to Chinese Hanzi glyphs,
507 including both simplified and traditional forms. The total glyph number in
508 this font is over 35,000, including over 21,000 Chinese Hanzi. This font has
509 full coverage to GBK(CP936) charset, CJK Unified Ideographs, as well as the
510 code-points needed for zh_cn, zh_sg, zh_tw, zh_hk, zh_mo, ja (Japanese) and
511 ko (Korean) locales for fontconfig.")
512 ;; GPLv2 with font embedding exception
513 (license license:gpl2)))
514
515 (define-public font-tex-gyre
516 (package
517 (name "font-tex-gyre")
518 (version "2.005")
519 (source
520 (origin
521 (method url-fetch)
522 (uri (string-append "http://www.gust.org.pl/projects/e-foundry/"
523 "tex-gyre/whole/tg-" version "otf.zip"))
524 (sha256
525 (base32
526 "0kph9l3g7jb2bpmxdbdg5zl56wacmnvdvsdn7is1gc750sqvsn31"))))
527 (build-system trivial-build-system)
528 (arguments
529 `(#:modules ((guix build utils))
530 #:builder
531 (begin
532 (use-modules (guix build utils))
533
534 (let ((unzip (string-append (assoc-ref %build-inputs "unzip")
535 "/bin/unzip"))
536 (font-dir (string-append %output "/share/fonts/opentype")))
537 (mkdir-p font-dir)
538 (system* unzip
539 (assoc-ref %build-inputs "source")
540 "-d" font-dir)))))
541 (native-inputs
542 `(("unzip" ,unzip)))
543 (home-page "http://www.gust.org.pl/projects/e-foundry/tex-gyre/")
544 (synopsis "Remake of Ghostscript fonts")
545 (description "The TeX Gyre collection of fonts is the result of an
546 extensive remake and extension of the freely available base PostScript fonts
547 distributed with Ghostscript version 4.00. The collection contains the
548 following fonts in the OpenType format: Adventor, Bonum, Chorus, Cursor,
549 Heros, Pagella, Schola, Termes.")
550 (license license:gfl1.0)))
551
552 (define-public font-anonymous-pro
553 (package
554 (name "font-anonymous-pro")
555 (version "1.002")
556 (source (origin
557 (method url-fetch)
558 (uri (string-append
559 "http://www.marksimonson.com/assets/content/fonts/"
560 "AnonymousPro-" version ".zip"))
561 (sha256
562 (base32
563 "1asj6lykvxh46czbal7ymy2k861zlcdqpz8x3s5bbpqwlm3mhrl6"))))
564 (build-system trivial-build-system)
565 (arguments
566 `(#:modules ((guix build utils))
567 #:builder
568 (begin
569 (use-modules (guix build utils))
570 (let ((unzip (string-append (assoc-ref %build-inputs "unzip")
571 "/bin/unzip"))
572 (font-dir (string-append %output "/share/fonts/truetype"))
573 (doc-dir (string-append %output "/share/doc/" ,name)))
574 (system* unzip (assoc-ref %build-inputs "source"))
575 (mkdir-p font-dir)
576 (mkdir-p doc-dir)
577 (chdir (string-append "AnonymousPro-" ,version ".001"))
578 (for-each (lambda (ttf)
579 (copy-file ttf
580 (string-append font-dir "/" ttf)))
581 (find-files "." "\\.ttf$"))
582 (for-each (lambda (doc)
583 (copy-file doc
584 (string-append doc-dir "/" doc)))
585 (find-files "." "\\.txt$"))))))
586 (native-inputs
587 `(("unzip" ,unzip)))
588 (home-page "http://www.marksimonson.com/fonts/view/anonymous-pro")
589 (synopsis "Fixed-width fonts designed with coding in mind")
590 (description "Anonymous Pro is a family of four fixed-width fonts designed
591 with coding in mind. Anonymous Pro features an international, Unicode-based
592 character set, with support for most Western and Central European Latin-based
593 languages, plus Greek and Cyrillic.")
594 (license license:silofl1.1)))
595
596 (define-public font-gnu-unifont
597 (package
598 (name "font-gnu-unifont")
599 (version "8.0.01")
600 (source (origin
601 (method url-fetch)
602 (uri (string-append
603 "mirror://gnu/unifont/unifont-8.0.01/unifont-"
604 version ".tar.gz"))
605 (sha256
606 (base32
607 "176bzc2y3i49xavrmbyyz5lkqp0qq3bkj7rjrl197kib873by82b"))))
608 (build-system gnu-build-system)
609 (outputs '("out" ; TrueType version
610 "pcf" ; PCF (bitmap) version
611 "psf" ; PSF (console) version
612 "bin" ; Utilities to manipulate '.hex' format
613 ))
614 (arguments
615 '(#:parallel-build? #f ; parallel build fails
616 #:tests? #f ; no check target
617 #:phases
618 (modify-phases %standard-phases
619 (replace 'configure
620 (lambda _
621 (setenv "CC" "gcc")))
622 (replace
623 'install
624 (lambda* (#:key outputs #:allow-other-keys)
625 (let* ((ttf (string-append (assoc-ref outputs "out")
626 "/share/fonts/truetype"))
627 (pcf (string-append (assoc-ref outputs "pcf")
628 "/share/fonts/misc"))
629 (psf (string-append (assoc-ref outputs "psf")
630 "/share/consolefonts"))
631 (bin (assoc-ref outputs "bin")))
632 (system* "make"
633 (string-append "PREFIX=" bin)
634 (string-append "TTFDEST=" ttf)
635 (string-append "PCFDEST=" pcf)
636 (string-append "CONSOLEDEST=" psf)
637 "install")
638 ;; Move Texinfo file to the right place.
639 (mkdir (string-append bin "/share/info"))
640 (rename-file (string-append bin "/share/unifont/unifont.info.gz")
641 (string-append bin "/share/info/unifont.info.gz"))
642 #t))))))
643 (inputs
644 `(("perl" ,perl))) ; for utilities
645 (synopsis
646 "Large bitmap font covering Unicode's Basic Multilingual Plane")
647 (description
648 "GNU Unifont is a bitmap font covering essentially all of
649 Unicode's Basic Multilingual Plane. The package also includes
650 utilities to ease adding new glyphs to the font.")
651 (home-page "http://unifoundry.com/unifont.html")
652 (license license:gpl2+)))
653
654 (define-public font-google-noto
655 (package
656 (name "font-google-noto")
657 (version "20150929")
658 (source (origin
659 (method url-fetch)
660 (uri (string-append "https://noto-website-2.storage.googleapis.com/"
661 "pkgs/Noto-hinted.zip"))
662 (sha256
663 (base32
664 "13jhpqzhsqhyby8n0ksqg155a3jyaif3nzj9anzbq8s2gn1xjyd9"))))
665 (build-system trivial-build-system)
666 (arguments
667 `(#:modules ((guix build utils))
668 #:builder (begin
669 (use-modules (guix build utils)
670 (srfi srfi-26))
671
672 (let ((PATH (string-append (assoc-ref %build-inputs
673 "unzip")
674 "/bin"))
675 (font-dir (string-append %output
676 "/share/fonts/truetype")))
677 (setenv "PATH" PATH)
678 (system* "unzip" (assoc-ref %build-inputs "source"))
679
680 (mkdir-p font-dir)
681 (for-each (lambda (ttf)
682 (copy-file ttf
683 (string-append font-dir "/" ttf)))
684 (find-files "." "\\.ttf$"))
685 (for-each (lambda (otf)
686 (copy-file otf
687 (string-append font-dir "/" otf)))
688 (find-files "." "\\.otf$"))))))
689 (native-inputs `(("unzip" ,unzip)))
690 (home-page "https://www.google.com/get/noto/")
691 (synopsis "Fonts aimed to cover all languages")
692 (description "Googe Noto Fonts is a family of fonts aimed to support all
693 languages with a consistent look and aesthetic. It's goal is to have no Unicode
694 symbols unable to be displayed properly.")
695 (license license:silofl1.1)))
696
697 (define-public font-un
698 (package
699 (name "font-un")
700 (version "1.0.2-080608")
701 ;; The upstream server at kldp.net is serving us broken MIME.
702 ;; See <http://bugs.gnu.org/22908>.
703 (source (origin
704 (method url-fetch)
705 (uri (list
706 (string-append
707 "http://krosos.sdf.org/static/unix/"
708 "un-fonts-core-" version ".tar.gz")
709 ;; XXX: The upstream server at kldp.net
710 (string-append
711 "https://kldp.net/projects/unfonts/download/4695?filename="
712 "un-fonts-core-" version ".tar.gz")))
713 (file-name (string-append name "-" version ".tar.gz"))
714 (sha256
715 (base32
716 "13liaz2pmww3aqabm55la5npd08m1skh334ky7qfidxaz5s742iv"))))
717 (build-system trivial-build-system)
718 (arguments
719 `(#:modules ((guix build utils))
720 #:builder
721 (begin
722 (use-modules (guix build utils))
723
724 (let ((tar (string-append (assoc-ref %build-inputs "tar")
725 "/bin/tar"))
726 (PATH (string-append (assoc-ref %build-inputs "gzip")
727 "/bin"))
728 (font-dir (string-append %output "/share/fonts/truetype"))
729 (doc-dir (string-append %output "/share/doc/" ,name)))
730 (setenv "PATH" PATH)
731 (system* tar "xvf" (assoc-ref %build-inputs "source"))
732 (mkdir-p font-dir)
733 (mkdir-p doc-dir)
734 (chdir (string-append "un-fonts"))
735 (for-each (lambda (ttf)
736 (copy-file ttf
737 (string-append font-dir "/"
738 (basename ttf))))
739 (find-files "." "\\.ttf$"))
740 (for-each (lambda (doc)
741 (copy-file doc
742 (string-append doc-dir "/"
743 (basename doc))))
744 '("COPYING" "README"))))))
745 (native-inputs
746 `(("tar" ,tar)
747 ("gzip" ,gzip)))
748 (home-page "https://kldp.net/projects/unfonts/")
749 (synopsis "Collection of Korean fonts")
750 (description
751 "Un-fonts is a family of mainly Korean fonts.
752 It contains the following fonts and styles:
753
754 @enumerate
755 @item UnBatang, UnBatangBold: serif;
756 @item UnDotum, UnDotumBold: sans-serif;
757 @item UnGraphic, UnGraphicBold: sans-serif style;
758 @item UnDinaru, UnDinaruBold, UnDinaruLight;
759 @item UnPilgi, UnPilgiBold: script;
760 @item UnGungseo: cursive, brush-stroke.
761 @end enumerate\n")
762 (license license:gpl2+)))