gnu: guix: Update to 0.10.0.
[jackhill/guix/guix.git] / gnu / packages / feh.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages feh)
21 #:use-module (gnu packages)
22 #:use-module (gnu packages image)
23 #:use-module (gnu packages curl)
24 #:use-module (gnu packages xorg)
25 #:use-module (guix packages)
26 #:use-module (guix download)
27 #:use-module (guix build-system gnu)
28 #:use-module ((guix licenses) #:prefix license:))
29
30 (define-public feh
31 (package
32 (name "feh")
33 (version "2.14.1")
34 (home-page "https://feh.finalrewind.org/")
35 (source (origin
36 (method url-fetch)
37 (uri (string-append home-page
38 name "-" version ".tar.bz2"))
39 (sha256
40 (base32
41 "1hlzgr0masgbm1vdn085vz81s9kpnah8kjkb1w1xfsxr1b99x8f0"))))
42 (build-system gnu-build-system)
43 (arguments
44 '(#:phases (alist-delete 'configure %standard-phases)
45 #:tests? #f
46 #:make-flags
47 (list "CC=gcc" (string-append "PREFIX=" (assoc-ref %outputs "out")))))
48 (inputs `(("imlib2" ,imlib2)
49 ("curl" ,curl)
50 ("libpng" ,libpng)
51 ("libxt" ,libxt)
52 ("libx11" ,libx11)
53 ("libxinerama" ,libxinerama)))
54 (synopsis "Fast and light imlib2-based image viewer")
55 (description
56 "feh is an X11 image viewer aimed mostly at console users.
57 Unlike most other viewers, it does not have a fancy GUI, but simply
58 displays images. It can also be used to set the desktop wallpaper.
59 It is controlled via commandline arguments and configurable key/mouse
60 actions.")
61
62 ;; The license is really the Expat license, with additional wording in the
63 ;; 2nd paragraph: "acknowledgment shall be given in the documentation and
64 ;; software packages that this Software was used."
65 (license (license:x11-style
66 "file://COPYING"
67 "See 'COPYING' in the distribution."))))