gnu: python-mako: Update to 1.0.7.
[jackhill/guix/guix.git] / gnu / packages / terraform.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2018 Christopher Baines <mail@cbaines.net>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages terraform)
20 #:use-module ((guix licenses) #:prefix license:)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix git-download)
24 #:use-module (guix build-system go)
25 #:use-module (gnu packages golang))
26
27 (define-public terraform-docs
28 (package
29 (name "terraform-docs")
30 (version "0.3.0")
31 (source (origin
32 (method git-fetch)
33 (uri (git-reference
34 (url "https://github.com/segmentio/terraform-docs")
35 (commit (string-append "v" version))))
36 (file-name (git-file-name name version))
37 (sha256
38 (base32
39 "0xchpik32ab8m89s6jv671vswg8xhprfvh6s5md0zd36482d2nmm"))))
40 (build-system go-build-system)
41 (native-inputs
42 `(("go-github-com-hashicorp-hcl" ,go-github-com-hashicorp-hcl)
43 ("go-github-com-tj-docopt" ,go-github-com-tj-docopt)))
44 (arguments
45 '(#:import-path "github.com/segmentio/terraform-docs"))
46 (synopsis "Generate documentation from Terraform modules")
47 (description
48 "The @code{terraform-docs} utility can generate documentation describing
49 the inputs and outputs for modules of the Terraform infrastructure management
50 tool. These can be shown, or written to a file in JSON or Markdown formats.")
51 (home-page "https://github.com/segmentio/terraform-docs")
52 (license license:expat)))