gnu: python-numpy-next: Update to 1.22.3.
[jackhill/guix/guix.git] / gnu / packages / web-browsers.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
3 ;;; Copyright © 2014, 2019 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2015, 2016, 2019, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
5 ;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
6 ;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
7 ;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
8 ;;; Copyright © 2018 Rutger Helling <rhelling@mykolab.com>
9 ;;; Copyright © 2018 Timo Eisenmann <eisenmann@fn.de>
10 ;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
11 ;;; Copyright © 2019 Clément Lassieur <clement@lassieur.org>
12 ;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
13 ;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
14 ;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
15 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
16 ;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
17 ;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@posteo.ro>
18 ;;; Copyright © 2021, 2022 Cage <cage-dev@twistfold.it>
19 ;;; Copyright © 2021 Benoit Joly <benoit@benoitj.ca>
20 ;;; Copyright © 2021 Alexander Krotov <krotov@iitp.ru>
21 ;;; Copyright © 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
22 ;;; Copyright © 2021 Christopher Howard <christopher@librehacker.com>
23 ;;;
24 ;;; This file is part of GNU Guix.
25 ;;;
26 ;;; GNU Guix is free software; you can redistribute it and/or modify it
27 ;;; under the terms of the GNU General Public License as published by
28 ;;; the Free Software Foundation; either version 3 of the License, or (at
29 ;;; your option) any later version.
30 ;;;
31 ;;; GNU Guix is distributed in the hope that it will be useful, but
32 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
33 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
34 ;;; GNU General Public License for more details.
35 ;;;
36 ;;; You should have received a copy of the GNU General Public License
37 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
38
39 (define-module (gnu packages web-browsers)
40 #:use-module (guix build-system asdf)
41 #:use-module (guix build-system cmake)
42 #:use-module (guix build-system glib-or-gtk)
43 #:use-module (guix build-system gnu)
44 #:use-module (guix build-system go)
45 #:use-module (guix build-system python)
46 #:use-module (guix download)
47 #:use-module (guix gexp)
48 #:use-module (guix git-download)
49 #:use-module ((guix licenses) #:prefix license:)
50 #:use-module (guix packages)
51 #:use-module (guix utils)
52 #:use-module (gnu packages)
53 #:use-module (gnu packages autotools)
54 #:use-module (gnu packages backup)
55 #:use-module (gnu packages base)
56 #:use-module (gnu packages bash)
57 #:use-module (gnu packages bison)
58 #:use-module (gnu packages compression)
59 #:use-module (gnu packages curl)
60 #:use-module (gnu packages documentation)
61 #:use-module (gnu packages fltk)
62 #:use-module (gnu packages fontutils)
63 #:use-module (gnu packages fonts)
64 #:use-module (gnu packages freedesktop)
65 #:use-module (gnu packages fribidi)
66 #:use-module (gnu packages gcc)
67 #:use-module (gnu packages gettext)
68 #:use-module (gnu packages glib)
69 #:use-module (gnu packages gnome)
70 #:use-module (gnu packages gnome-xyz)
71 #:use-module (gnu packages gnupg)
72 #:use-module (gnu packages gtk)
73 #:use-module (gnu packages image)
74 #:use-module (gnu packages libevent)
75 #:use-module (gnu packages libidn)
76 #:use-module (gnu packages libunistring)
77 #:use-module (gnu packages linux)
78 #:use-module (gnu packages lisp)
79 #:use-module (gnu packages lisp-check)
80 #:use-module (gnu packages lisp-xyz)
81 #:use-module (gnu packages lua)
82 #:use-module (gnu packages man)
83 #:use-module (gnu packages markup)
84 #:use-module (gnu packages mp3)
85 #:use-module (gnu packages nano)
86 #:use-module (gnu packages ncurses)
87 #:use-module (gnu packages pcre)
88 #:use-module (gnu packages perl)
89 #:use-module (gnu packages pkg-config)
90 #:use-module (gnu packages python)
91 #:use-module (gnu packages python-web)
92 #:use-module (gnu packages python-xyz)
93 #:use-module (gnu packages qt)
94 #:use-module (gnu packages sdl)
95 #:use-module (gnu packages sqlite)
96 #:use-module (gnu packages tls)
97 #:use-module (gnu packages webkit)
98 #:use-module (gnu packages xorg))
99
100 (define-public midori
101 (package
102 (name "midori")
103 (version "9.0")
104 (source
105 (origin
106 (method url-fetch)
107 (uri
108 (string-append "https://github.com/midori-browser/core/releases/"
109 "download/v" version "/" name "-v" version ".tar.gz"))
110 (sha256
111 (base32
112 "05i04qa83dnarmgkx4xsk6fga5lw1lmslh4rb3vhyyy4ala562jy"))))
113 (build-system cmake-build-system)
114 (arguments
115 `(#:imported-modules
116 (,@%cmake-build-system-modules
117 (guix build glib-or-gtk-build-system))
118 #:modules
119 ((guix build cmake-build-system)
120 ((guix build glib-or-gtk-build-system) #:prefix glib-or-gtk:)
121 (guix build utils))
122 #:phases
123 (modify-phases %standard-phases
124 (add-after 'install 'glib-or-gtk-compile-schemas
125 (assoc-ref glib-or-gtk:%standard-phases
126 'glib-or-gtk-compile-schemas))
127 (add-after 'install 'glib-or-gtk-wrap
128 (assoc-ref glib-or-gtk:%standard-phases
129 'glib-or-gtk-wrap)))))
130 (native-inputs
131 `(("desktop-file-utils" ,desktop-file-utils) ;for tests
132 ("glib:bin" ,glib "bin")
133 ("gtk+:bin" ,gtk+ "bin")
134 ("intltool" ,intltool)
135 ("pkg-config" ,pkg-config)
136 ("which" ,which))) ;for tests
137 (inputs
138 `(("adwaita-icon-theme" ,adwaita-icon-theme)
139 ("gcr" ,gcr)
140 ("glib" ,glib)
141 ("glib-networking" ,glib-networking)
142 ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
143 ("gtk+" ,gtk+)
144 ("json-glib" ,json-glib)
145 ("libarchive" ,libarchive)
146 ("libpeas" ,libpeas)
147 ("sqlite" ,sqlite)
148 ("vala" ,vala)
149 ("webkitgtk" ,webkitgtk-with-libsoup2)))
150 (synopsis "Lightweight graphical web browser")
151 (description "@code{Midori} is a lightweight, Webkit-based web browser.
152 It features integration with GTK+3, configurable web search engine, bookmark
153 management, extensions such as advertisement blocker and colorful tabs.")
154 (home-page "https://www.midori-browser.org")
155 (license license:lgpl2.1+)))
156
157 (define-public links
158 (package
159 (name "links")
160 (version "2.26")
161 (source (origin
162 (method url-fetch)
163 (uri (string-append "http://links.twibright.com/download/"
164 "links-" version ".tar.bz2"))
165 (sha256
166 (base32
167 "1jy90k04kl7y3l8jzg5jx7fglyqzngng0964j7j67gjxy9vkanzh"))))
168 (build-system gnu-build-system)
169 (arguments
170 (list
171 #:configure-flags #~(list "--enable-graphics")
172 #:phases
173 #~(modify-phases %standard-phases
174 (replace 'configure
175 (lambda* (#:key outputs (configure-flags '()) #:allow-other-keys)
176 ;; The tarball uses a very old version of autoconf. It doesn't
177 ;; understand extra flags like `--enable-fast-install', so
178 ;; we need to invoke it with just what it understands.
179 (let ((out (assoc-ref outputs "out")))
180 ;; 'configure' doesn't understand '--host'.
181 #$@(if (%current-target-system)
182 #~((setenv "CHOST" #$(%current-target-system)))
183 #~())
184 (setenv "CONFIG_SHELL" (which "bash"))
185 (apply invoke "./configure"
186 (string-append "--prefix=" out)
187 configure-flags)))))))
188 (native-inputs (list pkg-config))
189 (inputs
190 (list gpm
191 libevent
192 libjpeg-turbo
193 libpng
194 libtiff
195 libxt
196 openssl
197 zlib))
198 (synopsis "Text and graphics mode web browser")
199 (description "Links is a graphics and text mode web browser, with many
200 features including, tables, builtin image display, bookmarks, SSL and more.")
201 (home-page "http://links.twibright.com")
202 ;; The distribution contains a copy of GPLv2
203 ;; However, the copyright notices simply say:
204 ;; "This file is a part of the Links program, released under GPL."
205 ;; Therefore, under the provisions of Section 9, we can choose
206 ;; any version ever published by the FSF.
207 ;; One file (https.c) contains an exception permitting
208 ;; linking of the program with openssl.
209 (license license:gpl1+)))
210
211 (define-public luakit
212 (package
213 (name "luakit")
214 (version "2.3")
215 (source (origin
216 (method git-fetch)
217 (uri (git-reference
218 (url "https://github.com/luakit/luakit")
219 (commit version)))
220 (file-name (git-file-name name version))
221 (sha256
222 (base32
223 "1khbn7dpizkznnwkw7rcfhf72dnd1nazk7dwb4rkh9i97b53mf1y"))))
224 (inputs
225 `(("lua-5.1" ,lua-5.1)
226 ("gtk+" ,gtk+)
227 ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
228 ("glib-networking" ,glib-networking)
229 ("lua5.1-filesystem" ,lua5.1-filesystem)
230 ("luajit" ,luajit)
231 ("webkitgtk" ,webkitgtk-with-libsoup2)
232 ("sqlite" ,sqlite)))
233 (native-inputs
234 (list pkg-config))
235 (build-system glib-or-gtk-build-system)
236 (arguments
237 `(#:make-flags
238 (let ((out (assoc-ref %outputs "out")))
239 (list
240 "CC=gcc"
241 "LUA_BIN_NAME=lua"
242 "DEVELOPMENT_PATHS=0"
243 (string-append "PREFIX=" out)
244 (string-append "XDGPREFIX=" out "/etc/xdg")))
245 #:phases
246 (modify-phases %standard-phases
247 (add-before 'build 'lfs-workaround
248 (lambda _
249 (setenv "LUA_CPATH"
250 (string-append
251 (assoc-ref %build-inputs "lua5.1-filesystem")
252 "/lib/lua/5.1/?.so;;"))
253 #t))
254 (add-before 'build 'set-version
255 (lambda _
256 (setenv "VERSION_FROM_GIT" ,(package-version this-package))
257 #t))
258 (delete 'configure)
259 (delete 'check)
260 (add-after 'install 'wrap
261 (lambda* (#:key inputs outputs #:allow-other-keys)
262 (let* ((luakit (assoc-ref outputs "out"))
263 (lua5.1-filesystem (assoc-ref inputs "lua5.1-filesystem") )
264 (gtk (assoc-ref inputs "gtk+"))
265 (gtk-share (string-append gtk "/share")))
266 (wrap-program (string-append luakit "/bin/luakit")
267 `("LUA_CPATH" prefix
268 (,(string-append lua5.1-filesystem
269 "/lib/lua/5.1/?.so;;")))
270 `("XDG_CONFIG_DIRS" prefix
271 (,(string-append luakit "/etc/xdg/"))))
272 #t))))))
273 (synopsis "Fast, lightweight, and simple browser based on WebKit")
274 (description "Luakit is a fast, lightweight, and simple to use
275 micro-browser framework extensible by Lua using the WebKit web content engine
276 and the GTK+ toolkit.")
277 (home-page "https://luakit.github.io/")
278 (license license:gpl3+)))
279
280 (define-public lynx
281 (package
282 (name "lynx")
283 (version "2.9.0dev.9")
284 (source (origin
285 (method url-fetch)
286 (uri (string-append
287 "http://invisible-mirror.net/archives/lynx/tarballs"
288 "/lynx" version ".tar.bz2"))
289 (sha256
290 (base32
291 "06jhv8ibfw1xkf8d8zrnkc2aw4d462s77hlp6f6xa6k8awzxvmkg"))))
292 (build-system gnu-build-system)
293 (native-inputs (list pkg-config perl))
294 (inputs (list ncurses
295 libidn
296 openssl
297 libgcrypt
298 unzip
299 zlib
300 gzip
301 bzip2))
302 (arguments
303 `(#:configure-flags
304 (let ((openssl (assoc-ref %build-inputs "openssl")))
305 `("--with-pkg-config"
306 "--with-screen=ncurses"
307 "--with-zlib"
308 "--with-bzlib"
309 ,(string-append "--with-ssl=" openssl)
310 ;; "--with-socks5" ; XXX TODO
311 "--enable-widec"
312 "--enable-ascii-ctypes"
313 "--enable-local-docs"
314 "--enable-htmlized-cfg"
315 "--enable-gzip-help"
316 "--enable-nls"
317 "--enable-ipv6"))
318 #:tests? #f ; no check target
319 #:phases
320 (modify-phases %standard-phases
321 (add-before 'configure 'set-makefile-shell
322 (lambda _ (substitute* "po/makefile.inn"
323 (("/bin/sh") (which "sh")))
324 #t))
325 (replace 'install
326 (lambda* (#:key (make-flags '()) #:allow-other-keys)
327 (apply invoke "make" "install-full" make-flags)
328 #t)))))
329 (synopsis "Text Web Browser")
330 (description
331 "Lynx is a fully-featured World Wide Web (WWW) client for users running
332 cursor-addressable, character-cell display devices. It will display Hypertext
333 Markup Language (HTML) documents containing links to files on the local
334 system, as well as files on remote systems running http, gopher, ftp, wais,
335 nntp, finger, or cso/ph/qi servers. Lynx can be used to access information on
336 the WWW, or to build information systems intended primarily for local
337 access.")
338 (home-page "https://lynx.invisible-island.net/")
339 ;; This was fixed in 2.8.9dev.10.
340 (properties `((lint-hidden-cve . ("CVE-2016-9179"))))
341 (license license:gpl2)))
342
343 (define-public kristall
344 ;; Fixes to the build system applied after the latest tag
345 ;; Use tagged release when updating
346 (let ((commit "204b08a9303e75cd8d4c252b0554935062766f86")
347 (revision "1"))
348 (package
349 (name "kristall")
350 (version (string-append "0.3-" revision "." (string-take commit 7)))
351 (source
352 (origin
353 (method git-fetch)
354 (uri (git-reference
355 (url "https://github.com/MasterQ32/kristall")
356 (commit commit)))
357 (file-name (git-file-name name version))
358 (sha256
359 (base32
360 "1mymq0dh6r0829x74j0jkw8hw46amqwbznlf1b4ra6w77h9yz3lj"))
361 (modules '((srfi srfi-1)
362 (ice-9 ftw)
363 (guix build utils)))
364 (snippet
365 '(let ((preserved-lib-files '("luis-l-gist")))
366 (with-directory-excursion "lib"
367 (for-each
368 (lambda (directory)
369 (simple-format #t "deleting: ~A\n" directory)
370 (delete-file-recursively directory))
371 (lset-difference string=?
372 (scandir ".")
373 (cons* "." ".." preserved-lib-files))))
374 ;; Contains executable of 7z and pscp
375 (delete-file-recursively "ci/tools")
376 ;; Remove bundled fonts
377 (delete-file-recursively "src/fonts")
378 #t))))
379 (build-system gnu-build-system)
380 (arguments
381 `(#:modules ((guix build gnu-build-system)
382 (guix build qt-utils)
383 (guix build utils))
384 #:imported-modules (,@%gnu-build-system-modules
385 (guix build qt-utils))
386 #:make-flags
387 (list (string-append "PREFIX=" %output))
388 #:phases
389 (modify-phases %standard-phases
390 (delete 'configure) ; no ./configure script
391 (delete 'check) ; no check target
392 (add-before 'build 'set-program-version
393 (lambda _
394 ;; configure.ac relies on ‘git --describe’ to get the version.
395 ;; Patch it to just return the real version number directly.
396 (substitute* "src/kristall.pro"
397 (("(KRISTALL_VERSION=).*" _ match)
398 (string-append match ,version "\n")))
399 #t))
400 (add-before 'build 'dont-use-bundled-cmark
401 (lambda _
402 (substitute* "src/kristall.pro"
403 (("(^include\\(.*cmark.*)" _ match)
404 (string-append
405 "LIBS += -I" (assoc-ref %build-inputs "cmark") " -lcmark")))
406 #t))
407 (add-before 'build 'dont-use-bundled-breeze-stylesheet
408 (lambda _
409 (substitute* "src/kristall.pro"
410 (("../lib/BreezeStyleSheets/breeze.qrc")
411 (string-append
412 (assoc-ref %build-inputs "breeze-stylesheet") "/breeze.qrc")))
413 #t))
414 (add-before 'build 'dont-use-bundled-fonts
415 (lambda _
416 (substitute* "src/kristall.pro"
417 ((".*fonts.qrc.*") ""))
418 (substitute* "src/main.cpp"
419 (("/fonts/OpenMoji-Color")
420 (string-append
421 (assoc-ref %build-inputs "font-openmoji")
422 "/share/fonts/truetype/OpenMoji-Color"))
423 (("/fonts/NotoColorEmoji")
424 (string-append
425 (assoc-ref %build-inputs "font-google-noto")
426 "/share/fonts/truetype/NotoColorEmoji")))
427 #t))
428 (add-after 'install 'wrap-program
429 (lambda* (#:key outputs inputs #:allow-other-keys)
430 (let ((out (assoc-ref outputs "out")))
431 (wrap-qt-program "kristall" #:output out #:inputs inputs))
432 #t)))))
433 (native-inputs
434 `(("breeze-stylesheet"
435 ,(let ((commit "2d595a956f8a5f493aa51139a470b768a6d82cce")
436 (revision "0"))
437 (origin
438 (method git-fetch)
439 (uri
440 (git-reference
441 (url "https://github.com/Alexhuszagh/BreezeStyleSheets")
442 (commit "2d595a956f8a5f493aa51139a470b768a6d82cce")))
443 (file-name (git-file-name "breeze-stylesheet"
444 (git-version "0" revision commit)))
445 (sha256
446 (base32
447 "1kvkxkisi3czldnb43ig60l55pi4a3m2a4ixp7krhpf9fc5wp294")))))))
448 (inputs
449 (list cmark
450 font-google-noto
451 font-openmoji
452 openssl
453 qtbase-5
454 qtmultimedia
455 qtsvg))
456 (home-page "https://kristall.random-projects.net")
457 (synopsis "Small-internet graphical client")
458 (description "Graphical small-internet client with with many features
459 including multi-protocol support (gemini, HTTP, HTTPS, gopher, finger),
460 bookmarks, TSL certificates management, outline generation and a tabbed
461 interface.")
462 (license (list license:gpl3+
463 ;; for breeze-stylesheet
464 license:expat)))))
465
466 (define-public qutebrowser
467 (package
468 (name "qutebrowser")
469 (version "2.4.0")
470 (source
471 (origin
472 (method url-fetch)
473 (uri (string-append "https://github.com/qutebrowser/"
474 "qutebrowser/releases/download/v" version "/"
475 "qutebrowser-" version ".tar.gz"))
476 (sha256
477 (base32 "1v4jhlmgfm8v9sbf7i3xg1vjh6dy8y2gpckk0mizkazb2jxrmkgj"))))
478 (build-system python-build-system)
479 (native-inputs
480 (list python-attrs)) ; for tests
481 (inputs
482 (list bash-minimal
483 python-colorama
484 python-cssutils
485 python-jinja2
486 python-markupsafe
487 python-pygments
488 python-pypeg2
489 python-pyyaml
490 ;; FIXME: python-pyqtwebengine needs to come before python-pyqt so
491 ;; that it's __init__.py is used first.
492 python-pyqtwebengine
493 python-pyqt-without-qtwebkit
494 ;; While qtwebengine is provided by python-pyqtwebengine, it's
495 ;; included here so we can wrap QTWEBENGINEPROCESS_PATH.
496 qtwebengine))
497 (arguments
498 `(;; FIXME: With the existance of qtwebengine, tests can now run. But
499 ;; they are still disabled because test phase hangs. It's not readily
500 ;; apparent as to why.
501 #:tests? #f
502 #:phases
503 (modify-phases %standard-phases
504 (add-before 'check 'set-env-offscreen
505 (lambda _
506 (setenv "QT_QPA_PLATFORM" "offscreen")))
507 (add-after 'install 'install-more
508 (lambda* (#:key outputs #:allow-other-keys)
509 (let* ((out (assoc-ref outputs "out"))
510 (app (string-append out "/share/applications"))
511 (hicolor (string-append out "/share/icons/hicolor")))
512 (install-file "doc/qutebrowser.1"
513 (string-append out "/share/man/man1"))
514 (for-each
515 (lambda (i)
516 (let ((src (format #f "icons/qutebrowser-~dx~d.png" i i))
517 (dest (format #f "~a/~dx~d/apps/qutebrowser.png"
518 hicolor i i)))
519 (mkdir-p (dirname dest))
520 (copy-file src dest)))
521 '(16 24 32 48 64 128 256 512))
522 (install-file "icons/qutebrowser.svg"
523 (string-append hicolor "/scalable/apps"))
524 (substitute* "misc/org.qutebrowser.qutebrowser.desktop"
525 (("Exec=qutebrowser")
526 (string-append "Exec=" out "/bin/qutebrowser")))
527 (install-file "misc/org.qutebrowser.qutebrowser.desktop" app))))
528 (add-after 'wrap 'wrap-qt-process-path
529 (lambda* (#:key inputs outputs #:allow-other-keys)
530 (let* ((out (assoc-ref outputs "out"))
531 (bin (string-append out "/bin/qutebrowser"))
532 (qt-process-path (string-append
533 (assoc-ref inputs "qtwebengine")
534 "/lib/qt5/libexec/QtWebEngineProcess")))
535 (wrap-program bin
536 `("QTWEBENGINEPROCESS_PATH" = (,qt-process-path)))))))))
537 (home-page "https://qutebrowser.org/")
538 (synopsis "Minimal, keyboard-focused, vim-like web browser")
539 (description "qutebrowser is a keyboard-focused browser with a minimal
540 GUI. It is based on PyQt5 and QtWebEngine.")
541 (license license:gpl3+)))
542
543 (define-public vimb
544 (package
545 (name "vimb")
546 (version "3.6.0")
547 (source
548 (origin
549 (method git-fetch)
550 (uri (git-reference
551 (url "https://github.com/fanglingsu/vimb/")
552 (commit version)))
553 (sha256
554 (base32 "0228khh3lqbal046k6akqah7s5igq9s0wjfjbdjam75kjj42pbhj"))
555 (file-name (git-file-name name version))))
556 (build-system glib-or-gtk-build-system)
557 (arguments
558 '(#:tests? #f ; no tests
559 #:make-flags (list "CC=gcc"
560 "DESTDIR="
561 (string-append "PREFIX=" %output))
562 #:phases
563 (modify-phases %standard-phases
564 (delete 'configure))))
565 (inputs
566 `(("glib-networking" ,glib-networking)
567 ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
568 ("webkitgtk" ,webkitgtk-with-libsoup2)))
569 (native-inputs
570 (list pkg-config))
571 (home-page "https://fanglingsu.github.io/vimb/")
572 (synopsis "Fast and lightweight Vim-like web browser")
573 (description "Vimb is a fast and lightweight vim like web browser based on
574 the webkit web browser engine and the GTK toolkit. Vimb is modal like the great
575 vim editor and also easily configurable during runtime. Vimb is mostly keyboard
576 driven and does not detract you from your daily work.")
577 (license license:gpl3+)))
578
579 (define-public nyxt
580 (package
581 (name "nyxt")
582 (version "2.2.4")
583 (source
584 (origin
585 (method git-fetch)
586 (uri (git-reference
587 (url "https://github.com/atlas-engineer/nyxt")
588 (commit version)))
589 (sha256
590 (base32
591 "12l7ir3q29v06jx0zng5cvlbmap7p709ka3ik6x29lw334qshm9b"))
592 (file-name (git-file-name "nyxt" version))))
593 (build-system gnu-build-system)
594 (arguments
595 `(#:make-flags (list "nyxt" "NYXT_SUBMODULES=false"
596 (string-append "DESTDIR=" (assoc-ref %outputs "out"))
597 "PREFIX=")
598 #:strip-binaries? #f ; Stripping breaks SBCL binaries.
599 #:phases
600 (modify-phases %standard-phases
601 (delete 'configure)
602 (add-before 'build 'fix-common-lisp-cache-folder
603 (lambda _
604 (setenv "HOME" "/tmp")
605 #t))
606 (add-before 'check 'configure-tests
607 (lambda _
608 (setenv "NYXT_TESTS_NO_NETWORK" "1")
609 (setenv "NYXT_TESTS_ERROR_ON_FAIL" "1")
610 #t))
611 (add-after 'install 'wrap-program
612 (lambda* (#:key inputs outputs #:allow-other-keys)
613 (let* ((bin (string-append (assoc-ref outputs "out") "/bin/nyxt"))
614 (glib-networking (assoc-ref inputs "glib-networking"))
615 (libs '("gsettings-desktop-schemas"))
616 (path (string-join
617 (map (lambda (lib)
618 (string-append (assoc-ref inputs lib) "/lib"))
619 libs)
620 ":"))
621 (gi-path (getenv "GI_TYPELIB_PATH"))
622 (xdg-path (string-join
623 (map (lambda (lib)
624 (string-append (assoc-ref inputs lib) "/share"))
625 libs)
626 ":")))
627 (wrap-program bin
628 `("GIO_EXTRA_MODULES" prefix
629 (,(string-append glib-networking "/lib/gio/modules")))
630 `("GI_TYPELIB_PATH" prefix (,gi-path))
631 `("LD_LIBRARY_PATH" ":" prefix (,path))
632 `("XDG_DATA_DIRS" ":" prefix (,xdg-path)))
633 #t))))))
634 (native-inputs
635 `(("prove" ,sbcl-prove)
636 ("sbcl" ,sbcl)))
637 (inputs
638 `(("alexandria" ,sbcl-alexandria)
639 ("bordeaux-threads" ,sbcl-bordeaux-threads)
640 ("cl-base64" ,sbcl-cl-base64)
641 ("cl-calispel" ,sbcl-calispel)
642 ("cl-containers" ,sbcl-cl-containers)
643 ("cl-css" ,sbcl-cl-css)
644 ("cl-custom-hash-table" ,sbcl-custom-hash-table)
645 ("cl-html-diff" ,sbcl-cl-html-diff)
646 ("cl-json" ,sbcl-cl-json)
647 ("cl-ppcre" ,sbcl-cl-ppcre)
648 ("cl-prevalence" ,sbcl-cl-prevalence)
649 ("cl-qrencode" ,sbcl-cl-qrencode)
650 ("closer-mop" ,sbcl-closer-mop)
651 ("cluffer" ,sbcl-cluffer)
652 ("dexador" ,sbcl-dexador)
653 ("enchant" ,sbcl-enchant)
654 ("flexi-streams" ,cl-flexi-streams)
655 ("fset" ,sbcl-fset)
656 ("hu.dwim.defclass-star" ,sbcl-hu.dwim.defclass-star)
657 ("iolib" ,sbcl-iolib)
658 ("local-time" ,sbcl-local-time)
659 ("log4cl" ,sbcl-log4cl)
660 ("lparallel" ,sbcl-lparallel)
661 ("mk-string-metrics" ,sbcl-mk-string-metrics)
662 ("moptilities" ,sbcl-moptilities)
663 ("named-readtables" ,sbcl-named-readtables)
664 ("parenscript" ,sbcl-parenscript)
665 ("plump" ,sbcl-plump)
666 ("clss" ,sbcl-clss)
667 ("quri" ,sbcl-quri)
668 ("serapeum" ,sbcl-serapeum)
669 ("spinneret" ,sbcl-spinneret)
670 ("str" ,sbcl-cl-str)
671 ("swank" ,sbcl-slime-swank)
672 ("trivia" ,sbcl-trivia)
673 ("trivial-clipboard" ,sbcl-trivial-clipboard)
674 ("trivial-features" ,sbcl-trivial-features)
675 ("trivial-package-local-nicknames" ,sbcl-trivial-package-local-nicknames)
676 ("trivial-types" ,sbcl-trivial-types)
677 ("unix-opts" ,sbcl-unix-opts)
678 ;; WebKitGTK deps
679 ("cl-cffi-gtk" ,sbcl-cl-cffi-gtk)
680 ("cl-webkit" ,sbcl-cl-webkit)
681 ("glib-networking" ,glib-networking)
682 ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
683 ;; GObjectIntrospection
684 ("cl-gobject-introspection" ,sbcl-cl-gobject-introspection)
685 ("gtk" ,gtk+) ; For the main loop.
686 ("webkitgtk" ,webkitgtk) ; Required when we use its typelib.
687 ("gobject-introspection" ,gobject-introspection)))
688 (synopsis "Extensible web-browser in Common Lisp")
689 (home-page "https://nyxt.atlas.engineer")
690 (description "Nyxt is a keyboard-oriented, extensible web-browser designed
691 for power users. The application has familiar Emacs and VI key-bindings and
692 is fully configurable and extensible in Common Lisp.")
693 (license license:bsd-3)))
694
695 (define-public lagrange
696 (package
697 (name "lagrange")
698 (version "1.12.1")
699 (source
700 (origin
701 (method url-fetch)
702 (uri
703 (string-append "https://git.skyjake.fi/skyjake/lagrange/releases/"
704 "download/v" version "/lagrange-" version ".tar.gz"))
705 (sha256
706 (base32 "10v4bp5h1qq24by61yw52rr13m23smfj2whxfzcxc34qgsdjsd4a"))
707 (modules '((guix build utils)))
708 (snippet
709 '(begin
710 ;; TODO: unbundle fonts.
711 (delete-file-recursively "lib/fribidi")
712 (delete-file-recursively "lib/harfbuzz")))))
713 (build-system cmake-build-system)
714 (arguments
715 `(#:tests? #false ;no tests
716 #:configure-flags (list "-DTFDN_ENABLE_SSE41=OFF")))
717 (native-inputs
718 (list pkg-config zip))
719 (inputs
720 (list freetype
721 fribidi
722 harfbuzz
723 libunistring
724 libwebp
725 mpg123
726 openssl
727 pcre
728 sdl2
729 zlib))
730 (home-page "https://gmi.skyjake.fi/lagrange/")
731 (synopsis "Graphical Gemini client")
732 (description
733 "Lagrange is a desktop GUI client for browsing Geminispace. It offers
734 modern conveniences familiar from web browsers, such as smooth scrolling,
735 inline image viewing, multiple tabs, visual themes, Unicode fonts, bookmarks,
736 history, and page outlines.")
737 (properties
738 '((release-monitoring-url . "https://git.skyjake.fi/gemini/lagrange/releases")))
739 (license license:bsd-2)))
740
741 (define-public gmni
742 (package
743 (name "gmni")
744 (version "1.0")
745 (source (origin
746 (method git-fetch)
747 (uri (git-reference
748 (url "https://git.sr.ht/~sircmpwn/gmni")
749 (commit version)))
750 (sha256
751 (base32
752 "0bky9fd8iyr13r6gj4aynb7j9nd36xdprbgq6nh5hz6jiw04vhfw"))
753 (file-name (git-file-name name version))))
754 (build-system gnu-build-system)
755 (arguments
756 (list
757 #:tests? #f ;no check target
758 #:make-flags #~(list #$(string-append "CC=" (cc-for-target)))))
759 (inputs
760 (list bearssl))
761 (native-inputs
762 (list pkg-config scdoc))
763 (home-page "https://sr.ht/~sircmpwn/gmni")
764 (synopsis "Minimalist command line Gemini client")
765 (description "The gmni package includes:
766
767 @itemize
768 @item A CLI utility (like curl): gmni
769 @item A line-mode browser: gmnlm
770 @end itemize")
771 (license (list license:gpl3+
772 (license:non-copyleft
773 "https://curl.se/docs/copyright.html"
774 "Used only for files taken from curl.")))))
775
776 (define-public bombadillo
777 (package
778 (name "bombadillo")
779 (version "2.4.0")
780 (source (origin
781 (method git-fetch)
782 (uri (git-reference
783 (url "https://tildegit.org/sloum/bombadillo")
784 (commit version)))
785 (sha256
786 (base32
787 "03gcd813bmiy7ad179zg4p61nfa9z5l94sdmsmmn2x204h1ksd8n"))
788 (file-name (git-file-name name version))))
789 (build-system go-build-system)
790 (arguments
791 (list
792 #:import-path "tildegit.org/sloum/bombadillo"
793 #:install-source? #f
794 #:phases
795 #~(modify-phases %standard-phases
796 (add-after 'install 'install-data
797 (lambda _
798 (let* ((builddir "src/tildegit.org/sloum/bombadillo")
799 (pkg (strip-store-file-name #$output))
800 (sharedir (string-append #$output "/share"))
801 (appdir (string-append sharedir "/applications"))
802 (docdir (string-append sharedir "/doc/" pkg))
803 (mandir (string-append sharedir "/man/man1"))
804 (pixdir (string-append sharedir "/pixmaps")))
805 (with-directory-excursion builddir
806 (install-file "bombadillo.desktop" appdir)
807 (install-file "bombadillo.1" mandir)
808 (install-file "bombadillo-icon.png" pixdir))))))))
809 (home-page "https://bombadillo.colorfield.space")
810 (synopsis "Terminal browser for the gopher, gemini, and finger protocols")
811 (description "Bombadillo is a non-web browser for the terminal with
812 vim-like key bindings, a document pager, configurable settings, and robust
813 command selection. The following protocols are supported as first-class
814 citizens: gopher, gemini, finger, and local. There is also support for telnet,
815 http, and https via third-party applications.")
816 (license license:gpl3+)))
817
818 (define-public tinmop
819 (package
820 (name "tinmop")
821 (version "0.9.6")
822 (source
823 (origin
824 (method git-fetch)
825 (uri (git-reference
826 (url "https://notabug.org/cage/tinmop")
827 (commit (string-append "v" version))))
828 (file-name (git-file-name name version))
829 (sha256
830 (base32 "19rr1wcadm4698q5gyq0pxv81220l5g8zfnp61s43a4q7kn4mi1z"))))
831 (build-system gnu-build-system)
832 (native-inputs
833 (list autoconf
834 automake
835 gnu-gettext
836 mandoc
837 nano
838 openssl
839 sbcl
840 unzip
841 xdg-utils))
842 (inputs
843 (list ncurses
844 sbcl-access
845 sbcl-alexandria
846 sbcl-babel
847 sbcl-bordeaux-threads
848 sbcl-cl+ssl
849 sbcl-cl-base64
850 sbcl-cl-colors2
851 sbcl-cl-html5-parser
852 sbcl-cl-i18n
853 sbcl-cl-ppcre
854 sbcl-cl-spark
855 sbcl-cl-sqlite
856 sbcl-clunit2
857 sbcl-croatoan
858 sbcl-crypto-shortcuts
859 sbcl-drakma
860 sbcl-esrap
861 sbcl-ieee-floats
862 sbcl-local-time
863 sbcl-log4cl
864 sbcl-marshal
865 sbcl-osicat
866 sbcl-parse-number
867 sbcl-percent-encoding
868 sbcl-purgatory
869 sbcl-sxql
870 sbcl-sxql-composer
871 sbcl-tooter
872 sbcl-trivial-clipboard
873 sbcl-unix-opts
874 sbcl-usocket
875 sqlite))
876 (arguments
877 `(#:tests? #f
878 #:strip-binaries? #f
879 #:phases
880 (modify-phases %standard-phases
881 (add-after 'unpack 'set-home
882 (lambda _
883 (setenv "HOME" "/tmp")
884 #t))
885 (add-after 'unpack 'fix-configure.ac
886 (lambda _
887 (delete-file "configure")
888 (substitute* "configure.ac"
889 (("AC_PATH_PROG.+CURL")
890 "dnl")
891 (("AC_PATH_PROGS.+GIT")
892 "dnl")
893 (("AC_PATH_PROG.+GPG")
894 "dnl"))
895 #t))
896 (add-after 'configure 'fix-asdf
897 (lambda* (#:key inputs #:allow-other-keys)
898 (substitute* "Makefile.in"
899 (("LISP_COMPILER) ")
900 (string-concatenate
901 '("LISP_COMPILER) --eval \"(require 'asdf)\" "
902 "--eval \"(push \\\"$$(pwd)/\\\" asdf:*central-registry*)\" "))))
903 #t)))))
904 (synopsis "Gemini, kami and pleroma client with a terminal interface")
905 (description
906 "This package provides a Gemini, kami and pleroma client with a terminal
907 interface.")
908 (home-page "https://www.autistici.org/interzona/tinmop.html")
909 (license license:gpl3+)))
910
911 (define-public telescope
912 (package
913 (name "telescope")
914 (version "0.7.1")
915 (source
916 (origin
917 (method url-fetch)
918 (uri (string-append "https://github.com/omar-polo/telescope/releases/download/"
919 version "/telescope-" version ".tar.gz"))
920 (sha256
921 (base32 "055iqld99l4jshs10mhl2ml0p74wcyyv5kxjy8izzysw9lnkjjb5"))))
922 (build-system gnu-build-system)
923 (arguments
924 `(#:tests? #f)) ;no tests
925 (native-inputs
926 (list gettext-minimal pkg-config))
927 (inputs
928 (list libevent libressl ncurses))
929 (home-page "https://git.omarpolo.com/telescope/about/")
930 (synopsis "Gemini client with a terminal interface")
931 (description "Telescope is a w3m-like browser for Gemini.")
932 (license license:x11)))
933
934 (define-public leo
935 ;; PyPi only provides a wheel.
936 (let ((commit "88cc10a87afe2ec86be06e6ea2bcd099f5360b74")
937 (version "1.0.4")
938 (revision "1"))
939 (package
940 (name "leo")
941 (version (git-version version revision commit))
942 (source
943 (origin
944 (method git-fetch)
945 (uri (git-reference
946 (url "https://github.com/xyzshantaram/leo")
947 (commit commit)))
948 (file-name (git-file-name name version))
949 (sha256
950 (base32 "0jp4v4jw82qqynqqs7x35g5yvm1sd48cvbqh7j2r1ixw1z6ldhc4"))))
951 (build-system python-build-system)
952 (home-page "https://github.com/xyzshantaram/leo")
953 (synopsis "Gemini client written in Python")
954 (description
955 "@command{leo} is a gemini client written in Python with no external
956 dependencies that fully implements the Gemini spec. A list of URLs can be
957 saved to a file for further viewing in another window.")
958 (license license:expat))))
959
960 (define-public av-98
961 (package
962 (name "av-98")
963 (version "1.0.1")
964 (properties
965 '((upstream-name . "AV-98")))
966 (source
967 (origin
968 (method url-fetch)
969 (uri (pypi-uri "AV-98" version))
970 (sha256
971 (base32
972 "02fjnc2rvm010gb3i07p8r4xlhrmnv1wca1qymfjcymr7vm68h0i"))))
973 (build-system python-build-system)
974 (home-page "https://tildegit.org/solderpunk/AV-98/")
975 (synopsis "Command line Gemini client")
976 (description "AV-98 is an experimental client for the Gemini protocol.
977 Features include
978 @itemize
979 @item TOFU or CA server certificate validation;
980 @item Extensive client certificate support if an openssl binary is available;
981 @item Ability to specify external handler programs for different MIME types;
982 @item Gopher proxy support;
983 @item Advanced navigation tools like tour and mark (as per VF-1);
984 @item Bookmarks;
985 @item IPv6 support;
986 @item Support for any character encoding recognised by Python.
987 @end itemize")
988 (license license:bsd-2)))