gnu: Add wlgreet.
[jackhill/guix/guix.git] / gnu / packages / file.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
5 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
6 ;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
7 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
8 ;;; Copyright © 2021 Marius Bakke <marius@gnu.org>
9 ;;;
10 ;;; This file is part of GNU Guix.
11 ;;;
12 ;;; GNU Guix is free software; you can redistribute it and/or modify it
13 ;;; under the terms of the GNU General Public License as published by
14 ;;; the Free Software Foundation; either version 3 of the License, or (at
15 ;;; your option) any later version.
16 ;;;
17 ;;; GNU Guix is distributed in the hope that it will be useful, but
18 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
19 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
20 ;;; GNU General Public License for more details.
21 ;;;
22 ;;; You should have received a copy of the GNU General Public License
23 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
24
25 (define-module (gnu packages file)
26 #:use-module (gnu packages)
27 #:use-module (guix licenses)
28 #:use-module (guix packages)
29 #:use-module (guix download)
30 #:use-module (guix build-system gnu))
31
32 (define-public file
33 (package
34 (name "file")
35 (version "5.39")
36 (source (origin
37 (method url-fetch)
38 (uri (string-append "ftp://ftp.astron.com/pub/file/file-"
39 version ".tar.gz"))
40 (sha256
41 (base32
42 "1lgs2w2sgamzf27kz5h7pajz7v62554q21fbs11n4mfrfrm2hpgh"))))
43 (build-system gnu-build-system)
44
45 ;; When cross-compiling, this package depends upon a native install of
46 ;; itself.
47 (native-inputs (if (%current-target-system)
48 `(("self" ,this-package))
49 '()))
50
51 (properties
52 `((release-monitoring-url . "http://ftp.astron.com/pub/file/")))
53 (synopsis "File type guesser")
54 (description
55 "The file command is a file type guesser, a command-line tool that tells
56 you in words what kind of data a file contains. It does not rely on filename
57 extensions to tell you the type of a file, but looks at the actual contents
58 of the file. This package provides the libmagic library.")
59 (license bsd-2)
60 (home-page "https://www.darwinsys.com/file/")))
61
62 (define-public file-next
63 (package
64 (inherit file)
65 (version "5.41")
66 (source (origin
67 (method url-fetch)
68 (uri (string-append "http://ftp.astron.com/pub/file/file-"
69 version ".tar.gz"))
70 (sha256
71 (base32
72 "0gv027jgdr0hdkw7m9ck0nwhq583f4aa7vnz4dzdbxv4ng3k5r8k"))))))