gnu: rpm: Update to 4.12.0.1.
[jackhill/guix/guix.git] / gnu / packages / tre.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 John Darrington
3 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages tre)
21 #:use-module (gnu packages)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (guix licenses))
26
27 (define-public tre
28 (package
29 (name "tre")
30 (version "0.8.0")
31 (source
32 (origin
33 (method url-fetch)
34 (uri
35 (string-append "http://laurikari.net/tre/" name "-" version
36 ".tar.bz2"))
37 (sha256
38 (base32 "0n36cgqys59r2gmb7jzbqiwsy790v8nbxk82d2n2saz0rp145ild"))))
39
40 (build-system gnu-build-system)
41 (arguments
42 `(#:phases (alist-cons-before
43 'check 'install-locales
44 (lambda _
45 ;; The tests require the availability of the
46 ;; 'en_US.ISO-8859-1' locale.
47 (setenv "LOCPATH" (getcwd))
48 (zero? (system* "localedef" "--no-archive"
49 "--prefix" (getcwd) "-i" "en_US"
50 "-f" "ISO-8859-1" "./en_US.ISO-8859-1")))
51 %standard-phases)))
52 (synopsis "Approximate regex matching library and agrep utility")
53 (description "Superset of the POSIX regex API, enabling approximate
54 matching. Also ships a version of the agrep utility which behaves similar to
55 grep but features inexact matching.")
56 (home-page "http://laurikari.net/tre")
57 (license bsd-2)))