gnu: rpm: Update to 4.12.0.1.
[jackhill/guix/guix.git] / gnu / packages / openstack.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Cyril Roelandt <tipecaml@gmail.com>
3 ;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages openstack)
21 #:use-module (gnu packages python)
22 #:use-module (gnu packages tls)
23 #:use-module (guix build-system python)
24 #:use-module (guix download)
25 #:use-module ((guix licenses)
26 #:select (asl2.0))
27 #:use-module (guix packages)
28 #:use-module (srfi srfi-1))
29
30 (define-public python-bandit
31 (package
32 (name "python-bandit")
33 (version "0.13.2")
34 (source
35 (origin
36 (method url-fetch)
37 (uri (string-append
38 "https://pypi.python.org/packages/source/b/bandit/bandit-"
39 version ".tar.gz"))
40 (sha256
41 (base32
42 "03g3cflvrc99ncjd611iy5nnnscsc2vgnrx4mjaqyx8glbfw8y7g"))))
43 (build-system python-build-system)
44 (propagated-inputs
45 `(("python-appdirs" ,python-appdirs)
46 ("python-pyyaml" ,python-pyyaml)
47 ("python-six" ,python-six)
48 ("python-stevedore" ,python-stevedore)))
49 (inputs
50 `(("python-pbr" ,python-pbr)
51 ("python-setuptools" ,python-setuptools)
52 ;; Tests
53 ("python-fixtures" ,python-fixtures)
54 ("python-mock" ,python-mock)
55 ("python-testrepository" ,python-testrepository)
56 ("python-testscenarios" ,python-testscenarios)
57 ("python-testtools" ,python-testtools)))
58 (home-page "https://wiki.openstack.org/wiki/Security/Projects/Bandit")
59 (synopsis "Security oriented static analyser for python code.")
60 (description
61 "Bandit is a tool designed to find common security issues in Python code.
62 To do this Bandit processes each file, builds an AST from it, and runs
63 appropriate plugins against the AST nodes. Once Bandit has finished scanning
64 all the files it generates a report.")
65 (license asl2.0)))
66
67 (define-public python2-bandit
68 (package-with-python2 python-bandit))
69
70 (define-public python-debtcollector
71 (package
72 (name "python-debtcollector")
73 (version "1.0.0")
74 (source
75 (origin
76 (method url-fetch)
77 (uri (pypi-uri "debtcollector" version))
78 (sha256
79 (base32
80 "0g4dfskaiy47rhsh4gh66l5vmdsrgq0qk68pl3ix1cj3ffvfndzv"))))
81 (build-system python-build-system)
82 (propagated-inputs
83 `(("python-six" ,python-six)
84 ("python-wrapt" ,python-wrapt)))
85 (inputs
86 `(("python-babel" ,python-babel)
87 ("python-pbr" ,python-pbr)
88 ("python-setuptools" ,python-setuptools)
89 ;; Tests.
90 ("python-oslotest" ,python-oslotest)))
91 (home-page "http://www.openstack.org/")
92 (synopsis
93 "Find deprecated patterns and strategies in Python code")
94 (description
95 "This package provides a collection of Python deprecation patterns and
96 strategies that help you collect your technical debt in a non-destructive
97 manner.")
98 (license asl2.0)))
99
100 (define-public python2-debtcollector
101 (package-with-python2 python-debtcollector))
102
103 (define-public python-hacking
104 (package
105 (name "python-hacking")
106 (version "0.10.2")
107 (source
108 (origin
109 (method url-fetch)
110 (uri (pypi-uri "hacking" version))
111 (sha256
112 (base32
113 "1a310k3dv04jg7zvmk37h2ql7y9kf4hvdxb74bjlwdxgmy6h4wap"))))
114 (build-system python-build-system)
115 (propagated-inputs
116 `(("python-flake8-2.2.4" ,python-flake8-2.2.4)
117 ("python-mccabe-0.2.1" ,python-mccabe-0.2.1)
118 ("python-pbr" ,python-pbr)
119 ("python-pep8-1.5.7" ,python-pep8-1.5.7)
120 ("python-pyflakes-0.8.1" ,python-pyflakes-0.8.1)
121 ("python-six" ,python-six)))
122 (inputs
123 `(("python-setuptools" ,python-setuptools)
124 ;; Tests
125 ("python-testscenarios" ,python-testscenarios)))
126 (home-page "http://github.com/openstack-dev/hacking")
127 (synopsis "OpenStack hacking guideline enforcement")
128 (description
129 "Python-hacking is a set of flake8 plugins that test and enforce the
130 @uref{http://docs.openstack.org/developer/hacking/, OpenStack style
131 guidelines}.")
132 (license asl2.0)))
133
134 (define-public python2-hacking
135 (package-with-python2 python-hacking))
136
137 (define-public python-mox3
138 (package
139 (name "python-mox3")
140 (version "0.14.0")
141 (source
142 (origin
143 (method url-fetch)
144 (uri (pypi-uri "mox3" version))
145 (sha256
146 (base32
147 "0njmh40i1lg5mzn9hc2ax83adj6dli455j6xifilrw27c4wlkjzx"))))
148 (build-system python-build-system)
149 (native-inputs
150 `(("python-fixtures" ,python-fixtures)
151 ("python-pbr" ,python-pbr)
152 ("python-setuptools" ,python-setuptools)
153 ("python-six" ,python-six)
154 ("python-testtools" ,python-testtools)))
155 (home-page "http://www.openstack.org/")
156 (synopsis "Mock object framework for Python")
157 (description
158 "Mox3 is an unofficial port of the Google mox framework
159 (http://code.google.com/p/pymox/) to Python 3. It was meant to be as compatible
160 with mox as possible, but small enhancements have been made. The library was
161 tested on Python version 3.2, 2.7 and 2.6.")
162 (license asl2.0)))
163
164 (define-public python2-mox3
165 (package-with-python2 python-mox3))
166
167 (define-public python-os-client-config
168 (package
169 (name "python-os-client-config")
170 (version "1.12.0")
171 (source
172 (origin
173 (method url-fetch)
174 (uri (pypi-uri "os-client-config" version))
175 (sha256
176 (base32
177 "1vjn7667pswnmpqv6ngwyqm2xn46w90hi5b4pv2grwfz751cn1lf"))))
178 (build-system python-build-system)
179 (arguments
180 `(#:tests? #f)) ;; Circular dependency with python-oslotest
181 (inputs
182 `(("python-appdirs" ,python-appdirs)
183 ("python-fixtures" ,python-fixtures)
184 ("python-mimeparse" ,python-mimeparse)
185 ("python-pbr" ,python-pbr)
186 ("python-pyyaml" ,python-pyyaml)
187 ("python-testrepository" ,python-testrepository)
188 ("python-setuptools" ,python-setuptools)
189 ("python-testscenarios" ,python-testscenarios)
190 ("python-testtools" ,python-testtools)))
191 (home-page "http://www.openstack.org/")
192 (synopsis
193 "OpenStack Client Configuration Library")
194 (description
195 "The OpenStack Client Configuration Library is a library for collecting
196 client configuration for using an OpenStack cloud in a consistent and
197 comprehensive manner.")
198 (license asl2.0)))
199
200 (define-public python2-os-client-config
201 (package-with-python2 python-os-client-config))
202
203 (define-public python-os-testr
204 (package
205 (name "python-os-testr")
206 (version "0.5.0")
207 (source
208 (origin
209 (method url-fetch)
210 (uri (pypi-uri "os-testr" version))
211 (sha256
212 (base32
213 "0bv03wnmvxhyi8y08hjh9clxrwqc2251529v4kh5khvca0fsbqdp"))))
214 (build-system python-build-system)
215 (arguments
216 ;; os-testr uses itself to run the tests. It seems like pbr writes the
217 ;; exectuable in the virtualenv when using tox. Not sure how to do this
218 ;; when building the package. Skip the tests for now.
219 `(#:tests? #f))
220 (propagated-inputs
221 `(("python-pbr" ,python-pbr)
222 ("python-subunit" ,python-subunit)
223 ("python-testtools" ,python-testtools)))
224 (inputs
225 `(("python-babel" ,python-babel)
226 ("python-setuptools" ,python-setuptools)))
227 (home-page "http://www.openstack.org/")
228 (synopsis "Testr wrapper to provide functionality for OpenStack projects")
229 (description
230 "Os-testr provides developers with a testr wrapper and an output filter
231 for subunit.")
232 (license asl2.0)))
233
234 (define-public python2-os-testr
235 (package-with-python2 python-os-testr))
236
237 (define-public python-requests-mock
238 (package
239 (name "python-requests-mock")
240 (version "0.7.0")
241 (source
242 (origin
243 (method url-fetch)
244 (uri (pypi-uri "requests-mock" version))
245 (sha256
246 (base32
247 "0s6mrpiv2w0km39qvl1pq2d56xblnm57p369qdp5j1a55ncica7f"))))
248 (build-system python-build-system)
249 (propagated-inputs
250 `(("python-requests" ,python-requests)
251 ("python-six" ,python-six)))
252 (inputs
253 `(("python-mock" ,python-mock)
254 ("python-pbr" ,python-pbr)
255 ("python-setuptools" ,python-setuptools)))
256 (home-page "https://requests-mock.readthedocs.org/")
257 (synopsis "Mock out responses from the requests package")
258 (description
259 "This module provides a building block to stub out the HTTP requests
260 portions of your testing code.")
261 (license asl2.0)))
262
263 (define-public python2-requests-mock
264 (package-with-python2 python-requests-mock))
265
266 (define-public python-stevedore
267 (package
268 (name "python-stevedore")
269 (version "1.12.0")
270 (source
271 (origin
272 (method url-fetch)
273 (uri (pypi-uri "stevedore" version))
274 (sha256
275 (base32
276 "0999zvawaapzg6givjhn7vjscdwblcs73wf28wq1wb4g5mbb5phv"))))
277 (build-system python-build-system)
278 (propagated-inputs
279 `(("python-six" ,python-six)))
280 (inputs
281 `(("python-pbr" ,python-pbr)))
282 (native-inputs
283 `(("python-setuptools" ,python-setuptools)
284 ;; Tests
285 ("python-docutils" ,python-docutils)
286 ("python-mock" ,python-mock)
287 ("python-oslotest" ,python-oslotest)
288 ("python-sphinx" ,python-sphinx)))
289 (home-page "https://github.com/dreamhost/stevedore")
290 (synopsis "Manage dynamic plugins for Python applications")
291 (description
292 "Python makes loading code dynamically easy, allowing you to configure
293 and extend your application by discovering and loading extensions (\"plugins\")
294 at runtime. Many applications implement their own library for doing this,
295 using __import__ or importlib. Stevedore avoids creating yet another extension
296 mechanism by building on top of setuptools entry points. The code for managing
297 entry points tends to be repetitive, though, so stevedore provides manager
298 classes for implementing common patterns for using dynamically loaded
299 extensions.")
300 (license asl2.0)))
301
302 (define-public python2-stevedore
303 (package-with-python2 python-stevedore))
304
305 (define-public python-tempest-lib
306 (package
307 (name "python-tempest-lib")
308 (version "0.12.0")
309 (source
310 (origin
311 (method url-fetch)
312 (uri (pypi-uri "tempest-lib" version))
313 (sha256
314 (base32
315 "0f15wxk394cb2kw34krpxq8mvy1rxw0lnl5wfiv14cq1s1fm9cjd"))))
316 (build-system python-build-system)
317 (arguments
318 `(#:phases
319 (modify-phases %standard-phases
320 (add-before
321 'check 'pre-check
322 (lambda _
323 (substitute* "tempest_lib/tests/cli/test_execute.py"
324 (("/bin/ls") (which "ls"))))))))
325 (propagated-inputs
326 `(("python-fixtures" ,python-fixtures)
327 ("python-httplib2" ,python-httplib2)
328 ("python-iso8601" ,python-iso8601)
329 ("python-jsonschema" ,python-jsonschema)
330 ("python-oslo.log" ,python-oslo.log)
331 ("python-paramiko" ,python-paramiko)
332 ("python-pbr" ,python-pbr)
333 ("python-six" ,python-six)))
334 (inputs
335 `(("python-babel" ,python-babel)
336 ("python-mock" ,python-mock)
337 ("python-os-testr" ,python-os-testr)
338 ("python-oslotest" ,python-oslotest)
339 ("python-setuptools" ,python-setuptools)))
340 (home-page "http://www.openstack.org/")
341 (synopsis "OpenStack functional testing library")
342 (description
343 "Tempest-lib is a functional testing library for OpenStack. It provides
344 common features used in Tempest.")
345 (license asl2.0)))
346
347 (define-public python2-tempest-lib
348 (package-with-python2 python-tempest-lib))
349
350 ;; Packages from the Oslo library
351 (define-public python-oslo.config
352 (package
353 (name "python-oslo.config")
354 (version "2.4.0")
355 (source
356 (origin
357 (method url-fetch)
358 (uri (string-append
359 "https://pypi.python.org/packages/source/o/oslo.config/oslo.config-"
360 version
361 ".tar.gz"))
362 (sha256
363 (base32
364 "13r778jfb0fhna37c2pd1f2xipnsbd7zli7qhn96acrzymrwj5k1"))))
365 (build-system python-build-system)
366 (propagated-inputs
367 `(("python-netaddr" ,python-netaddr)
368 ("python-six" ,python-six)
369 ("python-stevedore" ,python-stevedore)))
370 (inputs
371 `(("python-pbr" ,python-pbr)
372 ("python-setuptools" ,python-setuptools)
373 ;; Tests
374 ("python-oslo.i18n" ,python-oslo.i18n)
375 ("python-mock" ,python-mock)
376 ("python-oslotest" ,python-oslotest)
377 ("python-testscenarios" ,python-testscenarios)))
378 (home-page "https://launchpad.net/oslo")
379 (synopsis "Oslo Configuration API")
380 (description
381 "The Oslo configuration API supports parsing command line arguments and
382 .ini style configuration files.")
383 (license asl2.0)))
384
385 (define-public python2-oslo.config
386 (package-with-python2 python-oslo.config))
387
388 (define-public python-oslo.context
389 (package
390 (name "python-oslo.context")
391 (version "1.0.0")
392 (source
393 (origin
394 (method url-fetch)
395 (uri (pypi-uri "oslo.context" version))
396 (sha256
397 (base32
398 "0kvha0rs9295njyl2z6n6zm5dapi5mrl5zwjm0m6ldqrvccyf8c3"))))
399 (build-system python-build-system)
400 (inputs
401 `(("python-babel" ,python-babel)
402 ("python-pbr" ,python-pbr)
403 ("python-setuptools" ,python-setuptools)
404 ;; Tests.
405 ("python-oslotest" ,python-oslotest)))
406 (home-page "http://launchpad.net/oslo")
407 (synopsis "Oslo context library")
408 (description
409 "The Oslo context library has helpers to maintain useful information
410 about a request context. The request context is usually populated in the WSGI
411 pipeline and used by various modules such as logging.")
412 (license asl2.0)))
413
414 (define-public python2-oslo.context
415 (package-with-python2 python-oslo.context))
416
417 (define-public python-oslo.i18n
418 (package
419 (name "python-oslo.i18n")
420 (version "3.0.0")
421 (source
422 (origin
423 (method url-fetch)
424 (uri (pypi-uri "oslo.i18n" version))
425 (sha256
426 (base32
427 "0bpb1c20sm8my650gl824nzaip83bfn8hr91s65k5ncmyh8hb6pl"))))
428 (build-system python-build-system)
429 (propagated-inputs
430 `(("python-babel" ,python-babel)
431 ("python-six" ,python-six)))
432 (inputs
433 `(("python-pbr" ,python-pbr)
434 ("python-setuptools" ,python-setuptools)
435 ;; Tests
436 ("python-mock" ,python-mock)
437 ("python-mox3" ,python-mox3)
438 ("python-oslotest" ,python-oslotest)
439 ("python-testscenarios" ,python-testscenarios)))
440 (home-page "http://launchpad.net/oslo")
441 (synopsis "Oslo internationalization (i18n) library")
442 (description
443 "The oslo.i18n library contain utilities for working with
444 internationalization (i18n) features, especially translation for text strings
445 in an application or library.")
446 (license asl2.0)))
447
448 (define-public python2-oslo.i18n
449 (package-with-python2 python-oslo.i18n))
450
451 (define-public python-oslo.log
452 (package
453 (name "python-oslo.log")
454 (version "1.6.0")
455 (source
456 (origin
457 (method url-fetch)
458 (uri (string-append
459 "https://pypi.python.org/packages/source/o/oslo.log/oslo.log-"
460 version
461 ".tar.gz"))
462 (sha256
463 (base32
464 "1fhy6yvbd565nv4x4i3ppyrlbmz3yy9d0xsvw5nkqsa7g43nmf8z"))))
465 (build-system python-build-system)
466 (propagated-inputs
467 `(("python-debtcollector" ,python-debtcollector)
468 ("python-oslo.config" ,python-oslo.config)
469 ("python-oslo.context" ,python-oslo.context)
470 ("python-oslo.i18n" ,python-oslo.i18n)
471 ("python-oslo.utils" ,python-oslo.utils)
472 ("python-oslo.serialization" ,python-oslo.serialization)
473 ("python-six" ,python-six)))
474 (inputs
475 `(("python-babel" ,python-babel)
476 ("python-iso8601" ,python-iso8601)
477 ("python-mock" ,python-mock)
478 ("python-oslotest" ,python-oslotest)
479 ("python-pbr" ,python-pbr)
480 ("python-setuptools" ,python-setuptools)))
481 (home-page "http://launchpad.net/oslo")
482 (synopsis "Python logging library of the Oslo project")
483 (description
484 "The oslo.log (logging) configuration library provides standardized
485 configuration for all OpenStack projects. It also provides custom formatters,
486 handlers and support for context specific logging (like resource id’s etc).")
487 (license asl2.0)))
488
489 (define-public python2-oslo.log
490 (package-with-python2 python-oslo.log))
491
492 (define-public python-oslo.serialization
493 (package
494 (name "python-oslo.serialization")
495 (version "2.2.0")
496 (source
497 (origin
498 (method url-fetch)
499 (uri (pypi-uri "oslo.serialization" version))
500 (sha256
501 (base32
502 "00s03krhf833gs76aw5ns32w9m1i4hx6x6d9g82m0j5wyqk0sci4"))))
503 (build-system python-build-system)
504 (propagated-inputs
505 `(("python-iso8601" ,python-iso8601)
506 ("python-netaddr" ,python-netaddr)
507 ("python-oslo.utils" ,python-oslo.utils)
508 ("python-simplejson" ,python-simplejson)
509 ("python-six" ,python-six)
510 ("python-pytz" ,python-pytz)))
511 (inputs
512 `(("python-babel" ,python-babel)
513 ("python-pbr" ,python-pbr)
514 ("python-setuptools" ,python-setuptools)
515 ;; Tests.
516 ("python-mock" ,python-mock)
517 ("python-oslo.i18n" ,python-oslo.i18n)
518 ("python-oslotest" ,python-oslotest)))
519 (home-page "http://launchpad.net/oslo")
520 (synopsis "Oslo serialization library")
521 (description
522 "The oslo.serialization library provides support for representing objects
523 in transmittable and storable formats, such as JSON and MessagePack.")
524 (license asl2.0)))
525
526 (define-public python2-oslo.serialization
527 (package-with-python2 python-oslo.serialization))
528
529 (define-public python-oslosphinx
530 (package
531 (name "python-oslosphinx")
532 (version "4.2.0")
533 (source
534 (origin
535 (method url-fetch)
536 (uri (pypi-uri "oslosphinx" version))
537 (sha256
538 (base32
539 "178svff46pmynpsnw06gpxk0w13p1gwkqbsvyxphblxv9wl09ksz"))))
540 (build-system python-build-system)
541 (propagated-inputs
542 `(("python-requests" ,python-requests)))
543 (inputs
544 `(("python-pbr" ,python-pbr)
545 ("python-docutils" ,python-docutils)
546 ("python-hacking" ,python-hacking)
547 ("python-setuptools" ,python-setuptools)
548 ("python-sphinx" ,python-sphinx)))
549 (home-page "http://www.openstack.org/")
550 (synopsis "OpenStack sphinx extensions and theme")
551 (description
552 "This package provides themes and extensions for Sphinx documentation
553 from the OpenStack project.")
554 (license asl2.0)))
555
556 (define-public python2-oslosphinx
557 (package-with-python2 python-oslosphinx))
558
559 (define-public python-oslotest
560 (package
561 (name "python-oslotest")
562 (version "1.10.0")
563 (source
564 (origin
565 (method url-fetch)
566 (uri (string-append
567 "https://pypi.python.org/packages/source/o/oslotest/oslotest-"
568 version
569 ".tar.gz"))
570 (sha256
571 (base32
572 "0l3ny48ddz5xbf0v4r0jv1yhbdzinc2vy0lybhdkmx3xy0b886fs"))))
573 (build-system python-build-system)
574 (propagated-inputs
575 `(("python-fixtures" ,python-fixtures)
576 ("python-mock" ,python-mock)
577 ("python-mox3" ,python-mox3)
578 ("python-six" ,python-six)))
579 (inputs
580 `(("python-pbr" ,python-pbr)
581 ("python-os-client-config" ,python-os-client-config)
582 ("python-setuptools" ,python-setuptools)
583 ("python-subunit" ,python-subunit)
584 ("python-testrepository" ,python-testrepository)
585 ("python-testscenarios" ,python-testscenarios)
586 ("python-testtools" ,python-testtools)))
587 (home-page "http://launchpad.net/oslo")
588 (synopsis "Oslo test framework")
589 (description
590 "The Oslo Test framework provides common fixtures, support for debugging,
591 and better support for mocking results.")
592 (license asl2.0)))
593
594 (define-public python2-oslotest
595 (package-with-python2 python-oslotest))
596
597 (define-public python-oslo.utils
598 (package
599 (name "python-oslo.utils")
600 (version "3.0.0")
601 (source
602 (origin
603 (method url-fetch)
604 (uri (pypi-uri "oslo.utils" version))
605 (sha256
606 (base32
607 "1c4jrbvfs4hs37fics8frqlyhmsv7v92ncv2cpbm0av9x0ic6pnj"))
608 (snippet
609 '(begin
610 ;; FIXME: setuptools fails to import this file during the test
611 ;; phase.
612 (delete-file "oslo_utils/tests/test_netutils.py")))))
613 (build-system python-build-system)
614 (propagated-inputs
615 `(("python-debtcollector" ,python-debtcollector)
616 ("python-oslo.i18n" ,python-oslo.i18n)
617 ("python-iso8601" ,python-iso8601)
618 ("python-monotonic" ,python-monotonic)
619 ("python-netaddr" ,python-netaddr)
620 ("python-netifaces" ,python-netifaces)
621 ("python-pytz" ,python-pytz)
622 ("python-six" ,python-six)))
623 (inputs
624 `(("python-babel" ,python-babel)
625 ("python-pbr" ,python-pbr)
626 ("python-setuptools" ,python-setuptools)
627 ;; Tests.
628 ("python-oslotest" ,python-oslotest)
629 ("python-mock" ,python-mock)
630 ("python-mox3" ,python-mox3)
631 ("python-testscenarios" ,python-testscenarios)))
632 (home-page "http://launchpad.net/oslo")
633 (synopsis "Oslo utility library")
634 (description
635 "The @code{oslo.utils} library provides support for common utility type
636 functions, such as encoding, exception handling, string manipulation, and time
637 handling.")
638 (license asl2.0)))
639
640 (define-public python2-oslo.utils
641 (package-with-python2 python-oslo.utils))
642
643 (define-public python-keystoneclient
644 (package
645 (name "python-keystoneclient")
646 (version "1.8.1")
647 (source
648 (origin
649 (method url-fetch)
650 (uri (pypi-uri "python-keystoneclient" version))
651 (sha256
652 (base32
653 "1w4csvkah67rfpxylxnvs2s3594i0f9isy8pf4gnsqs5zirvjaa4"))))
654 (build-system python-build-system)
655 (native-inputs
656 `(("python-setuptools" ,python-setuptools)
657 ("python-sphinx" ,python-sphinx)
658 ;; and some packages for the tests
659 ("openssl" ,openssl)
660 ("python-coverage" ,python-coverage)
661 ("python-discover" ,python-discover)
662 ("python-fixtures" ,python-fixtures)
663 ("python-hacking" ,python-hacking)
664 ("python-keyring" ,python-keyring)
665 ("python-lxml" ,python-lxml)
666 ("python-mock" ,python-mock)
667 ("python-mox3" ,python-mox3)
668 ("python-oauthlib" ,python-oauthlib)
669 ("python-oslosphinx" ,python-oslosphinx)
670 ("python-oslotest" ,python-oslotest)
671 ("python-pycrypto" ,python-pycrypto)
672 ("python-requests-mock" ,python-requests-mock)
673 ("python-temptest-lib" ,python-tempest-lib)
674 ("python-testrepository" ,python-testrepository)
675 ("python-testresources" ,python-testresources)
676 ("python-testtools" ,python-testtools)
677 ("python-webob" ,python-webob)))
678 (propagated-inputs
679 `(("python-babel" ,python-babel)
680 ("python-debtcollector" ,python-debtcollector)
681 ("python-iso8601" ,python-iso8601)
682 ("python-netaddr" ,python-netaddr)
683 ("python-oslo.config" ,python-oslo.config)
684 ("python-oslo.i18n" ,python-oslo.i18n)
685 ("python-oslo.serialization" ,python-oslo.serialization)
686 ("python-oslo.utils" ,python-oslo.utils)
687 ("python-pbr" ,python-pbr)
688 ("python-prettytable" ,python-prettytable)
689 ("python-requests" ,python-requests)
690 ("python-six" ,python-six)
691 ("python-stevedore" ,python-stevedore)))
692 (home-page "http://www.openstack.org/")
693 (synopsis "Client Library for OpenStack Identity")
694 (description
695 "Python-keystoneclient is the identity service used by OpenStack for
696 authentication (authN) and high-level authorization (authZ). It currently
697 supports token-based authN with user/service authZ, and is scalable to support
698 OAuth, SAML, and OpenID in future versions. Out of the box, Keystone uses
699 SQLite for its identity store database, with the option to connect to external
700 LDAP.")
701 (license asl2.0)))
702
703 (define-public python2-keystoneclient
704 (let ((keystoneclient (package-with-python2 python-keystoneclient)))
705 (package (inherit keystoneclient)
706 (propagated-inputs
707 `(("python2-requests" ,python2-requests)
708 ,@(alist-delete "python-requests"
709 (package-propagated-inputs keystoneclient))))
710 (native-inputs
711 `(("python2-oauthlib" ,python2-oauthlib)
712 ("python2-oslosphinx" ,python2-oslosphinx)
713 ("python2-requests-mock" ,python2-requests-mock)
714 ("python2-tempest-lib" ,python2-tempest-lib)
715 ,@(fold alist-delete (package-native-inputs keystoneclient)
716 '("python-oauthlib" "python-oslosphinx" "python-requests-mock" "python-tempest-lib")))))))
717
718 (define-public python-swiftclient
719 (package
720 (name "python-swiftclient")
721 (version "2.6.0")
722 (source
723 (origin
724 (method url-fetch)
725 (uri (pypi-uri "python-swiftclient" version))
726 (sha256
727 (base32
728 "1j33l4z9vqh0scfncl4fxg01zr1hgqxhhai6gvcih1gccqm4nd7p"))))
729 (build-system python-build-system)
730 (native-inputs
731 `(("python-pbr" ,python-pbr)
732 ("python-setuptools" ,python-setuptools)
733 ("python-sphinx" ,python-sphinx)
734 ;; The folloing packages are needed for the tests.
735 ("python-coverage" ,python-coverage)
736 ("python-discover" ,python-discover)
737 ("python-hacking" ,python-hacking)
738 ("python-mock" ,python-mock)
739 ("python-oslosphinx" ,python-oslosphinx)
740 ("python-keystoneclient" ,python-keystoneclient)
741 ("python-testrepository" ,python-testrepository)
742 ("python-testtools" ,python-testtools)))
743 (propagated-inputs
744 `(("python-requests" ,python-requests)
745 ("python-six" ,python-six)))
746 (home-page "http://www.openstack.org/")
747 (synopsis "OpenStack Object Storage API Client Library")
748 (description
749 "OpenStack Object Storage (code-named Swift) creates redundant, scalable
750 object storage using clusters of standardized servers to store petabytes of
751 accessible data. It is not a file system or real-time data storage system, but
752 rather a long-term storage system for a more permanent type of static data that
753 can be retrieved, leveraged, and then updated if necessary. Primary examples of
754 data that best fit this type of storage model are virtual machine images, photo
755 storage, email storage and backup archiving. Having no central \"brain\" or
756 master point of control provides greater scalability, redundancy and
757 permanence.")
758 (license asl2.0)))
759
760 (define-public python2-swiftclient
761 (let ((swiftclient (package-with-python2 python-swiftclient)))
762 (package (inherit swiftclient)
763 (propagated-inputs
764 `(("python2-futures" ,python2-futures)
765 ("python2-requests" ,python2-requests)
766 ,@(alist-delete "python-requests"
767 (package-propagated-inputs swiftclient))))
768 (native-inputs
769 `(("python2-keystoneclient" ,python2-keystoneclient)
770 ("python2-oslosphinx" ,python2-oslosphinx)
771 ,@(fold alist-delete (package-native-inputs swiftclient)
772 '("python-keystoneclient" "python-oslosphinx")))))))