Update e-mail for Kei Kebreau.
[jackhill/guix/guix.git] / gnu / packages / patches / scotch-test-threading.patch
1 Fix this test so that it succeeds when the library is not compiled with
2 SCOTCH_PTHREAD.
3
4 --- scotch_6.0.4/src/check/test_common_thread.c 2014-09-28 11:39:59.000000000 -0500
5 +++ scotch_6.0.4/src/check/test_common_thread.c 2015-01-10 00:52:00.076229542 -0600
6 @@ -175,14 +175,14 @@
7 char * argv[])
8 {
9 TestThreadGroup groudat;
10 -#if ((defined COMMON_PTHREAD) || (defined SCOTCH_PTHREAD))
11 +#if ((defined COMMON_PTHREAD) && (defined SCOTCH_PTHREAD))
12 TestThread * restrict thrdtab;
13 int thrdnbr;
14 #endif /* ((defined COMMON_PTHREAD) || (defined SCOTCH_PTHREAD)) */
15
16 SCOTCH_errorProg (argv[0]);
17
18 -#if ((defined COMMON_PTHREAD) || (defined SCOTCH_PTHREAD))
19 +#if ((defined COMMON_PTHREAD) && (defined SCOTCH_PTHREAD))
20 thrdnbr = SCOTCH_PTHREAD_NUMBER;
21
22 groudat.redusum = COMPVAL (thrdnbr);