gnu: sssd: Update to 2.7.4.
[jackhill/guix/guix.git] / gnu / packages / skribilo.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages skribilo)
20 #:use-module (guix packages)
21 #:use-module (guix download)
22 #:use-module (guix licenses)
23 #:use-module ((guix utils) #:select (version-major+minor))
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages guile)
26 #:use-module (gnu packages guile-xyz)
27 #:use-module (gnu packages lout)
28 #:use-module (gnu packages pkg-config)
29 #:use-module (gnu packages plotutils)
30 #:use-module (gnu packages imagemagick)
31 #:use-module (gnu packages ghostscript))
32
33 (define-public skribilo
34 (package
35 (name "skribilo")
36 (version "0.9.5")
37 (source (origin
38 (method url-fetch)
39 (uri (string-append "mirror://savannah/skribilo/skribilo-"
40 version ".tar.gz"))
41 (sha256
42 (base32
43 "02dzy2imqgfmwda4d1r51205si4c0r4fp2gf22sb0kv3qhhnm0h0"))))
44 (build-system gnu-build-system)
45 (arguments
46 ;; Make the modules available under the usual location.
47 `(#:phases
48 (modify-phases %standard-phases
49 (add-before 'configure 'pre-configure
50 (lambda* (#:key inputs #:allow-other-keys)
51 ;; Make sure the 'skribilo' command gets to see
52 ;; Guile-Reader, even if Guile-Reader is not in the search
53 ;; path.
54 (let ((reader (assoc-ref inputs "guile-reader"))
55 (effective ,(version-major+minor
56 (package-version
57 (car (assoc-ref (package-inputs this-package)
58 "guile"))))))
59 (substitute* "src/skribilo.in"
60 (("^exec (.*) -c" _ things)
61 (string-append "exec " things
62 " -L " reader "/share/guile/site/" effective
63 " -C " reader
64 "/lib/guile/" effective "/site-ccache"
65 " -c"))))
66 #t)))
67
68 #:parallel-build? #f
69
70 ;; XXX: Temporarily disable tests because they rely on
71 ;; 'test-runner-current' *not* returning #f after 'test-end', which is
72 ;; no longer the case in Guile >= 3.0.6. This is fixed upstream.
73 #:tests? #f))
74
75 (native-inputs (list pkg-config))
76
77 (inputs (list guile-3.0
78 imagemagick
79 ghostscript ; for 'convert'
80 ploticus
81 lout))
82
83 ;; The 'skribilo' command needs them, and for people using Skribilo as a
84 ;; library, these inputs are needed as well.
85 (propagated-inputs (list guile-reader guile-lib))
86
87 (home-page "https://www.nongnu.org/skribilo/")
88 (synopsis "Document production tool written in Guile Scheme")
89 (description
90 "Skribilo is a free document production tool that takes a structured
91 document representation as its input and renders that document in a variety of
92 output formats: HTML and Info for on-line browsing, and Lout and LaTeX for
93 high-quality hard copies.
94
95 The input document can use Skribilo's markup language to provide information
96 about the document's structure, which is similar to HTML or LaTeX and does not
97 require expertise. Alternatively, it can use a simpler, “markup-less” format
98 that borrows from Emacs' outline mode and from other conventions used in
99 emails, Usenet and text.
100
101 Lastly, Skribilo provides Guile Scheme APIs.")
102 (license gpl3+)))