gnu: sssd: Update to 2.7.4.
[jackhill/guix/guix.git] / gnu / packages / gnustep.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2016, 2017 Kei Kebreau <kkebreau@posteo.net>
4 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
6 ;;; Copyright © 2022 Zhu Zihao <all_but_last@163.com>
7 ;;;
8 ;;; This file is part of GNU Guix.
9 ;;;
10 ;;; GNU Guix is free software; you can redistribute it and/or modify it
11 ;;; under the terms of the GNU General Public License as published by
12 ;;; the Free Software Foundation; either version 3 of the License, or (at
13 ;;; your option) any later version.
14 ;;;
15 ;;; GNU Guix is distributed in the hope that it will be useful, but
16 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
17 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
18 ;;; GNU General Public License for more details.
19 ;;;
20 ;;; You should have received a copy of the GNU General Public License
21 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
22
23 (define-module (gnu packages gnustep)
24 #:use-module (guix download)
25 #:use-module (guix git-download)
26 #:use-module (guix gexp)
27 #:use-module (guix packages)
28 #:use-module (guix build-system gnu)
29 #:use-module (guix build-system cmake)
30 #:use-module ((guix licenses) #:prefix license:)
31 #:use-module (gnu packages)
32 #:use-module (gnu packages base)
33 #:use-module (gnu packages datastructures)
34 #:use-module (gnu packages xorg)
35 #:use-module (gnu packages libffcall)
36 #:use-module (gnu packages gcc)
37 #:use-module (gnu packages gnome)
38 #:use-module (gnu packages gtk)
39 #:use-module (gnu packages linux)
40 #:use-module (gnu packages llvm)
41 #:use-module (gnu packages texinfo)
42 #:use-module (gnu packages autotools)
43 #:use-module (gnu packages glib)
44 #:use-module (gnu packages fontutils)
45 #:use-module (gnu packages image)
46 #:use-module (gnu packages pkg-config)
47 #:use-module (gnu packages xml)
48 #:use-module (ice-9 match))
49
50 (define-public gnustep-make
51 (package
52 (name "gnustep-make")
53 (version "2.7.0")
54 (source (origin
55 (method url-fetch)
56 (uri (string-append "ftp://ftp.gnustep.org/pub/gnustep/core/"
57 name "-" version ".tar.gz"))
58 (sha256
59 (base32
60 "1khiygfkz0zhh9b5nybn40g0xnnjxchk24n49hff1bwanszir84h"))))
61 (build-system gnu-build-system)
62 (arguments
63 '(#:tests? #f)) ; no check target
64 (native-inputs
65 (list which))
66 (home-page "http://gnustep.org")
67 (synopsis "GNUstep make package")
68 (description "The makefile package is a simple, powerful and extensible way
69 to write makefiles for a GNUstep-based project. It allows the user to write a
70 project without having to deal with the complex issues associated with
71 configuration, building, installation, and packaging. It also allows the user
72 to easily create cross-compiled binaries.")
73 (license license:gpl3+)))
74
75 (define-public libobjc2
76 (package
77 (name "libobjc2")
78 (version "2.1")
79 (source (origin
80 (method git-fetch)
81 (uri (git-reference
82 (url "https://github.com/gnustep/libobjc2")
83 (commit (string-append "v" version))))
84 (sha256
85 (base32
86 "1zjryzvy06gjf36gz6zrkg9icwz6wsf80mp94x6bq1109vkl40b5"))
87 (file-name (git-file-name name version))
88 (patches
89 (search-patches "libobjc2-unbundle-robin-map.patch"))))
90 (build-system cmake-build-system)
91 (arguments
92 (list
93 ;; XXX: Cannot use GCC to compile ObjC code due to
94 ;; https://issues.guix.gnu.org/29644.
95 #:configure-flags #~(list "-DCMAKE_C_COMPILER=clang"
96 "-DCMAKE_CXX_COMPILER=clang++")))
97 (inputs
98 (list clang robin-map))
99 (home-page "http://www.gnustep.org/")
100 (synopsis "Objective-C runtime library for Clang")
101 (description "Libobjc2 is an Objective-C runtime library designed as a
102 drop-in replacement for GCC runtime. It supports following features beyond
103 GCC runtime.
104
105 @itemize
106 @item Modern Objective-C runtime APIs.
107 @item Blocks (Closures).
108 @item Synthesised property accessors.
109 @item Efficient support for @code{@@synchronized()}.
110 @item Type-dependent dispatch.
111 @item Associated reference API.
112 @item Automatic Reference Counting.
113 @end itemize")
114 (license license:expat)))
115
116 (define-public windowmaker
117 (package
118 (name "windowmaker")
119 (version "0.95.9")
120 (synopsis "NeXTSTEP-like window manager")
121 (source (origin
122 (method url-fetch)
123 (uri (string-append
124 "https://github.com/window-maker/wmaker/releases/download/"
125 "wmaker-" version "/WindowMaker-" version ".tar.gz"))
126 (sha256
127 (base32
128 "055pqvlkhipyjn7m6bb3fs4zz9rd1ynzl0mmwbhp05ihc3zmh8zj"))))
129 (build-system gnu-build-system)
130 (arguments
131 `(#:modules ((guix build gnu-build-system)
132 (guix build utils)
133 (ice-9 match))
134 #:phases
135 (modify-phases %standard-phases
136 (add-before 'configure 'pre-configure
137 (lambda* (#:key outputs #:allow-other-keys)
138 ;; 'wmaker' wants to invoke 'wmaker.inst' the first time,
139 ;; and the 'wmsetbg', so make sure it uses the right ones.
140 ;; We can't use a wrapper here because that would pollute
141 ;; $PATH in the whole session.
142 (let* ((out (assoc-ref outputs "out"))
143 (bin (string-append out "/bin")))
144 (substitute* "src/main.c"
145 (("\"wmaker\\.inst")
146 (string-append "\"" bin "/wmaker.inst")))
147 (substitute* '("src/defaults.c" "WPrefs.app/Menu.c")
148 (("\"wmsetbg")
149 (string-append "\"" bin "/wmsetbg")))
150 ;; Add enough cells to the command character array to
151 ;; allow passing our large path to the wmsetbg binary.
152 ;; The path to wmsetbg in Guix requires 67 extra characters.
153 (substitute* "src/defaults.c"
154 (("len = strlen\\(text\\) \\+ 40;")
155 (string-append "len = strlen(text) + 107;")))
156 #t)))
157 (add-after 'install 'install-xsession
158 (lambda* (#:key outputs #:allow-other-keys)
159 (let* ((out (assoc-ref outputs "out"))
160 (xsessions (string-append out "/share/xsessions")))
161 (mkdir-p xsessions)
162 (call-with-output-file
163 (string-append xsessions "/windowmaker.desktop")
164 (lambda (port)
165 (format port "~
166 [Desktop Entry]~@
167 Name=Window Maker~@
168 Comment=~a~@
169 Exec=~a/bin/wmaker~@
170 Type=Application~%"
171 (string-map (match-lambda
172 (#\newline #\space)
173 (chr chr))
174 ,synopsis) out))))
175 #t))
176 (add-after 'install-xsession 'wrap
177 (lambda* (#:key outputs #:allow-other-keys)
178 (let* ((out (assoc-ref outputs "out"))
179 (bin (string-append out "/bin")))
180 ;; In turn, 'wmaker.inst' wants to invoke 'wmmenugen'
181 ;; etc., so make sure everything is in $PATH.
182 (wrap-program (string-append bin "/wmaker.inst")
183 `("PATH" ":" prefix (,bin)))
184 #t))))))
185 (inputs
186 `(("libxmu" ,libxmu)
187 ("libxft" ,libxft)
188 ("libx11" ,libx11)
189 ("libxinerama" ,libxinerama)
190 ("fontconfig" ,fontconfig)
191 ("libjpeg" ,libjpeg-turbo)
192 ("giflib" ,giflib)
193 ("libpng" ,libpng)
194 ("libtiff" ,libtiff)))
195 (native-inputs
196 (list pkg-config))
197 (home-page "https://windowmaker.org/")
198 (description
199 "Window Maker is an X11 window manager originally designed to provide
200 integration support for the GNUstep Desktop Environment. In every way
201 possible, it reproduces the elegant look and feel of the NeXTSTEP user
202 interface. It is fast, feature rich, easy to configure, and easy to use.")
203
204 ;; Artwork is distributed under the WTFPL.
205 (license license:gpl2+)))
206
207 (define-public wmbattery
208 (package
209 (name "wmbattery")
210 (version "2.54")
211 (source (origin
212 (method url-fetch)
213 (uri (string-append
214 "mirror://debian/pool/main/w/wmbattery/wmbattery_"
215 version ".orig.tar.gz"))
216 (sha256
217 (base32
218 "1r4n58mwkm69y1pjs7l64hg8r1lpndrzyrfl2rdgd4zi6v0jhyyw"))))
219 (build-system gnu-build-system)
220 (arguments '(#:tests? #f)) ; no "check" target
221 (inputs
222 (list glib libx11 libxext libxpm upower))
223 (native-inputs
224 (list pkg-config))
225 (home-page "https://www.dockapps.net/wmbattery")
226 (synopsis "Display laptop battery info")
227 (description
228 "Wmbattery displays the status of your laptop's battery in a small icon.
229 This includes if it is plugged in, if the battery is charging, how many minutes
230 of battery life remain, battery life remaining (with both a percentage and a
231 graph), and battery status (high - green, low - yellow, or critical - red).")
232 (license license:gpl2)))
233
234 (define-public wmnd
235 (package
236 (name "wmnd")
237 (version "0.4.18")
238 (source (origin
239 (method url-fetch)
240 (uri (string-append
241 "http://www.thregr.org/~wavexx/software/wmnd/releases/"
242 name "-" version ".tar.gz"))
243 (sha256
244 (base32
245 "01s37d8cfpncza1mlw13ar4rcwbrc1vgaj3ifhglmlcnzvvayg0n"))))
246 (build-system gnu-build-system)
247 (inputs
248 (list libx11 libxext libxpm))
249 (native-inputs
250 (list pkg-config))
251 (home-page "http://www.thregr.org/~wavexx/software/wmnd/")
252 (synopsis "Network interface monitor")
253 (description
254 "WMND is a dockapp for monitoring network interfaces under WindowMaker and
255 other compatible window managers.")
256 (license license:gpl2+)))
257
258 (define-public wmcpuload
259 (package
260 (name "wmcpuload")
261 (version "1.1.1")
262 (source (origin
263 (method url-fetch)
264 (uri (string-append
265 "mirror://debian/pool/main/w/wmcpuload/"
266 name "_" version ".orig.tar.gz"))
267 (sha256
268 (base32
269 "1334y0axnxydwv05d172f405iljrfakg4kcyg9kmn46v6ywv424g"))))
270 (build-system gnu-build-system)
271 (inputs
272 (list libx11 libxext libxpm))
273 (native-inputs
274 (list pkg-config))
275 (home-page "https://www.dockapps.net/wmcpuload")
276 (synopsis "Monitor CPU usage")
277 (description
278 "Wmcpuload displays the current CPU usage, expressed as a percentile and a
279 chart, and has an LCD look-alike user interface. The back-light may be turned
280 on and off by clicking the mouse button over the application. If the CPU usage
281 hits a certain threshold, an alarm-mode will alert you by turning back-light
282 on.")
283 (license license:gpl2+)))
284
285 (define-public wmclock
286 (package
287 (name "wmclock")
288 (version "1.0.16")
289 (source (origin
290 (method url-fetch)
291 (uri (string-append
292 "mirror://debian/pool/main/w/wmclock/"
293 name "_" version ".orig.tar.gz"))
294 (sha256
295 (base32
296 "1lx276ba8r2yydhmwj1g586jdqg695ad89ng36fr3mb067gvb2rz"))))
297 (build-system gnu-build-system)
298 (inputs
299 (list libx11 libxext libxpm))
300 ;; wmclock requires autoreconf to generate its configure script.
301 (native-inputs
302 (list autoconf automake pkg-config))
303 (home-page "https://www.dockapps.net/wmclock")
304 (synopsis "Display the date and time")
305 (description
306 "wmclock is an applet for Window Maker which displays the date and time in
307 a dockable tile. It features multiple language support, 24h or 12h time
308 display, and can run a user-specified program on mouse click.")
309 (license license:gpl2+)))
310
311 (define-public wmfire
312 (package
313 (name "wmfire")
314 (version "1.2.4")
315 (source (origin
316 (method url-fetch)
317 (uri (string-append "http://www.improbability.net/"
318 name "/" name "-" version ".tar.gz"))
319 (sha256
320 (base32
321 "101grahd80n97y2dczb629clmcgiavdpbbwy78kk5wgs362m12z3"))
322 (patches
323 (search-patches "wmfire-update-for-new-gdk-versions.patch"))))
324 (build-system gnu-build-system)
325 (inputs
326 (list gtk+-2 libgtop))
327 (native-inputs
328 (list pkg-config))
329 (home-page "http://www.improbability.net/")
330 (synopsis "Display flames to represent resource usage")
331 (description
332 "wmfire is an applet for Window Maker that can monitor the average cpu
333 load, or individual cpu load on SMP computers. Additionally it can monitor the
334 memory, network load, a file or just be set to show a pretty flame. On
335 entering the dock a burning spot replaces the cursor, and after two seconds
336 symbols to represent the current monitor are \"burnt\" onscreen. The flame
337 colour can also be changed.")
338 (license license:gpl2+)))
339
340 (define-public wmamixer
341 (package
342 (name "wmamixer")
343 (version "1.0")
344 (source (origin
345 (method git-fetch)
346 (uri (git-reference
347 (url "https://github.com/gryf/wmamixer")
348 (commit version)))
349 (file-name (git-file-name name version))
350 (sha256
351 (base32
352 "04vv4kr4mj1nwri6zqgdg4yzbbmmng73qd4h0azliril75m7sldf"))))
353 (inputs (list libx11 libxpm libxext alsa-lib))
354 (build-system gnu-build-system)
355 (arguments
356 (list #:phases #~(modify-phases %standard-phases
357 (delete 'configure)
358 (delete 'check)
359 (replace 'install
360 (lambda* (#:key inputs outputs #:allow-other-keys)
361 (let* ((out (assoc-ref outputs "out"))
362 (bin (string-append out "/bin")))
363 (install-file "wmamixer" bin)))))))
364 (synopsis "Window maker applet to display the current volume")
365 (description
366 "wmamixer is an applet for window maker which displays the
367 current volume level both numerically and visiaully with a volume bar. It
368 includes the ability to toggle through different outputs to show their
369 respective volume level.")
370 (home-page "https://github.com/gryf/wmamixer")
371 (license license:gpl2+)))
372