gnu: mcrl2: Update to 202206.0.
[jackhill/guix/guix.git] / gnu / packages / patches / mcrl2-fix-counterexample.patch
1 Taken from upstream:
2 https://github.com/mCRL2org/mCRL2/commit/435421429dde9dcc5956e8a978597111a3947ec1
3
4 Fixes bug in ltscompare:
5 https://listserver.tue.nl/pipermail/mcrl2-users/2022-June/000396.html
6
7 From 435421429dde9dcc5956e8a978597111a3947ec1 Mon Sep 17 00:00:00 2001
8 From: Maurice Laveaux <m.laveaux@tue.nl>
9 Date: Wed, 29 Jun 2022 10:27:58 +0200
10 Subject: [PATCH] Write counterexample's structured output trace on single
11 line.
12
13 ---
14 libraries/lts/include/mcrl2/lts/detail/counter_example.h | 2 +-
15 1 file changed, 1 insertion(+), 1 deletion(-)
16
17 diff --git a/libraries/lts/include/mcrl2/lts/detail/counter_example.h b/libraries/lts/include/mcrl2/lts/detail/counter_example.h
18 index c339cfde4..ca3967768 100644
19 --- a/libraries/lts/include/mcrl2/lts/detail/counter_example.h
20 +++ b/libraries/lts/include/mcrl2/lts/detail/counter_example.h
21 @@ -139,7 +139,7 @@ class counter_example_constructor
22 if (m_structured_output)
23 {
24 std::cout << m_name << ": ";
25 - result.save("", mcrl2::lts::trace::tfPlain); // Write to stdout.
26 + result.save("", mcrl2::lts::trace::tfLine); // Write to stdout.
27 }
28 else
29 {
30 --
31 2.35.1
32