Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / pulseaudio.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
5 ;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages pulseaudio)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module ((guix licenses) #:prefix l:)
26 #:use-module (guix build-system gnu)
27 #:use-module (gnu packages)
28 #:use-module (gnu packages algebra)
29 #:use-module (gnu packages autotools)
30 #:use-module (gnu packages avahi)
31 #:use-module (gnu packages check)
32 #:use-module (gnu packages databases)
33 #:use-module (gnu packages glib)
34 #:use-module (gnu packages gtk)
35 #:use-module (gnu packages libcanberra)
36 #:use-module (gnu packages web)
37 #:use-module (gnu packages linux)
38 #:use-module (gnu packages m4)
39 #:use-module (gnu packages pkg-config)
40 #:use-module (gnu packages xiph))
41
42 (define-public libsndfile
43 (package
44 (name "libsndfile")
45 (version "1.0.26")
46 (source (origin
47 (method url-fetch)
48 (uri (string-append "http://www.mega-nerd.com/libsndfile/files/libsndfile-"
49 version ".tar.gz"))
50 (sha256
51 (base32
52 "14jhla289cj45946h0hq2an0a9g4wkwb3v4571bla6ixfvn20rfd"))))
53 (build-system gnu-build-system)
54 (inputs
55 `(("libvorbis" ,libvorbis)
56 ("libogg" ,libogg)
57 ("flac" ,flac)))
58 (native-inputs
59 `(("pkg-config" ,pkg-config)))
60 (home-page "http://www.mega-nerd.com/libsndfile/")
61 (synopsis "Reading and writing files containing sampled sound")
62 (description
63 "Libsndfile is a C library for reading and writing files containing
64 sampled sound (such as MS Windows WAV and the Apple/SGI AIFF format) through
65 one standard library interface.
66
67 It was designed to handle both little-endian (such as WAV) and
68 big-endian (such as AIFF) data, and to compile and run correctly on
69 little-endian (such as Intel and DEC/Compaq Alpha) processor systems as well
70 as big-endian processor systems such as Motorola 68k, Power PC, MIPS and
71 SPARC. Hopefully the design of the library will also make it easy to extend
72 for reading and writing new sound file formats.")
73 (license l:gpl2+)))
74
75 (define-public libsamplerate
76 (package
77 (name "libsamplerate") ; aka. Secret Rabbit Code (SRC)
78 (version "0.1.8")
79 (source (origin
80 (method url-fetch)
81 (uri (string-append "http://www.mega-nerd.com/SRC/libsamplerate-"
82 version ".tar.gz"))
83 (sha256
84 (base32
85 "01hw5xjbjavh412y63brcslj5hi9wdgkjd3h9csx5rnm8vglpdck"))))
86 (build-system gnu-build-system)
87 (native-inputs
88 `(("pkg-config" ,pkg-config)))
89 (propagated-inputs
90 `(("libsndfile" ,libsndfile)
91 ("fftw" ,fftw)))
92 (home-page "http://www.mega-nerd.com/SRC/index.html")
93 (synopsis "Audio sample rate conversion library")
94 (description
95 "Secret Rabbit Code (aka. libsamplerate) is a Sample Rate Converter for
96 audio. One example of where such a thing would be useful is converting audio
97 from the CD sample rate of 44.1kHz to the 48kHz sample rate used by DAT
98 players.
99
100 SRC is capable of arbitrary and time varying conversions; from downsampling by
101 a factor of 256 to upsampling by the same factor. Arbitrary in this case means
102 that the ratio of input and output sample rates can be an irrational
103 number. The conversion ratio can also vary with time for speeding up and
104 slowing down effects.
105
106 SRC provides a small set of converters to allow quality to be traded off
107 against computation cost. The current best converter provides a
108 signal-to-noise ratio of 145dB with -3dB passband extending from DC to 96% of
109 the theoretical best bandwidth for a given pair of input and output sample
110 rates.")
111 (license l:gpl2+)))
112
113 (define-public pulseaudio
114 (package
115 (name "pulseaudio")
116 (version "8.0")
117 (source (origin
118 (method url-fetch)
119 (uri (string-append
120 "https://freedesktop.org/software/pulseaudio/releases/"
121 name "-" version ".tar.xz"))
122 (sha256
123 (base32
124 "128rrlvrgb4ia3pbzipf5mi6nvrpm6zmxn5r3bynqiikhvify3k9"))
125 (modules '((guix build utils)))
126 (snippet
127 ;; Disable console-kit support by default since it's deprecated
128 ;; anyway.
129 '(substitute* "src/daemon/default.pa.in"
130 (("load-module module-console-kit" all)
131 (string-append "#" all "\n"))))
132 (patches (search-patches
133 "pulseaudio-fix-mult-test.patch"
134 "pulseaudio-longer-test-timeout.patch"))))
135 (build-system gnu-build-system)
136 (arguments
137 `(#:configure-flags (list "--localstatedir=/var" ;"--sysconfdir=/etc"
138 "--disable-oss-output"
139 "--enable-bluez5"
140 (string-append "--with-udev-rules-dir="
141 (assoc-ref %outputs "out")
142 "/lib/udev/rules.d"))
143 #:phases (alist-cons-before
144 'check 'pre-check
145 (lambda _
146 ;; 'tests/lock-autospawn-test.c' wants to create a file
147 ;; under ~/.config/pulse.
148 (setenv "HOME" (getcwd))
149 ;; 'thread-test' needs more time on hydra and on slower
150 ;; machines, so we set the default timeout to 120 seconds.
151 (setenv "CK_DEFAULT_TIMEOUT" "120"))
152 %standard-phases)))
153 (inputs
154 ;; TODO: Add optional inputs (GTK+?).
155 `(("alsa-lib" ,alsa-lib)
156 ("bluez" ,bluez)
157 ("sbc" ,sbc)
158 ("json-c" ,json-c)
159 ("speex" ,speex)
160 ("libsndfile" ,libsndfile)
161 ("libsamplerate" ,libsamplerate)
162 ("dbus" ,dbus)
163 ("glib" ,glib)
164 ("intltool" ,intltool)
165 ("m4" ,m4)
166 ("libltdl" ,libltdl)
167 ("fftwf" ,fftwf)
168 ("avahi" ,avahi)
169 ("eudev" ,eudev) ;for the detection of hardware audio devices
170 ("check" ,check)))
171 (native-inputs
172 `(("pkg-config" ,pkg-config)))
173 (propagated-inputs
174 ;; 'libpulse*.la' contain `-lgdbm' and `-lcap', so propagate them.
175 `(("libcap" ,libcap)
176 ("gdbm" ,gdbm)))
177 (home-page "http://www.pulseaudio.org/")
178 (synopsis "Sound server")
179 (description
180 "PulseAudio is a sound server. It is basically a proxy for your sound
181 applications. It allows you to do advanced operations on your sound data as
182 it passes between your application and your hardware. Things like
183 transferring the audio to a different machine, changing the sample format or
184 channel count and mixing several sounds into one are easily achieved using a
185 sound server.")
186
187 ;; PulseAudio is LGPLv2+, but some of the optional dependencies (GNU dbm,
188 ;; FFTW, etc.) are GPL'd, so the result is effectively GPLv2+. See
189 ;; 'LICENSE' for details.
190 (license l:gpl2+)))
191
192 (define-public pavucontrol
193 (package
194 (name "pavucontrol")
195 (version "3.0")
196 (source (origin
197 (method url-fetch)
198 (uri (string-append
199 "https://freedesktop.org/software/pulseaudio/pavucontrol/pavucontrol-"
200 version
201 ".tar.xz"))
202 (sha256
203 (base32
204 "14486c6lmmirkhscbfygz114f6yzf97h35n3h3pdr27w4mdfmlmk"))))
205 (build-system gnu-build-system)
206 (arguments
207 '(#:configure-flags '("CXXFLAGS=-std=c++11"))) ; required by gtkmm
208 (inputs
209 `(("libcanberra" ,libcanberra)
210 ("gtkmm" ,gtkmm)
211 ("pulseaudio" ,pulseaudio)))
212 (native-inputs
213 `(("intltool" ,intltool)
214 ("pkg-config" ,pkg-config)))
215 (home-page "http://freedesktop.org/software/pulseaudio/pavucontrol/")
216 (synopsis "PulseAudio volume control")
217 (description
218 "PulseAudio Volume Control (pavucontrol) provides a GTK+
219 graphical user interface to connect to a PulseAudio server and
220 easily control the volume of all clients, sinks, etc.")
221 (license l:gpl2+)))