Merge branch 'master' into staging
[jackhill/guix/guix.git] / gnu / packages / sphinx.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 David Thompson <davet@gnu.org>
3 ;;; Copyright © 2015, 2017, 2019 Ricardo Wurmus <rekado@elephly.net>
4 ;;; Copyright © 2015, 2016, 2017 Leo Famulari <leo@famulari.name>
5 ;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
6 ;;; Copyright © 2016, 2017, 2018, 2019 Marius Bakke <mbakke@fastmail.com>
7 ;;; Copyright © 2017 Danny Milosavljevic <dannym+a@scratchpost.org>
8 ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
9 ;;; Copyright © 2017 Frederick M. Muriithi <fredmanglis@gmail.com>
10 ;;; Copyright © 2017 Christopher Allan Webber <cwebber@dustycloud.org>
11 ;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
12 ;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
13 ;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
14 ;;;
15 ;;; This file is part of GNU Guix.
16 ;;;
17 ;;; GNU Guix is free software; you can redistribute it and/or modify it
18 ;;; under the terms of the GNU General Public License as published by
19 ;;; the Free Software Foundation; either version 3 of the License, or (at
20 ;;; your option) any later version.
21 ;;;
22 ;;; GNU Guix is distributed in the hope that it will be useful, but
23 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
24 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
25 ;;; GNU General Public License for more details.
26 ;;;
27 ;;; You should have received a copy of the GNU General Public License
28 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
29
30 (define-module (gnu packages sphinx)
31 #:use-module (guix packages)
32 #:use-module (guix download)
33 #:use-module (guix git-download)
34 #:use-module (guix utils)
35 #:use-module (guix build-system python)
36 #:use-module ((guix licenses) #:prefix license:)
37 #:use-module (gnu packages)
38 #:use-module (gnu packages check)
39 #:use-module (gnu packages graphviz)
40 #:use-module (gnu packages image)
41 #:use-module (gnu packages imagemagick)
42 #:use-module (gnu packages python-web)
43 #:use-module (gnu packages python-xyz)
44 #:use-module (gnu packages time))
45
46 (define-public python-sphinx
47 (package
48 (name "python-sphinx")
49 (version "2.2.0")
50 (source
51 (origin
52 (method url-fetch)
53 (uri (pypi-uri "Sphinx" version))
54 (sha256
55 (base32
56 "0ig8s94xg0p6h9y5s3ns9x8i10b24ihzvs65b5jwrhrgih7nnn0d"))))
57 (build-system python-build-system)
58 (arguments
59 `(#:phases
60 (modify-phases %standard-phases
61 (replace 'check
62 (lambda _
63 ;; Requires Internet access.
64 (delete-file "tests/test_build_linkcheck.py")
65 (substitute* "tests/test_build_latex.py"
66 (("@pytest.mark.sphinx\\('latex', testroot='images'\\)")
67 "@pytest.mark.skip()"))
68 (invoke "make" "test"))))))
69 (propagated-inputs
70 `(("python-imagesize" ,python-imagesize)
71 ("python-sphinx-alabaster-theme"
72 ,python-sphinx-alabaster-theme)
73 ("python-babel" ,python-babel)
74 ("python-snowballstemmer" ,python-snowballstemmer)
75 ("python-docutils" ,python-docutils)
76 ("python-jinja2" ,python-jinja2)
77 ("python-packaging" ,python-packaging)
78 ("python-pygments" ,python-pygments)
79 ("python-requests" ,python-requests)
80 ("python-sphinxcontrib-applehelp" ,python-sphinxcontrib-applehelp)
81 ("python-sphinxcontrib-devhelp" ,python-sphinxcontrib-devhelp)
82 ("python-sphinxcontrib-htmlhelp" ,python-sphinxcontrib-htmlhelp)
83 ("python-sphinxcontrib-jsmath" ,python-sphinxcontrib-jsmath)
84 ("python-sphinxcontrib-qthelp" ,python-sphinxcontrib-qthelp)
85 ("python-sphinxcontrib-serializinghtml"
86 ,python-sphinxcontrib-serializinghtml)))
87 (native-inputs
88 `(("graphviz" ,graphviz)
89 ("imagemagick" ,imagemagick) ;for "convert"
90 ("python-html5lib" ,python-html5lib)
91 ("python-mock" ,python-mock)
92 ("python-nose" ,python-nose)
93 ("python-pytest" ,python-pytest)))
94 (home-page "https://sphinx-doc.org/")
95 (synopsis "Python documentation generator")
96 (description "Sphinx is a tool that makes it easy to create documentation
97 for Python projects or other documents consisting of multiple reStructuredText
98 sources.")
99 (license license:bsd-3)
100 (properties `((python2-variant . ,(delay python2-sphinx))))))
101
102 ;; Sphinx 2 does not support Python 2, so we stick with this older version here.
103 ;; Remove this package once python2-pbcore no longer requires it.
104 (define-public python2-sphinx
105 (let ((base (package-with-python2 (strip-python2-variant python-sphinx))))
106 (package
107 (inherit base)
108 (version "1.7.7")
109 (source (origin
110 (method url-fetch)
111 (uri (pypi-uri "Sphinx" version))
112 (sha256
113 (base32
114 "0pkkbfj7cl157q550gcs45am5y78ps0h7q6455d64s1zmw01jlvi"))))
115 (arguments
116 (substitute-keyword-arguments (package-arguments base)
117 ((#:phases phases)
118 `(modify-phases ,phases
119 (add-before 'check 'disable-broken-tests
120 (lambda _
121 ;; These tests are broken when using Python2:
122 ;; <https://github.com/sphinx-doc/sphinx/issues/4710>.
123 (for-each delete-file '("tests/test_api_translator.py"
124 "tests/test_setup_command.py"))
125 #t))))))
126 (native-inputs `(("python2-mock" ,python2-mock)
127 ("python2-enum34" ,python2-enum34)
128 ,@(package-native-inputs base)))
129 ;; Sphinx 2 has some dependencies that do not support Python 2, so
130 ;; we keep our own propagated-inputs here instead of inheriting.
131 (propagated-inputs `(("python2-pytz" ,python2-pytz)
132 ("python2-typing" ,python2-typing)
133 ("python2-imagesize" ,python2-imagesize)
134 ("python2-sphinx-alabaster-theme"
135 ,python2-sphinx-alabaster-theme)
136 ("python2-babel" ,python2-babel-2.6)
137 ("python2-snowballstemmer" ,python2-snowballstemmer)
138 ("python2-docutils" ,python2-docutils)
139 ("python2-jinja2" ,python2-jinja2)
140 ("python2-packaging" ,python2-packaging)
141 ("python2-pygments" ,python2-pygments)
142 ("python2-requests" ,python2-requests)
143 ("python2-six" ,python2-six)
144 ("python2-sphinxcontrib-websupport"
145 ,python2-sphinxcontrib-websupport))))))
146
147 (define-public python-sphinxcontrib-applehelp
148 (package
149 (name "python-sphinxcontrib-applehelp")
150 (version "1.0.1")
151 (source (origin
152 (method url-fetch)
153 (uri (pypi-uri "sphinxcontrib-applehelp" version))
154 (sha256
155 (base32
156 "15rqmgphj4wqf4m5wnzxgmwxx5jwfzb0j0nb94ql0x5wnar0mapd"))))
157 (build-system python-build-system)
158 (arguments
159 `(#:tests? #f)) ;XXX: circular dependency on Sphinx
160 (home-page "https://github.com/sphinx-doc/sphinxcontrib-applehelp")
161 (synopsis "Sphinx extension for creating Apple help books")
162 (description
163 "@code{sphinxcontrib-applehelp} is a Sphinx extension which outputs
164 Apple help books.")
165 (license license:bsd-2)))
166
167 (define-public python-sphinx-copybutton
168 (package
169 (name "python-sphinx-copybutton")
170 (version "0.2.5")
171 (source
172 (origin
173 (method url-fetch)
174 (uri (pypi-uri "sphinx-copybutton" version))
175 (sha256
176 (base32
177 "1bk006nv5s9ym6v67cxd4d2wvd8wm6czqi21mqcs33risygksncl"))))
178 (build-system python-build-system)
179 (home-page "https://github.com/choldgraf/sphinx-copybutton")
180 (synopsis "Sphinx extension to add \"copy\" buttons to code blocks")
181 (description
182 "This package provides a small sphinx extension to add \"copy\" buttons
183 to code blocks.")
184 (license license:expat)))
185
186 (define-public python-sphinxcontrib-devhelp
187 (package
188 (name "python-sphinxcontrib-devhelp")
189 (version "1.0.1")
190 (source (origin
191 (method url-fetch)
192 (uri (pypi-uri "sphinxcontrib-devhelp" version))
193 (sha256
194 (base32
195 "0d2a57kqxl72i55rns0ly1i044y2x234b9sdi89ajc3kjdvv0r3c"))))
196 (build-system python-build-system)
197 (arguments
198 `(#:tests? #f)) ;XXX: circular dependency on Sphinx
199 (home-page "https://github.com/sphinx-doc/sphinxcontrib-devhelp")
200 (synopsis "Sphinx extension for creating Devhelp documents")
201 (description
202 "@code{sphinxcontrib-devhelp} is a Sphinx extension which outputs
203 @url{Devhelp,https://wiki.gnome.org/Apps/Devhelp} documents.")
204 (license license:bsd-2)))
205
206 (define-public python-sphinxcontrib-htmlhelp
207 (package
208 (name "python-sphinxcontrib-htmlhelp")
209 (version "1.0.2")
210 (source (origin
211 (method url-fetch)
212 (uri (pypi-uri "sphinxcontrib-htmlhelp" version))
213 (sha256
214 (base32
215 "08l4x8a2l4xjqdd5rhvmfsqihmlgg4prdayj9b6pigaii6gzjw26"))))
216 (build-system python-build-system)
217 (arguments
218 `(#:tests? #f)) ;XXX: circular dependency on Sphinx
219 (home-page "https://github.com/sphinx-doc/sphinxcontrib-htmlhelp")
220 (synopsis "Sphinx extension for rendering HTML help files")
221 (description
222 "@code{sphinxcontrib-htmlhelp} is a Sphinx extension which renders
223 HTML help files.")
224 (license license:bsd-2)))
225
226 (define-public python-sphinxcontrib-jsmath
227 (package
228 (name "python-sphinxcontrib-jsmath")
229 (version "1.0.1")
230 (source (origin
231 (method url-fetch)
232 (uri (pypi-uri "sphinxcontrib-jsmath" version))
233 (sha256
234 (base32
235 "1f64w19j33sp151jimibraw6qrbhd5gxy8hs3797w9478m55x4m9"))))
236 (build-system python-build-system)
237 (arguments
238 `(#:tests? #f)) ;XXX: circular dependency on Sphinx
239 (home-page "https://github.com/sphinx-doc/sphinxcontrib-jsmath")
240 (synopsis "Sphinx extension to render math equations")
241 (description
242 "@code{sphinxcontrib-jsmath} is a Sphinx extension which renders display
243 math in HTML via JavaScript.")
244 (license license:bsd-3)))
245
246 (define-public python-sphinxcontrib-newsfeed
247 (package
248 (name "python-sphinxcontrib-newsfeed")
249 (version "0.1.4")
250 (source (origin
251 (method url-fetch)
252 (uri (pypi-uri "sphinxcontrib-newsfeed" version))
253 (sha256
254 (base32
255 "1d7gam3mn8v4in4p16yn3v10vps7nnaz6ilw99j4klij39dqd37p"))))
256 (arguments '(#:tests? #f)) ; No tests.
257 (build-system python-build-system)
258 (propagated-inputs
259 `(("python-sphinx" ,python-sphinx)))
260 (synopsis "News Feed extension for Sphinx")
261 (description "Sphinxcontrib-newsfeed is an extension for adding a simple
262 Blog, News or Announcements section to a Sphinx website.")
263 (home-page "https://bitbucket.org/prometheus/sphinxcontrib-newsfeed")
264 (license license:bsd-2)))
265
266 (define-public python-sphinxcontrib-programoutput
267 (package
268 (name "python-sphinxcontrib-programoutput")
269 (version "0.10")
270 (source (origin
271 (method url-fetch)
272 (uri (pypi-uri "sphinxcontrib-programoutput" version))
273 (sha256
274 (base32
275 "153hhnlbx4688zj9wd64819ps5znc2jlyp5crkgzvn5hxgy99vpx"))))
276 (build-system python-build-system)
277 (arguments
278 ;; FIXME: Many tests are failing and the upstream is gone.
279 '(#:tests? #f))
280 (propagated-inputs
281 `(("python-sphinx" ,python-sphinx)))
282 (synopsis "Sphinx extension to include program output")
283 (description "A Sphinx extension to literally insert the output of arbitrary
284 commands into documents, helping you to keep your command examples up to date.")
285 (home-page "https://github.com/lunaryorn/sphinxcontrib-programoutput")
286 (license license:bsd-2)))
287
288 (define-public python2-sphinxcontrib-programoutput
289 (package-with-python2 python-sphinxcontrib-programoutput))
290
291 (define-public python-sphinxcontrib-qthelp
292 (package
293 (name "python-sphinxcontrib-qthelp")
294 (version "1.0.2")
295 (source (origin
296 (method url-fetch)
297 (uri (pypi-uri "sphinxcontrib-qthelp" version))
298 (sha256
299 (base32
300 "0vs09m6kf5vhiivpi5s5pks59iq0lqlsbkdycpqlysg53bhmqikr"))))
301 (build-system python-build-system)
302 (arguments
303 `(#:tests? #f)) ;XXX: circular dependency on Sphinx
304 (home-page "https://github.com/sphinx-doc/sphinxcontrib-qthelp")
305 (synopsis "Sphinx extension to output QtHelp documents")
306 (description
307 "@code{sphinxcontrib-qthelp} is a Sphinx extension which outputs QtHelp
308 documents.")
309 (license license:bsd-2)))
310
311 (define-public python-sphinxcontrib-serializinghtml
312 (package
313 (name "python-sphinxcontrib-serializinghtml")
314 (version "1.1.3")
315 (source (origin
316 (method url-fetch)
317 (uri (pypi-uri "sphinxcontrib-serializinghtml" version))
318 (sha256
319 (base32
320 "09sj3nwahwr4iymg86gczbh151cfczqhf2kclbblzh2jh0zv7vy0"))))
321 (build-system python-build-system)
322 (arguments
323 `(#:tests? #f)) ;XXX: circular dependency on Sphinx
324 (home-page "https://github.com/sphinx-doc/sphinxcontrib-serializinghtml")
325 (synopsis "Sphinx extension to serialize HTML files")
326 (description
327 "@code{sphinxcontrib-serializinghtml} is a Sphinx extension which outputs
328 \"serialized\" HTML files.")
329 (license license:bsd-2)))
330
331 (define-public python-sphinxcontrib-svg2pdfconverter
332 (package
333 (name "python-sphinxcontrib-svg2pdfconverter")
334 (version "0.1.0")
335 (source (origin
336 (method url-fetch)
337 (uri (pypi-uri "sphinxcontrib-svg2pdfconverter" version))
338 (sha256
339 (base32
340 "1abvbgkkii13q8nsb10r0gc5lm0p9iq1iwhfhakn5ifn6asa0183"))))
341 (build-system python-build-system)
342 (propagated-inputs
343 `(("python-sphinx" ,python-sphinx)))
344 (home-page "https://github.com/missinglinkelectronics/sphinxcontrib-svg2pdfconverter/releases")
345 (synopsis "Sphinx SVG to PDF converter extension")
346 (description "A Sphinx extension to convert SVG images to PDF in case the builder does not support
347 SVG images natively (e.g. LaTeX).")
348 (license license:bsd-3)))
349
350 (define-public python-sphinxcontrib-websupport
351 (package
352 (name "python-sphinxcontrib-websupport")
353 (version "1.1.0")
354 (source (origin
355 (method url-fetch)
356 (uri (pypi-uri "sphinxcontrib-websupport" version))
357 (sha256
358 (base32
359 "1ff3ix76xi1y6m99qxhaq5161ix9swwzydilvdya07mgbcvpzr4x"))))
360 (build-system python-build-system)
361 (arguments
362 ;; FIXME: Tests depend on Sphinx, which depends on this.
363 `(#:tests? #f))
364 (home-page "https://sphinx-doc.org/")
365 (synopsis "Sphinx API for web applications")
366 (description "This package provides a Python API to easily integrate
367 Sphinx documentation into your web application. It provides tools to
368 integrate Sphinx documents in web templates and to handle searches.")
369 (license license:bsd-3)))
370
371 (define-public python2-sphinxcontrib-websupport
372 (package-with-python2 python-sphinxcontrib-websupport))
373
374 (define-public python-sphinx-gallery
375 (package
376 (name "python-sphinx-gallery")
377 (version "0.1.13")
378 (source (origin
379 (method git-fetch)
380 (uri (git-reference
381 (url "https://github.com/sphinx-gallery/sphinx-gallery")
382 (commit (string-append "v" version))))
383 (file-name (git-file-name name version))
384 (sha256
385 (base32
386 "14nbqh9krx2l2y2ylbln6l6w8iak3wac1lngvaf278y1cx7685kg"))))
387 (build-system python-build-system)
388 (arguments
389 ;; FIXME: Tests attempt to download <https://docs.python.org/3/objects.inv>,
390 ;; <https://docs.scipy.org/doc/numpy/objects.inv>, and
391 ;; <https://matplotlib.org/objects.inv>.
392 `(#:tests? #f))
393 (native-inputs
394 `(("python-pytest-runner" ,python-pytest-runner)))
395 (home-page "https://sphinx-gallery.github.io/")
396 (synopsis "Generate an examples gallery automatically")
397 (description
398 "@code{sphinx_gallery} is a Sphinx extension that builds an HTML version
399 from any set of Python scripts and puts it into an examples gallery.")
400 (license license:bsd-3)))
401
402 (define-public python2-sphinx-gallery
403 (package-with-python2 python-sphinx-gallery))
404
405 (define-public python-sphinx-me
406 (package
407 (name "python-sphinx-me")
408 (version "0.3")
409 (source
410 (origin
411 (method url-fetch)
412 (uri (pypi-uri "sphinx-me" version))
413 (sha256
414 (base32
415 "06jzgp213zihnvpcy2y5jy3ykid3apc2ncp2pg6a2g05lhiziglq"))))
416 (build-system python-build-system)
417 (home-page "https://github.com/stephenmcd/sphinx-me")
418 (synopsis "Create a Sphinx documentation shell")
419 (description
420 "Create a Sphinx documentation shell for your project and include the
421 README file as the documentation index. It handles extracting the required
422 meta data such as the project name, author and version from your project for
423 use in your Sphinx docs.")
424 (license license:bsd-2)))
425
426 (define-public python2-sphinx-me
427 (package-with-python2 python-sphinx-me))
428
429 (define-public python-sphinx-repoze-autointerface
430 (package
431 (name "python-sphinx-repoze-autointerface")
432 (version "0.8")
433 (source (origin
434 (method url-fetch)
435 (uri (pypi-uri "repoze.sphinx.autointerface" version))
436 (sha256
437 (base32
438 "08ycivzf7bh4a1zcyp31hbyqs1b2c9r26raa3vxjwwmbfqr3iw4f"))))
439 (build-system python-build-system)
440 (arguments '(#:tests? #f)) ; No tests.
441 (propagated-inputs
442 `(("python-sphinx" ,python-sphinx)
443 ("python-zope-interface" ,python-zope-interface)))
444 (synopsis "Auto-generate Sphinx API docs from Zope interfaces")
445 (description "This package defines an extension for the Sphinx documentation
446 system. The extension allows generation of API documentation by
447 introspection of @code{zope.interface} instances in code.")
448 (home-page "https://github.com/repoze/repoze.sphinx.autointerface")
449 (license license:repoze)))
450
451 (define-public python2-sphinx-repoze-autointerface
452 (package-with-python2 python-sphinx-repoze-autointerface))
453
454 (define-public python-sphinx-alabaster-theme
455 (package
456 (name "python-sphinx-alabaster-theme")
457 (version "0.7.12")
458 (source (origin
459 (method url-fetch)
460 (uri (pypi-uri "alabaster" version))
461 (sha256
462 (base32
463 "00nwwjj2d2ym4s2kk217x7jkx1hnczc3fvm8yxbqmsp6b0nxfqd6"))))
464 (build-system python-build-system)
465 (propagated-inputs
466 `(("python-pygments" ,python-pygments)))
467 (home-page "https://alabaster.readthedocs.io/")
468 (synopsis "Configurable sidebar-enabled Sphinx theme")
469 (description "Alabaster is a visually (c)lean, responsive, configurable
470 theme for the Sphinx documentation system. It's the default theme of Sphinx.")
471 (license license:bsd-3)))
472
473 (define-public python2-sphinx-alabaster-theme
474 (package-with-python2 python-sphinx-alabaster-theme))
475
476 (define-public python-sphinx-cloud-sptheme
477 (package
478 (name "python-sphinx-cloud-sptheme")
479 (version "1.8.0")
480 (source (origin
481 (method url-fetch)
482 (uri (pypi-uri "cloud_sptheme" version))
483 (sha256
484 (base32
485 "1dniqb6a39yh786f86c4jn666rwnyi1jvzn4616zhcchb7sfdshd"))))
486 (build-system python-build-system)
487 ;; FIXME: The 'pypi' release archive does not contain tests.
488 (arguments '(#:tests? #f))
489 (native-inputs
490 `(("python-sphinx" ,python-sphinx)))
491 (home-page "https://bitbucket.org/ecollins/cloud_sptheme")
492 (synopsis "'Cloud' theme for Sphinx documenter")
493 (description "This package contains the \"Cloud\" theme for Sphinx and some
494 related extensions.")
495 (license license:bsd-3)))
496
497 (define-public python2-sphinx-cloud-sptheme
498 (package-with-python2 python-sphinx-cloud-sptheme))
499
500 (define-public python-guzzle-sphinx-theme
501 (package
502 (name "python-guzzle-sphinx-theme")
503 (version "0.7.11")
504 (source
505 (origin
506 (method url-fetch)
507 (uri (pypi-uri "guzzle_sphinx_theme" version))
508 (sha256
509 (base32
510 "1rnkzrrsbnifn3vsb4pfaia3nlvgvw6ndpxp7lzjrh23qcwid34v"))))
511 (build-system python-build-system)
512 (propagated-inputs
513 `(("python-sphinx" ,python-sphinx)))
514 (home-page "https://github.com/guzzle/guzzle_sphinx_theme")
515 (synopsis "Sphinx theme used by Guzzle")
516 (description "This package provides guzzle_sphinx_theme, a theme for the
517 Sphinx documentation system, used by @uref{http://docs.guzzlephp.org, Guzzle}
518 and several other projects.")
519 (license license:expat)))
520
521 (define-public python2-guzzle-sphinx-theme
522 (package-with-python2 python-guzzle-sphinx-theme))
523
524 (define-public python-sphinx-rtd-theme
525 (package
526 (name "python-sphinx-rtd-theme")
527 (version "0.2.4")
528 (source
529 (origin
530 (method url-fetch)
531 (uri (pypi-uri "sphinx_rtd_theme" version))
532 (sha256
533 (base32
534 "05rlhjzdyapr2w74jjs7mrm8hi69qskcr5vya9f9drpsys7lpxrd"))))
535 (build-system python-build-system)
536 (arguments '(#:tests? #f)) ; No tests.
537 (propagated-inputs
538 `(("python-sphinx" ,python-sphinx)))
539 (home-page "https://github.com/snide/sphinx_rtd_theme/")
540 (synopsis "ReadTheDocs.org theme for Sphinx")
541 (description "A theme for Sphinx used by ReadTheDocs.org.")
542 (license license:expat)))
543
544 (define-public python2-sphinx-rtd-theme
545 (package-with-python2 python-sphinx-rtd-theme))
546
547 (define-public python-breathe
548 (package
549 (name "python-breathe")
550 (version "4.13.1")
551 (source
552 (origin
553 (method url-fetch)
554 (uri (pypi-uri "breathe" version))
555 (sha256
556 (base32
557 "1aw749n2ry27434qd7gr99dvsrs3x3chyi9aywmhjj1g4m2j6xf6"))))
558 (build-system python-build-system)
559 (propagated-inputs
560 `(("python-docutils" ,python-docutils)
561 ("python-six" ,python-six)
562 ("python-sphinx" ,python-sphinx)))
563 (home-page "https://github.com/michaeljones/breathe")
564 (synopsis "ReStructuredText and Sphinx bridge to Doxygen")
565 (description "This package is an extension to reStructuredText and Sphinx
566 to be able to read and render the Doxygen xml output.")
567 (license license:bsd-3)))