gnu: Add cppunit
[jackhill/guix/guix.git] / gnu / packages / check.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages check)
20 #:use-module (gnu packages)
21 #:use-module (guix licenses)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu))
25
26 (define-public check
27 (package
28 (name "check")
29 (version "0.9.9")
30 (source
31 (origin
32 (method url-fetch)
33 (uri (string-append "mirror://sourceforge/check/check/"
34 version "/check-" version ".tar.gz"))
35 (sha256
36 (base32
37 "1jcahzrvxcnp5chdn2x46l0y4aba8d8yd70lljfin7h5knxrlyhs"))))
38 (build-system gnu-build-system)
39 (home-page "http://check.sourceforge.net/")
40 (synopsis "Check, a unit testing framework for C")
41 (description
42 "Check is a unit testing framework for C. It features a simple
43 interface for defining unit tests, putting little in the way of the
44 developer. Tests are run in a separate address space, so Check can
45 catch both assertion failures and code errors that cause segmentation
46 faults or other signals. The output from unit tests can be used within
47 source code editors and IDEs.")
48 (license lgpl2.1+)))
49
50
51 (define-public cppunit
52 (package
53 (name "cppunit")
54 (version "1.12.1")
55 (source (origin
56 (method url-fetch)
57 (uri (string-append "mirror://sourceforge/cppunit/" name "/"
58 name "-"
59 version ".tar.gz"))
60 (sha256
61 (base32
62 "0jm49v5rmc5qw34vqs56gy8xja1dhci73bmh23cig4kcir6a0a5c"))))
63 (build-system gnu-build-system)
64 (home-page "http://sourceforge.net/projects/cppunit/")
65 (synopsis "Unit testing framework for C++")
66 (description "CppUnit is the C++ port of the famous JUnit framework for
67 unit testing. Test output is in XML for automatic testing and GUI based for
68 supervised tests.")
69 (license lgpl2.1))) ; no copyright notices. LGPL2.1 is in the tarball
70
71