gnu: r-zellkonverter: Update to 1.6.5.
[jackhill/guix/guix.git] / gnu / packages / pikchr.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2022 pukkamustard <pukkamustard@posteo.net>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages pikchr)
20 #:use-module (guix packages)
21 #:use-module (guix build-system gnu)
22 #:use-module (guix download)
23 #:use-module ((guix licenses) #:prefix license:))
24
25 (define-public pikchr
26 (let ((commit "221988914eff6efe")
27 (revision "0")) ;increment for each new snapshot
28 (package
29 (name "pikchr")
30 ;; To update, use the last check-in in https://pikchr.org/home/timeline?r=trunk
31 (version (string-append revision "-" (string-take commit 5)))
32 (source (origin
33 (method url-fetch)
34 (uri (string-append "https://pikchr.org/home/tarball/" commit
35 "/pikchr.tar.gz"))
36 (file-name (string-append "pikchr-" version ".tar.gz"))
37 (sha256
38 (base32
39 "0yclkincsgfni4scjzp5avdsij8vmyxjn0q2qkwjhn3p43y8nxzd"))))
40 (build-system gnu-build-system)
41 (arguments
42 '(#:tests? #f ;no tests
43 #:phases
44 (modify-phases %standard-phases
45 (delete 'bootstrap)
46 (delete 'configure)
47 (replace 'install
48 (lambda* (#:key outputs #:allow-other-keys)
49 (let* ((out (assoc-ref outputs "out"))
50 (bin (string-append out "/bin")))
51 (install-file "pikchr" bin)))))))
52 (home-page "https://pikchr.org")
53 (synopsis "Markup language for diagrams in technical documentation")
54 (description
55 "Pikchr (pronounced @emph{picture}) is a PIC-like markup language for
56 diagrams in technical documentation. Pikchr is designed to be embedded in
57 fenced code blocks of Markdown or similar mechanisms of other documentation
58 markup languages.")
59 (license license:bsd-0))))