gnu: r-zellkonverter: Update to 1.6.5.
[jackhill/guix/guix.git] / gnu / packages / perl6.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
3 ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages perl6)
21 #:use-module ((guix licenses) #:prefix license:)
22 #:use-module (guix download)
23 #:use-module (guix git-download)
24 #:use-module (guix packages)
25 #:use-module (guix build-system perl)
26 #:use-module (guix build-system rakudo)
27 #:use-module (gnu packages bdw-gc)
28 #:use-module (gnu packages libevent)
29 #:use-module (gnu packages libffi)
30 #:use-module (gnu packages multiprecision)
31 #:use-module (gnu packages pkg-config)
32 #:use-module (gnu packages tls))
33
34 (define-public moarvm
35 (package
36 (name "moarvm")
37 (version "2019.03")
38 (source
39 (origin
40 (method url-fetch)
41 (uri (string-append "https://moarvm.org/releases/MoarVM-"
42 version ".tar.gz"))
43 (sha256
44 (base32
45 "017w1zvr6yl0cgjfc1b3ddlc6vjw9q8p7alw1vvsckw95190xc14"))
46 (modules '((guix build utils)))
47 (snippet
48 '(begin
49 ;(delete-file-recursively "3rdparty/dynasm") ; JIT
50 (delete-file-recursively "3rdparty/dyncall")
51 (delete-file-recursively "3rdparty/freebsd")
52 (delete-file-recursively "3rdparty/libatomicops")
53 (delete-file-recursively "3rdparty/libuv")
54 (delete-file-recursively "3rdparty/libtommath")
55 (delete-file-recursively "3rdparty/msinttypes")
56 #t))))
57 (build-system perl-build-system)
58 (arguments
59 '(#:phases
60 (modify-phases %standard-phases
61 (replace 'configure
62 (lambda* (#:key inputs outputs #:allow-other-keys)
63 (let ((out (assoc-ref outputs "out"))
64 (pkg-config (assoc-ref inputs "pkg-config")))
65 (setenv "CFLAGS" "-fcommon")
66 (setenv "LDFLAGS" (string-append "-Wl,-rpath=" out "/lib"))
67 (invoke "perl" "Configure.pl"
68 "--prefix" out
69 "--pkgconfig" (string-append pkg-config "/bin/pkg-config")
70 "--has-libtommath"
71 "--has-libatomic_ops"
72 "--has-libffi"
73 "--has-libuv")))))))
74 (home-page "https://moarvm.org/")
75 ;; These should be inputs but moar.h can't find them when building rakudo
76 (propagated-inputs
77 (list libatomic-ops libffi libtommath-1.0 libuv))
78 (native-inputs
79 (list pkg-config))
80 (synopsis "VM for NQP And Rakudo Perl 6")
81 (description
82 "Short for \"Metamodel On A Runtime\", MoarVM is a modern virtual machine
83 built for the Rakudo Perl 6 compiler and the NQP Compiler Toolchain. Highlights
84 include:
85
86 @itemize
87 @item Great Unicode support, with strings represented at grapheme level
88 @item Dynamic analysis of running code to identify hot functions and loops, and
89 perform a range of optimizations, including type specialization and inlining
90 @item Support for threads, a range of concurrency control constructs, and
91 asynchronous sockets, timers, processes, and more
92 @item Generational, parallel, garbage collection
93 @item Support for numerous language features, including first class functions,
94 exceptions, continuations, runtime loading of code, big integers and interfacing
95 with native libraries.
96 @end itemize")
97 (license license:artistic2.0)))
98
99 (define-public nqp
100 (package
101 (name "nqp")
102 (version "2019.03")
103 (source
104 (origin
105 (method url-fetch)
106 (uri (string-append "https://rakudo.perl6.org/downloads/nqp/nqp-"
107 version ".tar.gz"))
108 (sha256
109 (base32
110 "183zhll13fx416s3hkg4bkvib77kyr857h0nydgrl643fpacxp83"))
111 (modules '((guix build utils)))
112 (snippet
113 '(begin
114 (delete-file-recursively "3rdparty") #t))))
115 (build-system perl-build-system)
116 (arguments
117 '(#:phases
118 (modify-phases %standard-phases
119 (add-after 'patch-source-shebangs 'patch-more-shebangs
120 (lambda _
121 (substitute* '("tools/build/install-jvm-runner.pl.in"
122 "tools/build/gen-js-cross-runner.pl"
123 "tools/build/gen-js-runner.pl"
124 "tools/build/install-js-runner.pl"
125 "tools/build/install-moar-runner.pl"
126 "tools/build/gen-moar-runner.pl"
127 "t/nqp/111-spawnprocasync.t"
128 "t/nqp/113-run-command.t")
129 (("/bin/sh") (which "sh")))
130 #t))
131 (add-after 'unpack 'patch-source-date
132 (lambda _
133 (substitute* "tools/build/gen-version.pl"
134 (("gmtime") "gmtime(0)"))
135 #t))
136 (add-after 'unpack 'remove-failing-test
137 ;; One subtest fails for unknown reasons
138 (lambda _
139 (delete-file "t/nqp/019-file-ops.t")
140 #t))
141 (replace 'configure
142 (lambda* (#:key inputs outputs #:allow-other-keys)
143 (let ((out (assoc-ref outputs "out"))
144 (moar (assoc-ref inputs "moarvm")))
145 (invoke "perl" "Configure.pl"
146 "--backends=moar"
147 "--with-moar" (string-append moar "/bin/moar")
148 "--prefix" out)))))))
149 (inputs
150 (list moarvm))
151 (home-page "https://github.com/perl6/nqp")
152 (synopsis "Not Quite Perl")
153 (description "This is \"Not Quite Perl\" -- a lightweight Perl 6-like
154 environment for virtual machines. The key feature of NQP is that it's designed
155 to be a very small environment (as compared with, say, perl6 or Rakudo) and is
156 focused on being a high-level way to create compilers and libraries for virtual
157 machines like MoarVM, the JVM, and others.
158
159 Unlike a full-fledged implementation of Perl 6, NQP strives to have as small a
160 runtime footprint as it can, while still providing a Perl 6 object model and
161 regular expression engine for the virtual machine.")
162 (license license:artistic2.0)))
163
164 (define-public rakudo
165 (package
166 (name "rakudo")
167 (version "2019.03.1")
168 (source
169 (origin
170 (method url-fetch)
171 (uri (string-append "https://rakudo.perl6.org/downloads/rakudo/rakudo-"
172 version ".tar.gz"))
173 (sha256
174 (base32
175 "1nllf69v8xr6v3kkj7pmryg11n5m3ajfkr7j72pvhrgnjy8lv3r1"))))
176 (build-system perl-build-system)
177 (arguments
178 '(#:phases
179 (modify-phases %standard-phases
180 (add-after 'unpack 'patch-source-date
181 (lambda _
182 (substitute* "tools/build/gen-version.pl"
183 (("gmtime") "gmtime(0)"))
184 #t))
185 (add-after 'patch-source-shebangs 'patch-more-shebangs
186 (lambda _
187 (substitute* '("tools/build/create-js-runner.pl"
188 "tools/build/create-moar-runner.p6"
189 "tools/build/create-jvm-runner.pl"
190 "src/core/Proc.pm6")
191 (("/bin/sh") (which "sh")))
192 #t))
193 (replace 'configure
194 (lambda* (#:key inputs outputs #:allow-other-keys)
195 (let ((out (assoc-ref outputs "out"))
196 (nqp (assoc-ref inputs "nqp")))
197 (invoke "perl" "./Configure.pl"
198 "--backend=moar"
199 "--with-nqp" (string-append nqp "/bin/nqp")
200 "--prefix" out))))
201 ;; This is the recommended tool for distro maintainers to install perl6
202 ;; modules systemwide. See: https://github.com/ugexe/zef/issues/117
203 (add-after 'install 'install-dist-tool
204 (lambda* (#:key outputs #:allow-other-keys)
205 (let* ((out (assoc-ref outputs "out"))
206 (dest (string-append out "/share/perl6/tools")))
207 (install-file "tools/install-dist.p6" dest)
208 (substitute* (string-append dest "/install-dist.p6")
209 (("/usr/bin/env perl6")
210 (string-append out "/bin/perl6"))))
211 #t)))))
212 (inputs
213 (list moarvm nqp openssl))
214 (home-page "https://rakudo.org/")
215 (native-search-paths
216 (list (search-path-specification
217 (variable "PERL6LIB")
218 (separator ",")
219 (files '("share/perl6/lib"
220 "share/perl6/site/lib"
221 "share/perl6/vendor/lib")))))
222 (synopsis "Perl 6 Compiler")
223 (description "Rakudo Perl is a compiler that implements the Perl 6
224 specification and runs on top of several virtual machines.")
225 (license license:artistic2.0)))
226
227 (define-public perl6-grammar-debugger
228 ;; Last commit was September 2017
229 (let ((commit "0375008027c8caa216bd869476ce59ae09b2a702")
230 (revision "1"))
231 (package
232 (name "perl6-grammar-debugger")
233 (version (git-version "1.0.1" revision commit))
234 (source
235 (origin
236 (method git-fetch)
237 (uri (git-reference
238 (url "https://github.com/jnthn/grammar-debugger")
239 (commit commit)))
240 (file-name (git-file-name name version))
241 (sha256
242 (base32
243 "0y826z3m276n7ia810hgcb3div67nxmx125m2fzlc16994zd5vm5"))))
244 (build-system rakudo-build-system)
245 (propagated-inputs
246 (list perl6-terminal-ansicolor))
247 (home-page "https://github.com/jnthn/grammar-debugger")
248 (synopsis "Simple tracing and debugging support for Perl 6 grammars")
249 (description "This module provides a simple debugger for grammars. Just
250 @code{use} it: use @code{Grammar::Debugger;} and any grammar in the lexical
251 scope of the use statement will automatically have debugging enabled. The
252 debugger will break execution when you first enter the grammar, and provide a
253 prompt.")
254 (license license:artistic2.0))))
255
256 (define-public perl6-grammar-profiler-simple
257 ;; Last commit was June 2017
258 (let ((commit "c0aca5fab323b2974821dabd6b89330c609e0b7d")
259 (revision "1"))
260 (package
261 (name "perl6-grammar-profiler-simple")
262 (version (git-version "0.02" revision commit))
263 (source
264 (origin
265 (method git-fetch)
266 (uri (git-reference
267 (url "https://github.com/perlpilot/Grammar-Profiler-Simple")
268 (commit commit)))
269 (file-name (git-file-name name version))
270 (sha256
271 (base32
272 "1qcsa4lmcilp3vp0jng0hrgzyzxin9ayg2wjvkcd0k6h7djx9dff"))))
273 (build-system rakudo-build-system)
274 (arguments '(#:with-zef? #f))
275 (home-page "https://github.com/perlpilot/Grammar-Profiler-Simple")
276 (synopsis "Simple rule profiling for Perl 6 grammars")
277 (description "This module provides a simple profiler for Perl 6 grammars.
278 To enable profiling simply add use @code{Grammar::Profiler::Simple;} to your
279 code. Any grammar in the lexical scope of the use statement will automatically
280 have profiling information collected when the grammar is used.")
281 (license license:artistic2.0))))
282
283 (define-public perl6-json
284 (package
285 (name "perl6-json")
286 (version "1.0")
287 (source
288 (origin
289 (method git-fetch)
290 (uri (git-reference
291 (url "https://github.com/moritz/json")
292 ;; The commit where 1.0 was "tagged"
293 (commit "a5ef8c179350dae44ce7fb1abb684fc62c1c2b99")))
294 (file-name (git-file-name name version))
295 (sha256
296 (base32
297 "1kzryxkqyr129rcckd4jh0dfxdgzv71qx8dpkpm1divbfjyknlay"))))
298 (build-system rakudo-build-system)
299 (arguments '(#:with-zef? #f))
300 (home-page "https://github.com/moritz/json")
301 (synopsis "Minimal JSON (de)serializer")
302 (description "This module is a simple Perl 6 module for serializing and
303 deserializing JSON.")
304 (license license:artistic2.0)))
305
306 (define-public perl6-json-class
307 (package
308 (name "perl6-json-class")
309 (version "0.0.12")
310 (source
311 (origin
312 (method git-fetch)
313 (uri (git-reference
314 (url "https://github.com/jonathanstowe/JSON-Class")
315 (commit (string-append "v" version))))
316 (file-name (git-file-name name version))
317 (sha256
318 (base32
319 "1zyzajc57j3m8q0nr72h9pw4w2nx92rafywlvysgphc5q9sb8np2"))))
320 (build-system rakudo-build-system)
321 (propagated-inputs
322 (list perl6-json-marshal perl6-json-unmarshal))
323 (native-inputs
324 (list perl6-json-fast))
325 (home-page "https://github.com/jonathanstowe/JSON-Class")
326 (synopsis "Provide simple serialisation/deserialisation of objects to/from JSON")
327 (description "This is a simple role that provides methods to instantiate a
328 class from a JSON string that (hopefully,) represents it, and to serialise an
329 object of the class to a JSON string. The JSON created from an instance
330 should round trip to a new instance with the same values for the public
331 attributes. Private attributes (that is ones without accessors,) will be
332 ignored for both serialisation and de-serialisation. The exact behaviour
333 depends on that of @code{JSON::Marshal} and @code{JSON::Unmarshal}
334 respectively.")
335 (license license:artistic2.0)))
336
337 (define-public perl6-json-fast
338 (package
339 (name "perl6-json-fast")
340 (version "0.10")
341 (source
342 (origin
343 (method git-fetch)
344 (uri (git-reference
345 (url "https://github.com/timo/json_fast")
346 (commit version)))
347 (file-name (git-file-name name version))
348 (sha256
349 (base32 "1g8hr1mdrxwdpzc7hvs9l5r12phvba6y6a5chgkj90ing77ji4b2"))))
350 (build-system rakudo-build-system)
351 (arguments '(#:with-zef? #f))
352 (home-page "https://github.com/timo/json_fast")
353 (synopsis "Perl6 json parser")
354 (description "A naive imperative json parser in pure perl6 (but with direct
355 access to @code{nqp::} ops), to evaluate performance against @code{JSON::Tiny}.
356 It is a drop-in replacement for @code{JSON::Tiny}'s from-json and to-json subs,
357 but it offers a few extra features.")
358 (license license:artistic2.0)))
359
360 (define-public perl6-json-marshal
361 (package
362 (name "perl6-json-marshal")
363 (version "0.0.16")
364 (source
365 (origin
366 (method git-fetch)
367 (uri (git-reference
368 (url "https://github.com/jonathanstowe/JSON-Marshal")
369 (commit (string-append "v" version))))
370 (file-name (git-file-name name version))
371 (sha256
372 (base32
373 "0qy7j83h6gjzyyv74ncd92cd9h45rv8diaz3vldiv3b6fqwz4c6i"))))
374 (build-system rakudo-build-system)
375 (propagated-inputs
376 (list perl6-json-fast perl6-json-name))
377 (native-inputs
378 (list perl6-json-fast))
379 (home-page "https://github.com/jonathanstowe/JSON-Marshal")
380 (synopsis "Simple serialisation of objects to JSON")
381 (description "This library provides a single exported subroutine to create
382 a JSON representation of an object. It should round trip back into an object
383 of the same class using @code{JSON::Unmarshal}.")
384 (license license:artistic2.0)))
385
386 (define-public perl6-json-name
387 (package
388 (name "perl6-json-name")
389 (version "0.0.3")
390 (source
391 (origin
392 (method git-fetch)
393 (uri (git-reference
394 (url "https://github.com/jonathanstowe/JSON-Name")
395 (commit (string-append "v" version))))
396 (file-name (git-file-name name version))
397 (sha256
398 (base32
399 "130qwdpbj5qdlsdz05y0rksd79lzbq79scy47n6lnf21b0hz1qjc"))))
400 (build-system rakudo-build-system)
401 (arguments '(#:with-zef? #f))
402 (home-page "https://github.com/jonathanstowe/JSON-Name")
403 (synopsis "Provides a trait to store an alternative JSON Name")
404 (description "This is released as a dependency of @code{JSON::Marshal} and
405 @code{JSON::Unmarshal} in order to save duplication, it is intended to store a
406 separate JSON name for an attribute where the name of the JSON attribute might be
407 changed, either for aesthetic reasons or the name is not a valid Perl identifier.
408 It will of course also be needed in classes thar are going to use
409 @code{JSON::Marshal} or @code{JSON::Unmarshal} for serialisation/de-serialisation.")
410 (license license:artistic2.0)))
411
412 (define-public perl6-json-unmarshal
413 ;; Last commit was May 2017
414 (let ((commit "e1b6288c5f3165058f36c0f4e171cdf2dfd640da")
415 (revision "1"))
416 (package
417 (name "perl6-json-unmarshal")
418 (version (git-version "0.0.0" revision commit))
419 (source
420 (origin
421 (method git-fetch)
422 (uri (git-reference
423 (url "https://github.com/tadzik/JSON-Unmarshal")
424 (commit commit)))
425 (file-name (git-file-name name version))
426 (sha256
427 (base32
428 "14azsmzmwdn8k0gqcpvballharcvzylmlyrx2wmv4kpqfnz29fjc"))))
429 (build-system rakudo-build-system)
430 (propagated-inputs
431 (list perl6-json-fast perl6-json-name))
432 (home-page "https://github.com/tadzik/JSON-Unmarshal")
433 (synopsis "Make JSON from an Object")
434 (description "This library provides a single exported subroutine to
435 create an object from a JSON representation of an object.")
436 (license license:expat))))
437
438 (define-public perl6-license-spdx
439 (package
440 (name "perl6-license-spdx")
441 (version "3.4.0")
442 (source
443 (origin
444 (method git-fetch)
445 (uri (git-reference
446 (url "https://github.com/jonathanstowe/License-SPDX")
447 (commit (string-append "v" version))))
448 (file-name (git-file-name name version))
449 (sha256
450 (base32
451 "0dl263c3fbxk001gm5fisrzqz1dx182ipaa0x2qva2gxvl075xm8"))))
452 (build-system rakudo-build-system)
453 (propagated-inputs
454 (list perl6-json-class))
455 (home-page "https://github.com/jonathanstowe/License-SPDX")
456 (synopsis "Abstraction over the SPDX License List")
457 (description "This provides an abstraction over the SPDX License List as
458 provided in JSON format. Its primary raison d'être is to help the licence
459 checking of @code{Test::META} and to allow for the warning about deprecated
460 licences therein.")
461 (license license:artistic2.0)))
462
463 (define-public perl6-meta6
464 (package
465 (name "perl6-meta6")
466 (version "0.0.23")
467 (source
468 (origin
469 (method git-fetch)
470 (uri (git-reference
471 (url "https://github.com/jonathanstowe/META6")
472 (commit (string-append "v" version))))
473 (file-name (git-file-name name version))
474 (sha256
475 (base32
476 "1xnlaamfbdlfb2zidim3bbc4mawsrg6qxhxi6gbld46z1cyry1cw"))))
477 (build-system rakudo-build-system)
478 (propagated-inputs
479 (list perl6-json-class))
480 (native-inputs
481 (list perl6-json-fast))
482 (home-page "https://github.com/jonathanstowe/META6")
483 (synopsis "Do things with Perl 6 [META files]")
484 (description "This provides a representation of the Perl 6 META files
485 specification - the META file data can be read, created, parsed and written in a
486 manner that is conformant with the specification.
487
488 Where they are known about it also makes allowance for customary usage in
489 existing software (such as installers and so forth.)
490
491 The intent of this is allow the generation and testing of META files for
492 module authors, so it can provide meta-information whether the attributes are
493 mandatory as per the spec and where known the places that customary attributes
494 are used.")
495 (license license:artistic2.0)))
496
497 (define-public perl6-mime-base64
498 (package
499 (name "perl6-mime-base64")
500 (version "1.2.1")
501 (source
502 (origin
503 (method git-fetch)
504 (uri (git-reference
505 (url "https://github.com/perl6/Perl6-MIME-Base64")
506 (commit (string-append "v" version))))
507 (file-name (git-file-name name version))
508 (sha256
509 (base32
510 "0l67m8mvz3gxml425sd1ggfnhzh4lf754k7w8fngfr453s6lsza1"))))
511 (build-system rakudo-build-system)
512 (arguments '(#:with-zef? #f))
513 (home-page "https://github.com/perl6/Perl6-MIME-Base64")
514 (synopsis "Encoding and decoding Base64 ASCII strings")
515 (description "This Perl 6 module implements encoding and decoding to and
516 from base64.")
517 (license license:artistic2.0)))
518
519 (define-public perl6-oo-monitors
520 (package
521 (name "perl6-oo-monitors")
522 (version "1.1")
523 (source
524 (origin
525 (method git-fetch)
526 (uri (git-reference
527 (url "https://github.com/jnthn/oo-monitors")
528 ;; The commit where 1.1 was "tagged"
529 (commit "494db3a3852854f30a80c9bd1489a7d5e429e7c5")))
530 (file-name (git-file-name name version))
531 (sha256
532 (base32
533 "1sbw2x54wwjjanghjnc7ipmplaw1srvbrphsdv4ym6cipnbmbj9x"))))
534 (build-system rakudo-build-system)
535 (arguments '(#:with-zef? #f))
536 (home-page "https://github.com/jnthn/oo-monitors")
537 (synopsis "Monitors with condition variables for Perl 6")
538 (description "A monitor provides per-instance mutual exclusion for objects.
539 This means that for a given object instance, only one thread can ever be inside
540 its methods at a time. This is achieved by a lock being associated with each
541 object. The lock is acquired automatically at the entry to each method in the
542 monitor. Condition variables are also supported.")
543 (license license:artistic2.0)))
544
545 (define-public perl6-svg
546 ;; Latest commit, basically unchanged since August 2015
547 (let ((commit "07190c0602aa276e5319f06aa0012452dbff3582")
548 (revision "1"))
549 (package
550 (name "perl6-svg")
551 (version (git-version "0.0.0" revision commit))
552 (source
553 (origin
554 (method git-fetch)
555 (uri (git-reference
556 (url "https://github.com/moritz/svg")
557 (commit commit)))
558 (file-name (git-file-name name version))
559 (sha256
560 (base32
561 "0mkjdhg7ajksdn61n8fqhyzfd7ly9myazsvpsm02a5c2q73hdygg"))))
562 (build-system rakudo-build-system)
563 (propagated-inputs
564 (list perl6-xml-writer))
565 (home-page "https://github.com/moritz/svg")
566 (synopsis "Perl 6 module to generate SVG")
567 (description "This is a Perl 6 module that makes it easy to write
568 @dfn{Scalable Vector Graphic files} (SVG). Right now it is a shallow wrapper
569 around @code{XML::Writer}, adding only the xmlns attributes that identifies an
570 XML file as SVG.")
571 (license license:artistic2.0))))
572
573 (define-public perl6-svg-plot
574 ;; Latest commit
575 (let ((commit "062570a78fd38c3c6baba29dfe2fbb8ca014f4de")
576 (revision "1"))
577 (package
578 (name "perl6-svg-plot")
579 (version (git-version "0.0.0" revision commit))
580 (source
581 (origin
582 (method git-fetch)
583 (uri (git-reference
584 (url "https://github.com/moritz/svg-plot")
585 (commit commit)))
586 (file-name (git-file-name name version))
587 (sha256
588 (base32
589 "095ga5hbg92jnmczxvhk1hjz14yr334zyf8cph4w5w5frcza44my"))))
590 (build-system rakudo-build-system)
591 (propagated-inputs
592 (list perl6-svg))
593 (home-page "https://github.com/moritz/svg-plot")
594 (synopsis "Perl 6 charting and plotting library that produces SVG output")
595 (description "@code{SVG::Plot} is a simple 2D chart plotter for Perl 6.
596 It currently supports bars, stacked bars, lines and points (both equally spaced
597 with optional labels, or xy plots).")
598 (license license:artistic2.0))))
599
600 (define-public perl6-tap-harness
601 (package
602 (name "perl6-tap-harness")
603 (version "0.0.7")
604 (source
605 (origin
606 (method git-fetch)
607 (uri (git-reference
608 (url "https://github.com/perl6/tap-harness6")
609 (commit (string-append "v" version))))
610 (file-name (git-file-name name version))
611 (sha256
612 (base32
613 "1lig8i0my3fgqvlay9532xslbf3iis2d7wz89gniwvwqffi2kh6r"))))
614 (build-system rakudo-build-system)
615 (arguments
616 '(#:with-zef? #f
617 #:with-prove6? #f
618 #:phases
619 (modify-phases %standard-phases
620 (replace 'check
621 (lambda _
622 (invoke "perl6" "-Ilib" "bin/prove6" "-l" "t"))))))
623 (home-page "https://github.com/perl6/tap-harness6/")
624 (synopsis "TAP harness for perl6")
625 (description "This module provides the @command{prove6} command which runs a
626 TAP based test suite and prints a report. The @command{prove6} command is a
627 minimal wrapper around an instance of this module.")
628 (license license:artistic2.0)))
629
630 (define-public perl6-terminal-ansicolor
631 (package
632 (name "perl6-terminal-ansicolor")
633 (version "0.5")
634 (source
635 (origin
636 (method git-fetch)
637 (uri (git-reference
638 (url "https://github.com/tadzik/Terminal-ANSIColor")
639 ;; The commit where 0.5 was "tagged"
640 (commit "edded4a7116ce11cbc9fb5a83669c7ba119d0212")))
641 (file-name (git-file-name name version))
642 (sha256
643 (base32
644 "1apm999azkyg5s35gid12wq019aqnvzrkz7qjmipd74mdxgr00x7"))))
645 (build-system rakudo-build-system)
646 (arguments '(#:with-zef? #f))
647 (home-page "https://github.com/tadzik/Terminal-ANSIColor")
648 (synopsis "Colorize terminal output")
649 (description "This is a @code{Terminal::ANSIColor} module for Perl 6.")
650 (license license:expat)))
651
652 (define-public perl6-test-meta
653 (package
654 (name "perl6-test-meta")
655 (version "0.0.14")
656 (source
657 (origin
658 (method git-fetch)
659 (uri (git-reference
660 (url "https://github.com/jonathanstowe/Test-META")
661 (commit (string-append "v" version))))
662 (file-name (git-file-name name version))
663 (sha256
664 (base32
665 "1mzrglb7lbiy5h9dlc7dyhvv9gppxmdmpmrv6nzbd695jzr38bri"))))
666 (build-system rakudo-build-system)
667 (propagated-inputs
668 (list perl6-meta6 perl6-uri))
669 (home-page "https://github.com/jonathanstowe/Test-META")
670 (synopsis "Test a distributions META file")
671 (description "This provides a simple mechanism for module authors to have
672 some confidence that they have a working distribution META description file.")
673 (license license:artistic2.0)))
674
675 (define-public perl6-test-mock
676 (package
677 (name "perl6-test-mock")
678 (version "1.5")
679 (source
680 (origin
681 (method git-fetch)
682 (uri (git-reference
683 (url "https://github.com/jnthn/test-mock")
684 ;; The commit where 1.5 was "tagged"
685 (commit "6eddb42f73f40b9ac29c14badb41ce4a04d876f2")))
686 (file-name (git-file-name name version))
687 (sha256
688 (base32
689 "07yr3qimc8fl29p23562ayj2j9h53madcnf9sgqvgf2kcprh0zd2"))))
690 (build-system rakudo-build-system)
691 (propagated-inputs
692 (list perl6-oo-monitors))
693 (home-page "https://github.com/jnthn/test-mock")
694 (synopsis "Module for simply generating and checking mock objects")
695 (description "@code{Test::Mock} is a module that works alongside the
696 standard Test module to help you write tests when you want to verify what
697 methods are called on an object, while still having calls to undefined methods
698 die. You get started just as normal with the test file, but also add a use
699 statement for @code{Test::Mock}.")
700 (license license:artistic2.0)))
701
702 (define-public perl6-uri
703 (package
704 (name "perl6-uri")
705 (version "0.1.5")
706 (source
707 (origin
708 (method git-fetch)
709 (uri (git-reference
710 (url "https://github.com/perl6-community-modules/uri")
711 (commit version)))
712 (file-name (git-file-name name version))
713 (sha256
714 (base32
715 "0h318g75jqn2ckw051g35iqyfxz1mps0jyg5z6pd857y3kacbkpl"))))
716 (build-system rakudo-build-system)
717 (arguments '(#:with-zef? #f))
718 (home-page "https://github.com/perl6-community-modules/uri")
719 (synopsis "URI implementation using Perl 6")
720 (description "A URI implementation using Perl 6 grammars to implement RFC
721 3986 BNF. Currently only implements parsing. Includes @code{URI::Escape} to
722 (un?)escape characters that aren't otherwise allowed in a URI with % and a hex
723 character numbering.")
724 (license license:artistic2.0)))
725
726 (define-public perl6-xml-writer
727 ;; Last commit was May 2017
728 (let ((commit "4d30a9d8e06033ca97387971b653817becd5a759")
729 (revision "1"))
730 (package
731 (name "perl6-xml-writer")
732 (version (git-version "0.0.0" revision commit))
733 (source
734 (origin
735 (method git-fetch)
736 (uri (git-reference
737 (url "https://github.com/masak/xml-writer")
738 (commit commit)))
739 (file-name (git-file-name name version))
740 (sha256
741 (base32
742 "1kwrf7akp70kyzw1b90khp71a6hpilihwndy2jsjpffcd4hd4m4z"))))
743 (build-system rakudo-build-system)
744 (arguments '(#:with-zef? #f))
745 (home-page "https://github.com/masak/xml-writer")
746 (synopsis "Perl 6 module to generate XML")
747 (description "@code{XML::Writer} is a module for creating XML in Perl 6.")
748 (license license:artistic2.0))))
749
750 (define-public perl6-zef
751 (package
752 (name "perl6-zef")
753 (version "0.6.7")
754 (source
755 (origin
756 (method git-fetch)
757 (uri (git-reference
758 (url "https://github.com/ugexe/zef")
759 (commit (string-append "v" version))))
760 (file-name (git-file-name name version))
761 (sha256
762 (base32
763 "07n7g1xw2c4g860rs890gx85vyhdq0ysgwbrnzw6q905jph2bkv7"))))
764 (build-system rakudo-build-system)
765 (arguments
766 '(#:with-zef? #f
767 #:phases
768 (modify-phases %standard-phases
769 (replace 'check
770 (lambda _
771 (setenv "HOME" "/tmp")
772 (invoke "perl6" "-I." "bin/zef" "--debug"
773 "--tap-harness" "test" "."))))))
774 (home-page "https://github.com/ugexe/zef")
775 (synopsis "Perl6 Module Management")
776 (description "Zef is a Perl 6 package (module) manager. It can be used to
777 download and install Perl 6 modules in your home directory or as a system-wide
778 module.")
779 (license license:artistic2.0)))