gnu: r-zellkonverter: Update to 1.6.5.
[jackhill/guix/guix.git] / gnu / packages / kde-systemtools.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2017, 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
3 ;;; Copyright © 2021 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages kde-systemtools)
21 #:use-module (guix build-system qt)
22 #:use-module (guix download)
23 #:use-module ((guix licenses) #:prefix license:)
24 #:use-module (guix packages)
25 #:use-module (guix utils)
26 #:use-module (gnu packages)
27 #:use-module (gnu packages compression)
28 #:use-module (gnu packages kde)
29 #:use-module (gnu packages kde-frameworks)
30 #:use-module (gnu packages linux)
31 #:use-module (gnu packages pkg-config)
32 #:use-module (gnu packages qt)
33 #:use-module (gnu packages ruby)
34 #:use-module (gnu packages search)
35 #:use-module (gnu packages vnc)
36 #:use-module (gnu packages xml)
37 #:use-module (gnu packages xorg))
38
39 (define-public dolphin
40 (package
41 (name "dolphin")
42 (version "20.04.1")
43 (source
44 (origin
45 (method url-fetch)
46 (uri (string-append "mirror://kde/stable/release-service/" version
47 "/src/dolphin-" version ".tar.xz"))
48 (sha256
49 (base32 "0xr5s0s40i2bsfjfapvpa7dxh9s4604cxirg97xcaacd6fdvhpds"))))
50 (build-system qt-build-system)
51 (native-inputs
52 (list extra-cmake-modules kdoctools ruby ruby-test-unit))
53 (inputs
54 (list baloo
55 baloo-widgets
56 kactivities
57 kbookmarks
58 kcmutils
59 kcompletion
60 kconfig
61 kcoreaddons
62 kcrash
63 kdbusaddons
64 ki18n
65 kiconthemes
66 kinit
67 kio
68 knewstuff
69 knotifications
70 kparts
71 ktextwidgets
72 kwindowsystem
73 oxygen-icons ;; default icon set
74 phonon
75 qtbase-5
76 solid))
77 (arguments
78 `(#:tests? #f)) ;; TODO: 4/15 tests fail even with offscreen
79 (home-page "https://kde.org/applications/system/org.kde.dolphin")
80 (synopsis "File manager for KDE")
81 (description "Dolphin is a file manager for KDE focusing on usability.
82 The main features of Dolphin are:
83 @itemize
84 @item Navigation bar for URLs, which navigates quickly
85 through the file hierarchy.
86 @item View properties are remembered for each folder.
87 @item Split of views is supported.
88 @item Network transparency.
89 @item Undo/redo functionality.
90 @item Renaming of a variable number of selected items in one step.
91 @end itemize")
92 (license ;; GPL for programs, FDL for documentation
93 (list license:gpl2+ license:fdl1.2+))))
94
95 (define-public dolphin-plugins
96 (package
97 (name "dolphin-plugins")
98 (version "20.04.1")
99 (source
100 (origin
101 (method url-fetch)
102 (uri (string-append "mirror://kde/stable/release-service/" version
103 "/src/dolphin-plugins-" version ".tar.xz"))
104 (sha256
105 (base32 "12g44s6g7ma6avp15l45l42qyzbglswvahm2wji79zdls5vjnz7r"))))
106 (build-system qt-build-system)
107 (native-inputs
108 (list extra-cmake-modules))
109 (inputs
110 (list dolphin
111 ki18n
112 kio
113 ktexteditor
114 kxmlgui
115 oxygen-icons ;; default icon set
116 qtbase-5))
117 (home-page "http://www.kde.org/")
118 (synopsis "VCS-Plugins for Dolphin")
119 (description "This package contains plugins that offer integration in
120 Dolphin with the version control systems: Bzr, Git, Mercurial, Subversion.")
121 (license license:gpl2+)))
122
123 (define-public khelpcenter
124 (package
125 (name "khelpcenter")
126 (version "20.04.1")
127 (source
128 (origin
129 (method url-fetch)
130 (uri (string-append "mirror://kde/stable/release-service/" version
131 "/src/khelpcenter-" version ".tar.xz"))
132 (sha256
133 (base32 "0wxzjragvjcfc7c4qja8wzpshhaywficj7f7wkmppzybcsxwn9qb"))))
134 (build-system qt-build-system)
135 (native-inputs
136 (list extra-cmake-modules kdoctools))
137 (inputs
138 (list grantlee
139 karchive
140 kbookmarks
141 kcodecs
142 kconfig
143 kcoreaddons
144 kdbusaddons
145 khtml
146 ki18n
147 kinit
148 kio
149 kjs
150 kparts
151 kservice
152 kwindowsystem
153 libxml2
154 oxygen-icons ;; default icon set
155 qtbase-5
156 xapian))
157 (arguments
158 `(#:tests? #f)) ;; 1/1 test fails
159 (home-page "https://kde.org/applications/system/org.kde.Help")
160 (synopsis "KDE documentation viewer")
161 (description "KHelpCenter uses meta data files which describe the
162 documentation available in the system. Each document is represented by a meta
163 data file and shown as an entry in the KHelpCenter navigation tree view. The
164 meta data contains information about title and short description of the
165 document, the location of the document and some more information like how to
166 search the document and translations of title and description. Document
167 hierarchy is represented as hierarchy of the meta data files. Directories are
168 also described by a meta data file which contains the same information as a
169 document meta data file.")
170 (license license:gpl2+)))
171
172 (define-public konsole
173 (package
174 (name "konsole")
175 (version "20.04.1")
176 (source
177 (origin
178 (method url-fetch)
179 (uri (string-append "mirror://kde/stable/release-service/" version
180 "/src/konsole-" version ".tar.xz"))
181 (sha256
182 (base32 "0ckr7bjkyaw0gr5kx569jfnhkhwmlk4lqk41ng61qwxlb4bsdbdm"))))
183 (build-system qt-build-system)
184 (native-inputs
185 (list extra-cmake-modules kdoctools))
186 (inputs
187 (list kbookmarks
188 kcompletion
189 kconfig
190 kconfigwidgets
191 kcoreaddons
192 kcrash
193 kdbusaddons
194 kguiaddons
195 ki18n
196 kiconthemes
197 kinit
198 kio
199 knewstuff
200 kglobalaccel
201 knotifications
202 knotifyconfig
203 kparts
204 kpty
205 kservice
206 ktextwidgets
207 kwidgetsaddons
208 kwindowsystem
209 kxmlgui
210 oxygen-icons ;; default icon set
211 qtbase-5
212 qtscript))
213 (arguments
214 `(#:tests? #f)) ;; TODO: 2/15 tests fail even with HOME, offscreen, SHELL, debus
215 (home-page "http://www.kde.org/")
216 (synopsis "Terminal emulator similar for KDE")
217 (description "Konsole is a terminal emulator, similar to xterm, built on
218 the KDE Platform. It can contain multiple terminal sessions inside one window
219 using detachable tabs. Konsole supports customizable schemes, saved sessions,
220 output monitoring and more.
221
222 This package is part of the KDE base applications module.")
223 (license ;; GPL for programs, LGPL for libraries, FDL for documentation
224 (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
225
226 (define-public krfb
227 (package
228 (name "krfb")
229 (version "20.04.1")
230 (source
231 (origin
232 (method url-fetch)
233 (uri (string-append "mirror://kde/stable/release-service/" version
234 "/src/krfb-" version ".tar.xz"))
235 (sha256
236 (base32 "092ijn88jpmgk2zwz37vzf35jisl234mc3krc9jl7bd955akx51k"))))
237 (build-system qt-build-system)
238 (native-inputs
239 (list extra-cmake-modules pkg-config kdoctools))
240 (inputs
241 (list kcompletion
242 kconfig
243 kcoreaddons
244 kcrash
245 kdbusaddons
246 kdnssd
247 ki18n
248 knotifications
249 kwallet
250 kwidgetsaddons
251 kwindowsystem
252 kxmlgui
253 libvnc
254 libxcb
255 libxtst
256 oxygen-icons ;; default icon set
257 pipewire-0.3
258 qtbase-5
259 qtx11extras
260 xcb-util-image
261 zlib))
262 (home-page "https://kde.org/applications/internet/org.kde.krfb")
263 (synopsis "Desktop Sharing utility")
264 (description "KDE Desktop Sharing is a server application that allows you
265 to share your current session with a user on another machine. The desktop
266 session can be viewed or even controlled remotely by any VNC or RFB client,
267 such as the KDE Remote Desktop Connection client.
268
269 KDE Desktop Sharing can restrict access to only users who are explicitly
270 invited, and will ask for confirmation when a user attempts to connect.
271
272 This package is part of the KDE networking module.")
273 (license ;; GPL for programs, LGPL for libraries, FDL for documentation
274 (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
275
276 (define-public ksystemlog
277 (package
278 (name "ksystemlog")
279 (version "20.04.1")
280 (source
281 (origin
282 (method url-fetch)
283 (uri (string-append "mirror://kde/stable/release-service/" version
284 "/src/ksystemlog-" version ".tar.xz"))
285 (sha256
286 (base32 "1826h89ynvlxdwzyqil2d79cvynglww6fax7qp41wxasgarxhsni"))))
287 (build-system qt-build-system)
288 (native-inputs
289 (list extra-cmake-modules kdoctools))
290 (inputs
291 ;; Not including Journald since this is not used in guix
292 (list karchive
293 kcompletion
294 kconfig
295 kcoreaddons
296 ki18n
297 kiconthemes
298 kio
299 kitemviews
300 ktextwidgets
301 kwidgetsaddons
302 kxmlgui
303 oxygen-icons ;; default icon set
304 qtbase-5))
305 (home-page "https://kde.org/applications/system/org.kde.ksystemlog")
306 (synopsis "System log viewer")
307 (description "This program is developed for being used by beginner users,
308 which don't know how to find information about their Linux system, and how the
309 log files are in their computer. But it is also designed for advanced users,
310 who want to quickly see problems occurring on their server.
311
312 This package is part of the KDE administration module.")
313 (license license:gpl2+)))
314
315 (define-public yakuake
316 (package
317 (name "yakuake")
318 (version "20.12.1")
319 (source (origin
320 (method url-fetch)
321 (uri (string-append "mirror://kde/stable/release-service/" version
322 "/src/yakuake-" version ".tar.xz"))
323 (sha256
324 (base32
325 "02pal9xx1wbpw7dimvs2aw1xnyjqlvbjlybkkfhf8x7c6m1r63aa"))))
326 (build-system qt-build-system)
327 (native-inputs
328 (list extra-cmake-modules))
329 (inputs
330 (list breeze-icons
331 karchive
332 kconfig
333 kcoreaddons
334 kcrash
335 kdbusaddons
336 kglobalaccel
337 ki18n
338 kiconthemes
339 kio
340 knewstuff
341 knotifications
342 knotifyconfig
343 konsole
344 kparts
345 kwayland
346 kwidgetsaddons
347 kwindowsystem
348 qtbase-5
349 qtsvg-5
350 qtx11extras))
351 (home-page "https://www.kde.org/applications/system/yakuake/")
352 (synopsis "Quad-style terminal emulator for KDE")
353 (description "Yakuake is a drop-down terminal emulator based on KDE Konsole
354 technology. Features include:
355 @itemize
356 @item Smoothly rolls down from the top of your screen
357 @item Tabbed interface
358 @item Configurable dimensions and animation speed
359 @item Skinnable
360 @item Sophisticated D-Bus interface
361 @end itemize")
362 (license license:gpl2+)))