gnu: Add IO-Socket-IP.
[jackhill/guix/guix.git] / gnu / packages / web.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2013 Aljosha Papsch <misc@rpapsch.de>
4 ;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
5 ;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
6 ;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
7 ;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
8 ;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
9 ;;;
10 ;;; This file is part of GNU Guix.
11 ;;;
12 ;;; GNU Guix is free software; you can redistribute it and/or modify it
13 ;;; under the terms of the GNU General Public License as published by
14 ;;; the Free Software Foundation; either version 3 of the License, or (at
15 ;;; your option) any later version.
16 ;;;
17 ;;; GNU Guix is distributed in the hope that it will be useful, but
18 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
19 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
20 ;;; GNU General Public License for more details.
21 ;;;
22 ;;; You should have received a copy of the GNU General Public License
23 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
24
25 (define-module (gnu packages web)
26 #:use-module (ice-9 match)
27 #:use-module ((guix licenses) #:prefix l:)
28 #:use-module (guix packages)
29 #:use-module (guix download)
30 #:use-module (guix git-download)
31 #:use-module (guix cvs-download)
32 #:use-module (guix build-system gnu)
33 #:use-module (guix build-system perl)
34 #:use-module (guix build-system cmake)
35 #:use-module (gnu packages apr)
36 #:use-module (gnu packages asciidoc)
37 #:use-module (gnu packages docbook)
38 #:use-module (gnu packages autotools)
39 #:use-module (gnu packages compression)
40 #:use-module (gnu packages cyrus-sasl)
41 #:use-module (gnu packages openssl)
42 #:use-module (gnu packages gettext)
43 #:use-module (gnu packages icu4c)
44 #:use-module (gnu packages lua)
45 #:use-module (gnu packages base)
46 #:use-module (gnu packages pcre)
47 #:use-module (gnu packages pkg-config)
48 #:use-module (gnu packages xml)
49 #:use-module (gnu packages curl)
50 #:use-module (gnu packages perl)
51 #:use-module (gnu packages texinfo))
52
53 (define-public httpd
54 (package
55 (name "httpd")
56 (version "2.4.12")
57 (source (origin
58 (method url-fetch)
59 (uri (string-append "mirror://apache/httpd/httpd-"
60 version ".tar.bz2"))
61 (sha256
62 (base32
63 "1r7a63ka41vlswrqbb21vall6sc7svwgd497kb6dh8a6zvnkjvdd"))))
64 (build-system gnu-build-system)
65 (inputs `(("apr" ,apr)
66 ("apr-util" ,apr-util)
67 ("openssl" ,openssl)
68 ("pcre" ,pcre)
69 ("perl" ,perl))) ; needed to run bin/apxs
70 (arguments
71 `(#:test-target "test"
72 #:configure-flags (list "--enable-rewrite"
73 "--enable-userdir"
74 "--enable-vhost-alias"
75 "--enable-ssl"
76 "--enable-mime-magic"
77 (string-append "--sysconfdir="
78 (assoc-ref %outputs "out")
79 "/etc/httpd"))))
80 (synopsis "Featureful HTTP server")
81 (description
82 "The Apache HTTP Server Project is a collaborative software development
83 effort aimed at creating a robust, commercial-grade, featureful, and
84 freely-available source code implementation of an HTTP (Web) server. The
85 project is jointly managed by a group of volunteers located around the world,
86 using the Internet and the Web to communicate, plan, and develop the server
87 and its related documentation.")
88 (license l:asl2.0)
89 (home-page "https://httpd.apache.org/")))
90
91 (define-public nginx
92 (package
93 (name "nginx")
94 (version "1.6.2")
95 (source (origin
96 (method url-fetch)
97 (uri (string-append "http://nginx.org/download/nginx-"
98 version ".tar.gz"))
99 (sha256
100 (base32
101 "060s77qxhkn02fjkcndsr0xppj2bppjzkj0gn84svrykb4lqqq5m"))))
102 (build-system gnu-build-system)
103 (inputs `(("pcre" ,pcre)
104 ("openssl" ,openssl)
105 ("zlib" ,zlib)))
106 (arguments
107 `(#:tests? #f ; no test target
108 #:phases
109 (alist-cons-before
110 'configure 'patch-/bin/sh
111 (lambda _
112 (substitute* "auto/feature"
113 (("/bin/sh") (which "bash"))))
114 (alist-replace
115 'configure
116 (lambda* (#:key outputs #:allow-other-keys)
117 (let ((flags
118 (list (string-append "--prefix=" (assoc-ref outputs "out"))
119 "--with-http_ssl_module"
120 "--with-pcre-jit"
121 "--with-ipv6"
122 "--with-debug"
123 ;; Even when not cross-building, we pass the
124 ;; --crossbuild option to avoid customizing for the
125 ;; kernel version on the build machine.
126 ,(let ((system "Linux") ; uname -s
127 (release "2.6.32") ; uname -r
128 ;; uname -m
129 (machine (match (or (%current-target-system)
130 (%current-system))
131 ("x86_64-linux" "x86_64")
132 ("i686-linux" "i686")
133 ("mips64el-linux" "mips64"))))
134 (string-append "--crossbuild="
135 system ":" release ":" machine)))))
136 (setenv "CC" "gcc")
137 (format #t "environment variable `CC' set to `gcc'~%")
138 (format #t "configure flags: ~s~%" flags)
139 (zero? (apply system* "./configure" flags))))
140 %standard-phases))))
141 (home-page "http://nginx.org")
142 (synopsis "HTTP and reverse proxy server")
143 (description
144 "Nginx (\"engine X\") is a high-performance web and reverse proxy server
145 created by Igor Sysoev. It can be used both as a standalone web server
146 and as a proxy to reduce the load on back-end HTTP or mail servers.")
147 ;; Almost all of nginx is distributed under the bsd-2 license.
148 ;; The exceptions are:
149 ;; * The 'nginx-http-push' module is covered by the expat license.
150 ;; * The 'nginx-development-kit' module is mostly covered by bsd-3,
151 ;; except for two source files which are bsd-4 licensed.
152 (license (list l:bsd-2 l:expat l:bsd-3 l:bsd-4))))
153
154 (define-public jansson
155 (package
156 (name "jansson")
157 (version "2.7")
158 (source (origin
159 (method url-fetch)
160 (uri
161 (string-append "http://www.digip.org/jansson/releases/jansson-"
162 version ".tar.gz"))
163 (sha256
164 (base32
165 "1mvq9p85khsl818i4vbszyfab0fd45mdrwrxjkzw05mk1xcyc1br"))))
166 (build-system gnu-build-system)
167 (home-page "http://www.digip.org/jansson/")
168 (synopsis "JSON C library")
169 (description
170 "Jansson is a C library for encoding, decoding and manipulating JSON
171 data.")
172 (license l:expat)))
173
174 (define-public json-c
175 (package
176 (name "json-c")
177 (version "0.12")
178 (source (origin
179 (method url-fetch)
180 (uri (string-append "https://s3.amazonaws.com/json-c_releases/releases/json-c-"
181 version ".tar.gz"))
182 (sha256
183 (base32
184 "0gwzic3ifg2d0w32ya3agpxh8i083cgvf7kmc51cnbgqnfr02300"))
185 (modules '((guix build utils)))
186 (snippet
187 '(begin
188 ;; Somehow 'config.h.in' is older than
189 ;; 'aclocal.m4', which would trigger a rule to
190 ;; run 'autoheader'.
191 (set-file-time "config.h.in"
192 (stat "aclocal.m4"))
193
194 ;; Don't try to build with -Werror.
195 (substitute* (find-files "." "Makefile\\.in")
196 (("-Werror") ""))))))
197 (build-system gnu-build-system)
198 (arguments '(#:parallel-build? #f
199 #:parallel-tests? #f))
200 (home-page "https://github.com/json-c/json-c/wiki")
201 (synopsis "JSON implementation in C")
202 (description
203 "JSON-C implements a reference counting object model that allows you to
204 easily construct JSON objects in C, output them as JSON formatted strings and
205 parse JSON formatted strings back into the C representation of JSON objects.")
206 (license l:x11)))
207
208 (define-public libwebsockets
209 (package
210 (name "libwebsockets")
211 (version "1.3")
212 (source (origin
213 ;; The project does not publish tarballs, so we have to take
214 ;; things from Git.
215 (method git-fetch)
216 (uri (git-reference
217 (url "git://git.libwebsockets.org/libwebsockets")
218 (commit (string-append "v" version
219 "-chrome37-firefox30"))))
220 (sha256
221 (base32
222 "12fqh2d2098mgf0ls19p9lzibpsqhv7mc5rn1yvrbfnazmcr40g4"))
223 (file-name (string-append name "-" version))))
224
225 (build-system cmake-build-system)
226 (arguments
227 ;; XXX: The thing lacks a 'make test' target, because CMakeLists.txt
228 ;; doesn't use 'add_test', and it's unclear how to run the test suite.
229 '(#:tests? #f))
230
231 (native-inputs `(("perl" ,perl))) ; to build the HTML doc
232 (inputs `(("zlib" ,zlib)
233 ("openssl" ,openssl)))
234 (synopsis "WebSockets library written in C")
235 (description
236 "Libwebsockets is a library that allows C programs to establish client
237 and server WebSockets connections---a protocol layered above HTTP that allows
238 for efficient socket-like bidirectional reliable communication channels.")
239 (home-page "http://libwebsockets.org/")
240
241 ;; This is LGPLv2.1-only with extra exceptions specified in 'LICENSE'.
242 (license l:lgpl2.1)))
243
244 (define-public libpsl
245 (package
246 (name "libpsl")
247 (version "0.6.0")
248 (source (origin
249 (method url-fetch)
250 (uri (string-append "https://github.com/rockdaboot/libpsl/"
251 "archive/" version ".tar.gz"))
252 (sha256
253 (base32
254 "10s7xxxx6pp4ydp3san69sa6q379ih3pv92fyi565ggmlw8igv7a"))
255 (file-name (string-append name "-" version ".tar.gz"))
256 (modules '((guix build utils)))
257 (snippet
258 ;; Believe it or not, the .pc is invalid. Fix it.
259 '(substitute* "libpsl.pc.in"
260 (("-llibpsl") "-lpsl")))))
261 (build-system gnu-build-system)
262 (inputs `(("icu4c" ,icu4c)))
263 ;; The release tarball lacks the generated files.
264 (native-inputs `(("autoconf" ,autoconf)
265 ("automake" ,automake)
266 ("gettext" ,gnu-gettext)
267 ("which" ,which)
268 ("libtool" ,libtool)))
269 (arguments
270 `(#:phases (alist-cons-after
271 'unpack 'bootstrap
272 (lambda _
273 (zero? (system* "sh" "autogen.sh")))
274 %standard-phases)))
275 (home-page "https://github.com/rockdaboot/libpsl")
276 (synopsis "C library for the Publix Suffix List")
277 (description
278 "A \"public suffix\" is a domain name under which Internet users can
279 directly register own names.
280
281 Browsers and other web clients can use it to avoid privacy-leaking
282 \"supercookies\", avoid privacy-leaking \"super domain\" certificates, domain
283 highlighting parts of the domain in a user interface, and sorting domain lists
284 by site.
285
286 Libpsl has built-in PSL data for fast access, allows to load PSL data from
287 files, checks if a given domain is a public suffix, provides immediate cookie
288 domain verification, finds the longest public part of a given domain, finds
289 the shortest private part of a given domain, works with international
290 domains (UTF-8 and IDNA2008 Punycode), is thread-safe, and handles IDNA2008
291 UTS#46")
292 (license l:x11)))
293
294 (define-public tidy
295 (package
296 (name "tidy")
297 (version "20091223")
298 (source (origin
299 (method cvs-fetch)
300 (uri (cvs-reference
301 (root-directory
302 ":pserver:anonymous@tidy.cvs.sourceforge.net:/cvsroot/tidy")
303 (module "tidy")
304 (revision "2009-12-23")))
305 (sha256
306 (base32
307 "14dsnmirjcrvwsffqp3as70qr6bbfaig2fv3zvs5g7005jrsbvpb"))))
308 (build-system gnu-build-system)
309 (arguments
310 '(#:phases (alist-cons-after
311 'unpack 'bootstrap
312 (lambda* (#:key inputs #:allow-other-keys)
313 ;; configure.in and Makefile.am aren't in the root of the
314 ;; source tree.
315 (copy-recursively "build/gnuauto" ".")
316 (setenv "AUTOMAKE" "automake --foreign")
317 (zero? (system* "autoreconf" "-vfi")))
318 %standard-phases)))
319 (native-inputs
320 `(("automake" ,automake)
321 ("autoconf" ,autoconf)
322 ("libtool" ,libtool)))
323 (synopsis "HTML validator and tidier")
324 (description "HTML Tidy is a command-line tool and C library that can be
325 used to validate and fix HTML data.")
326 (home-page "http://tidy.sourceforge.net/")
327 (license (l:x11-style "file:///include/tidy.h"))))
328
329 (define-public tinyproxy
330 (package
331 (name "tinyproxy")
332 (version "1.8.3")
333 (source (origin
334 (method url-fetch)
335 (uri (string-append
336 "http://www.samba.org/~obnox/" name "/download/"
337 name "-" version ".tar.bz2"))
338 (sha256
339 (base32
340 "0vl9igw7vm924rs6d6bkib7zfclxnlf9s8rmml1sfwj7xda9nmdy"))))
341 (build-system gnu-build-system)
342 (arguments
343 `(#:configure-flags
344 (list
345 ;; For the log file, etc.
346 "--localstatedir=/var")
347 #:phases
348 (alist-cons-before
349 'build 'pre-build
350 (lambda* (#:key inputs #:allow-other-keys #:rest args)
351 ;; Uncommenting the next two lines may assist in debugging
352 ;; (substitute* "docs/man5/Makefile" (("a2x") "a2x -v"))
353 ;; (setenv "XML_DEBUG_CATALOG" "1")
354 #t)
355 %standard-phases)))
356 ;; All of the below are used to generate the documentation
357 ;; (Should they be propagated inputs of asciidoc ??)
358 (native-inputs `(("asciidoc" ,asciidoc)
359 ("libxml2" ,libxml2)
360 ("docbook-xml" ,docbook-xml)
361 ("docbook-xsl" ,docbook-xsl)
362 ("libxslt" ,libxslt)))
363 (home-page "https://banu.com/tinyproxy/")
364 (synopsis "Light-weight HTTP/HTTPS proxy daemon")
365 (description "Tinyproxy is a light-weight HTTP/HTTPS proxy
366 daemon. Designed from the ground up to be fast and yet small, it is an ideal
367 solution for use cases such as embedded deployments where a full featured HTTP
368 proxy is required, but the system resources for a larger proxy are
369 unavailable.")
370 (license l:gpl2+)))
371
372 (define-public polipo
373 (package
374 (name "polipo")
375 (version "1.1.1")
376 (source
377 (origin
378 (method url-fetch)
379 (uri (string-append
380 "http://www.pps.univ-paris-diderot.fr/~jch/software/files/polipo/polipo-"
381 version ".tar.gz"))
382 (sha256
383 (base32
384 "05g09sg9qkkhnc2mxldm1w1xkxzs2ylybkjzs28w8ydbjc3pand2"))))
385 (native-inputs `(("texinfo" ,texinfo)))
386 (build-system gnu-build-system)
387 (arguments
388 `(#:phases
389 (alist-delete 'configure %standard-phases)
390 #:make-flags (let ((out (assoc-ref %outputs "out")))
391 (list (string-append "PREFIX=" out)
392 (string-append "LOCAL_ROOT="
393 out "/share/polipo/www")
394 "CC=gcc"))
395 ;; No 'check' target.
396 #:tests? #f))
397 (home-page "http://www.pps.univ-paris-diderot.fr/~jch/software/polipo/")
398 (synopsis "Small caching web proxy")
399 (description
400 "Polipo is a small caching web proxy (web cache, HTTP proxy, and proxy
401 server). It was primarily designed to be used by one person or a small group
402 of people.")
403 (license l:expat)))
404
405 (define-public libyaml
406 (package
407 (name "libyaml")
408 (version "0.1.5")
409 (source
410 (origin
411 (method url-fetch)
412 (uri (string-append
413 "http://pyyaml.org/download/libyaml/yaml-"
414 version ".tar.gz"))
415 (sha256
416 (base32
417 "1vrv5ly58bkmcyc049ad180f2m8iav6l9h3v8l2fqdmrny7yx1zs"))))
418 (build-system gnu-build-system)
419 (home-page "http://pyyaml.org/wiki/LibYAML")
420 (synopsis "YAML 1.1 parser and emitter written in C")
421 (description
422 "LibYAML is a YAML 1.1 parser and emitter written in C.")
423 (license l:expat)))
424
425 (define-public libquvi-scripts
426 (package
427 (name "libquvi-scripts")
428 (version "0.4.21")
429 (source
430 (origin
431 (method url-fetch)
432 (uri (string-append
433 "mirror://sourceforge/quvi/libquvi-scripts-" version ".tar.xz"))
434 (sha256
435 (base32 "0d0giry6bb57pnidymvdl7i5x9bq3ljk3g4bs294hcr5mj3cq0kw"))))
436 (build-system gnu-build-system)
437 (home-page "http://quvi.sourceforge.net/")
438 (synopsis "Media stream URL parser")
439 (description "This package contains support scripts called by libquvi to
440 parse media stream properties.")
441 (license l:lgpl2.1+)))
442
443 (define-public libquvi
444 (package
445 (name "libquvi")
446 (version "0.4.1")
447 (source
448 (origin
449 (method url-fetch)
450 (uri (string-append
451 "mirror://sourceforge/quvi/libquvi-" version ".tar.xz"))
452 (sha256
453 (base32 "00x9gbmzc5cns0gnfag0hsphcr3cb33vbbb9s7ppvvd6bxz2z1mm"))))
454 (build-system gnu-build-system)
455 (native-inputs `(("pkg-config" ,pkg-config)))
456 (inputs
457 `(("curl" ,curl)
458 ("cyrus-sasl" ,cyrus-sasl)
459 ("libquvi-scripts" ,libquvi-scripts)
460 ("lua" ,lua-5.1)
461 ("openssl" ,openssl)
462 ("zlib" ,zlib)))
463 (arguments
464 ;; Lua provides no .pc file, so add CFLAGS/LIBS manually.
465 '(#:configure-flags
466 (let ((lua (assoc-ref %build-inputs "lua")))
467 (list
468 (string-append "liblua_CFLAGS=-I" lua "/include")
469 (string-append "liblua_LIBS=-L" lua "/libs -llua")))))
470 (home-page "http://quvi.sourceforge.net/")
471 (synopsis "Media stream URL parser")
472 (description "libquvi is a library with a C API for parsing media stream
473 URLs and extracting their actual media files.")
474 (license l:lgpl2.1+)))
475
476 (define-public quvi
477 (package
478 (name "quvi")
479 (version "0.4.2")
480 (source
481 (origin
482 (method url-fetch)
483 (uri (string-append
484 "mirror://sourceforge/quvi/quvi-" version ".tar.xz"))
485 (sha256
486 (base32 "09lhl6dv5zpryasx7yjslfrcdcqlsbwapvd5lg7w6sm5x5n3k8ci"))))
487 (build-system gnu-build-system)
488 (native-inputs `(("pkg-config" ,pkg-config)))
489 (inputs
490 `(("curl" ,curl)
491 ("libquvi" ,libquvi)))
492 (home-page "http://quvi.sourceforge.net/")
493 (synopsis "Media stream URL parser")
494 (description "quvi is a command-line-tool suite to extract media files
495 from streaming URLs. It is a command-line wrapper for the libquvi library.")
496 (license l:lgpl2.1+)))
497
498 \f
499 (define-public perl-apache-logformat-compiler
500 (package
501 (name "perl-apache-logformat-compiler")
502 (version "0.32")
503 (source
504 (origin
505 (method url-fetch)
506 (uri (string-append "mirror://cpan/authors/id/K/KA/KAZEBURO/"
507 "Apache-LogFormat-Compiler-" version ".tar.gz"))
508 (sha256
509 (base32
510 "0zyx4r2bxc6d48m70fhcq80nw0q9wnfz6qgn1g0r6bigqgdjq4dw"))))
511 (build-system perl-build-system)
512 (native-inputs
513 `(("perl-http-message" ,perl-http-message)
514 ("perl-test-mocktime" ,perl-test-mocktime)
515 ("perl-try-tiny" ,perl-try-tiny)
516 ("perl-uri" ,perl-uri)))
517 (propagated-inputs
518 `(("perl-posix-strftime-compiler" ,perl-posix-strftime-compiler)))
519 (arguments `(#:tests? #f)) ;TODO: Timezone test failures
520 (home-page "http://search.cpan.org/dist/Apache-LogFormat-Compiler")
521 (synopsis "Compile a log format string to perl-code")
522 (description "This module provides methods to compile a log format string
523 to perl-code, for faster generation of access_log lines.")
524 (license (package-license perl))))
525
526 (define-public perl-encode-locale
527 (package
528 (name "perl-encode-locale")
529 (version "1.03")
530 (source (origin
531 (method url-fetch)
532 (uri (string-append
533 "mirror://cpan/authors/id/G/GA/GAAS/Encode-Locale-"
534 version ".tar.gz"))
535 (sha256
536 (base32
537 "0m9d1vdphlyzybgmdanipwd9ndfvyjgk3hzw250r299jjgh3fqzp"))))
538 (build-system perl-build-system)
539 (license (package-license perl))
540 (synopsis "Perl locale encoding determination")
541 (description
542 "The POSIX locale system is used to specify both the language
543 conventions requested by the user and the preferred character set to consume
544 and output. The Encode::Locale module looks up the charset and encoding
545 (called a CODESET in the locale jargon) and arranges for the Encode module
546 to know this encoding under the name \"locale\". It means bytes obtained
547 from the environment can be converted to Unicode strings by calling
548 Encode::encode(locale => $bytes) and converted back again with
549 Encode::decode(locale => $string).")
550 (home-page "http://search.cpan.org/~gaas/Encode-Locale/")))
551
552 (define-public perl-file-listing
553 (package
554 (name "perl-file-listing")
555 (version "6.04")
556 (source (origin
557 (method url-fetch)
558 (uri (string-append
559 "mirror://cpan/authors/id/G/GA/GAAS/File-Listing-"
560 version ".tar.gz"))
561 (sha256
562 (base32
563 "1xcwjlnxaiwwpn41a5yi6nz95ywh3szq5chdxiwj36kqsvy5000y"))))
564 (build-system perl-build-system)
565 (propagated-inputs
566 `(("perl-http-date" ,perl-http-date)))
567 (license (package-license perl))
568 (synopsis "Perl directory listing parser")
569 (description
570 "The File::Listing module exports a single function called parse_dir(),
571 which can be used to parse directory listings.")
572 (home-page "http://search.cpan.org/~gaas/File-Listing/")))
573
574 (define-public perl-html-parser
575 (package
576 (name "perl-html-parser")
577 (version "3.71")
578 (source (origin
579 (method url-fetch)
580 (uri (string-append
581 "mirror://cpan/authors/id/G/GA/GAAS/HTML-Parser-"
582 version ".tar.gz"))
583 (sha256
584 (base32
585 "00nqzdgl7c3jilx7mil19k5jwcw3as14pvkjgxi97zyk94vqp4dy"))))
586 (build-system perl-build-system)
587 (inputs
588 `(("perl-html-tagset" ,perl-html-tagset)))
589 (license (package-license perl))
590 (synopsis "Perl HTML parser class")
591 (description
592 "Objects of the HTML::Parser class will recognize markup and separate
593 it from plain text (alias data content) in HTML documents. As different
594 kinds of markup and text are recognized, the corresponding event handlers
595 are invoked.")
596 (home-page "http://search.cpan.org/~gaas/HTML-Parser/")))
597
598 (define-public perl-html-tagset
599 (package
600 (name "perl-html-tagset")
601 (version "3.20")
602 (source (origin
603 (method url-fetch)
604 (uri (string-append
605 "mirror://cpan/authors/id/P/PE/PETDANCE/HTML-Tagset-"
606 version ".tar.gz"))
607 (sha256
608 (base32
609 "1qh8249wgr4v9vgghq77zh1d2zs176bir223a8gh3k9nksn7vcdd"))))
610 (build-system perl-build-system)
611 (license (package-license perl))
612 (synopsis "Perl data tables useful in parsing HTML")
613 (description
614 "The HTML::Tagset module contains several data tables useful in various
615 kinds of HTML parsing operations.")
616 (home-page "http://search.cpan.org/dist/HTML-Tagset/")))
617
618 (define-public perl-http-cookiejar
619 (package
620 (name "perl-http-cookiejar")
621 (version "0.006")
622 (source
623 (origin
624 (method url-fetch)
625 (uri (string-append "mirror://cpan/authors/id/D/DA/DAGOLDEN/"
626 "HTTP-CookieJar-" version ".tar.gz"))
627 (sha256
628 (base32
629 "0c7l29ak6ba2j006ca00vnkxpyc1fvpikydjvsb24s50zf1mv7b2"))))
630 (build-system perl-build-system)
631 (native-inputs
632 `(("perl-test-deep" ,perl-test-deep)
633 ("perl-test-requires" ,perl-test-requires)
634 ("perl-time-mock" ,perl-time-mock)))
635 (inputs
636 `(("perl-time-local" ,perl-time-local)
637 ("perl-http-date" ,perl-http-date)))
638 (home-page "http://search.cpan.org/dist/HTTP-CookieJar")
639 (synopsis "Minimalist HTTP user agent cookie jar")
640 (description "This module implements a minimalist HTTP user agent cookie
641 jar in conformance with RFC 6265 <http://tools.ietf.org/html/rfc6265>.")
642 (license l:asl2.0)))
643
644 (define-public perl-http-cookies
645 (package
646 (name "perl-http-cookies")
647 (version "6.01")
648 (source (origin
649 (method url-fetch)
650 (uri (string-append
651 "mirror://cpan/authors/id/G/GA/GAAS/HTTP-Cookies-"
652 version ".tar.gz"))
653 (sha256
654 (base32
655 "087bqmg22dg3vj7gssh3pcsh9y1scimkbl5h1kc8jqyfhgisvlzm"))))
656 (build-system perl-build-system)
657 (propagated-inputs
658 `(("perl-http-message" ,perl-http-message)))
659 (license (package-license perl))
660 (synopsis "Perl HTTP cookie jars")
661 (description
662 "The HTTP::Cookies class is for objects that represent a cookie jar,
663 that is, a database of all the HTTP cookies that a given LWP::UserAgent
664 object knows about.")
665 (home-page "http://search.cpan.org/~gaas/HTTP-Cookies/")))
666
667 (define-public perl-http-daemon
668 (package
669 (name "perl-http-daemon")
670 (version "6.01")
671 (source (origin
672 (method url-fetch)
673 (uri (string-append
674 "mirror://cpan/authors/id/G/GA/GAAS/HTTP-Daemon-"
675 version ".tar.gz"))
676 (sha256
677 (base32
678 "1hmd2isrkilf0q0nkxms1q64kikjmcw9imbvrjgky6kh89vqdza3"))))
679 (build-system perl-build-system)
680 (propagated-inputs
681 `(("perl-http-message" ,perl-http-message)
682 ("perl-lwp-mediatypes" ,perl-lwp-mediatypes)))
683 (license (package-license perl))
684 (synopsis "Perl simple http server class")
685 (description
686 "Instances of the HTTP::Daemon class are HTTP/1.1 servers that listen
687 on a socket for incoming requests. The HTTP::Daemon is a subclass of
688 IO::Socket::INET, so you can perform socket operations directly on it too.")
689 (home-page "http://search.cpan.org/~gaas/HTTP-Daemon/")))
690
691 (define-public perl-http-date
692 (package
693 (name "perl-http-date")
694 (version "6.02")
695 (source (origin
696 (method url-fetch)
697 (uri (string-append
698 "mirror://cpan/authors/id/G/GA/GAAS/HTTP-Date-"
699 version ".tar.gz"))
700 (sha256
701 (base32
702 "0cz357kafhhzw7w59iyi0wvhw7rlh5g1lh38230ckw7rl0fr9fg8"))))
703 (build-system perl-build-system)
704 (license (package-license perl))
705 (synopsis "Perl date conversion routines")
706 (description
707 "The HTTP::Date module provides functions that deal with date formats
708 used by the HTTP protocol (and then some more).")
709 (home-page "http://search.cpan.org/~gaas/HTTP-Date/")))
710
711 (define-public perl-http-message
712 (package
713 (name "perl-http-message")
714 (version "6.06")
715 (source (origin
716 (method url-fetch)
717 (uri (string-append
718 "mirror://cpan/authors/id/G/GA/GAAS/HTTP-Message-"
719 version ".tar.gz"))
720 (sha256
721 (base32
722 "0qxdrcak97azjvqyx1anpb2ky6vp6vc37x0wcfjdqfajkh09fzh8"))))
723 (build-system perl-build-system)
724 (propagated-inputs
725 `(("perl-http-date" ,perl-http-date)
726 ("perl-uri" ,perl-uri)))
727 (inputs
728 `(("perl-io-html" ,perl-io-html)
729 ("perl-lwp-mediatypes" ,perl-lwp-mediatypes)))
730 (license (package-license perl))
731 (synopsis "Perl HTTP style message")
732 (description
733 "An HTTP::Message object contains some headers and a content body.")
734 (home-page "http://search.cpan.org/~gaas/HTTP-Message/")))
735
736 (define-public perl-http-negotiate
737 (package
738 (name "perl-http-negotiate")
739 (version "6.01")
740 (source (origin
741 (method url-fetch)
742 (uri (string-append
743 "mirror://cpan/authors/id/G/GA/GAAS/HTTP-Negotiate-"
744 version ".tar.gz"))
745 (sha256
746 (base32
747 "05p053vjs5g91v5cmjnny7a3xzddz5k7vnjw81wfh01ilqg9qwhw"))))
748 (build-system perl-build-system)
749 (propagated-inputs
750 `(("perl-http-message" ,perl-http-message)))
751 (license (package-license perl))
752 (synopsis "Perl http content negotiation")
753 (description
754 "The HTTP::Negotiate module provides a complete implementation of the
755 HTTP content negotiation algorithm specified in
756 draft-ietf-http-v11-spec-00.ps chapter 12. Content negotiation allows for
757 the selection of a preferred content representation based upon attributes
758 of the negotiable variants and the value of the various Accept* header
759 fields in the request.")
760 (home-page "http://search.cpan.org/~gaas/HTTP-Negotiate/")))
761
762 (define-public perl-io-html
763 (package
764 (name "perl-io-html")
765 (version "1.00")
766 (source (origin
767 (method url-fetch)
768 (uri (string-append
769 "mirror://cpan/authors/id/C/CJ/CJM/IO-HTML-"
770 version ".tar.gz"))
771 (sha256
772 (base32
773 "06nj3a0xgp5jxwxx6ayglfk2v7npf5a7gwkqsjlkapjkybarzqh4"))))
774 (build-system perl-build-system)
775 (license (package-license perl))
776 (synopsis "Perl module to open an HTML file with automatic charset detection")
777 (description
778 "IO::HTML provides an easy way to open a file containing HTML while
779 automatically determining its encoding. It uses the HTML5 encoding sniffing
780 algorithm specified in section 8.2.2.1 of the draft standard.")
781 (home-page "http://search.cpan.org/~cjm/IO-HTML/")))
782
783 (define-public perl-io-socket-ip
784 (package
785 (name "perl-io-socket-ip")
786 (version "0.36")
787 (source
788 (origin
789 (method url-fetch)
790 (uri (string-append "mirror://cpan/authors/id/P/PE/PEVANS/"
791 "IO-Socket-IP-" version ".tar.gz"))
792 (sha256
793 (base32
794 "0ky20hmln6waipzqikizyw04vpszf70fgpshz7ib8zv8480ri456"))))
795 (build-system perl-build-system)
796 (home-page "http://search.cpan.org/dist/IO-Socket-IP")
797 (synopsis "Family-neutral IP socket supporting both IPv4 and IPv6")
798 (description "This module provides a protocol-independent way to use IPv4
799 and IPv6 sockets, intended as a replacement for IO::Socket::INET.")
800 (license (package-license perl))))
801
802 (define-public perl-io-socket-ssl
803 (package
804 (name "perl-io-socket-ssl")
805 (version "2.002")
806 (source (origin
807 (method url-fetch)
808 (uri (string-append "mirror://cpan/authors/id/S/SU/SULLR/"
809 "IO-Socket-SSL-" version ".tar.gz"))
810 (sha256
811 (base32
812 "1mph52lw6x5v44wf8mw00llzi8pp6k5c4jnrnrvlacrlfv260jb8"))))
813 (build-system perl-build-system)
814 (propagated-inputs `(("perl-net-ssleay" ,perl-net-ssleay)))
815 (synopsis "Nearly transparent SSL encapsulation for IO::Socket::INET")
816 (description
817 "IO::Socket::SSL makes using SSL/TLS much easier by wrapping the
818 necessary functionality into the familiar IO::Socket interface and providing
819 secure defaults whenever possible. This way existing applications can be made
820 SSL-aware without much effort, at least if you do blocking I/O and don't use
821 select or poll.")
822 (license (package-license perl))
823 (home-page "https://github.com/noxxi/p5-io-socket-ssl")))
824
825 (define-public perl-libwww
826 (package
827 (name "perl-libwww")
828 (version "6.05")
829 (source (origin
830 (method url-fetch)
831 (uri (string-append
832 "mirror://cpan/authors/id/G/GA/GAAS/libwww-perl-"
833 version ".tar.gz"))
834 (sha256
835 (base32
836 "08wgwyz7748pv5cyngxia0xl6nragfnhrp4p9s78xhgfyygpj9bv"))))
837 (build-system perl-build-system)
838 (propagated-inputs
839 `(("perl-encode-locale" ,perl-encode-locale)
840 ("perl-file-listing" ,perl-file-listing)
841 ("perl-html-parser" ,perl-html-parser)
842 ("perl-http-cookies" ,perl-http-cookies)
843 ("perl-http-daemon" ,perl-http-daemon)
844 ("perl-http-negotiate" ,perl-http-negotiate)
845 ("perl-net-http" ,perl-net-http)
846 ("perl-www-robotrules" ,perl-www-robotrules)))
847 (license (package-license perl))
848 (synopsis "Perl modules for the WWW")
849 (description
850 "The libwww-perl collection is a set of Perl modules which provides a
851 simple and consistent application programming interface to the
852 World-Wide Web. The main focus of the library is to provide classes
853 and functions that allow you to write WWW clients. The library also
854 contains modules that are of more general use and even classes that
855 help you implement simple HTTP servers.")
856 (home-page "http://search.cpan.org/~gaas/libwww-perl/")))
857
858 (define-public perl-lwp-mediatypes
859 (package
860 (name "perl-lwp-mediatypes")
861 (version "6.02")
862 (source (origin
863 (method url-fetch)
864 (uri (string-append
865 "mirror://cpan/authors/id/G/GA/GAAS/LWP-MediaTypes-"
866 version ".tar.gz"))
867 (sha256
868 (base32
869 "0xmnblp962qy02akah30sji8bxrqcyqlff2w95l199ghql60ny8q"))))
870 (build-system perl-build-system)
871 (license (package-license perl))
872 (synopsis "Perl module to guess the media type for a file or a URL")
873 (description
874 "The LWP::MediaTypes module provides functions for handling media (also
875 known as MIME) types and encodings. The mapping from file extensions to
876 media types is defined by the media.types file. If the ~/.media.types file
877 exists it is used instead.")
878 (home-page "http://search.cpan.org/~gaas/LWP-MediaTypes/")))
879
880 (define-public perl-net-http
881 (package
882 (name "perl-net-http")
883 (version "6.06")
884 (source (origin
885 (method url-fetch)
886 (uri (string-append
887 "mirror://cpan/authors/id/G/GA/GAAS/Net-HTTP-"
888 version ".tar.gz"))
889 (sha256
890 (base32
891 "1m1rvniffadq99gsy25298ia3lixwymr6kan64jd3ylyi7nkqkhx"))))
892 (build-system perl-build-system)
893 (license (package-license perl))
894 (synopsis "Perl low-level HTTP connection (client)")
895 (description
896 "The Net::HTTP class is a low-level HTTP client. An instance of the
897 Net::HTTP class represents a connection to an HTTP server. The HTTP protocol
898 is described in RFC 2616. The Net::HTTP class supports HTTP/1.0 and
899 HTTP/1.1.")
900 (home-page "http://search.cpan.org/~gaas/Net-HTTP/")))
901
902 (define-public perl-uri
903 (package
904 (name "perl-uri")
905 (version "1.60")
906 (source (origin
907 (method url-fetch)
908 (uri (string-append
909 "mirror://cpan/authors/id/G/GA/GAAS/URI-"
910 version ".tar.gz"))
911 (sha256
912 (base32
913 "0xr31mf7lfrwhyvlx4pzp6p7alls5gi4bj8pk5g89f5cckfd74hz"))))
914 (build-system perl-build-system)
915 (license (package-license perl))
916 (synopsis "Perl Uniform Resource Identifiers (absolute and relative)")
917 (description
918 "The URI module implements the URI class. Objects of this class
919 represent \"Uniform Resource Identifier references\" as specified in RFC 2396
920 and updated by RFC 2732.")
921 (home-page "http://search.cpan.org/~gaas/URI/")))
922
923 (define-public perl-www-curl
924 (package
925 (name "perl-www-curl")
926 (version "4.17")
927 (source (origin
928 (method url-fetch)
929 (uri (string-append
930 "mirror://cpan/authors/id/S/SZ/SZBALINT/WWW-Curl-"
931 version".tar.gz"))
932 (sha256
933 (base32
934 "1fmp9aib1kaps9vhs4dwxn7b15kgnlz9f714bxvqsd1j1q8spzsj"))))
935 (build-system perl-build-system)
936 (arguments
937 '(#:tests? #f)) ;XXX: tests require network access
938 (inputs `(("curl" ,curl)))
939 (synopsis "Perl extension interface for libcurl")
940 (description
941 "This is a Perl extension interface for the libcurl file downloading
942 library.")
943 (license (package-license perl))
944 (home-page "http://search.cpan.org/~szbalint/WWW-Curl-4.17/lib/WWW/Curl.pm")))
945
946 (define-public perl-www-robotrules
947 (package
948 (name "perl-www-robotrules")
949 (version "6.02")
950 (source (origin
951 (method url-fetch)
952 (uri (string-append
953 "mirror://cpan/authors/id/G/GA/GAAS/WWW-RobotRules-"
954 version ".tar.gz"))
955 (sha256
956 (base32
957 "07m50dp5n5jxv3m93i55qvnd67a6g7cvbvlik115kmc8lbkh5da6"))))
958 (build-system perl-build-system)
959 (propagated-inputs
960 `(("perl-uri" ,perl-uri)))
961 (license (package-license perl))
962 (synopsis "Perl database of robots.txt-derived permissions")
963 (description
964 "The WWW::RobotRules module parses /robots.txt files as specified in
965 \"A Standard for Robot Exclusion\", at
966 <http://www.robotstxt.org/wc/norobots.html>. Webmasters can use the
967 /robots.txt file to forbid conforming robots from accessing parts of
968 their web site.")
969 (home-page "http://search.cpan.org/~gaas/WWW-RobotRules/")))