gnu: python-pathpy: Build documentation.
[jackhill/guix/guix.git] / gnu / packages / aspell.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2015, 2016 Alex Kost <alezost@gmail.com>
4 ;;; Copyright ©2016 John Darrington <jmd@gnu.org>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages aspell)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (guix licenses)
26 #:use-module (gnu packages perl)
27 #:use-module (gnu packages base))
28
29 (define-public aspell
30 (package
31 (name "aspell")
32 (version "0.60.6.1")
33 (source
34 (origin
35 (method url-fetch)
36 (uri (string-append "mirror://gnu/aspell/aspell-"
37 version ".tar.gz"))
38 (sha256
39 (base32
40 "1qgn5psfyhbrnap275xjfrzppf5a83fb67gpql0kfqv37al869gm"))))
41 (build-system gnu-build-system)
42 (arguments
43 `(#:phases
44 (modify-phases %standard-phases
45 (add-after 'install 'wrap-aspell
46 (lambda* (#:key outputs #:allow-other-keys)
47 (let ((bin/aspell (string-append (assoc-ref outputs "out")
48 "/bin/aspell")))
49 (wrap-program bin/aspell
50 '("ASPELL_CONF" "" =
51 ("${ASPELL_CONF:-\"dict-dir ${GUIX_PROFILE:-$HOME/.guix-profile}/lib/aspell\"}")))))))))
52 (inputs `(("perl" ,perl)))
53 (home-page "http://aspell.net/")
54 (synopsis "Spell checker")
55 (description
56 "Aspell is a spell-checker which can be used either as a library or as
57 a standalone program. Notable features of Aspell include its full support of
58 documents written in the UTF-8 encoding and its ability to use multiple
59 dictionaries, including personal ones.")
60 (license lgpl2.1+)))
61
62 \f
63 ;;;
64 ;;; Dictionaries.
65 ;;;
66 ;;; Use 'export ASPELL_CONF="dict-dir $HOME/.guix-profile/lib/aspell"' to use them.
67 ;;;
68
69 (define* (aspell-dictionary dict-name full-name
70 #:key version sha256 (prefix "aspell6-"))
71 (package
72 (name (string-append "aspell-dict-" dict-name))
73 (version version)
74 (source (origin
75 (method url-fetch)
76 (uri (string-append "mirror://gnu/aspell/dict/" dict-name
77 "/" prefix dict-name "-"
78 version ".tar.bz2"))
79 (sha256 sha256)))
80 (build-system gnu-build-system)
81 (arguments
82 `(#:phases (alist-replace
83 'configure
84 (lambda* (#:key outputs #:allow-other-keys)
85 (let ((out (assoc-ref outputs "out")))
86 (zero? (system* "./configure"))))
87 %standard-phases)
88 #:make-flags (let ((out (assoc-ref %outputs "out")))
89 (list (string-append "dictdir=" out "/lib/aspell")
90 (string-append "datadir=" out "/lib/aspell")))
91 #:tests? #f))
92 (native-inputs `(("aspell" ,aspell)
93 ("which" ,which)))
94 (synopsis (string-append full-name " dictionary for GNU Aspell")) ; XXX: i18n
95 (description
96 "This package provides a dictionary for the GNU Aspell spell checker.")
97 (license gpl2+)
98 (home-page "http://aspell.net/")))
99
100
101 (define-public aspell-dict-de
102 (aspell-dictionary "de" "German"
103 #:version "20030222-1"
104 #:sha256
105 (base32
106 "01p92qj66cqb346gk7hjfynaap5sbcn85xz07kjfdq623ghr8v5s")))
107
108 (define-public aspell-dict-en
109 (aspell-dictionary "en" "English"
110 #:version "2016.01.19-0"
111 #:sha256
112 (base32
113 "01h4cl4lngp6mcfbyb47cjrc2gspyg2519dvknd97ki896nx7vcn")))
114
115 (define-public aspell-dict-eo
116 (aspell-dictionary "eo" "Esperanto"
117 #:version "2.1.20000225a-2"
118 #:sha256
119 (base32
120 "09vf0mbiicbmyb4bwb7v7lgpabnylg0wy7m3hlhl5rjdda6x3lj1")))
121
122 (define-public aspell-dict-es
123 (aspell-dictionary "es" "Spanish"
124 #:version "1.11-2"
125 #:sha256
126 (base32
127 "1k5g328ac1hdpp6fsg57d8md6i0aqcwlszp3gbmp5706wyhpydmd")))
128
129 (define-public aspell-dict-fr
130 (aspell-dictionary "fr" "French"
131 #:version "0.50-3"
132 #:prefix "aspell-"
133 #:sha256
134 (base32
135 "14ffy9mn5jqqpp437kannc3559bfdrpk7r36ljkzjalxa53i0hpr")))
136
137 (define-public aspell-dict-ru
138 (aspell-dictionary "ru" "Russian"
139 #:version "0.99f7-1"
140 #:sha256
141 (base32
142 "0ip6nq43hcr7vvzbv4lwwmlwgfa60hrhsldh9xy3zg2prv6bcaaw")))
143
144 (define-public aspell-dict-it
145 (aspell-dictionary "it" "Italian"
146 #:version "2.2_20050523-0"
147 #:sha256
148 (base32
149 "1gdf7bc1a0kmxsmphdqq8pl01h667mjsj6hihy6kqy14k5qdq69v")))
150
151 (define-public aspell-dict-nl
152 (aspell-dictionary "nl" "Dutch"
153 #:version "0.50-2"
154 #:prefix "aspell-"
155 #:sha256
156 (base32
157 "0ffb87yjsh211hllpc4b9khqqrblial4pzi1h9r3v465z1yhn3j4")))