gnu: hidapi: Fix 'license'.
[jackhill/guix/guix.git] / gnu / packages / scribus.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages scribus)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix utils)
24 #:use-module ((guix licenses) #:prefix license:)
25 #:use-module (guix build-system cmake)
26 #:use-module (gnu packages)
27 #:use-module (gnu packages compression)
28 #:use-module (gnu packages cups)
29 #:use-module (gnu packages fontutils)
30 #:use-module (gnu packages ghostscript)
31 #:use-module (gnu packages gtk)
32 #:use-module (gnu packages image)
33 #:use-module (gnu packages linux)
34 #:use-module (gnu packages pkg-config)
35 #:use-module (gnu packages python)
36 #:use-module (gnu packages qt)
37 #:use-module (gnu packages imagemagick)
38 #:use-module (gnu packages xml))
39
40 (define-public scribus
41 (package
42 (name "scribus")
43 (version "1.5.2")
44 (source (origin
45 (method url-fetch)
46 (uri (string-append "mirror://sourceforge/scribus/scribus-devel/"
47 version "/scribus-" version ".tar.xz"))
48 (sha256
49 (base32
50 "1xbl7h4x32y2nfhn57ivjziyvlnwadcbizqwfqx5srfsmqiyqppc"))))
51 (build-system cmake-build-system)
52 (arguments
53 `(#:tests? #f ; no test target
54 #:configure-flags
55 '("-DCMAKE_CXX_FLAGS=-std=gnu++11")))
56 (inputs
57 `(("cairo" ,cairo)
58 ("cups" ,cups)
59 ("graphicsmagick" ,graphicsmagick)
60 ("lcms" ,lcms)
61 ("libjpeg" ,libjpeg)
62 ("libtiff" ,libtiff)
63 ("libxml2" ,libxml2)
64 ("python" ,python-2)
65 ("freetype" ,freetype)
66 ("qtbase" ,qtbase)
67 ("qtdeclarative" ,qtdeclarative)
68 ("qttools" ,qttools)
69 ("zlib" ,zlib)))
70 (native-inputs
71 `(("util-linux" ,util-linux)
72 ("pkg-config" ,pkg-config)))
73 (home-page "http://scribus.net")
74 (synopsis "Desktop publishing and page layout program")
75 (description
76 "Scribus is a @dfn{desktop publishing} (DTP) application and can be used
77 for many tasks; from brochure design to newspapers, magazines, newsletters and
78 posters to technical documentation. Scribus supports professional DTP
79 features, such as CMYK color and a color management system to soft proof
80 images for high quality color printing, flexible PDF creation options,
81 Encapsulated PostScript import/export and creation of four color separations,
82 import of EPS/PS and SVG as native vector graphics, Unicode text including
83 right to left scripts such as Arabic and Hebrew via freetype.")
84 (license license:gpl2+)))