gnu: hidapi: Fix 'license'.
[jackhill/guix/guix.git] / gnu / packages / ragel.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages ragel)
20 #:use-module ((guix licenses) #:prefix license:)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages))
25
26 (define-public ragel
27 (package
28 (name "ragel")
29 (version "6.9")
30 (source (origin
31 (method url-fetch)
32 (uri (string-append "http://www.colm.net/files/ragel/ragel-"
33 version ".tar.gz"))
34 (sha256
35 (base32
36 "02k6rwh8cr95f1p5sjjr3wa6dilg06572xz1v71dk8awmc7vw1vf"))))
37 (build-system gnu-build-system)
38 (home-page "http://www.colm.net/open-source/ragel/")
39 (synopsis "State machine compiler")
40 (description
41 "Ragel compiles executable finite state machines from regular languages.
42 Ragel targets C, C++, Obj-C, C#, D, Java, Go and Ruby. Ragel state machines
43 can not only recognize byte sequences as regular expression machines do, but
44 can also execute code at arbitrary points in the recognition of a regular
45 language. Code embedding is done using inline operators that do not disrupt
46 the regular language syntax.")
47 ;; GPLv2 (or later) with exception for generated code.
48 (license license:gpl2+)))
49