gnu: hidapi: Fix 'license'.
[jackhill/guix/guix.git] / gnu / packages / openldap.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
4 ;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages openldap)
22 #:use-module (gnu packages autotools)
23 #:use-module (gnu packages databases)
24 #:use-module (gnu packages compression)
25 #:use-module (gnu packages cyrus-sasl)
26 #:use-module (gnu packages gnupg)
27 #:use-module (gnu packages groff)
28 #:use-module (gnu packages icu4c)
29 #:use-module (gnu packages tls)
30 #:use-module ((guix licenses) #:select (openldap2.8))
31 #:use-module (guix packages)
32 #:use-module (guix download)
33 #:use-module (guix build-system gnu))
34
35 (define-public openldap
36 (package
37 (name "openldap")
38 (version "2.4.44")
39 (source (origin
40 (method url-fetch)
41
42 ;; See <http://www.openldap.org/software/download/> for a list of
43 ;; mirrors.
44 (uri (list (string-append
45 "ftp://mirror.switch.ch/mirror/OpenLDAP/"
46 "openldap-release/openldap-" version ".tgz")
47 (string-append
48 "ftp://ftp.OpenLDAP.org/pub/OpenLDAP/"
49 "openldap-release/openldap-" version ".tgz")
50 (string-append
51 "ftp://ftp.dti.ad.jp/pub/net/OpenLDAP/"
52 "openldap-release/openldap-" version ".tgz")))
53 (sha256
54 (base32
55 "0044p20hx07fwgw2mbwj1fkx04615hhs1qyx4mawj2bhqvrnppnp"))))
56 (build-system gnu-build-system)
57 (inputs `(("bdb" ,bdb-5.3)
58 ("openssl" ,openssl)
59 ("cyrus-sasl" ,cyrus-sasl)
60 ("groff" ,groff)
61 ("icu4c" ,icu4c)
62 ("libgcrypt" ,libgcrypt)
63 ;; FIXME: currently, openldap requires openssl or gnutls<3, see
64 ;; http://www.openldap.org/its/index.cgi/Incoming?id=7430;page=17
65 ;; Once this is fixed, switch to gnutls.
66 ("zlib" ,zlib)))
67 (native-inputs `(("libtool" ,libtool)))
68 (arguments
69 `(#:tests? #f
70 #:phases
71 (alist-cons-after
72 'configure 'provide-libtool
73 (lambda _ (copy-file (which "libtool") "libtool"))
74 %standard-phases)))
75 (synopsis "Implementation of the Lightweight Directory Access Protocol")
76 (description
77 "OpenLDAP is a free implementation of the Lightweight Directory Access Protocol.")
78 (license openldap2.8)
79 (home-page "http://www.openldap.org/")))