gnu: hidapi: Fix 'license'.
[jackhill/guix/guix.git] / gnu / packages / lighting.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 John J. Foerch <jjfoerch@earthlink.net>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages lighting)
20 #:use-module (guix build-system gnu)
21 #:use-module (guix download)
22 #:use-module ((guix licenses) #:prefix license:)
23 #:use-module (guix packages)
24 #:use-module (gnu packages bison)
25 #:use-module (gnu packages check)
26 #:use-module (gnu packages compression)
27 #:use-module (gnu packages gnunet)
28 #:use-module (gnu packages flex)
29 #:use-module (gnu packages libftdi)
30 #:use-module (gnu packages libusb)
31 #:use-module (gnu packages linux)
32 #:use-module (gnu packages pkg-config)
33 #:use-module (gnu packages protobuf))
34
35 (define-public ola
36 (package
37 (name "ola")
38 (version "0.10.2")
39 (source (origin
40 (method url-fetch)
41 (uri (string-append
42 "https://github.com/OpenLightingProject/ola/releases/download/"
43 version "/ola-" version ".tar.gz"))
44 (sha256
45 (base32
46 "09zx1c8nkj29shfdzkahrh9397m3mwnsy0gj7jrb63f89f3n2vlq"))))
47 (build-system gnu-build-system)
48 (native-inputs
49 `(("bison" ,bison)
50 ("cppunit" ,cppunit)
51 ("flex" ,flex)
52 ("pkg-config" ,pkg-config)))
53 (inputs
54 `(("libftdi" ,libftdi)
55 ("libmicrohttpd" ,libmicrohttpd)
56 ("libusb" ,libusb)
57 ("libuuid" ,util-linux)
58 ("zlib" ,zlib)))
59 (propagated-inputs
60 `(("protobuf" ,protobuf))) ;; for pkg-config --libs libola
61 (arguments
62 `(;; G++ >= 4.8 macro expansion tracking requires lots of memory, causing
63 ;; build to fail on low memory systems. We disable that with the
64 ;; following configure flags.
65 #:configure-flags (list "CXXFLAGS=-ftrack-macro-expansion=0")))
66 (synopsis "Framework for controlling entertainment lighting equipment")
67 (description "The Open Lighting Architecture is a framework for lighting
68 control information. It supports a range of protocols and over a dozen USB
69 devices. It can run as a standalone service, which is useful for converting
70 signals between protocols, or alternatively using the OLA API, it can be used
71 as the backend for lighting control software. OLA runs on many different
72 platforms including ARM, which makes it a perfect fit for low cost Ethernet to
73 DMX gateways.")
74 (home-page "https://www.openlighting.org/ola")
75 (license license:lgpl2.1+)))