gnu: hidapi: Fix 'license'.
[jackhill/guix/guix.git] / gnu / packages / inkscape.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
3 ;;; Copyright © 2014, 2016 Mark H Weaver <mhw@netris.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages inkscape)
21 #:use-module ((guix licenses) #:prefix license:)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix utils)
25 #:use-module (guix build-system gnu)
26 #:use-module (gnu packages)
27 #:use-module (gnu packages aspell)
28 #:use-module (gnu packages bdw-gc)
29 #:use-module (gnu packages boost)
30 #:use-module (gnu packages glib)
31 #:use-module (gnu packages gtk)
32 #:use-module (gnu packages maths)
33 #:use-module (gnu packages perl)
34 #:use-module (gnu packages pdf)
35 #:use-module (gnu packages popt)
36 #:use-module (gnu packages python)
37 #:use-module (gnu packages xml)
38 #:use-module (gnu packages ghostscript)
39 #:use-module (gnu packages fontutils)
40 #:use-module (gnu packages image)
41 #:use-module (gnu packages pkg-config))
42
43 (define-public inkscape
44 (package
45 (name "inkscape")
46 (version "0.91")
47 (source (origin
48 (method url-fetch)
49 (uri (string-append "https://launchpad.net/inkscape/"
50 (version-major+minor version) ".x/"
51 version "/+download/inkscape-"
52 version ".tar.gz"))
53 (sha256
54 (base32
55 "086v01jy896dj86bq7plrf6si4p6gh6ga2v5417llgmminycz8rc"))
56 (patch-flags '("-p0"))
57 (patches
58 (search-patches "inkscape-drop-wait-for-targets.patch"))))
59 (build-system gnu-build-system)
60 (inputs
61 `(("aspell" ,aspell)
62 ("gtkmm" ,gtkmm-2)
63 ("gtk" ,gtk+-2)
64 ("gsl" ,gsl)
65 ("poppler" ,poppler)
66 ("libpng" ,libpng)
67 ("libxml2" ,libxml2)
68 ("libxslt" ,libxslt)
69 ("libgc" ,libgc)
70 ("freetype" ,freetype)
71 ("popt" ,popt)
72 ("python" ,python-2)
73 ("lcms" ,lcms)
74 ("boost" ,boost)))
75 (native-inputs
76 `(("intltool" ,intltool)
77 ("perl" ,perl)
78 ("pkg-config" ,pkg-config)))
79 (arguments
80 `(;; Add '-std=c++11', required by recent versions of GLibmm & co.
81 ;; Use '-g0' to reduce disk usage during the build.
82 #:configure-flags '("CXXFLAGS=-g0 -O2 -fopenmp -std=c++11")
83
84 #:phases (alist-cons-after
85 'unpack 'fix-test-includes
86 (lambda _
87 (substitute* "src/cxxtests.cpp"
88 (("\\.\\./\\.\\./src") "../src")))
89 %standard-phases)))
90 (home-page "http://inkscape.org/")
91 (synopsis "Vector graphics editor")
92 (description "Inkscape is a vector graphics editor. What sets Inkscape
93 apart is its use of Scalable Vector Graphics (SVG), an XML-based W3C standard,
94 as the native format.")
95 (license license:gpl2+)))