gnu: hidapi: Fix 'license'.
[jackhill/guix/guix.git] / gnu / packages / calcurse.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014, 2015 Eric Bavier <bavier@member.fsf.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages calcurse)
20 #:use-module (guix packages)
21 #:use-module (guix licenses)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages ncurses))
26
27 (define-public calcurse
28 (package
29 (name "calcurse")
30 (version "4.0.0")
31 (source
32 (origin
33 (method url-fetch)
34 (uri (string-append "http://calcurse.org/files/calcurse-"
35 version ".tar.gz"))
36 (sha256
37 (base32
38 "0d33cpkbhyidvm3xx6iw9ljqdvl6477c2kcwix3bs63nj0ch06v2"))))
39 (build-system gnu-build-system)
40 (inputs `(("ncurses" ,ncurses)))
41 (arguments
42 ;; The ical tests all want to create a ".calcurse" directory, and may
43 ;; fail with "cannot create directory '.calcurse': File exists" if run
44 ;; concurently.
45 '(#:parallel-tests? #f))
46 (home-page "http://www.calcurse.org")
47 (synopsis "Text-based calendar and scheduling")
48 (description
49 "Calcurse is a text-based calendar and scheduling application. It helps
50 keep track of events, appointments and everyday tasks. A configurable
51 notification system reminds user of upcoming deadlines, and the curses based
52 interface can be customized to suit user needs. All of the commands are
53 documented within an online help system.")
54 (license bsd-2)))